Guía de productividad para Visual StudioProductivity guide for Visual Studio

Si quiere ahorrar tiempo mientras escribe código, está en el lugar correcto.If you want to save time while you're writing code, you're in the right place. Esta guía de productividad incluye sugerencias que pueden ayudarle a empezar a trabajar con Visual Studio, escribir código, depurar código, controlar errores y usar métodos abreviados de teclado: todo en una sola página.This productivity guide includes tips that can help you get started with Visual Studio, write code, debug code, handle errors, and use keyboard shortcuts—all on one page.

Para obtener información sobre métodos abreviados de teclado útiles, vea Métodos abreviados de productividad.For information about helpful keyboard shortcuts, see Productivity shortcuts. Para obtener una lista completa de accesos directos de comandos, consulte Accesos directos de teclado predeterminados.For a complete list of command shortcuts, see Default keyboard shortcuts.

Primeros pasosGet started

Ahorre tiempo indagando en los menús mediante búsquedas rápidas de todo lo que necesite, como, por ejemplo, comandos, opciones de configuración, documentación y opciones de instalación.Save time digging through menus by quickly searching for anything you need, including commands, settings, documentation, and install options. Vea los métodos abreviados de teclado de los comandos en los resultados de la búsqueda en Visual Studio para que pueda memorizarlos más fácilmente.See keyboard shortcuts for commands within your search results in Visual Studio so you can memorize them more easily.

  • Usar código ficticio con la lista de tareas.Mock code using task list. Si no tiene requisitos suficientes para completar alguna parte del código, use la opción Lista de tareas para realizar un seguimiento de los comentarios de código que usan tokens tales como TODO y HACK (o tokens personalizados) y administrar los accesos directos que le llevarán directamente a una ubicación predefinida en el código.If you don't have enough requirements to complete a piece of code, use Task List to track code comments that use tokens such as TODO and HACK, or custom tokens, and to manage shortcuts that take you directly to a predefined location in code. Para más información, consulte el artículo sobre el uso de la lista de tareas.For more information, see Use the Task List.

  • Usar accesos directos del Explorador de soluciones.Use Solution Explorer shortcuts. Si no está familiarizado con Visual Studio, estos accesos directos le resultarán útiles y le ahorrarán tiempo mientras se pone al día con un nuevo código base.If you're new to Visual Studio, these shortcuts will come in handy and save you time while you're coming up to speed on a new codebase. Para ver la lista completa de accesos directos, consulte Métodos abreviados de teclado predeterminados de Visual Studio.For the full list of shortcuts, see Default keyboard shortcuts in Visual Studio.

  • Identificar y personalizar métodos abreviados de teclado en Visual Studio .Identify and customize keyboard shortcuts in Visual Studio. Puede identificar los métodos abreviados de teclado de los comandos de Visual Studio, personalizarlos y exportarlos para que los usen otras personas.You can identify keyboard shortcuts for Visual Studio commands, customize those shortcuts, and export them for others to use. Siempre puede buscar y cambiar un método abreviado de teclado en el cuadro de diálogo Opciones.You can always find and change a keyboard shortcut in the Options dialog box.

  • Aumentar la accesibilidad en Visual Studio.Make Visual Studio more accessible. Visual Studio tiene características de accesibilidad integradas que son compatibles con los lectores de pantalla y otras tecnologías de asistencia.Visual Studio has built-in accessibility features that are compatible with screen readers and other assistive technologies. Consulte Sugerencias y trucos de accesibilidad de Visual Studio para ver la lista completa de características disponibles.See Accessibility tips and tricks for Visual Studio for the full list of available features.

  • Comprobar el ciclo de vida y mantenimiento del producto de Visual StudioCheck out the Visual Studio Product Lifecycle and Servicing. Para más información sobre cómo obtener actualizaciones de Visual Studio, opciones de soporte técnico para clientes empresariales y profesionales, compatibilidad con versiones anteriores de Visual Studio y componentes no cubiertos por el mantenimiento de Visual Studio, consulte Ciclo de vida y mantenimiento del producto de Visual Studio.For information on how to get updates for Visual Studio, support options for Enterprise and Professional customers, support for older versions of Visual Studio, and components not covered by Visual Studio servicing, see Visual Studio Product Lifecycle and Servicing.

  • Instalar y administrar paquetes NuGet en Visual Studio.Install and manage NuGet packages in Visual Studio. La interfaz de usuario del Administrador de paquetes NuGet en Visual Studio de Windows le permite instalar, desinstalar y actualizar fácilmente paquetes NuGet en proyectos y soluciones.The NuGet Package Manager UI in Visual Studio on Windows allows you to easily install, uninstall, and update NuGet packages in projects and solutions. Para más información, consulte Instalar y administrar paquetes en Visual Studio con el Administrador de paquetes NuGet.For more information, see Install and manage packages in Visual Studio using the NuGet Package Manager.

Escribir códigoWrite code

Escriba código más rápidamente con las características siguientes.Write code more quickly by using the following features.

  • Usar comandos prácticos.Use convenience commands. Visual Studio contiene varios comandos que le ayudarán a realizar las tareas de edición comunes con mayor rapidez.Visual Studio contains various commands to help you accomplish common editing tasks faster. Por ejemplo, puede elegir un comando para duplicar fácilmente una línea de código sin tener que copiarla, cambiar la posición del cursor y luego pegarla.For example, you can choose a command to easily duplicate a line of code without having to copy it, reposition the cursor, and then paste it. Elija Editar > Duplicar o presione Ctrl+E,V.Choose Edit > Duplicate or press Ctrl+E,V. También puede expandir o contraer una selección de texto rápidamente; para ello, seleccione Edición > Avanzado > Expandir selección o Edición > Avanzado > Contraer selección, o bien presione Mayús+Alt+ = o Mayús+Alt+ - .You can also quickly expand or contract a selection of text by choosing Edit > Advanced > Expand Selection or Edit > Advanced > Contract Selection, or by pressing Shift+Alt+= or Shift+Alt+-.

  • Usar IntelliSense.Use IntelliSense. Cuando se escribe código en el editor, aparece información de IntelliSense, como Lista de miembros, Información de parámetros, Información rápida, ayuda para las signaturas y Palabra completa.As you enter code in the editor, IntelliSense information, such as List Members, Parameter Info, Quick Info, Signature Help, and Complete Word, appears. Estas características admiten la coincidencia aproximada de texto; por ejemplo, las listas de resultados para Lista de miembros no solo incluyen las entradas que comienzan con los caracteres que escribió, sino también entradas que contienen la combinación de caracteres en cualquier lugar de sus nombres.These features support fuzzy matching of text; for example, the results lists for List Members include not only entries that start with the characters that you have entered but also entries that contain the character combination anywhere in their names. Para obtener más información, vea Usar IntelliSense.For more information, see Use IntelliSense.

  • Cambiar la inserción automática de opciones de IntelliSense mientras se escribe código.Change auto-insertion of IntelliSense options as you enter code. Si se cambia IntelliSense al modo de sugerencias, se puede especificar que las opciones de IntelliSense solo se inserten si se eligen explícitamente.By switching IntelliSense to suggestion mode, you can specify that IntelliSense options are inserted only if you explicitly choose them.

    Para habilitar el modo de sugerencias, pulse las teclas Ctrl+Alt+Barra espaciadora o bien, en la barra de menús, elija Editar > IntelliSense > Alternar el modo de finalización.To enable suggestion mode, choose the Ctrl+Alt+Spacebar keys, or, on the menu bar, choose Edit > IntelliSense > Toggle Completion Mode.

  • Usar fragmentos de código.Use code snippets. Puede usar fragmentos de código integrados o crear sus propios fragmentos de código.You can use built-in snippets, or create your own snippets.

    Para insertar un fragmento de código, en la barra de menús, elijaEditar > IntelliSense > Insertar fragmento de código o Delimitar con, o abra el menú contextual en un archivo y seleccione Fragmento de código > Insertar fragmento de código o Delimitar con.To insert a snippet, on the menu bar, choose Edit > IntelliSense > Insert Snippet or Surround With, or open the shortcut menu in a file and choose Snippet > Insert Snippet or Surround With. Para obtener más información, vea Fragmentos de código.For more information, see Code Snippets.

  • Corregir errores de código alineados.Fix code errors inline. Las acciones rápidas le permiten refactorizar, generar o modificar el código de otra manera fácilmente con una sola acción.Quick Actions let you easily refactor, generate, or otherwise modify code with a single action. Estas acciones se pueden aplicar con los iconos de destornillador icono de destornillador o de bombilla icono de bombilla o presionando Alt+Entrar o Ctrl+ .These actions can be applied using the screwdriver Screwdriver icon or light bulb Light bulb icon icons, or by pressing Alt+Enter or Ctrl+. cuando el cursor esté en la línea de código adecuada.when your cursor is on the appropriate line of code. Para obtener más información, vea Acciones rápidas.See Quick Actions for more information.

  • Mostrar y editar la definición de un elemento de código.Show and edit the definition of a code element. Puede mostrar y editar rápidamente el módulo en el que se define un elemento de código, como un miembro, una variable o un valor local.You can quickly show and edit the module in which a code element, such as a member, a variable, or a local, is defined.

    Para abrir una definición en una ventana emergente, resalte el elemento y, después, presione las teclas Alt+F12, o abra el menú contextual del elemento y seleccione Ver la definición.To open a definition in a pop-up window, highlight the element and then choose the Alt+F12 keys, or open the shortcut menu for the element and then choose Peek Definition. Para abrir una definición en una ventana de código diferente, abra el menú contextual del elemento de código y, después, pulse Ir a definición.To open a definition in a separate code window, open the shortcut menu for the element, and then choose Go to Definition.

  • Usar aplicaciones de ejemplo.Use sample applications. Puede acelerar el desarrollo de aplicaciones si descarga e instala aplicaciones de ejemplo desde Microsoft Developer Network.You can speed up application development by downloading and installing sample applications from Microsoft Developer Network. También puede obtener información sobre una tecnología o un concepto de programación determinado si descarga y explora un Sample Pack para esa área.You can also learn a particular technology or programming concept by downloading and exploring a Sample Pack for that area.

  • Cambiar el formato de llaves con Formato/Nuevas líneas.Change brace formatting with Formatting/New Lines. Use la página de opciones Formato para establecer opciones de formato de código en el editor de código, incluidas nuevas líneas.Use the Formatting options page to set options for formatting code in the code editor, including new lines. Para más información sobre cómo usar esta configuración en C#, consulte Cuadro de diálogo Opciones: Editor de texto > C# > Estilo de código > FormatoFor more information on how to use this setting in C#, see Options dialog box: Text Editor > C# > Code Style > Formatting. Para C++, consulte el artículo sobre establecimiento de preferencias de codificación de C++ en Visual Studio.For C++, see Set your C++ coding preferences in Visual Studio. Para Python, consulte el artículo sobre formato de código de Python.For Python, see Format Python code.

  • Cambiar la sangría por pestañas.Change your indentation with Tabs. Utilice la configuración personalizada del editor, adaptada a cada código base, para aplicar estilos de codificación coherentes para varios desarrolladores que trabajan en un mismo proyecto en distintos editores y entornos de desarrollo integrado (IDE).Use custom editor settings, tailored to each codebase, to enforce consistent coding styles for multiple developers working on the same project across different editors and IDEs. Asegúrese de que todo el equipo sigue las mismas convenciones de lenguaje, convenciones de nomenclatura y reglas de formato.Ensure your whole team follows the same language conventions, naming conventions, and formatting rules. Dado que esta configuración personalizada es portátil y viaja con el código, puede aplicar estilos de codificación incluso fuera de Visual Studio.Since these custom settings are portable and travel with your code, you can enforce coding styles even outside of Visual Studio. Para más información, consulte el artículo sobre opciones, editor de texto, todos los lenguajes, pestañas.For more information, see Options, Text Editor, All Languages, Tabs.

Puede usar diversas técnicas para buscar determinadas ubicaciones del código e ir a ellas con más rapidez.You can use various techniques to find and move to specific locations in your code more quickly. También puede cambiar el diseño de las ventanas de Visual Studio en función de sus preferencias.You can also change the layout of your Visual Studio windows based on your preferences.

  • Establecer marcadores en líneas de código.Bookmark lines of code. Puede usar marcadores para navegar rápidamente a líneas de código concretas de un archivo.You can use bookmarks to navigate quickly to specific lines of code in a file.

    Para establecer un marcador, en la barra de menús, pulse Editar > Marcadores > Alternar marcador.To set a bookmark, on the menu bar, choose Edit > Bookmarks > Toggle Bookmark. Puede ver todos los marcadores de una solución en la ventana Marcadores.You can view all of the bookmarks for a solution in the Bookmarks window. Para obtener más información, vea Establecer marcadores en el código.For more information, see Set bookmarks in code.

  • Buscar definiciones de símbolos en un archivo.Search for symbol definitions in a file. Puede buscar en una solución para encontrar definiciones de símbolos y nombres de archivo, pero los resultados de la búsqueda no incluyen espacios de nombres ni variables locales.You can search within a solution to locate symbol definitions and file names, but search results don't include namespaces or local variables.

    Para tener acceso a esta característica, en la barra de menús, pulse Editar > Navegar a.To access this feature, on the menu bar, choose Edit > Navigate To.

  • Examinar la estructura general del código.Browse the overall structure of your code. En el Explorador de soluciones, puede buscar y examinar clases y sus tipos y miembros en los proyectos.In Solution Explorer, you can search and browse classes and their types and members in your projects. También puede buscar símbolos, ver la jerarquía de llamadas de un método, buscar referencias de símbolos y realizar otras tareas.You can also search for symbols, view a method's Call Hierarchy, find symbol references, and perform other tasks. Si elige un elemento de código en el Explorador de soluciones, el archivo asociado se abre en una pestaña Vista previa y el cursor se desplaza al elemento en el archivo.If you choose a code element in Solution Explorer, the associated file opens in a Preview tab, and the cursor moves to the element in the file. Para obtener más información, vea Visualización de la estructura del código.For more information, see View the structure of code.

  • Saltar a una ubicación en un archivo con el modo de mapa.Jump to a location in a file with map mode. El modo de mapa muestra líneas de código en miniatura en la barra de desplazamiento.Map mode displays lines of code, in miniature, on the scroll bar. Para más información sobre este modo de presentación, consulte Procedimiento para Personalizar la barra de desplazamiento.For more information about this display mode, see How to: Customize the scroll bar.

  • Comprender la estructura del código con un mapa de código.Understand your code structure with code map. Los mapas de código pueden ayudarle a visualizar las dependencias en el código y ver cómo encaja en su conjunto sin necesidad de leer archivos ni líneas de código.Code maps can help you visualize dependencies across your code, and see how it fits together without reading through files and lines of code. Para más información, vea Map dependencies with code maps (Asignar dependencias con mapas de código).For more information, see Map dependencies with code maps.

  • Consultar archivos usados con frecuencia con Editar/Ir a archivo reciente.See frequently used files with Edit/Go to Recent File. Use los comandos "Ir a" de Visual Studio realizan una búsqueda centrada en su código para ayudarle a encontrar rápidamente elementos específicos.Use the Go To commands in Visual Studio to perform a focused search of your code to help you quickly find specified items. Para obtener instrucciones detalladas, consulte el artículo sobre búsqueda de código mediante comandos Ir a.For detailed instructions, see Find code using Go To commands.

  • Mover la ventana Propiedades al lado derecho.Move the Properties window to the right-hand side. Si busca un diseño de ventana más familiar, puede mover la ventana Propiedades en Visual Studio presionando F4.If you're looking for a more familiar window layout, you can move the Properties window in Visual Studio by pressing F4.

Buscar elementos más rápidoFind items faster

Puede buscar comandos, archivos y opciones en el IDE, además de filtrar el contenido de las ventanas de herramientas para mostrar solo la información pertinente para la tarea actual.You can search across the IDE for commands, files, and options, in addition to filtering the contents of tool windows to show only relevant information for your current task.

  • Filtrar el contenido de las ventanas de herramientas.Filter the contents of tool windows. Puede buscar dentro del contenido de muchas ventanas de herramientas, como el Cuadro de herramientas, la ventana Propiedades y el Explorador de soluciones, pero mostrar únicamente los elementos cuyos nombres contengan los caracteres que especifique.You can search within the contents of many tool windows, such as the Toolbox, the Properties window, and Solution Explorer, but display only items whose names contain the characters that you specify.

  • Mostrar solo los errores que quiera abordar.Display only the errors you want to address. Si elige el selecciona el botón Filtro de la barra de herramientas Lista de errores, puede reducir el número de errores que aparecen en la ventana Lista de errores.If you choose the Filter button on the Error List toolbar, you can reduce the number of errors that appear in the Error List window. Puede mostrar solo los errores de los archivos que están abiertos en el editor, solo los errores del archivo actual o solo los errores del proyecto actual.You can display only the errors in the files that are open in the editor, only the errors in the current file, or only the errors in the current project. También puede buscar errores específicos dentro de la ventana Lista de errores.You can also search within the Error List window to find specific errors.

  • Buscar cuadros de diálogo, comandos de menú, opciones y demás.Find dialog boxes, menu commands, options, and more. En el cuadro de búsqueda, escriba palabras clave o frases correspondientes a los elementos que intenta buscar.In the search box, enter keywords or phrases for the items that you're trying to find. Por ejemplo, aparecen las opciones siguientes si escribe nuevo proyecto:For example, the following options appear if you enter new project:

    Resultados de inicio rápido para 'nuevo proyecto'

    En Inicio rápido se muestran vínculos para crear un proyecto, agregar un nuevo elemento a un proyecto y a la página Proyectos y soluciones del cuadro de diálogo Opciones, entre otros.Quick Launch displays links to create a new project, to add a new item to a project, and to the Projects and Solutions page in the Options dialog box, among others. Los resultados de Inicio rápido también pueden incluir archivos de proyecto y ventanas de herramientas.Search results can also include project files and tool windows.

    Resultados de la búsqueda para "nuevo proyecto"

    Presione Ctrl+Q para ir directamente al cuadro de búsqueda.Press Ctrl+Q to jump straight to the search box.

Depurar códigoDebug code

La depuración puede consumir mucho tiempo, pero las siguientes sugerencias pueden ayudarle a acelerar el proceso.Debugging can consume a lot of time, but the following tips can help you speed up the process.

  • Usar las herramientas del depurador de Visual Studio.Use the Visual Studio debugger tools. En el contexto de Visual Studio, depurar la aplicación normalmente significa ejecutar la aplicación en modo del depurador.In the Visual Studio context, when you debug your app, it usually means that you are running the application in debugger mode. El depurador ofrece muchas formas de ver lo que hace el código durante su ejecución.The debugger provides many ways to see what your code is doing while it runs. Consulte el artículo sobre primer vistazo al depurador de Visual Studio para obtener una guía de introducción.See First look at the Visual Studio Debugger for a guide to getting started.

  • Probar la misma página, aplicación o sitio en exploradores diferentes.Test the same page, application, or site in different browsers. Cuando depura código, puede cambiar fácilmente entre los exploradores web instalados, incluido Inspector de página (Visual Studio), sin tener que abrir el cuadro de diálogo Explorar con.As you debug your code, you can easily switch among the installed web browsers, including Page Inspector (Visual Studio), without having to open the Browse With dialog box. Puede usar la lista Depurar destino, que se encuentra en la barra de herramientas Estándar junto al botón Iniciar depuración, para comprobar rápidamente qué explorador está usando mientras depura o ve páginas.You can use the Debug Target list, which is on the Standard toolbar next to the Start Debugging button, to quickly verify which browser you're using as you debug or view pages.

    Selección de opciones de depuración del explorador web

  • Establecer puntos de interrupción temporales.Set temporary breakpoints. Puede crear un punto de interrupción temporal en la línea actual de código e iniciar el depurador simultáneamente.You can create a temporary breakpoint in the current line of code and start the debugger simultaneously. Al llegar a esa línea de código, el depurador activa el modo de interrupción.When you hit that line of code, the debugger enters break mode. Para obtener más información, vea Desplazarse por el código con el depurador.For more information, see Navigate through code with the debugger.

    Para usar esta característica, pulse las teclas Ctrl+F10 o abra el menú contextual de la línea de código en la que desea establecer una interrupción y, después, elija Ejecutar hasta el cursor.To use this feature, choose the Ctrl+F10 keys, or open the shortcut menu for the line of code on which you want to break, and then choose Run To Cursor.

  • Mover el punto de ejecución durante la depuración.Move the execution point during debugging. Puede mover el punto de ejecución actual a otra sección de código y reiniciar la depuración a partir de ese punto.You can move the current execution point to a different section of code and then restart debugging from that point. Esta técnica es útil si desea depurar una sección de código sin tener que volver a crear todos los pasos necesarios para llegar a esa sección.This technique is useful if you want to debug a section of code without having to recreate all of the steps that are required to reach that section. Para obtener más información, vea Desplazarse por el código con el depurador.For more information, see Navigate through code with the debugger.

    Para mover el punto de ejecución, arrastre la punta de flecha amarilla hasta una ubicación donde desee establecer la siguiente instrucción en el mismo archivo de código fuente y elija la tecla F5 para continuar con la depuración.To move the execution point, drag the yellow arrowhead to a location where you want to set the next statement in the same source file, and then choose the F5 key to continue debugging.

  • Capturar información de valor para variables.Capture value information for variables. Puede agregar una información sobre datos a una variable del código y anclarla para poder tener acceso al último valor conocido de la variable una vez finalizada la depuración.You can add a DataTip to a variable in your code and pin it so that you can access the last known value for the variable after debugging has finished. Para obtener más información, consulte Ver valores de datos en sugerencias de datos en el editor de código.For more information, see View data values in Data Tips.

    Para agregar una Información sobre datos, el depurador debe estar en modo de interrupción.To add a DataTip, the debugger must be in break mode. Coloque el cursor en la variable y elija el botón de anclaje en la información sobre datos que aparece.Place the cursor on the variable, and then choose the pin button on the DataTip that appears. Cuando se detiene la depuración, aparece un icono azul de anclaje en el archivo de código fuente junto a la línea de código que contiene la variable.When debugging is stopped, a blue pin icon appears in the source file next to the line of code that contains the variable. Si apunta al icono azul, aparece el valor de la variable de la sesión de depuración más reciente.If you point to the blue pin, the value of the variable from the most recent debugging session appears.

  • Borrar la ventana Inmediato.Clear the Immediate window. Para borrar el contenido de la ventana Inmediato en tiempo de diseño, escriba >cls o >Edit.ClearAll.You can erase the contents of the Immediate window at design time by entering >cls or >Edit.ClearAll

    Para obtener más información sobre los comandos adicionales, vea Alias de comandos de Visual Studio.For more information about additional commands, see Visual Studio command aliases.

  • Buscar cambios en el código y otro historial con CodeLens .Find code changes and other history with CodeLens. CodeLens le permite averiguar qué ocurrió con el código mientras sigue centrado en su trabajo sin dejar el editor.CodeLens lets you stay focused on your work while you find out what happened to your code—without leaving the editor. Puede buscar referencias de una parte del código, cambios de código, errores vinculados, elementos de trabajo, revisiones de código y pruebas unitarias.You can find references to a piece of code, changes to your code, linked bugs, work items, code reviews, and unit tests.

  • Usar Live Share para depurar en tiempo real con otros usuarios.Use Live Share to debug in real time with others. Live Share le permite editar y depurar en colaboración con otros usuarios en tiempo real, con independencia de los lenguajes de programación que use o los tipos de aplicaciones que compile.Live Share enables you to collaboratively edit and debug with others in real time, regardless of the programming languages you're using or app types you're building. Para más información, consulte ¿Qué es Visual Studio Live Share?For more information, see What is Visual Studio Live Share?

  • Usar la ventana interactiva para escribir y probar código pequeño.Use Interactive Window to write and test small code. Visual Studio ofrece una ventana interactiva de read–eval–print loop (REPL) que le permite escribir código arbitrario y ver resultados inmediatos.Visual Studio provides an interactive read-evaluate-print-loop (REPL) window that lets you enter arbitrary code and see immediate results. Esta forma de codificación le ayuda a aprender y experimentar con las API y las bibliotecas, así como a desarrollar de manera interactiva código de trabajo para incluirlo en sus proyectos.This way of coding helps you to learn and experiment with APIs and libraries, and to interactively develop working code to include in your projects. Para Python, consulte Uso de la ventana interactiva de Python.For Python, see Work with the Python Interactive window. La característica de ventana interactiva también está disponible para C#.The Interactive Window feature is also available for C#.

Acceso a Visual Studio ToolsAccess Visual Studio tools

Puede tener acceso rápidamente al Símbolo del sistema para desarrolladores o a otra herramienta de Visual Studio si ancla este elemento en el menú Inicio o en la barra de tareas.You can quickly access the Developer Command Prompt, or another Visual Studio tool, if you pin it to the Start menu or the taskbar.

  1. En el Explorador de Windows, vaya a %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.
  1. En el Explorador de Windows, vaya a %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.
  1. Haga clic con el botón derecho o abra el menú contextual de Símbolo del sistema para desarrolladores y, luego, elija Anclar a Inicio o Anclar a la barra de tareas.Right-click or open the context menu for Developer Command Prompt, and then choose Pin to Start or Pin to taskbar.

Administrar archivos, barras de herramientas y ventanasManage files, toolbars, and windows

En cualquier momento, puede trabajar en varios archivos de código y desplazarse entre varias ventanas de herramientas mientras desarrolla una aplicación.At any one time, you may be working in multiple code files and moving among several tool windows as you develop an application. Para organizarse, utilice las sugerencias siguientes:You can keep organized by using the following tips:

  • Mantener los archivos que usa con frecuencia visibles en el editor.Keep files that you frequently use visible in the editor. Puede anclar archivos en el lado izquierdo de la pestaña de modo que sigan siendo visibles independientemente de cuántos archivos haya abiertos en el editor.You can pin files to the left side of the tab so that they remain visible regardless of how many files are open in the editor.

    Para anclar un archivo, pulse la pestaña del archivo y, después, seleccione el botón Alternar estado de anclaje.To pin a file, choose the file's tab, and then choose the Toggle Pin Status button.

  • Mover documentos y ventanas a otros monitores.Move documents and windows to other monitors. Si utiliza más de un monitor al desarrollar aplicaciones, puede trabajar en algunas partes de la aplicación más fácilmente si mueve a otro monitor los archivos que están abiertos en el editor.If you use more than one monitor when you develop applications, you can work on portions of your application more easily by moving files that are open in the editor to another monitor. También puede mover las ventanas de herramientas, por ejemplo las ventanas del depurador, a otro monitor y acoplar en una pestaña las ventanas de documentos y de herramientas para crear "pilas".You can also move tool windows, such as debugger windows, to another monitor and tab dock document and tool windows together to create "rafts." Para obtener más información, vea Personalizar los diseños de ventana de Visual Studio.For more information, see Customize window layouts in Visual Studio.

    También puede administrar los archivos más fácilmente si crea otra instancia del Explorador de soluciones y la mueve a otro monitor.You can also manage files more easily by creating another instance of Solution Explorer and moving it to another monitor. Para crear otra instancia del Explorador de soluciones, abra un menú contextual en el Explorador de soluciones y pulse Nueva vista del Explorador de soluciones.To create another instance of Solution Explorer, open a shortcut menu in Solution Explorer, and then choose New Solution Explorer View.

  • Personalizar las fuentes que aparecen en Visual Studio.Customize the fonts that appear in Visual Studio. Puede cambiar la fuente, el tamaño y el color que se usa para el texto en el IDE.You can change the font face, size, and color that's used for text in the IDE. Por ejemplo, puede personalizar el color de determinados elementos de código en el editor y la fuente en las ventanas de herramientas o en todo el IDE.For example, you can customize the color of specific code elements in the editor and the font face in tool windows or throughout the IDE. Para obtener más información, vea Cómo: Cambiar fuentes y colores y Cómo: Cambiar las fuentes y los colores del editor.For more information, see How to: Change fonts and colors and How to: Change fonts and colors in the editor.

Vea tambiénSee also