Käyttäjät eivät voi muodostaa yhteyttä POP3-tai IMAP4-yhteyden muodostamiseen

Alkuperäinen tietämys kannan numero:   3025138

Oire 1

Käyttäjät, joilla on posti laatikko Exchange Server 2016-tai Exchange Server 2013-palvelimessa, voivat huomata, että niiden yhteydet POP3-tai IMAP4-palveluun lakkaavat toimimasta. Lisäksi näyttöön voi tulla seuraava virhe sanoma:

Microsoft. Exchange. Monitoring. ProtocolException: todentaminen epäonnistui.
Yhteys suljetaan. Tietoja ei voi lukea siirto yhteydestä:
etäisäntä sulki nykyisen yhteyden väkisin. Palvelimen vastaus, kun teet
yhteys: []. ---> System. IO. IOException: tietoja ei voi lukea kuljetuksesta
yhteys: etäisäntä sulki olemassa olevan yhteyden väkisin. --->
System .net. Sockets. SocketException: aiemmin luotu yhteys suljettiin väkisin
etähallintapalveluun liittyvä palvelu käynnistetään, järjestelmässä ei ole virhe-tai varoitus tapahtumia
sovellus loki.

Oire 2

Käyttäjät voivat Telnet-yhteyden POP3-tai IMAP-porttiin palvelimen FQDN avulla. He eivät kuitenkaan näe banneria. Sen sijaan he näkevät vain tyhjän näytön.

Syy

Tämä ongelma ilmenee, koska PopProxy-ja ImapProxy-osat ovat passiivisessa tilassa.

Voit Get-ServerComponentState <ServerName> tarkistaa komponenttien tilan käyttämällä komentoa.

Ratkaisu

Jos haluat korjata ongelman, määritä PopProxy-ja ImapProxy-osat aktiivi seksi. Voit tehdä tämän seuraavasti:

  1. Seuraavan komennon avulla voit määrittää, mikä pyytäjä on tehnyt PopProxy-toiminnon käytöstä:

    Get-ServerComponentState-Identity <ServerName> -Component PopProxy). LocalStates

    Seuraavassa esimerkissä HealthAPI näytetään pyytäjä, joka muutti PopProxy-tilaa passiiviseksi.

    näyttö kuva Get-ServerComponentState-tilasta

  2. Voit tehdä PopProxy aktiivi seksi seuraavan komennon avulla:

    Asento-ServerComponentState-Identity <ServerName> -Component PopProxy-State Active-pyytäjän HealthAPI

    Esimerkiksi:

    näyttö kuva joukko-ServerComponentState-tilasta