Makron suorittaminen automaattisesti Projectin käynnistyessä

Alkuperäinen KB-numero:   128622

Yhteenveto

Jos haluat, että makro suoritetaan automaattisesti aina, kun Microsoft Project -kuvaketta käytetään Microsoft Projectin käynnistämiseen, muokkaa kuvakkeen ominaisuuksien komentoriviä niin, että Auto_Open-makron sisältävä projekti avataan automaattisesti käynnistyksen yhteydessä.

Lisätietoja

Seuraavat vaiheet aiheuttavat Auto_Open-makron suorittamisen, kun käynnistät Microsoft Projectin kaksoisnapsauttamalla Microsoft Project -pikakuvaketta tai kaksoisnapsauttamalla Microsoft Project -tiedostoa, joka sisältää Auto_Open-makron.

Toimi Project 2013:ssa ja 2010:ssä seuraavasti:

  1. Luo uusi projekti.

    Huomautus

    Tässä esimerkissä projektin nimi on STARTUP. MPP,, mutta voit käyttää mitä tahansa kelvollista tiedostonimeä.

  2. Valitse Näytä-valikosta Makrot ja valitse Näytä makrot.

  3. Ala kirjoittaa makrolle uutta nimeä nimeltä "Auto_Open" ja valitse Luo. Microsoft Visual Basic for Applications -ikkuna avautuu.

  4. Kirjoita VBA-editorissa koodi, jonka haluat suorittaa aina, kun Microsoft Project käynnistetään.

  5. Valitse editorin Tiedosto-valikosta Tallenna KÄYNNISTYS. MPP: valitse Tiedosto-valikosta Sulje ja palaa Microsoft Projectiin.

  6. Tallenna suunnitelma ja sulje Microsoft Project. Kun avaat tämän suunnitelman seuraavan kerran, Auto_Open makro suoritetaan, jos vastaat Kyllä makrojen käyttöönottoon.

    Huomautus

    Makro Auto_Open myös suorittaa muita makroja. Jos GLOBAL-ssa on esimerkiksi vain yksi makro. MPT-niminen "Oma-Aloitus", ja jos se ei käytä argumentteja, Auto_Open suorittaa sen käyttäen: Makro "Oma-Aloitus".

  7. Luo työpöydälle pikakuvake Microsoft Projectia varten. Suoritettavaa tiedostoa kutsutaan WINPROJ.EXE.

  8. Napsauta pikakuvaketta hiiren kakkospainikkeella ja valitse Ominaisuudet. Liitä Kohde-kohteessa polku tallennettuun käynnistyssuunnitelmaan. MPP. Esimerkki: c:\winproj\winproj.exe c:\data\Startup.mpp, valitse OK.

Huomautus

Makro Auto_Open myös suorittaa muita makroja. Jos GLOBAL-ssa on esimerkiksi vain yksi makro. MPT-niminen "Oma-Aloitus", ja jos se ei käytä argumentteja, Auto_Open suorittaa sen käyttäen: Makro "Oma-Aloitus".

Noudata näitä ohjeita Microsoft Projectin aiempien versioiden kanssa:

  1. Luo uusi projekti.

    Huomautus

    Tässä esimerkissä projektin nimi on STARTUP. MPP,, mutta voit käyttää mitä tahansa kelvollista tiedostonimeä.

  2. Valitse Työkalut-valikosta Makrot ja valitse sitten Uusi-painike. Valitse Asetukset ja valitse Tallenna makro sijaintiin -kohdassa Nykyinen projektitiedosto.

  3. Kirjoita Makron nimi -ruutuun Auto_Open ja valitse OK.

  4. Noudata yllä olevia vaiheita 4–8.

Jos et halua käyttää Auto_Open KÄYNNISTYS-ssa. Suoritettava MPP, pidä VAIHTO-näppäintä painettuna, kun käynnistät Microsoft Projectin.

Microsoft Project ei luo automaattisesti tyhjää Project1:tä, kun kuvake on määritetty avaamaan projekti automaattisesti. Jos haluat luoda uuden projektin, voit käyttää FileNew-menetelmää Auto_Open KÄYNNISTYS-makrossa. MPP.

Jos haluat sulkea KÄYNNISTYKSEN. Kun käynnistät Microsoft Projectin, voit sulkea sen lisäämällä Auto_Open MPP-makroon. Esimerkiksi seuraavat rivit aktivoivat KÄYNNISTYS-toiminnon. MPP ja sulje se tallentamatta muutoksia:

Projects("Startup.mpp").Activate
FileClose save:=pjDoNotSave