Erreur lorsque Outlook tente de se connecter à un serveur à l’aide d’une connexion RPC ou HTTPS : un problème s’est produite avec le certificat de sécurité du serveur proxy

Numéro de la ko d’origine :   923575

Symptômes

Lorsque Microsoft Outlook tente de se connecter à un serveur à l’aide d’une connexion d’appel de procédure distante (RPC) ou d’une connexion HTTPS sécurisée, vous recevez l’un des messages d’erreur suivants :

  • Message d’erreur 1

    Un problème est à l’étude avec le certificat de sécurité du serveur proxy, %s. Outlook ne parvient pas à se connecter à ce serveur. (%s)

  • Message d’erreur 2

    Un problème est à l’étude avec le certificat de sécurité du serveur proxy, %s. Le nom du certificat de sécurité n’est pas valide ou ne correspond pas au nom du site. Outlook ne parvient pas à se connecter à ce serveur. (%s)

  • Message d’erreur 3

    Un problème est à l’étude avec le certificat de sécurité du serveur proxy, %s. Le certificat de sécurité ne fait pas partie d’une autorité de certification fiable. Outlook ne parvient pas à se connecter à ce serveur. (%s) »

  • Message d’erreur 4

    Il existe un problème avec le certificat de sécurité du serveur proxy. Le nom du certificat de sécurité n’est pas valide ou ne correspond pas au nom du site cible outlook.office365.com. Outlook ne parvient pas à se connecter au serveur proxy (Code d’erreur 0)

Remarques sur les messages d’erreur

  • L’espace réservé %s est la propriété Outlook profil 001f6622. Il s’agit du nom Microsoft Exchange Server serveur proxy RPC.

  • L’espace réservé (%s) est le code d’erreur.

    Pour le message d’erreur 1 et le message d’erreur 2, le code d’erreur renvoyé est la somme de tous les codes de problème de certificat de masque de bits. Consultez la section « Plus d’informations » pour plus d’informations sur les codes de problème de certificat de masque de bits.

    Pour le message d’erreur 3, le code d’erreur est censé toujours être 0x00000008.

Cause

Ce problème peut se produire si une ou plusieurs des conditions suivantes sont vraies :

  • La connexion au serveur nécessite une autorité de certification.
  • Vous n’avez pas approuvé l’autorité de certification à la racine.
  • Le certificat peut être non valide ou révoqué.
  • Le certificat ne correspond pas au nom du site.
  • Un add-in tiers ou un autre navigateur tiers empêche l’accès.

Résolution 1 : Examiner le certificat pour le message d’erreur 1 ou 2

Examinez le certificat. Ensuite, contactez votre administrateur système pour résoudre ce problème.

Pour examiner le certificat, suivez les étapes suivantes :

  1. Dans Microsoft Internet Explorer, connectez-vous au serveur RPC ou au serveur sécurisé. Par exemple, tapez https://www . server_name.com/rpc dans la barre d’adresses du navigateur Web, puis appuyez sur Entrée.

    Notes

    L server_name réservé fait référence au nom du serveur RPC ou au nom du serveur sécurisé.

  2. Double-cliquez sur l’icône de cadenas située dans le coin inférieur droit du navigateur Web.

  3. Cliquez sur l'onglet Details (Détails).

  4. Notez les informations dans les champs suivants :

    • Valide pour
      Le champ Valide pour indique la date jusqu’à laquelle le certificat est valide.
    • Subject
      Les données du champ Objet doivent correspondre au nom du site.

Résolution 2 : Installer le certificat racine approuvé pour le message d’erreur 3

Pour installer le certificat racine approuvé sur le client, suivez les étapes suivantes :

  1. Cliquez sur Installer le certificat lorsque vous y êtes invité à l’aide de la boîte de dialogue Certificat.
  2. Cliquez sur Suivant.
  3. Cliquez pour sélectionner la case à cocher Placer tout le certificat dans la case à cocher suivante.
  4. Cliquez sur Parcourir.
  5. Cliquez sur Autorités de certification racines de confiance > OK.
  6. Cliquez sur Suivant.
  7. Cliquez sur Terminer.
  8. Cliquez sur OK.

Pour obtenir des références, voir Installation d’un certificat racine approuvé.

Résolution 3 : Désactiver le add-in tiers ou le navigateur tiers pour le message d’erreur 4

Désactiver les add-ins tiers

  1. Démarrez Outlook en mode sans échec pour vous aider à isoler le problème. Pour ce faire, cliquez sur Démarrer > l'outlook.exe /safe, puis cliquez sur OK.

    Si Outlook démarre correctement en mode sans échec, le problème que vous rencontrez peut être dû à un module tiers.

  2. Recherchez des compl?ments COM tiers et désactivez-les. Pour cela, procédez comme suit :

    1. Dans le menu Fichier, cliquez sur Options pour > les add-ins.
    2. Dans la zone Gérer, cliquez sur Ajouter des com. >
    3. Cliquez pour désactiver la case à cocher en regard des add-ins tiers que vous souhaitez désactiver.
    4. Redémarrez Outlook.

Pour plus d’informations, voir la section « Étape 6 : démarrer Outlook en mode sans échec » de l’article suivant de la Base de connaissances Microsoft :

2632425 Comment résoudre les incidents Outlook 2010 et Outlook 2013

Désactiver les add-ins de navigateur tiers

Outlook utilise les paramètres Internet Explorer pour les requêtes HTTP. Si un add-in de navigateur tiers est à l’origine de ce problème, désactivez-le dans Internet Explorer. Pour connaître la procédure à suivre, consultez la section « Désactiver les modules supplémentaires dans Internet Explorer » de l’article suivant de la Base de connaissances Microsoft :

Erreur 956196 « Internet Explorer ne peut pas afficher la page web »

Informations supplémentaires

Les codes de problème de certificat de masque de bits sont répertoriés dans le tableau suivant.

Description Code d’erreur
FLAG_CERT_REV_FAILED 0x00000001
FLAG_INVALID_CERT 0x00000002
FLAG_CERT_REVOKED 0x00000004
FLAG_INVALID_CA 0x00000008
FLAG_CERT_CN_INVALID 0x00000010
FLAG_CERT_DATE_INVALID 0x00000020
FLAG_CERT_WRONG_USAGE 0x00000040
FLAG_SECURITY_CHANNEL_ERROR 0x80000000