Comment réparer votre fichier Outlook dossier personnel (.pst)

Numéro de la ko d’origine :   272227

Suivez ces étapes pour réparer Outlook fichier de dossier personnel (.pst) à l’aide de l’outil de réparation de la boîte de réception.

Étape 1 : quittez Outlook et démarrez l’outil de réparation de la boîte de réception

Démarrer automatiquement l’outil de réparation de la boîte de réception

Démarrez l’outil de réparation de boîte de réception (Scanpst.exe). Sélectionnez Ensuite Ouvrir ou Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez les étapes de l’Assistant Réparation simple.

Une fois l’outil de réparation de la boîte de réception démarré, continuez à l’étape 2. (Vous ne pouvez pas démarrer l’outil de réparation de la boîte de réception ?)

Démarrer manuellement l’outil de réparation de la boîte de réception

Pour démarrer manuellement l’outil de réparation de la boîte de réception, recherchez l’un des dossiers à l’aide de l’Explorateur Microsoft Windows, puis double-cliquez sur Scanpst.exe fichier.

Notes

Le ou les dossiers peuvent être masqués. Pour obtenir des instructions sur la façon de démasthiser des fichiers et des dossiers, consultez la documentation de votre système d’exploitation.

Emplacement type Remarque
<disk drive>\Program Files(x86)\Microsoft Office\root\Office16 Par Outlook 2016'installation « En un clic sur une version 32 bits de Windows
<disk drive>\Program Files\Microsoft Office\root\Office16 Pour Outlook 2016'installation « En un clic sur une version 64 bits de Windows
<disk drive>\Program Files(x86)\Microsoft Office\Office16 Pour Outlook 2016'installation basée sur MSI sur une version 32 bits de Windows
<disk drive>\Program Files\Microsoft Office\Office16 Pour Outlook 2016'installation basée sur MSI sur une version 64 bits de Windows
<disk drive>\Program Files\Microsoft Office 15\root\office15 Pour Outlook 2013 sur une version 64 bits de Windows
<disk drive>\Program Files(x86)\Microsoft Office 15\root\office15 Pour Outlook 2013 sur une version 32 bits de Windows
<disk drive>\Program Files\Microsoft Office\Office15 Pour Outlook installation MSI 2013 sur une version 64 bits de Windows
<disk drive>\Program Files(x86)\Microsoft Office\Office15 Pour Outlook installation MSI 2013 sur une version 32 bits de Windows
<disk drive>:\Program Files\Microsoft Office\Office14 Pour Outlook 2010 sur une version 64 bits de Windows
<disk drive>:\Program Files\Microsoft Office(x86)\Office14 Pour Outlook 2010 sur une version 32 bits de Windows
<disk drive>:\Program Files\Microsoft Office\Office12 Par Outlook 2007 sur une version 64 bits de Windows
<disk drive>:\Program Files(x86)\Microsoft Office\Office12 Pour Outlook 2007 sur une version 32 bits de Windows
<disk drive>:\Program Files\Common Files\System\Mapi\1033 | Other typical location
<disk drive>:\Program Files\Common Files\System\MSMAPI\1033 Autre emplacement classique
<disk drive>:\Program Files\Common Files\System\Mapi\1033\NT Autre emplacement classique (pour Windows NT et Windows 2000)
<disk drive>:\Program Files\Common Files\System\Mapi\1033\95 Autre emplacement classique (pour Windows 95 et Windows 98)

(Vous ne trouvez pas l’outil de réparation de la boîte de réception ?)

Étape 2 : réparer le fichier .pst

Dans l’outil de réparation de la boîte de réception, tapez le chemin d’accès et le nom de fichier de votre fichier de dossiers personnels (.pst) ou sélectionnez Parcourir pour localiser le fichier à l’aide du système de fichiers Windows, puis sélectionnez Démarrer.

Notes

Si vous ne savez pas où se trouve le fichier .pst, suivez les étapes de la procédure de localisation, de déplacement ou de back up de votre fichier .pst.

Réparer le fichier .pst

Notes

  • L’outil de réparation de boîte de réception peut avoir besoin d’être exécuté plusieurs fois pour réparer entièrement votre fichier de dossier personnel (.pst).
  • L’outil de réparation de la boîte de réception ne peut pas réparer tous les problèmes détectés. Dans certains cas, les éléments peuvent ne pas être récupérés s’ils ont été définitivement supprimés ou endommagés après réparation.

Étape 3 : récupérer les éléments réparés dans un nouveau fichier .pst

Après avoir exécuté l’outil De réparation de la boîte de réception, vous pouvez démarrer Outlook et récupérer les éléments réparés. Si vous le souhaitez, vous pouvez essayer de récupérer d’autres éléments réparés à partir du dossier personnel de sauvegarde.

Pour commencer, créez une entrée de fichier dossiers personnels (.pst) dans votre profil. Ensuite, vous pouvez déplacer les éléments récupérés vers votre nouveau fichier de dossiers personnels (.pst).

  1. Démarrez Outlook. Si vous utilisez plusieurs profils dans Outlook, veillez à sélectionner le profil qui contient le fichier de dossiers personnels (.pst) que vous avez essayé de réparer.

  2. Appuyez sur Ctrl+6 pour activer l’affichage Liste des dossiers.

  3. Dans votre liste de dossiers, vous devez voir les dossiers récupérés suivants :

    Recovered Personal Folders
    
    Calendar
    Contacts
    Deleted Items
    Inbox
    Journal
    Notes
    Outbox
    Sent Items
    Tasks
    

    Notes

    Ces dossiers récupérés sont généralement vides, car il s’agit d’un fichier .pst reconstruit. Vous devriez également voir un dossier nommé Lost and Found. Ce dossier contient des dossiers et des éléments récupérés par l’outil de réparation de boîte de réception. Malheureusement, les éléments manquants dans le dossier Perdu et trouvé peuvent être insurparables.

  4. Créez un fichier de dossier personnel (.pst) dans votre profil. Les étapes peuvent être différentes, selon la version de Outlook que vous exécutez.

    Outlook 2010 et versions ultérieures

    1. Sélectionnez l’onglet Fichier sur le ruban, puis l’onglet Informations dans le menu.
    2. Sélectionnez le bouton Paramètres compte, puis sélectionnez Compte Paramètres nouveau.
    3. Sélectionnez l’onglet Fichiers de données.
    4. Sélectionnez Ajouter pour ouvrir la boîte de dialogue Créer Outlook fichier de données.
    5. Entrez un nom de fichier pour votre nouveau fichier Outlook données (.pst), puis sélectionnez OK.
    6. Vous devez avoir un nouveau fichier Outlook données (.pst) dans votre profil.

    Outlook 2007

    1. Dans le menu Fichier, sélectionnez Gestion des fichiers de données.
    2. Sélectionnez Ajouter pour ouvrir la boîte de dialogue Nouveau Outlook données.
    3. Dans la boîte de dialogue Types de stockage, sélectionnez Office Outlook fichier de dossiers personnels (.pst), puis sélectionnez OK.
    4. Dans la boîte de dialogue Créer ou ouvrir un fichier de données Outlook, sélectionnez l’emplacement et un nom de fichier pour votre nouveau fichier de dossiers personnels (.pst), puis sélectionnez OK.
    5. Sélectionnez OK.
    6. Vous devez avoir un nouveau fichier de dossiers personnels (.pst) dans votre profil.

    Outlook 2003

    1. Dans le menu Fichier, pointez sur Nouveau, puis sélectionnez Outlook fichier de données.
    2. Sélectionnez OK pour ouvrir la boîte de dialogue Créer Outlook fichier de données.
    3. Entrez un nom de fichier pour votre nouveau fichier de dossiers personnels (.pst), puis sélectionnez OK pour ouvrir la boîte de dialogue Créer des dossiers personnels Microsoft.
    4. Entrez un nom de fichier pour votre nouveau fichier de dossiers personnels (.pst), puis sélectionnez OK.
    5. Vous devez avoir un nouveau fichier de dossiers personnels (.pst) dans votre profil.

    Outlook 2002

    1. Dans le menu Fichier, pointer sur Nouveau, puis sélectionnez Fichier de dossiers personnels (.pst).
    2. Sélectionnez Créer pour ouvrir la boîte de dialogue Créer des dossiers personnels Microsoft.
    3. Entrez un nom de fichier pour votre nouveau fichier de dossiers personnels (.pst), puis sélectionnez OK.
    4. Vous devez avoir un nouveau fichier de dossiers personnels (.pst) dans votre profil.
  5. Faites glisser les éléments récupérés du dossier Perdu et trouvé vers votre nouveau fichier De dossiers personnels (.pst).

  6. Lorsque vous avez terminé le déplacement de tous les éléments, vous pouvez supprimer le fichier Dossiers personnels récupérés (.pst) de votre profil. Cela inclut le dossier Perdu et Trouvé.

  7. Si vous êtes satisfait des informations récupérées, vous avez terminé. Toutefois, si vous souhaitez essayer de récupérer des informations supplémentaires, allez à la section Récupérer les éléments réparés à partir de la section du fichier de sauvegarde (facultatif).

Qu’est-ce que l’outil de réparation de la boîte de réception ?

L’outil de réparation de boîte de réception (Scanpst.exe) est conçu pour résoudre les problèmes associés aux fichiers de dossier personnel (.pst).

L’outil de réparation de la boîte de réception est automatiquement installé avec toutes les options d’installation de Microsoft Outlook en anglais en fonction de votre système d’exploitation.

Can’t find or start the Inbox Repair tool

Si vous ne pouvez pas démarrer l’outil de réparation de la boîte de réception automatiquement ou manuellement, vous pouvez essayer de réparer Office application.

Récupérer les éléments réparés à partir du fichier de sauvegarde (facultatif)

Notes

Si vous n’avez pas pu ouvrir votre fichier de dossiers personnels d’origine (.pst) avant d’avoir utilisé l’outil de réparation de boîte de réception, les procédures suivantes risquent de ne pas fonctionner. Si cela ne fonctionne pas, malheureusement, vous ne pourz pas récupérer d’informations supplémentaires. Si vous pouvez ouvrir le fichier, la procédure suivante peut vous aider à récupérer des éléments supplémentaires à partir de votre fichier dossiers personnels endommagé (.pst).

Lorsque vous exécutez l’Outil de réparation de la boîte de réception, l’option permettant de créer une sauvegarde du fichier de dossiers personnels d’origine (.pst) est automatiquement sélectionnée. Cette option crée un fichier sur votre disque dur nommé Nom de fichier.bak. Ce fichier est une copie du fichier .pst de nom de fichier d’origine avec une extension différente. Si vous pensez que des éléments sont toujours manquants après avoir suivi les étapes de la section précédente, vous pouvez essayer de récupérer des informations supplémentaires à partir de ce fichier de sauvegarde en suivant les étapes suivantes :

Recherchez le fichier .bak. Il se trouve dans le dossier de votre fichier de dossiers personnels d’origine (.pst).

  1. Recherchez le fichier .bak. Il se trouve dans le dossier de votre fichier de dossiers personnels d’origine (.pst).

  2. Faites une copie du fichier .bak et donnez un nouveau nom au fichier avec une extension .pst. Par exemple, nommez le fichier Nouveau nom.pst.

  3. Importez le fichier.pst nouveau nom que vous avez créé à l’étape précédente à l’aide de l’Assistant Importation et exportation Outlook. Pour cela, procédez comme suit :

    1. Dans le menu Fichier, sélectionnez Importer et exporter.

      Notes

      On Outlook 2010 and later, select the File tab on the Ribbon, select Open, and then select Import.

    2. Sélectionnez Importer à partir d’un autre programme ou fichier, puis sélectionnez Suivant.
    3. Sélectionnez fichier de dossier personnel (.pst), puis sélectionnez Suivant.
    4. Sous Fichier à importer, sélectionnez Parcourir, puis double-cliquez sur votre fichier Newname.pst.
    5. Sous Options, sélectionnez Ne pas importer les doublons, puis sélectionnez Suivant.
    6. Sous Sélectionner le dossier à partir de , sélectionnez le fichier Dossiers personnels (.pst), puis sélectionnez Inclure les sous-dossiers.
    7. Sélectionnez Importer des dossiers dans le même dossier, puis sélectionnez vos nouveaux dossiers personnels (.pst).
    8. Sélectionnez Terminer.

Notes

N’oubliez pas que le fichier de sauvegarde était le fichier endommagé d’origine et que vous ne pouvez pas récupérer autre chose que ce qui a été récupéré dans le dossier Perdu et trouvé. Si vous ne pouvez pas importer le fichier Newname.pst dans Outlook, malheureusement vous avez perdu toutes les informations qui ne se trouvent pas dans le dossier Perdu et trouvé.

Comment l’outil de réparation de la boîte de réception valide et corrige les erreurs

ScanPST valide et corrige principalement les erreurs dans les structures de données internes d’un fichier .pst. Le fichier .pst est un fichier de base de données. Par conséquent, les structures telles que BTrees et le nombre de références sont vérifiées et réparées si nécessaire. Ces objets de bas niveau ne connaissent pas les structures de niveau supérieur, telles que les messages, les éléments de calendrier, etc., qui reposent sur elles.

Si ScanPST détermine qu’un bloc spécifique de la structure ou de la table est illisible ou endommagé, ScanPST le supprime. Si ce bloc faisait partie d’un élément spécifique dans Outlook, l’élément est supprimé lorsqu’il est validé.

Vous ne vous attendez peut-être pas à ce comportement, mais la suppression de l’élément est appropriée dans les circonstances. En outre, ce type de situation spécifique est rare et il est toujours entré dans le fichier journal ScanPST.

À un niveau supérieur, les modifications les plus visibles que vous voyez impliquent des dossiers et des messages.

Folders

ScanPST examine chaque dossier dans le fichier .pst et effectue les opérations suivantes :

  1. ScanPST s’assure qu’il existe les tables correctes associées au dossier.
  2. ScanPST vérifie chaque ligne de chaque tableau et vérifie que le message ou le sous-folder existe dans le système.
  3. Si ScanPST ne peut pas trouver le message ou le sous-foldeur, ScanPST supprime la ligne du tableau.
  4. Si ScanPST trouve le message ou le sous-dossier, ScanPST valide le message ou le dossier.
  5. Si cette validation échoue, le message ou le dossier est considéré comme endommagé, et il est supprimé de la table et supprimé de la base de données.
  6. Si la validation réussit, ScanPST fait une autre analyse pour s’assurer que les valeurs de message récupérées sont cohérentes avec les valeurs du tableau. Les dossiers endommagés sont recréés à partir de zéro, si nécessaire. Ces dossiers ne contiennent aucune donnée utilisateur.

Messages

La plupart des utilisateurs seront concernés par les opérations de message, car un élément endommagé est susceptible de provoquer la suppression d’un élément du fichier .pst. ScanPST effectue les opérations suivantes sur les messages :

  1. ScanPST valide de base les tables de pièces jointes et les tables des destinataires. Cette opération ressemble au fonctionnement d’un dossier avec les messages qu’il contient.

  2. Dès que la table des destinataires est validée pour garantir que les destinataires sont correctement formatés, ScanPST effectue toutes les modifications nécessaires pour synchroniser ces contenus de table des destinataires valides avec les propriétés du destinataire du message. ScanPST garantit également que le dossier parent du message fait référence à un dossier valide. Les propriétés de message suivantes sont vérifiées pour s’assurer qu’elles suivent des formats de données valides :

    • PR_MESSAGE_CLASS

      ScanPST vérifie que cette propriété existe. Si la propriété n’existe pas, elle est définie sur IPM. Remarque.

    • PR_MESSAGE_FLAGS

      Chaque indicateur est validé séparément.

    • PR_SUBMIT_FLAGS

      Cette validation ressemble à l’opération pour les indicateurs de message.

    • PR_CLIENT_SUBMIT_TIME

      Si les indicateurs d’soumission indiquent que le message est marqué comme envoyé, cette propriété doit exister. Si les indicateurs d’soumission n’indiquent pas que le message est marqué comme envoyé, l’heure est définie sur Now.

    • PR_SEARCH_KEY

      Cette propriété doit exister. Si la propriété n’est pas présente, un GUID aléatoire est généré pour elle.

    • PR_CREATION_TIME

      Cette propriété doit exister. Si la propriété n’est pas présente, l’heure est définie sur Now.

    • PR_LAST_MODIFICATION_TIME

      Cette propriété doit exister. Si la propriété n’est pas présente, l’heure est définie sur Now.

    • PR_MESSAGE_SIZE

      Les tailles sont recalculées et comparées aux valeurs stockées. Si les tailles diffèrent d’un delta à l’autre, la valeur calculée est écrite.

Aucune validation n’est explicitement effectuée sur les propriétés liées au corps ou sur les propriétés liées au sujet, à l’exception de la validation implicite de bas niveau que cet article traite précédemment. Les propriétés d’affichage des destinataires sont modifiées pour être cohérentes avec la table des destinataires récupérée. Une fois cette opération terminée, d’autres algorithmes sont exécutés pour collecter tous les messages orphelins et les placer dans un dossier Orphelins.

Pour plus d’informations sur les arbre binaires (btrees), voir Un examen approfondi des structures de données.