Certaines règles sont désactivées et vous recevez un message d’erreur lorsque vous essayez de créer ou d’activer des règles dans Outlook

Numéro de la ko d’origine :   886616

Symptômes

Après la mise à niveau vers Office Outlook 2003 (ou version ultérieure), vous remarquerez peut-être que certaines de vos règles sont désactivées et ne peuvent pas être activées. Les autres règles fonctionnent correctement. Si vous essayez d’activer les règles désactivées, vous recevez le message d’erreur suivant :

Une ou plusieurs règles n’ont pas pu être téléchargées vers Exchange serveur et ont été désactivées. Cela peut être dû au fait que certains paramètres ne sont pas pris en charge ou que l’espace est insuffisant pour stocker toutes vos règles.

Cause

  • Boîtes aux lettres Microsoft Exchange Server 2007, Exchange Server 2010 ou Exchange Server 2013

    Ce comportement se produit si les règles qui se produisent dans votre boîte aux lettres dépassent le quota de règles établi pour votre boîte aux lettres. La taille limite des règles pour les boîtes aux lettres Exchange Server 2007 (et ultérieures) a une taille par défaut de 64 Ko par boîte aux lettres. La limite de taille totale des règles est également une limite personnalisable de 256 Ko par boîte aux lettres.

  • Boîtes aux lettres Exchange Server 2003

    Ce comportement se produit si les règles qui se produisent dans votre boîte aux lettres dépassent la taille de 32 kilo-octets (Ko). La limite de taille totale des règles pour les boîtes aux lettres Exchange Server 2003 est de 32 Ko. La limite de règles Exchange 2003 ne peut pas être modifiée.

Dans Outlook 2003 et les ultérieures, la taille des règles a principalement augmenté pour prendre en charge le format Unicode.

Solution de contournement

Si votre boîte aux lettres est Exchange Server 2007 ou une ultérieure, vous pouvez demander à votre administrateur Exchange d’augmenter le quota de règles pour votre boîte aux lettres.

L’exemple de commande suivant définit le quota de règles sur la valeur maximale de 256 Ko.

Set-Mailbox john@contoso.com -RulesQuota:256kb

L’exemple de commande suivant vous permet d’afficher le quota de règles actuel pour une boîte aux lettres.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Si votre administrateur Exchange ne peut pas augmenter le quota de règles pour votre boîte aux lettres, essayez l’une des solutions de contournement suivantes qui s’appliquent à toutes les versions de Exchange.

Pour contourner ce comportement afin que vos règles soient restaurées, utilisez une ou plusieurs des méthodes suivantes pour réduire la taille de vos règles existantes.

Méthode 1

Renommez vos règles sous un nom plus court. Pour renommer une règle dans Outlook, suivez ces étapes.

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie, cliquez sur la règle à renommer.
  4. Cliquez sur Modifier les règles, puis sur Renommer la règle.
  5. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils, cliquez sur Règles et alertes.
  2. Sous l’onglet Règles de messagerie, cliquez sur la règle à renommer.
  3. Dans la liste Modifier la règle, cliquez sur Renommer la règle.
  4. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  5. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Méthode 2

Supprimez les anciennes règles. Pour supprimer une règle dans Outlook, suivez les étapes suivantes :

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie, cliquez sur la règle à renommer.
  4. Cliquez sur le bouton Supprimer, puis sur Oui pour confirmer la suppression.
  5. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils, cliquez sur Règles et alertes.
  2. Sous l’onglet Règles de messagerie, cliquez sur la règle à supprimer.
  3. Cliquez sur Supprimer, puis sur Oui pour confirmer la suppression.
  4. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Méthode 3

Combinez des règles similaires pour réduire la taille globale de vos règles. Si possible, combinez des règles similaires pour réduire la taille globale de vos règles. Une fois que vous avez combiné des règles similaires, supprimez les règles dont vous n’avez plus besoin. Pour modifier une règle existante dans Outlook, suivez ces étapes.

Pour Outlook 2010 et versions ultérieures :

  1. Sous l’onglet Fichier, cliquez sur Informations.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie, cliquez sur la règle à renommer.
  4. Cliquez sur Modifier la règle, puis sur Modifier la règle Paramètres.
  5. Modifiez la règle selon le cas.
  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils, cliquez sur Règles et alertes.

  2. Sous l’onglet Règles de messagerie, cliquez sur la règle à modifier.

  3. Dans la liste Modifier la règle, cliquez sur Modifier la règle Paramètres.

    Modifiez la règle selon le cas.

  4. Lorsque vous avez terminé, cliquez sur Terminer, puis cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Notes

Si la règle est une règle client uniquement, vous devez cliquer deux fois sur OK pour fermer la boîte de dialogue Règles et alertes.

Méthode 4

Déplacez votre fichier de dossiers personnels (.pst) vers un emplacement dont le nom de chemin d’accès est le plus court. Si vous avez des règles qui déplacent des messages électroniques vers un fichier .pst, déplacez votre fichier .pst vers un emplacement dont le nom de chemin d’accès est le plus court possible. Par exemple, déplacez votre fichier .pst vers un emplacement tel que C: \<file_name>.pst. Pour déplacer votre fichier .pst dans Outlook, suivez les étapes suivantes :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur Dossiers personnels ou sur le nom du dossier qui apparaît pour votre fichier .pst, puis cliquez sur Propriétés pour <folder_name>.

    Notes

    Ce dossier sera toujours un dossier de niveau supérieur dans le volet de navigation, dans courrier électronique.

  2. Sous l’onglet Général, cliquez sur Avancé.

  3. Dans la zone de texte Nom de fichier, notez le chemin d’accès complet et le nom de fichier du fichier .pst.

  4. Cliquez deux fois sur OK pour fermer la boîte de<folder_name> Propriétés.

  5. Quittez Outlook.

  6. Utilisez Microsoft Windows Explorer pour déplacer votre fichier .pst vers le nouvel emplacement.

    Par défaut, l’emplacement d’un fichier .pst est le dossier drive:\Documents and \ Paramètres<user_name>\Local Paramètres\Application Data\Microsoft\Outlook. L’emplacement par défaut est un dossier masqué. Pour utiliser Windows Explorer pour localiser ce dossier, vous devez d’abord activer l’affichage des dossiers masqués. Pour cela, procédez comme suit :

    1. Dans Windows Explorer, cliquez sur Options de dossier dans le menu Outils.

    2. Cliquez sur l’onglet Affichage.

    3. Dans la section Avancé Paramètres, cliquez sur Afficher les fichiers et dossiers masqués sous Fichiers et dossiers masqués.

    4. Si vous souhaitez voir toutes les extensions de nom de fichier, cliquez pour effacer la case à cocher Masquer les extensions pour les types de fichiers connus sous Fichiers et dossiers.

      Notes

      Les dossiers masqués apparaissent estommés pour indiquer qu’ils ne sont pas des dossiers classiques.

    5. Cliquez sur OK.

  7. Utilisez l’une des méthodes suivantes pour ouvrir l’élément de courrier dans le Panneau de contrôle :

    • Pour ce faire, sur un ordinateur Windows XP ou sur un ordinateur Windows Server 2003, cliquez sur Démarrer, cliquez sur Panneau de Windows, sur Comptes d’utilisateurs, puis sur Courrier .

      Notes

      Si vous utilisez la vue Classique, cliquez sur Démarrer, cliquez sur Panneau de contrôle, puis double-cliquez sur Courrier.

    • Pour ce faire sur un ordinateur Microsoft Windows 2000, cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de contrôle, puis double-cliquez sur Courrier.

  8. Cliquez sur Afficher les profils, puis cliquez sur le profil qui contient votre fichier .pst.

  9. Cliquez sur Propriétés, puis sur Fichiers de données.

  10. Cliquez sur le fichier de données .pst que vous avez déplacé, puis cliquez sur Paramètres.

  11. Lorsque vous êtes invité à dire que le fichier de données n’est pas trouvé à l’ancien emplacement, cliquez sur OK.

  12. Recherchez, puis cliquez sur votre fichier .pst dans le nouvel emplacement du dossier, puis cliquez sur Ouvrir.

  13. Cliquez sur OK, puis sur Fermer deux fois.

  14. Cliquez sur OK.

  15. Quitter le Panneau de commande.

  16. Redémarrez Outlook.

Méthode 5

Cochez uniquement la case sur cet ordinateur. Si vous utilisez une règle pour déplacer des messages électroniques vers un fichier .pst, cliquez pour effacer la case à cocher sur cet ordinateur uniquement, sauf si vous accédez à votre messagerie Exchange Server à partir de différents ordinateurs clients. Pour ce faire, Outlook, suivez les étapes suivantes :

Pour Outlook 2010 et versions ultérieures :

  1. Sous l’onglet Fichier, cliquez sur Informations.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie, cliquez sur la règle à renommer.
  4. Cliquez sur Modifier la règle, puis sur Modifier la règle Paramètres.
  5. Cliquez pour effacer la case à cocher Sur cet ordinateur uniquement si la case à cocher est cocher.
  6. Terminez l’Assistant Règles. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils, cliquez sur Règles et alertes.

  2. Sous l’onglet Règles de messagerie, cliquez sur la règle à modifier.

  3. Dans la liste Modifier la règle, cliquez sur Modifier la règle Paramètres.

  4. S’il est sélectionné, cliquez pour effacer la case à cocher sur cet ordinateur uniquement.

  5. Terminez l’Assistant Règles.

  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes.

    Notes

    Si vous utilisez des règles client uniquement pointant vers des fichiers de ressources locales, par exemple le déplacement d’éléments vers un dossier dans un fichier .pst, et que vous utilisez plusieurs ordinateurs pour accéder à Microsoft Outlook, des conflits de règles peuvent se produire. Par conséquent, certaines règles client uniquement peuvent être désactivées.