Certaines règles sont désactivées et vous recevez un message d’erreur lorsque vous essayez de créer ou d’activer des règles dans Outlook

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Symptômes

Après la mise à niveau vers Office Outlook 2003 (ou version ultérieure), vous remarquerez peut-être que certaines de vos règles sont désactivées et ne peuvent pas être activées. Les autres règles fonctionnent correctement. Si vous essayez d’activer les règles désactivées, le message d’erreur suivant s’affiche :

Une ou plusieurs règles n’ont pas pu être chargées sur le serveur Exchange et ont été désactivées. Cela peut être dû au fait que certains paramètres ne sont pas pris en charge ou qu’il n’y a pas suffisamment d’espace pour stocker toutes vos règles.

Cause

  • Boîtes aux lettres Microsoft Exchange Server 2007, Exchange Server 2010 ou Exchange Server 2013

    Ce comportement se produit si les règles qui se trouvent dans votre boîte aux lettres dépassent le quota de règles établi pour votre boîte aux lettres. La taille limite des règles pour les boîtes aux lettres dans Exchange Server 2007 (et versions ultérieures) a une taille par défaut de 64 Ko par boîte aux lettres. La limite de taille totale des règles est également personnalisable jusqu’à 256 Ko par boîte aux lettres.

  • Boîtes aux lettres Exchange Server 2003

    Ce comportement se produit si les règles qui se trouvent dans votre boîte aux lettres dépassent une taille de 32 kilo-octets (Ko). La limite de taille totale des règles pour les boîtes aux lettres sur Exchange Server 2003 est de 32 Ko. La limite de règles pour Exchange 2003 ne peut pas être modifiée.

Dans Outlook 2003 et versions ultérieures, la taille des règles a augmenté principalement pour assurer la prise en charge du format Unicode.

Solution de contournement

Si votre boîte aux lettres se trouve sur Exchange Server 2007 ou version ultérieure, vous pouvez demander à votre administrateur Exchange d’augmenter le quota de règles pour votre boîte aux lettres.

L’exemple de commande suivant définit le quota de règles sur la valeur maximale de 256 Ko.

Set-Mailbox john@contoso.com -RulesQuota:256kb

L’exemple de commande suivant vous permet d’afficher le quota de règles en cours pour une boîte aux lettres.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Si votre administrateur Exchange ne peut pas augmenter le quota de règles pour votre boîte aux lettres, essayez l’une des solutions de contournement suivantes qui s’appliquent à toutes les versions d’Exchange.

Pour contourner ce comportement afin que vos règles soient restaurées, utilisez une ou plusieurs des méthodes suivantes pour réduire la taille de vos règles existantes.

Méthode 1

Renommez vos règles en nom plus court. Pour renommer une règle dans Outlook, procédez comme suit.

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur Modifier les règles, puis sur Renommer la règle.
  5. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur Règles et alertes.
  2. Sous l’onglet Règles de messagerie , cliquez sur la règle que vous souhaitez renommer.
  3. Dans la liste Modifier la règle , cliquez sur Renommer la règle.
  4. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  5. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Méthode 2

Supprimez les anciennes règles. Pour supprimer une règle dans Outlook, procédez comme suit :

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur le bouton Supprimer , puis sur Oui pour confirmer la suppression.
  5. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur Règles et alertes.
  2. Sous l’onglet Règles de messagerie , cliquez sur la règle à supprimer.
  3. Cliquez sur Supprimer, puis sur Oui pour confirmer la suppression.
  4. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Méthode 3

Combinez des règles similaires pour réduire la taille globale de vos règles. Si possible, combinez des règles similaires pour réduire la taille globale de vos règles. Une fois que vous avez combiné des règles similaires, supprimez les règles dont vous n’avez plus besoin. Pour modifier une règle existante dans Outlook, procédez comme suit.

Pour Outlook 2010 et versions ultérieures :

  1. Sous l’onglet Fichier , cliquez sur Informations.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur Modifier la règle, puis sur Modifier les paramètres de la règle.
  5. Modifiez la règle comme il convient.
  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur Règles et alertes.

  2. Sous l’onglet Règles de messagerie , cliquez sur la règle à modifier.

  3. Dans la liste Modifier la règle , cliquez sur Modifier les paramètres de la règle.

    Modifiez la règle comme il convient.

  4. Lorsque vous avez terminé, cliquez sur Terminer, puis sur OK pour fermer la boîte de dialogue Règles et alertes .

Remarque

Si la règle est une règle cliente uniquement, vous devez cliquer deux fois sur OK pour fermer la boîte de dialogue Règles et alertes .

Méthode 4

Déplacez votre fichier de dossiers personnels (.pst) vers un emplacement qui a le nom de chemin d’accès le plus court. Si vous avez des règles qui déplacent les messages électroniques vers un fichier .pst, déplacez votre fichier .pst vers un emplacement qui a le nom de chemin d’accès le plus court possible. Par exemple, déplacez votre fichier .pst vers un emplacement tel que C :\<file_name.pst>. Pour déplacer votre fichier .pst dans Outlook, procédez comme suit :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur Dossiers personnels ou sur le nom du dossier qui s’affiche pour votre fichier .pst, puis cliquez sur Propriétés pour <folder_name>.

    Remarque

    Ce dossier sera toujours un dossier de niveau supérieur dans le volet de navigation, dans Courrier.

  2. Sous l’onglet Général , cliquez sur Avancé.

  3. Dans la zone de texte Nom de fichier, notez le chemin d’accès complet et le nom de fichier du fichier .pst.

  4. Cliquez deux fois sur OK pour fermer la <boîte de dialogue Propriétés folder_name>.

  5. Quittez Outlook.

  6. Utilisez Microsoft Windows Explorer pour déplacer votre fichier .pst vers le nouvel emplacement.

    Par défaut, l’emplacement d’un fichier .pst est le dossier drive :\Documents and Settings\<user_name>\Local Settings\Application Data\Microsoft\Outlook. L’emplacement par défaut est un dossier masqué. Pour utiliser Windows Explorer pour localiser ce dossier, vous devez d’abord activer l’affichage des dossiers masqués. Pour cela, procédez comme suit :

    1. Dans Windows Explorer, cliquez sur Options des dossiers dans le menu Outils.

    2. Cliquez sur l’onglet Affichage .

    3. Dans la section Paramètres avancés , cliquez sur Afficher les fichiers et dossiers masqués sous Fichiers et dossiers masqués.

    4. Si vous souhaitez voir toutes les extensions de nom de fichier, cliquez pour effacer la zone Masquer les extensions pour les types de fichiers connus case activée sous Fichiers et dossiers.

      Remarque

      Les dossiers masqués apparaissent grisés pour indiquer qu’ils ne sont pas des dossiers classiques.

    5. Cliquez sur OK.

  7. Utilisez l’une des méthodes suivantes pour ouvrir l’élément de courrier dans Panneau de configuration :

    • Pour ce faire sur un ordinateur Windows XP ou sur un ordinateur Windows Server 2003, cliquez sur Démarrer, sur Panneau de configuration, sur Comptes d’utilisateur, puis sur Courrier.

      Remarque

      Si vous utilisez l’affichage classique, cliquez sur Démarrer, sur Panneau de configuration, puis double-cliquez sur Courrier.

    • Pour ce faire, sur un ordinateur Microsoft Windows 2000, cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Courrier.

  8. Cliquez sur Afficher les profils, puis sur le profil qui contient votre fichier .pst.

  9. Cliquez sur Propriétés, puis sur Fichiers de données.

  10. Cliquez sur le fichier de données .pst que vous avez déplacé, puis cliquez sur Paramètres.

  11. Lorsque vous êtes invité à indiquer que le fichier de données est introuvable à l’ancien emplacement, cliquez sur OK.

  12. Recherchez et cliquez sur votre fichier .pst dans le nouvel emplacement du dossier, puis cliquez sur Ouvrir.

  13. Cliquez sur OK, puis sur Fermer deux fois.

  14. Cliquez sur OK.

  15. Quittez Panneau de configuration.

  16. Redémarrez Outlook.

Méthode 5

Décochez la case sur cet ordinateur uniquement case activée. Si vous utilisez une règle pour déplacer des messages électroniques vers un fichier .pst, cliquez pour décochez la case sur cet ordinateur uniquement case activée, sauf si vous accédez à votre Exchange Server courrier électronique à partir de différents ordinateurs clients. Pour ce faire dans Outlook, procédez comme suit :

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur Gérer les règles et les alertes.
  3. Sous l’onglet Règles de messagerie , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur Modifier la règle, puis sur Modifier les paramètres de la règle.
  5. Désactivez la case Sur cet ordinateur uniquement case activée si la zone case activée est sélectionnée.
  6. Terminez l’Assistant Règles. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur Règles et alertes.

  2. Sous l’onglet Règles de messagerie , cliquez sur la règle à modifier.

  3. Dans la liste Modifier la règle , cliquez sur Modifier les paramètres de la règle.

  4. Si cette option est sélectionnée, cliquez pour effacer la case sur cet ordinateur uniquement case activée.

  5. Terminez l’Assistant Règles.

  6. Cliquez sur OK pour fermer la boîte de dialogue Règles et alertes .

    Remarque

    Si vous utilisez des règles client uniquement qui pointent vers des fichiers de ressources locaux, par exemple le déplacement d’éléments vers un dossier dans un fichier .pst, et que vous utilisez plusieurs ordinateurs pour accéder à Microsoft Outlook, des conflits de règles peuvent se produire. Par conséquent, certaines règles client uniquement peuvent être désactivées.