Comment les administrateurs système peuvent résoudre une erreur HTTP 404 - Message d’erreur de fichier in trouvé sur un serveur exécutant IIS

Cet article vous aide à résoudre le problème où le fichier d’erreur HTTP 404 n’a pas été trouvé sur un serveur exécutant Internet Information Services (IIS).

Notes

Cet article est destiné aux administrateurs de sites Web. Les utilisateurs finaux qui rencontrent ces erreurs doivent informer l’administrateur du site Web du problème.

Version du produit d’origine :   Internet Information Services
Numéro de la ko d’origine :   248033

Symptômes

Lorsqu’une page Web est demandée, vous recevez le message d’erreur suivant en haut du navigateur Web :

La page est indessable
La page que vous recherchez a peut-être été supprimée, son nom a été modifié ou est temporairement indisponible.

Vous recevez le message d’erreur suivant plus bas sur la page Web :

HTTP 404 - Fichier in trouvé
Services Internet (IIS)

Cause

Le serveur Web renvoie le message d’erreur HTTP 404 - Fichier in trouvé lorsqu’il ne peut pas récupérer la page demandée.

Voici quelques causes courantes de ce message d’erreur :

  • Le fichier demandé a été renommé.
  • Le fichier demandé a été déplacé vers un autre emplacement et/ou supprimé.
  • Le fichier demandé est temporairement indisponible en raison de la maintenance, des mises à niveau ou d’autres causes inconnues.
  • Le fichier demandé n’existe pas.
  • IIS 6.0 : l’extension de service Web ou le type MIME approprié n’est pas activé.
  • Un répertoire virtuel est mappé à la racine d’un lecteur sur un autre serveur.

Résolution

Pour résoudre ce problème, vérifiez que le fichier demandé dans l’URL du navigateur existe sur l’ordinateur IIS et qu’il se trouve à l’emplacement correct.

Utilisez le logiciel en snap-in MMC (Microsoft Management Console) IIS pour déterminer où le fichier demandé doit exister dans le système de fichiers de l’ordinateur IIS.

Ceci est important si le site Web utilise un répertoire virtuel (VDIR). Un VDIR est un répertoire qui n’est pas contenu dans le répertoire d’accueil du site Web, mais qui apparaît dans le navigateur client comme s’il le fait. Ce répertoire virtuel doit être mappé à un sous-dossier sur un lecteur ou référencer les fichiers par leur nom.

Par exemple, supposons que l’URL à l’origine de l’erreur 404 soit , et que le logiciel en snap-in IIS indique que pour le site Web Microsoft.Com, le répertoire /Test/ est en fait un répertoire virtuel qui maie l’emplacement de c:\Information sur l’ordinateur http://Microsoft.Com/Test/File1.htm IIS. Cela signifie que vous devez vérifier que le fichier File1.htm est situé dans le répertoire c:\Information (et que le nom du fichier est correctement orthographé).

Contenu dynamique IIS : une entrée 404.2 dans le fichier journal étendu W3C est enregistrée lorsqu’une extension Web n’est pas activée. Utilisez le logiciel en snap-in MMC (Microsoft Management Console) IIS pour activer l’extension Web appropriée. Les extensions web par défaut sont les suivantes : ASP, ASP.NET, Server-Side Includes, La publication WebDAV, Extensions serveur FrontPage, Interface passerelle commune (CGI). Les extensions personnalisées doivent être ajoutées et explicitement activées. Pour plus d’informations, voir le fichier d’aide IIS.

Contenu statique IIS : une entrée 404.3 dans le fichier journal étendu W3C est enregistrée lorsqu’une extension n’est pas mappée sur une extension connue dans la propriété MIME Map. Utilisez le logiciel enfichable MMC (Microsoft Management Console) IIS pour configurer l’extension appropriée dans la carte MIME. Pour plus d’informations, voir le fichier d’aide IIS.

Pour plus d’informations sur les autres causes moins courantes de ce message d’erreur, voir les fichiers statiques masqués IIS renvoyer les erreurs HTTP 404ou Accès refusé.

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