Erreur 3266 ou 3013 lorsque vous effectuez une sauvegarde de base de données sur un disque ou une bande ou une restauration de base de données à partir d’un disque ou d’une bande

Cet article fournit une aide pour résoudre l’erreur 3266 ou 3013 qui se produit lorsque vous effectuez une sauvegarde de base de données sur un disque ou une bande ou une restauration de base de données à partir d’un disque ou d’une bande.

Version du produit d’origine :   Windows Server 2012 R2
Numéro de la base de connaissances initiale :   290787

Symptômes

Lorsque vous effectuez une sauvegarde de base de données sur un disque ou une bande, ou une restauration à partir d’un disque ou d’une bande, le message d’erreur suivant peut s’afficher :

Serveur SQL Server 7,0 :

MSG 3266, niveau 16, état 1, ligne 1
La base de données logicielle Microsoft Tape Format (MTF) sur l’unité de sauvegarde’nom_périphérique’ne peut pas être lue, ce qui empêche l’accès aléatoire.
Serveur : MSG 3013, niveau 16, état 1, ligne 1
L’opération de sauvegarde ou de restauration a été arrêtée de manière anormale.

Serveur SQL Server 2000 :

MSG 3266, niveau 16, état 1, ligne 1
La mise en forme des données de sauvegarde dans’DeviceName’est incorrecte. Les sauvegardes ne peuvent pas être ajoutées, mais les jeux de sauvegarde existants peuvent toujours être utilisables.
Serveur : MSG 3013, niveau 16, état 1, ligne 1
La base de données de sauvegarde se termine anormalement.

Serveur SQL Server 2005 :

MSG 3013, niveau 16, état 1, ligne 1
La mise en forme des données de sauvegarde à la fin de « nom_périphérique » est incorrecte. Les jeux de sauvegarde sur le support peuvent être endommagés et inutilisables. Pour déterminer les jeux de sauvegarde sur le support, utilisez RESTORE HEADERONLY. Pour déterminer la convivialité des jeux de sauvegarde, exécutez RESTORE VERIFYONLY. Si tous les jeux de sauvegarde sont incomplets, reformatez le média à l’aide de BACKUP WITH FORMAT, qui détruit tous les jeux de sauvegarde.
Serveur : MSG 3013, niveau 16, état 1, ligne 1

La base de données de sauvegarde se termine anormalement.

Cause

Une marque de la marque dans l’unité de sauvegarde n’a pas pu être lue. Il existe de nombreuses raisons pour lesquelles vous pouvez rencontrer une erreur de la marque. Voici quelques-unes des causes possibles :

  • Une panne de support peut se produire sur l’appareil où se trouve la sauvegarde.

  • Un échec d’écriture peut se produire pendant la création de la sauvegarde.

    Par exemple, une perte de connectivité peut se produire pendant une sauvegarde réseau. Ou, une défaillance du chemin e/s pour vider l’écriture sur le disque peut se produire après que l’écriture sur le disque a été signalée à SQL Server comme étant réussie.

Solution de contournement

Pour permettre à SQL Server d’effectuer de nouvelles sauvegardes sur l’appareil de sauvegarde, vous devez manuellement supprimer ou effacer l’appareil à l’aide de la commande suivante :

BACKUP DATABASE mydatabase TO DISK='C:\MyDatabase.bak' with FORMAT

Si le message d’erreur se produit pendant une opération de restauration, il est possible de récupérer d’autres jeux de sauvegarde à partir de l’appareil en spécifiant le numéro de fichier. Par exemple, si trois (3) sauvegardes se trouvaient sur un (1) périphérique de sauvegarde, les jeux de sauvegarde 1 et 2 peuvent être utilisables. Pour déterminer si plusieurs jeux de sauvegarde sont sur un appareil, exécutez le code suivant à partir de l’analyseur de requêtes :

RESTORE HEADERONLY FROM DISK='C:\MyDatabase.bak'

Chaque jeu de sauvegarde comporte une entrée dans la sortie. Pour indiquer un jeu de sauvegarde spécifique, utilisez le code suivant :

RESTORE DATABASE mydatabase FROM DISK='C:\MyDatabase.bak WITH FILE = FileNumber

Notes

FileNumber est le numéro du jeu de sauvegarde que vous souhaitez restaurer.

Informations supplémentaires

La liste suivante contient des remarques importantes concernant les sauvegardes et SQL Server.

  • Une fois que SQL Server a détecté une erreur de recherche de marque sur un appareil, SQL Server n’écrit pas d’informations supplémentaires sur l’appareil.

  • SQL Server stocke toutes les sauvegardes au format Microsoft Tape Format, que la sauvegarde soit effectuée sur disque ou sur bande. Le format Microsoft Tape utilise les marques de données pour conserver des informations telles que la taille du bloc et le nombre de blocs dans une sauvegarde, ainsi que d’autres informations sur la sauvegarde. Le format Microsoft Tape utilise également des marques de sauvegarde pour délimiter les sauvegardes dans un périphérique de sauvegarde. Le fait qu’une marque de page est manquante ou endommagée suggère qu’au moins une sauvegarde sur l’appareil n’est pas valide.

  • Bien que vous puissiez restaurer certains jeux de sauvegarde à partir de l’appareil endommagé, vous devez vérifier l’intégrité de la base de données restaurée.

  • SQL Server enregistre les détails de la réussite ou de l’échec lors d’une opération de sauvegarde ou d’une opération de restauration dans le journal des erreurs SQL Server et dans les tables d’historique de sauvegarde de la base de données système msdb.

  • Si vous êtes confronté à une erreur 3266 lorsque vous restaurez un journal des transactions ou une sauvegarde de base de données, recherchez des informations supplémentaires dans les journaux suivants :

    • Journal des erreurs SQL Server
    • Tables d’historique de sauvegarde et de restauration
    • Journal des événements d’application
    • Journal des événements système

S’il n’y a pas de détails sur l’échec dans ces journaux, il se peut que vous rencontriez une erreur non signalée. Si vous avez besoin d’aide, contactez les services de support technique Microsoft.