Présentation des requêtes dans Power BI DesktopQuery overview in Power BI Desktop

Avec Power BI Desktop, vous pouvez vous connecter à tout un monde de données, créer des rapports attrayants et fondamentaux, puis les partager avec d’autres utilisateurs, qui peuvent ensuite s’appuyer sur votre travail pour développer leurs talents en matière de décisionnel.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop propose trois vues :Power BI Desktop has three views:

  • La vue Rapport : c’est là où vous utilisez des requêtes que vous avez créées pour générer des visualisations attrayantes, organisées comme vous souhaitez qu’elles apparaissent et avec plusieurs pages, que vous pouvez partager avec d’autres utilisateurs.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • La vue Données : elle vous permet de consulter les données de votre rapport dans un format de modèle de données, où vous pouvez ajouter des mesures, créer des colonnes et gérer les relations.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • La vue Relations : elle vous permet d’obtenir une représentation graphique des relations qui ont été définies dans votre modèle de données et de les gérer ou de les modifier si nécessaire.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Accédez à ces vues en sélectionnant l’une des trois icônes affichées sur le côté gauche de Power BI Desktop.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Dans l’image suivante, la vue Rapport est sélectionnée, indiqué par la bande jaune à côté de l’icône.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop vient aussi avec l’Éditeur Power Query.Power BI Desktop also comes with Power Query Editor. Utilisez l’Éditeur Power Query pour vous connecter à une ou plusieurs sources de données, modeler et transformer les données en fonction de vos besoins, puis charger ce modèle dans Power BI Desktop.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Ce document fournit une vue d’ensemble de l’utilisation des données dans l’Éditeur Power Query, mais vous pouvez en apprendre plus.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. À la fin de ce document, vous trouverez des liens vers des instructions détaillées sur les types de données pris en charge.At the end of this document, you’ll find links to detailed guidance about supported data types. Vous y trouverez également des conseils sur la connexion aux données, la mise en forme des données, la création de relations et comment démarrer.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Mais tout d’abord, nous allons nous familiariser avec l’Éditeur Power Query.But first, let’s see get acquainted with Power Query Editor.

Éditeur Power QueryPower Query Editor

Pour accéder à l’Éditeur Power Query, sélectionnez Modifier les requêtes sous l’onglet Accueil de Power BI Desktop.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Sans connexion de données, l’Éditeur Power Query se présente sous la forme d’un volet vide, prêt à accueillir des données.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Une fois qu’une requête est chargée, la vue de l’Éditeur Power Query devient plus intéressante.Once a query is loaded, Power Query Editor view becomes more interesting. Si nous nous connectons à la source de données web suivante, l’Éditeur Power Query charge des informations sur les données, que nous pouvons commencer à mettre en forme.If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Voici à quoi ressemble l’Éditeur Power Query une fois qu’une connexion de données est établie :Here’s how Power Query Editor appears once a data connection is established:

  1. Dans le ruban, de nombreux boutons sont maintenant actifs pour interagir avec les données de la requête.In the ribbon, many buttons are now active to interact with the data in the query.

  2. Dans le volet gauche, les requêtes sont listées et disponibles pour être sélectionnées, consultées et mises en forme.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. Dans le volet central, les données de la requête sélectionnée sont affichées et prêtes à être mises en forme.In the center pane, data from the selected query is displayed and available for shaping.

  4. Le volet Paramètres d’une requête s’affiche et liste les propriétés et les étapes appliquées de la requête.The Query Settings pane appears, listing the query’s properties and applied steps.

Nous allons examiner chacune de ces quatre zones : le ruban, le volet des requêtes, la vue des données et le volet Paramètres d’une requête.We’ll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Ruban de la vue RequêteThe query ribbon

Le ruban de l’Éditeur Power Query se compose de quatre onglets : Accueil, Transformer, Ajouter une colonne et Affichage.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

L’onglet Accueil contient les tâches de requête courantes.The Home tab contains the common query tasks.

Pour vous connecter à des données et démarrer le processus de création d’une requête, sélectionnez Nouvelle source.To connect to data and begin the query building process, select New Source. Un menu s’affiche, proposant les sources de données les plus courantes.A menu appears, providing the most common data sources.

Pour plus d’informations sur les sources de données disponibles, consultez Sources de données.For more information about available data sources, see Data Sources. Pour obtenir plus d’informations sur la connexion à des données, ainsi que des exemples et des étapes, consultez Se connecter à des données.For information about connecting to data, including examples and steps, see Connect to Data.

L’onglet Transformer donne accès à des tâches de transformation de données courantes, telles que :The Transform tab provides access to common data transformation tasks, such as:

  • Ajout ou suppression de colonnesAdding or removing columns
  • Changement de types de donnéesChanging data types
  • Fractionnement de colonnesSplitting columns
  • Autres tâches pilotées par les donnéesOther data-driven tasks

Pour plus d’informations sur la transformation des données, notamment des exemples, consultez Tutoriel : Mettre en forme et combiner des données dans Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

L’onglet Ajouter une colonne offre des tâches supplémentaires associées à l’ajout de colonne, à la mise en forme des données d’une colonne et à l’ajout de colonnes personnalisées.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. L’image suivante montre l’onglet Ajouter une colonne .The following image shows the Add Column tab.

L’onglet Affichage du ruban permet d’afficher ou de masquer certains volets ou fenêtres.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Il est également utilisé pour afficher l’Éditeur avancé.It’s also used to display the Advanced Editor. L’image suivante montre l’onglet Affichage.The following image shows the View tab.

Le saviez-vous ? De nombreuses tâches disponibles à partir du ruban sont également accessibles dans le volet central en cliquant avec le bouton droit sur une colonne ou sur des données.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Volet gauche (Requêtes)The left (Queries) pane

Le volet gauche, ou volet Requêtes, affiche le nombre de requêtes actives et le nom de la requête.The left pane, or Queries pane, displays the number of active queries and the name of the query. Quand vous sélectionnez une requête dans le volet gauche, ses données sont affichées dans le volet central, où vous pouvez mettre en forme et transformer les données à votre guise.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. L’image suivante montre le volet gauche avec une requête.The following image shows the left pane with a query.

Volet central (Données)The center (Data) pane

Le volet central, ou volet Données, affiche les données de la requête sélectionnée.In the center pane, or Data pane, data from the selected query is displayed. Ce volet est l’endroit où le gros du travail de la vue Requête est effectué.This pane is where much of the work of the Query view is accomplished.

L’image suivante montre la connexion de données web établie précédemment.In the following image shows the Web data connection established earlier. La colonne Produit est sélectionnée et son en-tête montre les éléments de menu disponibles quand vous cliquez dessus avec le bouton droit.The Product column is selected, and its header is right-clicked to show the available menu items. Notez que la plupart de ces éléments de menu contextuel correspondent à des boutons des onglets du ruban.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Quand vous sélectionnez un élément de menu contextuel (ou un bouton de ruban) obtenu par clic droit, la requête applique l’étape aux données.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Elle enregistre également l’étape en tant que partie d’elle-même.It also saves step as part of the query itself. Les étapes sont enregistrées séquentiellement dans le volet Paramètres d’une requête , comme décrit dans la section suivante.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Volet droit (Paramètres d’une requête)The right (Query Settings) pane

Le volet droit, ou volet Paramètres d’une requête affiche toutes les étapes associées à une requête.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Par exemple, dans l’image suivante, la section Étapes appliquées du volet Paramètres d’une requête reflète le fait que nous venons de modifier le type de la colonne Overall score (Score global).For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

À mesure que d’autres étapes de mise en forme sont appliquées à la requête, elles sont capturées dans la section Étapes appliquées.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Il est important de savoir que les données sous-jacentes ne sont pas modifiées.It’s important to know that the underlying data isn't changed. À la place, l’Éditeur Power Query ajuste et met en forme sa vue des données.Rather, Power Query Editor adjusts and shapes its view of the data. Il met également en forme et ajuste la vue de toute interaction avec les données sous-jacentes qui se produit en fonction de sa vue mise en forme et modifiée de ces données.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor’s shaped and modified view of that data.

Dans le volet Paramètres d’une requête , vous pouvez renommer des étapes, supprimer des étapes ou réorganiser les étapes comme vous le souhaitez.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Pour ce faire, cliquez avec le bouton droit sur l’étape dans la section Étapes appliquées , puis choisissez une option dans le menu qui s’affiche.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Toutes les étapes de la requête sont effectuées dans l’ordre de leur apparition dans le volet Étapes appliquées.All query steps are carried out in the order they appear in the Applied Steps pane.

Éditeur avancéAdvanced Editor

L’Éditeur avancé vous permet de voir le code que l’Éditeur Power Query crée à chaque étape.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Il vous permet aussi de créer votre propre code de mise en forme.It also lets you create your own shaping code. Pour lancer l’Éditeur avancé, sélectionnez Affichage dans le ruban, puis sélectionnez Éditeur avancé.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Une fenêtre apparaît, affichant le code de requête existant.A window appears, showing the existing query code.

Vous pouvez modifier le code directement dans la fenêtre Éditeur avancé .You can directly edit the code in the Advanced Editor window. Pour fermer la fenêtre, cliquez sur le bouton Terminé ou Annuler .To close the window, select the Done or Cancel button.

Enregistrement de votre travailSaving your work

Quand votre requête se trouve là où vous voulez, sélectionnez Fermer et appliquer dans le menu Fichier de l’Éditeur Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Cette action applique les modifications et ferme l’éditeur.This action applies the changes and closes the editor.

À chaque étape, Power BI Desktop affiche une boîte de dialogue pour afficher l’état de la progression.As progress is made, Power BI Desktop provides a dialog to display its status.

Quand vous êtes prêt, Power BI Desktop peut enregistrer votre travail sous la forme d’un fichier .pbix.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Pour enregistrer votre travail, sélectionnez Fichier > Enregistrer (ou Fichier > Enregistrer sous), comme illustré dans l’image suivante.To save your work, select File > Save (or File > Save As), as shown in the following image.

Étapes suivantesNext steps

Power BI Desktop vous permet d’effectuer des tâches très diverses.There are all sorts of things you can do with Power BI Desktop. Pour plus d’informations sur ses fonctionnalités, passez en revue les ressources suivantes :For more information on its capabilities, check out the following resources: