Erreur lors de l’ouverture d’un fichier dans Teams : Vous n’avez pas accès à ce fichier

Symptômes

Dans Microsoft Teams, vous partagez un fichier avec un autre utilisateur dans une fenêtre de conversation. Ensuite, le fichier est automatiquement stocké sur votre site OneDrive. Lorsque l’autre utilisateur tente d’ouvrir le fichier dans Teams, le message d’erreur suivant apparaît :

Vous n’avez pas accès à ce fichier.

Cause

Ce problème survient parce que la fonctionnalité Mode de verrouillage des autorisations d’utilisateur ayant un accès limité est activée sur votre site OneDrive. Il s’agit d’une fonctionnalité de collection de sites qui permet d’empêcher les utilisateurs anonymes d’accéder à des pages d’application principalement utiles sur les sites SharePoint classiques basés sur la publication. Nous vous recommandons de ne pas activer cette fonctionnalité sur les sites OneDrive.

Résolution

Pour corriger ce problème, désactivez cette fonctionnalité dans OneDrive.

  1. Connectez-vous à votre site OneDrive.
  2. Sélectionnez l’icône Paramètre dans le coin supérieur droit de l’écran.
  3. Sélectionnez Paramètres OneDrive>Autres paramètres.
  4. Sous Fonctionnalités et stockage, sélectionnez Fonctionnalités des collections de sites.
  5. Recherchez Mode de verrouillage des autorisations d’utilisateur ayant un accès limité, puis sélectionnez Désactiver.

Pour plus d’informations sur le Mode de verrouillage des autorisations d’utilisateur ayant un accès limité, consultez l’article Activer ou désactiver des fonctionnalités de collection de sites.

Exécuter un outil de diagnostic autonome

Les utilisateurs administrateurs de Microsoft 365 ont accès aux diagnostics qui peuvent être exécutés au sein du client pour vérifier les problèmes éventuels dʼaccès aux fichiers partagés dans la conversation Teams.

Remarque

Cette fonctionnalité nʼest pas disponible pour Microsoft 365 Secteur Public, Microsoft 365 géré par 21Vianet ou Microsoft 365 Allemagne.

Sélectionnez Exécuter les tests ci-dessous, ce qui fera apparaître le diagnostic dans le centre Administration Microsoft 365.

Le diagnostic effectue un grand nombre de vérifications.

Besoin d’une aide supplémentaire ?

Vous pouvez obtenir de l’aide de la communauté en ligne Microsoft Community, rechercher des informations supplémentaires sur le site Support Microsoft ou Aide et formation sur Office, ou encore obtenir plus d’informations sur les options de support assisté.