Intégrer des applications avec écran 3270 sur des mainframes IBM avec Azure à l’aide d’Azure Logic Apps et du connecteur IBM 3270Integrate 3270 screen-driven apps on IBM mainframes with Azure by using Azure Logic Apps and IBM 3270 connector

Notes

Ce connecteur est en préversion publique.This connector is in public preview.

Avec Azure Logic Apps et le connecteur IBM 3270, vous pouvez atteindre et exécuter des applications mainframe IBM que vous pilotez généralement en parcourant les écrans de l’émulateur 3270.With Azure Logic Apps and the IBM 3270 connector, you can access and run IBM mainframe apps that you usually drive by navigating through 3270 emulator screens. De cette façon, vous pouvez intégrer vos applications mainframe IBM avec Azure, Microsoft et d’autres applications, services et systèmes en créant des workflows automatisés avec Azure Logic Apps.That way, you can integrate your IBM mainframe apps with Azure, Microsoft, and other apps, services, and systems by creating automated workflows with Azure Logic Apps. Le connecteur communique avec les mainframes IBM en utilisant le protocole TN3270. De plus, il est disponible dans toutes les régions Azure Logic Apps à l’exception d’Azure Government et Azure China 21Vianet.The connector communicates with IBM mainframes by using the TN3270 protocol and is available in all Azure Logic Apps regions except for Azure Government and Azure China 21Vianet. Si vous débutez avec les applications logiques, consultez Qu’est-ce qu’Azure Logic Apps ?If you're new to logic apps, review What is Azure Logic Apps?

Cet article décrit les aspects suivants relatifs à l’utilisation du connecteur 3270 :This article describes these aspects for using the 3270 connector:

  • Pourquoi utiliser le connecteur IBM 3270 dans Azure Logic Apps et comment le connecteur exécute des applications avec écran 3270Why use the IBM 3270 connector in Azure Logic Apps and how the connector runs 3270 screen-driven apps

  • Prérequis et configuration lors de l’utilisation du connecteur 3270The prerequisites and setup for using the 3270 connector

  • Étapes pour l’ajout d’actions de connecteur 3270 à votre application logiqueThe steps for adding 3270 connector actions to your logic app

Pourquoi utiliser ce connecteurWhy use this connector?

Pour accéder aux applications sur des mainframes IBM, vous utilisez généralement un émulateur de terminal 3270, souvent appelé « écran vert ».To access apps on IBM mainframes, you typically use a 3270 terminal emulator, often called a "green screen". Cette méthode est un moyen éprouvé mais qui a des limitations.This method is a time-tested way but has limitations. Bien que HIS (Host Integration Server) vous permette de travailler directement avec ces applications, il n’est parfois pas possible de séparer l’écran et la logique métier.Although Host Integration Server (HIS) helps you work directly with these apps, sometimes, separating the screen and business logic might not be possible. Ou il se peut que vous n’ayez plus d’informations sur le fonctionnement des applications hôtes.Or, maybe you no longer have information for how the host applications work.

Pour étendre ces scénarios, le connecteur IBM 3270 dans Azure Logic Apps fonctionne avec l’outil de conception 3270, que vous utilisez pour enregistrer, ou « capturer », les écrans d’hôte utilisés pour une tâche spécifique, définir le flux de navigation pour cette tâche via votre application mainframe et définir les méthodes avec des paramètres d’entrée et de sortie pour cette tâche.To extend these scenarios, the IBM 3270 connector in Azure Logic Apps works with the 3270 Design Tool, which you use to record, or "capture", the host screens used for a specific task, define the navigation flow for that task through your mainframe app, and define the methods with input and output parameters for that task. L’outil de conception convertit ces informations en métadonnées que le connecteur 3270 utilise lors de l’appel d’une action qui représente cette tâche à partir de votre application logique.The design tool converts that information into metadata that the 3270 connector uses when calling an action that represents that task from your logic app.

Une fois que vous avez généré le fichier de métadonnées à partir de l’outil de conception, vous ajoutez ce fichier à un compte d’intégration dans Azure.After you generate the metadata file from the design tool, you add that file to an integration account in Azure. De cette façon, votre application logique peut accéder aux métadonnées de votre application lorsque vous ajoutez une action de connecteur 3270.That way, your logic app can access your app's metadata when you add a 3270 connector action. Le connecteur lit le fichier de métadonnées à partir de votre compte d’intégration, gère la navigation à travers les écrans 3270 et présente dynamiquement les paramètres pour l’action de connecteur 3270.The connector reads the metadata file from your integration account, handles navigation through the 3270 screens, and dynamically presents the parameters for the 3270 connector action. Vous pouvez ensuite fournir des données à l’application hôte et le connecteur retourne les résultats à votre application logique.You can then provide data to the host application, and the connector returns the results to your logic app. De cette façon, vous pouvez intégrer vos applications héritées avec Azure, Microsoft et d’autres applications, services et systèmes pris en charge par Azure Logic Apps.That way, you can integrate your legacy apps with Azure, Microsoft, and other apps, services, and systems that Azure Logic Apps supports.

PrérequisPrerequisites

  • Un abonnement Azure.An Azure subscription. Si vous n’avez pas d’abonnement Azure, inscrivez-vous pour bénéficier d’un compte Azure gratuit.If you don't have an Azure subscription, sign up for a free Azure account.

  • Des connaissances de base en création d’applications logiquesBasic knowledge about how to create logic apps

  • Recommandé : Environnement de service d’intégrationRecommended: An integration service environment (ISE)

    Vous pouvez sélectionner cet environnement en tant qu’emplacement de création et d’exécution de votre application logique.You can select this environment as the location for creating and running your logic app. Une environnement de service d’intégration permet d’accéder à partir de votre application logique à des ressources qui sont protégées à l’intérieur des réseaux virtuels Azure.An ISE provides access from your logic app to resources that are protected inside Azure virtual networks.

  • Application logique à utiliser pour l’automatisation et l’exécution de votre application contrôlée par écran 3270The logic app to use for automating and running your 3270 screen-driven app

    Comme le connecteur IBM 3270 n’a pas de déclencheur, utilisez un autre déclencheur pour démarrer votre application logique, tel que le déclencheur de périodicité.The IBM 3270 connector doesn't have triggers, so use another trigger to start your logic app, such as the Recurrence trigger. Vous pouvez ensuite ajouter des actions de connecteur 3270.You can then add 3270 connector actions. Pour commencer, créez une application logique vide.To get started, create a blank logic app. Si vous utilisez un environnement de service d’intégration, sélectionnez ce dernier en tant qu’emplacement de votre application logique.If you use an ISE, select that ISE as your logic app's location.

  • Téléchargez et installez l’outil de conception 3270.Download and install the 3270 Design Tool. Le seul prérequis est Microsoft .NET Framework 4.6.1.The only prerequisite is Microsoft .NET Framework 4.6.1.

    Cet outil vous permet d’enregistrer les écrans, les chemins de navigation, les méthodes et les paramètres pour les tâches dans votre application que vous ajoutez et exécutez en tant qu’actions du connecteur 3270.This tool helps you record the screens, navigation paths, methods, and parameters for the tasks in your app that you add and run as 3270 connector actions. L’outil génère un fichier HIDX (Host Integration Designer XML) qui fournit les métadonnées nécessaires que le connecteur utilise pour le pilotage de votre application mainframe.The tool generates a Host Integration Designer XML (HIDX) file that provides the necessary metadata for the connector to use for driving your mainframe app.

    Après le téléchargement et l’installation de cet outil, procédez comme suit pour la connexion à votre hôte :After downloading and installing this tool, follow these steps for connecting to your host:

    1. Ouvrez l’outil de conception 3270.Open the 3270 Design Tool. À partir du menu Session, sélectionnez Host Sessions (Sessions hôte) .From the Session menu, select Host Sessions.

    2. Fournissez les informations relatives au serveur hôte TN3270.Provide your TN3270 host server information.

  • Un compte d’intégration, qui est l’endroit où vous stockez votre fichier HIDX sous forme de carte afin que votre application logique puisse accéder aux définitions de métadonnées et de méthode dans ce fichier.An integration account, which is the place where you store your HIDX file as a map so your logic app can access the metadata and method definitions in that file.

    Assurez-vous que votre compte d’intégration est lié à l’application logique que vous utilisez.Make sure your integration account is linked to the logic app you're using. De plus, si vous utilisez un environnement de service d’intégration, veillez à ce que l’emplacement de votre compte d’intégration soit dans le même environnement de service d’intégration que celui que votre application logique utilise.Also, if you use an ISE, make sure your integration account's location is the same ISE that your logic app uses.

  • L’accès au serveur TN3270 qui héberge votre application mainframe.Access to the TN3270 server that hosts your mainframe app

Créer la vue d’ensemble des métadonnéesCreate metadata overview

Dans une application 3270 pilotée par écran, les écrans et les champs de données sont uniques à vos scénarios. Par conséquent, le connecteur 3270 a besoin des informations relatives à votre application, que vous pouvez fournir en tant que métadonnées.In a 3270 screen-driven app, the screens and data fields are unique to your scenarios, so the 3270 connector needs this information about your app, which you can provide as metadata. Ces métadonnées décrivent les informations qui aident votre application logique à identifier et à reconnaître les écrans, expliquent comment naviguer entre les écrans, où entrer les données et où attendre des résultats.This metadata describes information that helps your logic app identify and recognize screens, describes how to navigate between screens, where to input data, and where to expect results. Pour spécifier et générer ces métadonnées, vous utilisez l’outil de conception 3270, qui vous guide à travers ces modes spécifiques, ou étapes, comme décrit plus loin plus en détails :To specify and generate this metadata, you use the 3270 Design Tool, which walks you through these specific modes, or stages, as described later in more details:

  • Capture : dans ce mode, vous enregistrez les écrans requis pour effectuer une tâche spécifique avec votre application mainframe, par exemple, l’obtention d’un solde de compte.Capture: In this mode, you record the screens required for completing a specific task with your mainframe app, for example, getting a bank balance.

  • Navigation : dans ce mode, vous spécifiez le plan ou le chemin d’accès pour la navigation dans les écrans de votre application mainframe pour la tâche spécifique.Navigation: In this mode, you specify the plan or path for how to navigate through your mainframe app's screens for the specific task.

  • Méthodes : dans ce mode, vous définissez la méthode, par exemple GetBalance, qui décrit le chemin de navigation des écrans.Methods: In this mode, you define the method, for example, GetBalance, that describes the screen navigation path. Vous choisissez également les champs de chaque écran qui deviennent les paramètres d’entrée et de sortie de la méthode.You also choose the fields on each screen that become the method's input and output parameters.

Éléments non pris en chargeUnsupported elements

L’outil de conception ne prend pas en charge les éléments suivants :The design tool doesn't support these elements:

  • Cartes IBM BMS (Basic Mapping Support) partielles : si vous importez une carte BMS, l’outil de conception ignore les définitions d’écran partielles.Partial IBM Basic Mapping Support (BMS) maps: If you import a BMS map, the design tool ignores partial screen definitions.
  • Paramètres d’entrée et de sortie : vous ne pouvez pas définir de paramètres d’entrée et de sortie.In/Out parameters: You can't define In/Out parameters.
  • Traitement des menus : non pris en charge pendant la préversionMenu processing: Not supported during preview
  • Traitement des groupes : non pris en charge pendant la préversionArray processing: Not supported during preview

Capturer les écransCapture screens

Dans ce mode, vous marquez un élément sur chaque écran 3270 qui identifie de façon unique cet écran.In this mode, you mark an item on each 3270 screen that uniquely identifies that screen. Par exemple, vous pouvez spécifier une ligne de texte ou un ensemble plus complexe de conditions, comme un texte spécifique et un champ non vide.For example, you might specify a line of text or a more complex set of conditions, such as specific text and a non-empty field. Vous pouvez enregistrer ces écrans sur une connexion active au serveur hôte, ou importer ces informations à partir d’une carte IBM BMS (Basic Mapping Support).You can either record these screens over a live connection to the host server, or import this information from an IBM Basic Mapping Support (BMS) map. La connexion active utilise un émulateur TN3270 pour la connexion à l’hôte.The live connection uses a TN3270 emulator for connecting to the host. Chaque action de connecteur doit mapper à une seule tâche qui démarre avec la connexion à votre session et se termine avec la déconnexion de votre session.Each connector action must map to a single task that starts with connecting to your session and ends with disconnecting from your session.

  1. Si ce n’est pas déjà fait, ouvrez l’outil de conception 3270.If you haven't already, open the 3270 Design Tool. Dans la barre d’outils, choisissez Capture pour passer au mode Capture.On the toolbar, choose Capture so that you enter Capture mode.

  2. Pour démarrer l’enregistrement, appuyez sur la touche F5, ou à partir du menu Recording (Enregistrement) , sélectionnez Start Recording (Démarrer l’enregistrement) .To start recording, press the F5 key, or from the Recording menu, select Start Recording.

  3. Dans le menu Session, sélectionnez Connect (Se connecter) .From the Session menu, select Connect.

  4. Dans le volet Capture, à partir du premier écran de votre application, pilotez votre application pour la tâche spécifique que vous enregistrez.In the Capture pane, starting from the first screen in your app, step through your app for the specific task that you're recording.

  5. Une fois que vous avez terminé la tâche, déconnectez-vous de votre application comme vous le faites habituellement.After you finish the task, sign out from your app as you usually do.

  6. À partir du menu Session, sélectionnez Disconnect (Se déconnecter) .From the Session menu, select Disconnect.

  7. Pour arrêter l’enregistrement, appuyez sur les touches Maj+F5, ou à partir du menu Recording (Enregistrement) , sélectionnez Stop Recording (Arrêter l’enregistrement) .To stop recording, press the Shift + F5 keys, or from the Recording menu, select Stop Recording.

    Une fois que vous avez capturé les écrans d’une tâche, l’outil de concepteur affiche des miniatures qui représentent ces écrans.After you capture the screens for a task, the designer tool shows thumbnails that represent those screens. Quelques remarques concernant ces miniatures :Some notes about these thumbnails:

    • Parmi vos écrans capturés, vous disposez d’un écran qui est nommé « Empty Vide » (Vide).Included with your captured screens, you have a screen that's named "Empty".

      Lorsque vous vous connectez à CICS pour la première fois, vous devez envoyer la clé « Clear » (Vierge) avant de pouvoir entrer le nom de la transaction que vous souhaitez exécuter.When you first connect to CICS, you must send the "Clear" key before you can enter the name for the transaction you want to run. L’écran où vous envoyez la clé « Clear » ne possède aucun attribut de reconnaissance, par exemple un titre d’écran, que vous pouvez ajouter à l’aide de l’éditeur de reconnaissance de l’écran.The screen where you send the "Clear" key doesn't have any recognition attributes, such as a screen title, which you can add by using the Screen Recognition editor. Pour représenter cet écran, la miniature inclut un écran nommé « Empty » (Vide).To represent this screen, the thumbnails includes a screen named "Empty". Vous pouvez utiliser cet écran ultérieurement pour représenter l’écran où vous entrez le nom de la transaction.You can later use this screen for representing the screen where you enter the transaction name.

    • Par défaut, le nom d’un écran capturé utilise le premier mot à l’écran.By default, the name for a captured screen uses the first word on the screen. Si ce nom existe déjà, l’outil de conception ajoute au nom un trait de soulignement et un nombre, par exemple, « WBGB » et « WBGB_1 ».If that name already exists, the design tool appends the name with an underscore and a number, for example, "WBGB" and "WBGB_1".

  8. Pour donner un nom plus significatif à un écran capturé, procédez comme suit :To give a more meaningful name to a captured screen, follow these steps:

    1. Dans le volet Host Screens (Écrans de l’hôte) , sélectionnez l’écran que vous souhaitez renommer.In the Host Screens pane, select the screen you want to rename.

    2. Dans le même volet, en bas, recherchez la propriété Screen Name (Nom de l’écran) .In the same pane, near the bottom in the same pane, find the Screen Name property.

    3. Remplacez le nom d’écran actuel par un nom plus descriptif.Change the current screen name to a more descriptive name.

  9. Maintenant, spécifiez les champs d’identification de chaque écran.Now specify the fields for identifying each screen.

    Avec le flux de données 3270, les écrans n’ont pas d’identificateurs par défaut. Vous devez donc sélectionner du texte unique sur chaque écran.With the 3270 data stream, screens don't have default identifiers, so you need to select unique text on each screen. Pour des scénarios complexes, vous pouvez spécifier plusieurs conditions, par exemple, un texte unique et un champ avec une condition spécifique.For complex scenarios, you can specify multiple conditions, for example, unique text and a field with a specific condition.

Une fois que vous avez terminé de sélectionner les champs de reconnaissance, passez au mode suivant.After you finish selecting the recognition fields, move to the next mode.

Conditions de l’identification des écrans répétésConditions for identifying repeated screens

Pour que le connecteur parcourt et différencie les écrans, vous trouvez généralement un texte unique sur un écran que vous pouvez utiliser en tant qu’identificateur parmi les écrans capturés.For the connector to navigate and differentiate between screens, you usually find unique text on a screen that you can use as an identifier among the captured screens. Pour les écrans répétés, vous aurez peut-être besoin de plusieurs méthodes d’identification.For repeated screens, you might need more identification methods. Par exemple, supposons que vous avez 2 écrans qui se ressemblent, à ceci près qu’un écran retourne une valeur valide tandis que l’autre écran retourne un message d’erreur.For example, suppose you have two screens that look the same except one screen returns a valid value, while the other screen returns an error message.

Dans l’outil de conception, vous pouvez ajouter des attributs de reconnaissance, par exemple un titre d’écran tel que « Obtenir le solde du compte », à l’aide de l’éditeur de reconnaissance d’écran.In the design tool, you can add recognition attributes, for example, a screen title such as "Get Account Balance", by using the Screen Recognition editor. Si vous avez un chemin comprenant des branches et que les deux branches retournent le même écran, mais avec des résultats différents, vous avez besoin d’autres attributs de reconnaissance.If you have a forked path and both branches return the same screen but with different results, you need other recognition attributes. Au moment de l’exécution, le connecteur utilise ces attributs pour déterminer la branche actuelle et la branche dupliquée.At run time, the connector uses these attributes for determining the current branch and fork. Voici les conditions utilisables :Here are the conditions you can use:

  • Specific value (Valeur spécifique) : cette valeur correspond à la chaîne spécifiée à l’emplacement spécifié.Specific value: This value matches the specified string at the specified location.
  • NOT a specific value (PAS une valeur spécifique) : cette valeur ne correspond pas à la chaîne spécifiée à l’emplacement spécifié.NOT a specific value: This value doesn't match the specified string at the specified location.
  • Empty (Vide) : ce champ est vide.Empty: This field is empty.
  • NOT empty (NON vide) : ce champ n’est pas vide.NOT empty: This field isn't empty.

Pour plus d’informations, consultez l’exemple de plan de navigation plus loin dans cette rubrique.To learn more, see the Example navigation plan later in this topic.

Définir des plans de navigationDefine navigation plans

Dans ce mode, vous définissez le flux ou les étapes pour parcourir les écrans de votre application mainframe pour votre tâche spécifique.In this mode, you define the flow or steps for navigating through your mainframe app's screens for your specific task. Par exemple, vous pouvez parfois avoir plusieurs chemins que votre application peut suivre, où un chemin produit le résultat correct tandis que l’autre chemin génère une erreur.For example, sometimes, you might have more than one path that your app can take where one path produces the correct result, while the other path produces an error. Pour chaque écran, spécifiez les séquences de touches nécessaires pour le passage à l’écran suivant, telles que CICSPROD <enter>.For each screen, specify the keystrokes necessary for moving to the next screen, such as CICSPROD <enter>.

Conseil

Si vous automatisez plusieurs tâches qui utilisent les mêmes écrans de connexion et de déconnection, l’outil de conception fournit les types de plan spéciaux Connect (Se connecter) et Disconnect (Se déconnecter).If you're automating several tasks that use the same connect and disconnect screens, the design tool provides special Connect and Disconnect plan types. Lorsque vous définissez ces plans, vous pouvez les ajouter au début et à la fin de votre plan de navigation.When you define these plans, you can add them to your navigation plan's beginning and end.

Instructions pour les définitions de planGuidelines for plan definitions

  • Incluez tous les écrans, en commençant par la connexion et en terminant par la déconnexion.Include all screens, starting with connecting and ending with disconnecting.

  • Vous pouvez créer un plan autonome ou utiliser les plans Se connecter et Se déconnecter, qui vous permettent de réutiliser une série d’écrans communs à toutes vos opérations.You can create a standalone plan or use the Connect and Disconnect plans, which let you reuse a series of screens common to all your transactions.

    • Le dernier écran de votre plan de connexion doit être le même écran que le premier écran de votre plan de navigation.The last screen in your Connect plan must be the same screen as the first screen in your navigation plan.

    • Le premier écran de votre plan de déconnexion doit être le même écran que le dernier écran de votre plan de navigation.The first screen in your Disconnect plan must be same screen as the last screen in your navigation plan.

  • Vos écrans capturés peuvent contenir de nombreux écrans répétés. Aussi, sélectionnez et utilisez une seule instance des écrans répétés dans votre plan.Your captured screens might contain many repeated screens, so select and use only one instance of any repeated screens in your plan. Voici quelques exemples d’écrans répétés :Here are some examples of repeated screens:

    • L'écran de connexion, par exemple l'écran MSG-10The sign-in screen, for example, the MSG-10 screen
    • L’écran d’accueil pour CICSThe welcome screen for CICS
    • L’écran « Clear » ou Empty (Vide)The "Clear" or Empty screen

Créer des plansCreate plans

  1. Dans la barre d’outils de l’outil de conception 3270, choisissez Navigation afin de passer au mode Navigation.On the 3270 Design Tool's toolbar, choose Navigation so that you enter Navigation mode.

  2. Pour démarrer votre plan, dans le volet Navigation, choisissez New Plan (Nouveau plan) .To start your plan, in the Navigation pane, choose New Plan.

  3. Sous Choose New Plan Name (Choisir un nouveau nom de plan) , entrez un nom pour votre plan.Under Choose New Plan Name, enter a name for your plan. Dans la liste Type, sélectionnez le type de plan :From the Type list, select the plan type:

    Type de planPlan type DescriptionDescription
    ProcessusProcess Pour des plans autonomes ou combinésFor standalone or combined plans
    ConnexionConnect Pour des plans de connexionFor Connect plans
    DéconnexionDisconnect Pour des plans de déconnexionFor Disconnect plans
  4. Dans le volet Host Screens (Écrans de l’hôte) , faites glisser les miniatures capturées dans la surface du plan de navigation dans le volet Navigation.From the Host Screens pane, drag the captured thumbnails to the navigation plan surface in the Navigation pane.

    Pour représenter l’écran vide où vous entrez le nom de la transaction, utilisez l’écran « Vide ».To represent the blank screen where you enter the transaction name, use the "Empty" screen.

  5. Réorganisez les écrans dans l’ordre qui décrit la tâche que vous définissez.Arrange the screens in the order that describes the task that you're defining.

  6. Pour définir le chemin entre des écrans, notamment les branches et les jointures, sur la barre d’outils de l’outil de conception, choisissez Flow (Flux) .To define the flow path between screens, including forks and joins, on the design tool's toolbar, choose Flow.

  7. Choisissez le premier écran dans le flux.Choose the first screen in the flow. Faites glisser et dessinez une connexion à l’écran suivant dans le flux.Drag and draw a connection to the next screen in the flow.

  8. Pour chaque écran, indiquez les valeurs pour la propriété AID Key (Clé AID) (identificateur d’attention) et pour la propriété Fixed Text (Texte fixe) , qui déplace le flux à l’écran suivant.For each screen, provide the values for the AID Key property (Attention Identifier) and for the Fixed Text property, which moves the flow to the next screen.

    Vous pouvez avoir uniquement la clé AID, ou à la fois la clé AID et le texte fixe.You might have just the AID key, or both the AID key and fixed text.

Une fois que vous avez terminé votre plan de navigation, vous pouvez définir des méthodes dans le mode suivant.After you finish your navigation plan, you can define methods in the next mode.

ExemplesExample

Dans cet exemple, supposons que vous exécutez une transaction CICS nommée « WBGB » qui inclut les étapes suivantes :In this example, suppose you run a CICS transaction named "WBGB" that has these steps:

  • Dans le premier écran, vous entrez un nom et un compte.On the first screen, you enter a name and an account.
  • Dans le deuxième écran, vous obtenez le solde du compte.On the second screen, you get the account balance.
  • Vous quittez l’écran « Vide ».You exit to the "Empty" screen.
  • Vous vous déconnectez de CICS pour vous connecter à l’écran « MSG-10 ».You sign out from CICS to the "MSG-10" screen.

Supposons également que vous répétez ces étapes, mais que vous entrez des données incorrectes, capturant ainsi l’écran qui affiche l’erreur.Also suppose that you repeat these steps, but you enter incorrect data so you can capture the screen that shows the error. Voici les écrans que vous capturez :Here are the screens you capture:

  • MSG-10MSG-10
  • CICS Welcome (Bienvenue dans CICS)CICS Welcome
  • VideEmpty
  • WBGB_1 (input) (WBGB_1 (entrée))WBGB_1 (input)
  • WBGB_2 (error) (WBGB_2 (erreur))WBGB_2 (error)
  • Empty_1 (Vide_1)Empty_1
  • MSG-10_1MSG-10_1

Bien que de nombreux écrans ici aient des noms uniques, certains écrans sont identiques, par exemple « MSG-10 » et « Vide ».Although many screens here get unique names, some screens are the same screen, for example, "MSG-10" and "Empty". Pour un écran répété, utilisez une seule instance de cet écran dans votre plan.For a repeated screen, use only one instance for that screen in your plan. Voici des exemples qui illustrent la façon dont un plan autonome, un plan de connexion, un plan de déconnexion et un plan combiné peuvent se présenter :Here are examples that show how a standalone plan, Connect plan, Disconnect plan, and a combined plan might look:

  • Plan autonomeStandalone plan

    Plan de navigation autonome

  • Plan de connexionConnect plan

    Plan de connexion

  • Plan de déconnexionDisconnect plan

    Plan de déconnexion

  • Plan combinéCombined plan

    Plan combiné

Exemple : Identifier les écrans répétésExample: Identify repeated screens

Pour que le connecteur parcourt et différencie les écrans, vous trouvez généralement un texte unique sur un écran que vous pouvez utiliser en tant qu’identificateur parmi les écrans capturés.For the connector to navigate and differentiate screens, you usually find unique text on a screen that you can use as an identifier across the captured screens. Pour les écrans répétés, vous aurez peut-être besoin de plusieurs méthodes d’identification.For repeated screens, you might need more identification methods. L’exemple de plan a une branche où vous pouvez avoir des écrans qui se ressemblent.The example plan has a fork where you can get screens that look similar. Un des écrans retourne un solde de compte, tandis que l’autre écran retourne un message d’erreur.One screen returns an account balance, while the other screen returns an error message.

Dans l’outil de conception, vous pouvez ajouter des attributs de reconnaissance, par exemple un titre d’écran tel que « Obtenir le solde du compte », à l’aide de l’éditeur de reconnaissance d’écran.The design tool lets you add recognition attributes, for example, a screen title named "Get Account Balance", by using the Screen Recognition editor. Dans le cas présentant des écrans similaires, vous avez besoin d’autres attributs.In the case with similar screens, you need other attributes. Au moment de l’exécution, le connecteur utilise ces attributs pour déterminer la branche et la branche dupliquée.At run time, the connector uses these attributes for determining the branch and fork.

  • Dans la branche qui retourne une entrée valide, qui est l’écran avec le solde du compte, vous pouvez ajouter un champ qui a une condition « non vide ».In the branch that returns valid input, which is the screen with the account balance, you can add a field that has a "not empty" condition.

  • Dans la branche qui retourne une erreur, vous pouvez ajouter un champ qui a une condition « vide ».In the branch that returns with an error, you can add a field that has an "empty" condition.

Définir des méthodesDefine methods

Dans ce mode, vous définissez une méthode qui est associée à votre plan de navigation.In this mode, you define a method that's associated with your navigation plan. Pour chaque paramètre de méthode, vous spécifiez le type de données (chaîne, entier, date ou heure et ainsi de suite).For each method parameter, you specify the data type, such as a string, integer, date or time, and so on. Lorsque vous avez terminé, vous pouvez tester votre méthode sur l’hôte actif et vérifier que la méthode fonctionne comme prévu.When you're done, you can test your method on the live host and confirm that the method works as expected. Vous générez ensuite le fichier de métadonnées, ou le fichier Host Integration Designer XML (HIDX), qui comporte à présent les définitions de méthode à utiliser pour la création et l’exécution d’une action pour le connecteur IBM 3270.You then generate the metadata file, or Host Integration Designer XML (HIDX) file, which now has the method definitions to use for creating and running an action for the IBM 3270 connector.

  1. Dans la barre d’outils de l’outil de conception 3270, choisissez Méthodes afin de passer au mode Méthodes.On the 3270 Design Tool's toolbar, choose Methods so that you enter Methods mode.

  2. Dans le volet Navigation, sélectionnez l’écran qui a les champs d’entrée souhaités.In the Navigation pane, select the screen that has the input fields you want.

  3. Pour ajouter le premier paramètre d’entrée pour votre méthode, procédez comme suit :To add the first input parameter for your method, follow these steps:

    1. Dans le volet Capture, sur l’écran de l’émulateur 3270, choisissez le champ entier, pas uniquement le texte dans le champ, que vous souhaitez comme première entrée.In the Capture pane, on the 3270 emulator screen, choose the whole field, not just text inside the field, that you want as the first input.

      Conseil

      Pour afficher tous les champs et vous assurer que vous sélectionnez le champ complet, dans le menu View (Vue) , sélectionnez All Fields (Tous les champs) .To display all the fields and make sure that you select the complete field, on the View menu, select All Fields.

    2. Dans la barre d’outils de l’outil de conception, choisissez Input Field (Champ d’entrée) .On the design tool's toolbar, choose Input Field.

    Pour ajouter plus de paramètres d’entrée, répétez les étapes précédentes pour chaque paramètre.To add more input parameters, repeat the previous steps for each parameter.

  4. Pour ajouter le premier paramètre de sortie pour votre méthode, procédez comme suit :To add the first output parameter for your method, follow these steps:

    1. Dans le volet Capture, sur l’écran de l’émulateur 3270, choisissez le champ entier, pas uniquement le texte dans le champ, que vous souhaitez comme première sortie.In the Capture pane, on the 3270 emulator screen, choose the whole field, not just text inside the field, that you want as the first output.

      Conseil

      Pour afficher tous les champs et vous assurer que vous sélectionnez le champ complet, dans le menu View (Vue) , sélectionnez All Fields (Tous les champs) .To display all the fields and make sure that you select the complete field, on the View menu, select All Fields.

    2. Dans la barre d’outils de l’outil de conception, choisissez Output Field (Champ de sortie) .On the design tool's toolbar, choose Output Field.

    Pour ajouter plus de paramètres de sortie, répétez les étapes précédentes pour chaque paramètre.To add more output parameters, repeat the previous steps for each parameter.

  5. Une fois que vous avez ajouté tous les paramètres de la méthode, définissez ces propriétés pour chaque paramètre :After you add all your method's parameters, define these properties for each parameter:

    Nom de la propriétéProperty name Valeurs possiblesPossible values
    Type de donnéesData Type Byte, Date Time, Decimal, Int, Long, Short, StringByte, Date Time, Decimal, Int, Long, Short, String
    Field Fill Technique (Technique de remplissage de champ)Field Fill Technique Les paramètres prennent en charge ces types de remplissage, en ajoutant des espaces vides si nécessaire :Parameters support these fill types, filling with blanks if necessary:

    - Type : entrez les caractères séquentiellement dans le champ.- Type: Enter characters sequentially into the field.

    - Fill (Remplir)  : remplacez le contenu du champ par des caractères, en ajoutant des espaces vides si nécessaire.- Fill: Replace the field's contents with characters, filling with blanks if necessary.

    - EraseEofType : effacez le champ, puis tapez les caractères de manière séquentielle dans le champ.- EraseEofType: Clear the field, and then enter characters sequentially into the field.

    Format String (Chaîne de format)Format String Certains types de données de paramètre utilisent une chaîne de format, qui indique au connecteur 3270 comment convertir le texte de l’écran en type de données .NET :Some parameter data types use a format string, which informs the 3270 connector how to convert text from the screen into a .NET data type:

    - DateTime : la chaîne de format DateTime suit le format des chaînes de date et heure personnalisées .NET.- DateTime: The DateTime format string follows the .NET custom date and time format strings. Par exemple, la date 06/30/2019 utilise la chaîne de format MM/dd/yyyy.For example, the date 06/30/2019 uses the format string MM/dd/yyyy.

    - Decimal : la chaîne de format décimal utilise la clause COBOL Picture.- Decimal: The decimal format string uses the COBOL Picture clause. Par exemple, le nombre 100.35 utilise la chaîne de format 999V99.For example, the number 100.35 uses the format string 999V99.

Enregistrer et afficher les métadonnéesSave and view metadata

Une fois que vous avez défini votre méthode, mais avant de la tester, enregistrez toutes les informations que vous avez définies jusqu’à présent dans un fichier RAP (.rap).After you define your method, but before you test your method, save all the information that you defined so far to a RAP (.rap) file. Vous pouvez enregistrer ce fichier RAP à tout moment et quel que soit le mode.You can save to this RAP file at any time during any mode. L’outil de conception inclut également un exemple de fichier de stratégie que vous pouvez ouvrir et consulter en accédant au dossier d’installation de l’outil de conception à cet emplacement et en ouvrant le fichier « WoodgroveBank.rap » :The design tool also includes a sample RAP file that you can open and review by browsing to the design tool's installation folder at this location and opening the "WoodgroveBank.rap" file:

..\Program Files\Microsoft Host Integration Server - 3270 Design Tool\SDK\WoodgroveBank.rap

Toutefois, si vous essayez d’enregistrer les modifications apportées à l’exemple de fichier RAP ou de générer un fichier HIDX à partir de l’exemple de fichier RAP tandis que le fichier reste dans le dossier d’installation de l’outil de conception, vous pouvez obtenir une erreur « accès refusé ».However, if you try saving changes to the sample RAP file or generating an HIDX file from the sample RAP file while the file stays in the design tool's installation folder, you might get an "access denied" error. Par défaut, l’outil de conception est installé dans votre dossier Program Files sans autorisations élevées.By default, the design tool installs in your Program Files folder without elevated permissions. Si vous obtenez une erreur, essayez l’une de ces solutions :If you get an error, try one of these solutions:

  • Copiez l’exemple de fichier vers un autre emplacement.Copy the sample file to a different location.
  • Exécutez l’outil de conception en tant qu’administrateur.Run the design tool as an administrator.
  • Définissez-vous comme propriétaire du dossier du SDK.Make yourself the owner for the SDK folder.

Tester votre méthodeTest your method

  1. Pour exécuter votre méthode sur l’hôte actif, tout en restant dans le mode Méthodes, appuyez sur la touche F5, ou dans la barre d’outils de l’outil de conception, choisissez Run (Exécuter) .To run your method against the live host, while still in Methods mode, press the F5 key, or from the design tool's toolbar, choose Run.

    Conseil

    Vous pouvez changer de mode à tout moment.You can change modes at any time. Dans le menu File (Fichier) , sélectionnez Mode, puis le mode souhaité.On the File menu, select Mode, and then select the mode you want.

  2. Entrez les valeurs de vos paramètres, puis choisissez OK.Enter your parameters' values, and choose OK.

  3. Pour passer à l’écran suivant, choisissez Next (Suivant) .To continue to the next screen, choose Next.

  4. Lorsque vous avez terminé, choisissez Done (Terminé) , ce qui a pour effet d’afficher vos valeurs de paramètre de sortie.When you're finished, choose Done, which shows your output parameter values.

Générer et charger un fichier HIDXGenerate and upload HIDX file

Lorsque vous êtes prêt, générez le fichier HIDX afin que vous puissiez le charger dans votre compte d’intégration.When you're ready, generate the HIDX file so you can upload to your integration account. L’outil de conception 3270 crée le fichier HIDX dans un nouveau sous-dossier où vous avez enregistré votre fichier RAP.The 3270 Design Tool creates the HIDX file in a new subfolder where you saved your RAP file.

  1. Dans la barre d’outils de l’outil de conception 3270, choisissez Generate Code (Générer le code) .On the 3270 Design Tool's toolbar, choose Generate Code.

  2. Accédez au dossier qui contient votre fichier RAP, puis ouvrez le sous-dossier créé par l’outil après la génération de votre fichier HIDX.Go to the folder that contains your RAP file, and open the subfolder that the tool created after generating your HIDX file. Vérifiez que l’outil a créé le fichier HIDX.Confirm that the tool created the HIDX file.

  3. Connectez-vous au portail Azure, puis trouvez votre compte d’intégration.Sign in to the Azure portal, and find your integration account.

  4. Ajoutez votre fichier HIDX sous forme de carte à votre compte d’intégration en suivant ces étapes pour ajouter des cartes similaires, mais lorsque vous sélectionnez le type de carte, sélectionnez HIDX.Add your HIDX file as a map to your integration account by follow these similar steps for adding maps, but when you select the map type, select HIDX.

Plus loin dans cette rubrique, lorsque vous ajoutez une action IBM 3270 à votre application logique pour la première fois, vous êtes invité à créer une connexion entre votre application logique et le serveur hôte en fournissant des informations de connexion, telles que le nom de votre compte d’intégration et du serveur hôte.Later in this topic, when you add an IBM 3270 action to your logic app for the first time, you're prompted to create a connection between your logic app and the host server by providing connection information, such as the names for your integration account and host server. Une fois que vous avez créé la connexion, vous pouvez sélectionner votre fichier HIDX précédemment ajouté, la méthode à exécuter et les paramètres à utiliser.After you create the connection, you can select your previously added HIDX file, the method to run, and the parameters to use.

Lorsque vous avez terminé toutes ces étapes, vous pouvez utiliser l’action que vous créez dans votre application logique pour la connexion à votre mainframe IBM, piloter les écrans de votre application, entrer des données, retourner des résultats et ainsi de suite.When you finish all these steps, you can use the action that you create in your logic app for connecting to your IBM mainframe, drive screens for your app, enter data, return results, and so on. Vous pouvez également continuer à ajouter d’autres actions à votre application logique pour l’intégration avec d’autres applications, services et systèmes.You can also continue adding other actions to your logic app for integrating with other apps, services, and systems.

Exécuter des actions IBM 3270Run IBM 3270 actions

Pour que votre application logique puisse accéder à tout service, vous devez créer une connexion entre votre application logique et ce service.Before your logic app can access any service, you must create a connection between your logic app and that service. Si vous n’avez pas créé cette connexion, vous êtes invité à fournir des informations de connexion lorsque vous ajoutez un déclencheur ou une action pour ce service vers votre application logique.If you didn't previously create this connection, you're prompted for connection information when you add a trigger or action for that service to your logic app. Le Concepteur d’applications logiques vous permet de créer facilement cette connexion, directement à partir de votre application logique.The Logic Apps Designer provides an easy way for you to create this connection directly from your logic app.

  1. Connectez-vous au portail Azure et ouvrez votre application logique dans le concepteur d’application logique, si elle n’est pas déjà ouverte.Sign in to the Azure portal, and open your logic app in Logic App Designer, if not open already.

  2. Sous la dernière étape où vous souhaitez ajouter une action, choisissez New step (Nouvelle étape) , puis sélectionnez Add an action (Ajouter une action) .Under the last step where you want to add an action, choose New step, and select Add an action.

  3. Sous la zone de recherche, choisissez Enterprise.Under the search box, choose Enterprise. Dans la zone de recherche, entrez 3270 comme filtre.In the search box, enter "3270" as your filter. Dans la liste des actions, sélectionnez cette action : Exécute un programme mainframe via une connexion TN3270From the actions list, select this action: Runs a mainframe program over a TN3270 connection

    Sélectionner une action 3270

    Pour ajouter une action entre des étapes, placez votre pointeur au-dessus de la flèche qui les sépare.To add an action between steps, move your pointer over the arrow between steps. Cliquez sur le signe plus ( + ) qui s’affiche, puis sélectionnez Ajouter une action.Choose the plus sign (+) that appears, and then select Add an action.

  4. Si aucune connexion n’existe encore, fournissez les informations nécessaires pour votre connexion, puis choisissez Create (Créer) .If no connection exists yet, provide the necessary information for your connection, and choose Create.

    PropriétéProperty ObligatoireRequired ValueValue DescriptionDescription
    Nom de connexionConnection Name OUIYes <connection-name><connection-name> Nom de votre connexionThe name for your connection
    ID de compte d’intégrationIntegration Account ID OUIYes <integration-account-name><integration-account-name> Nom de votre compte d’intégrationYour integration account's name
    URL SAP du compte d’intégrationIntegration Account SAS URL OUIYes <integration-account-SAS-URL><integration-account-SAS-URL> URL de signature d’accès partagé (SAP) de votre compte d’intégration, que vous pouvez générer à partir des paramètres de votre compte d’intégration dans le portail Azure.Your integration account's Shared Access Signature (SAS) URL, which you can generate from your integration account's settings in the Azure portal.

    1. Dans le menu du compte d’intégration, sous Paramètres, sélectionnez URL de rappel.1. On your integration account menu, under Settings, select Callback URL.
    2. Dans le volet de droite, copiez la valeur URL de rappel générée.2. In the right-hand pane, copy the Generated Callback URL value.

    ServeurServer OUIYes <TN3270-server-name><TN3270-server-name> Nom du serveur pour votre service TN3270The server name for your TN3270 service
    PortPort NonNo <TN3270-server-port><TN3270-server-port> Port utilisé par votre serveur TN3270.The port used by your TN3270 server. Si ce champ est vide, le connecteur utilise 23 comme valeur par défaut.If left blank, the connector uses 23 as the default value.
    Type d’appareilDevice Type NonNo <IBM-terminal-model><IBM-terminal-model> Numéro ou nom de modèle du terminal IBM à émuler.The model name or number for the IBM terminal to emulate. Si ce champ est vide, le connecteur utilise les valeurs par défaut.If left blank, the connector uses default values.
    Page de codesCode Page NonNo <code-page-number><code-page-number> Numéro de page de codes pour l’hôte.The code page number for the host. Si ce champ est vide, le connecteur utilise 37 comme valeur par défaut.If left blank, the connector uses 37 as the default value.
    Nom d’unité logiqueLogical Unit Name NonNo <logical-unit-name><logical-unit-name> Nom d’unité logique spécifique à demander à partir de l’hôteThe specific logical unit name to request from the host
    Activer le protocole SSL ?Enable SSL? NonNo Activé ou désactivéOn or off Activer ou désactiver le chiffrement SSL.Turn on or turn off SSL encryption.
    Valider le certificat SSL de l’hôte ?Validate host ssl certificate? NonNo Activé ou désactivéOn or off Activez ou désactivez la validation du certificat du serveur.Turn on or turn off validation for the server's certificate.

    Par exemple :For example:

    Propriétés de connexion

  5. Entrez les informations nécessaires pour l’action :Provide the necessary information for the action:

    PropriétéProperty ObligatoireRequired ValueValue DescriptionDescription
    Nom d’un fichier HidxHidx Name OUIYes <HIDX-file-name><HIDX-file-name> Sélectionnez le fichier HIDX 3270 à utiliser.Select the 3270 HIDX file that you want to use.
    Nom de la méthodeMethod Name OUIYes <method-name><method-name> Sélectionnez la méthode dans le fichier HIDX à utiliser.Select the method in the HIDX file that you want to use. Une fois que vous sélectionnez une méthode, la liste Add new parameter (Ajouter un nouveau paramètre) s’affiche et vous pouvez alors sélectionner les paramètres à utiliser avec cette méthode.After you select a method, the Add new parameter list appears so you can select parameters to use with that method.

    Par exemple :For example:

    Sélectionner le fichier HIDXSelect the HIDX file

    Sélectionner le fichier HIDX

    Sélectionner la méthodeSelect the method

    Sélectionner la méthode

    Sélectionner les paramètresSelect the parameters

    Sélectionner les paramètres

  6. Lorsque vous avez terminé, enregistrez et exécutez votre application logique.When you're done, save and run your logic app.

    Lorsque l’exécution de votre application logique est terminée, les étapes de l’exécution apparaissent.After your logic app finishes running, the steps from the run appear. Les étapes réussies affichent des coches, alors que les étapes ayant échoué affichent la lettre « X ».Successful steps show check marks, while unsuccessful steps show the letter "X".

  7. Pour réviser les entrées et les sorties de chaque étape, développez l’étape à vérifier.To review the inputs and outputs for each step, expand that step.

  8. Pour réviser les sorties, choisissez See raw outputs (Afficher les sorties brutes) .To review the outputs, choose See raw outputs.

Référence de connecteurConnector reference

Pour obtenir des détails techniques sur les déclencheurs, les actions et les limites, qui sont décrits par la description OpenAPI du connecteur (anciennement Swagger), consultez la page de référence du connecteur.For technical details about triggers, actions, and limits, which are described by the connector's OpenAPI (formerly Swagger) description, review the connector's reference page.

Étapes suivantesNext steps