Corriger la version des packages R Fix the version of R packages

Lorsque vous utilisez la fonction install. Packages () pour installer des packages cran, vous ne pouvez pas spécifier la version du package, car vous devez installer la version la plus récente du package et celle-ci doit être compatible avec la version la plus récente de ses dépendances.When you use the install.packages() function to install CRAN packages, you cannot specify the version of the package, because the expectation is that you will install the latest version of the package and it should be compatible with the latest version of its dependencies. Si une dépendance obsolète est installée, elle est également mise à jour.If you have an outdated dependency installed, it will be updated as well.

Parfois, vous souhaitez corriger la version d’un package R.Sometimes you want to fix the version of an R package. Pour ce faire, plusieurs méthodes sont possibles :There are several ways to do this:

Lorsque vous utilisez l' interface utilisateur ou l’API bibliothèques pour installer des packages R sur toutes les instances d’un cluster, nous vous recommandons la troisième option.When you use the Libraries UI or API to install R packages on all the instances of a cluster, we recommend the third option.

Le réseau d’applications Microsoft R gère un ordinateur cran qui stocke une capture instantanée de cran chaque nuit.The Microsoft R Application Network maintains a CRAN Time Machine that stores a snapshot of CRAN every night. Les instantanés sont disponibles à https://cran.microsoft.com/snapshot/<date> l’emplacement où <date> est la date de l’instantané souhaité, par exemple, 2019-05-01.The snapshots are available at https://cran.microsoft.com/snapshot/<date> where <date> is the date of the desired snapshot, for example, 2019-05-01. Pour installer des versions spécifiques des packages R, spécifiez cette URL comme référentiel de votre bibliothèque cran lorsque vous créez la bibliothèque.To install specific versions of R packages, specify this URL as the repository of your CRAN library when you create the library.