Configurer BFD sur ExpressRouteConfigure BFD over ExpressRoute

ExpressRoute prend en charge la détection de transfert bidirectionnel (BFD, Bidirectional Forwarding Detection) sur le peering privé et le peering Microsoft.ExpressRoute supports Bidirectional Forwarding Detection (BFD) both over private and Microsoft peering. En activant BFD via ExpressRoute, vous pouvez accélérer la détection des défaillances des liaisons entre les appareils MSEE (Microsoft Enterprise Edge) et les routeurs sur lesquels vous terminez le circuit ExpressRoute (CE/PE).By enabling BFD over ExpressRoute, you can expedite link failure detection between Microsoft Enterprise edge (MSEE) devices and the routers on which you terminate the ExpressRoute circuit (CE/PE). Vous pouvez établir une terminaison d’ExpressRoute sur des appareils de routage de périphérie du client ou des appareils de routage de périphérie de partenaire (si vous avez utilisé le service de connexion de couche 3 managé).You can terminate ExpressRoute over Customer Edge routing devices or Partner Edge routing devices (if you went with managed Layer 3 connection service). Ce document explique pourquoi BFD peut être nécessaire et comment activer BFD sur ExpressRoute.This document walks you through the need for BFD, and how to enable BFD over ExpressRoute.

Besoin de BFDNeed for BFD

Le diagramme suivant présente les avantages de l’activation de BFD sur le circuit ExpressRoute : 1The following diagram shows the benefit of enabling BFD over ExpressRoute circuit: 1

Vous pouvez activer le circuit ExpressRoute par des connexions de couche 2 ou par des connexions de couche 3 managées.You can enable ExpressRoute circuit either by Layer 2 connections or managed Layer 3 connections. Dans les deux cas, s’il existe un ou plusieurs appareils de couche 2 dans le chemin de connexion ExpressRoute, la responsabilité de la détection des échecs des liaisons dans le chemin incombe au protocole BGP superposé.In either case, if there are one or more Layer-2 devices in the ExpressRoute connection path, responsibility of detecting any link failures in the path lies with the overlying BGP.

Sur les appareils MSEE, les durées de conservation et de mise en suspens de BGP sont généralement configurées respectivement sur 60 et 180 secondes.On the MSEE devices, BGP keepalive and hold-time are typically configured as 60 and 180 seconds respectively. Par conséquent, après un échec de liaison, jusqu’à 3 minutes seraient nécessaires pour détecter cet échec et basculer le trafic vers une autre connexion.Therefore, following a link failure it would take up to three minutes to detect any link failure and switch traffic to alternate connection.

Vous pouvez contrôler les minuteurs BGP en configurant des durées de conservation et de mise en suspens de BGP avec des valeurs inférieures sur l’appareil de peering de périphérie du client.You can control the BGP timers by configuring lower BGP keepalive and hold-time on the customer edge peering device. Si les minuteurs BGP ne correspondent pas entre les deux appareils du peering, la session BGP entre les pairs utilise la valeur des minuteurs la plus basse.If the BGP timers are mismatched between the two peering devices, the BGP session between the peers would use the lower timer value. La durée de conservation de BGP peut être définie avec une valeur minimale de 3 secondes, et la durée de mise en suspens avec une valeur de l’ordre de quelques dizaines de secondes.The BGP keepalive can be set as low as three seconds, and the hold-time in the order of tens of seconds. Cependant, la définition de valeurs agressives pour les minuteurs BGP est moins préférable, car le protocole est basé sur un processus consommant des ressources de façon intensive.However, setting BGP timers aggressively is less preferable because the protocol is process intensive.

Dans ce scénario, BFD peut être bénéfique.In this scenario, BFD can help. BFD assure la détection de la défaillance des liaisons en consommant peu de ressources et dans un intervalle de temps inférieur à la seconde.BFD provides low-overhead link failure detection in a subsecond time interval.

Activation de BFDEnabling BFD

BFD est configuré par défaut sous toutes les interfaces de peering privé ExpressRoute nouvellement créées sur les appareils MSEE.BFD is configured by default under all the newly created ExpressRoute private peering interfaces on the MSEEs. Ainsi, pour activer BFD, vous devez simplement configurer BFD sur vos routeurs CE/PE (sur vos appareils principaux et secondaires).Therefore, to enable BFD, you need to just configure BFD on your CEs/PEs (both on your primary and secondary devices). La configuration de BFD est un processus en deux étapes : vous devez configurer BFD sur l’interface, puis la lier à la session BGP.Configuring BFD is two-step process: you need to configure the BFD on the interface and then link it to the BGP session.

Voici un exemple de configuration de CE/PE (avec Cisco IOS XE).An example CE/PE (using Cisco IOS XE) configuration is shown below.

interface TenGigabitEthernet2/0/0.150
  description private peering to Azure
  encapsulation dot1Q 15 second-dot1q 150
  ip vrf forwarding 15
  ip address 192.168.15.17 255.255.255.252
  bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
  address-family ipv4 vrf 15
    network 10.1.15.0 mask 255.255.255.128
    neighbor 192.168.15.18 remote-as 12076
    neighbor 192.168.15.18 fall-over bfd
    neighbor 192.168.15.18 activate
    neighbor 192.168.15.18 soft-reconfiguration inbound
  exit-address-family

Notes

Pour activer BFD sous un peering privé déjà existant, vous devez réinitialiser le peering.To enable BFD under an already existing private peering; you need to reset the peering. Consultez Réinitialiser les peerings ExpressRouteSee Reset ExpressRoute peerings

Négociation des minuteurs BFDBFD Timer Negotiation

Entre les pairs BFD, le plus lent des deux pairs détermine la vitesse de transmission.Between BFD peers, the slower of the two peers determine the transmission rate. Les intervalles de transmission/réception BFD des appareils MSEE sont définis sur 300 millisecondes.MSEEs BFD transmission/receive intervals are set to 300 milliseconds. Dans certains scénarios, l'intervalle peut être défini sur une valeur supérieure de 750 millisecondes.In certain scenarios, the interval may be set at a higher value of 750 milliseconds. En configurant des valeurs plus élevées, vous pouvez forcer ces intervalles à être plus longs, mais pas plus courts.By configuring higher values, you can force these intervals to be longer; but, not shorter.

Notes

Si vous avez configuré des circuits ExpressRoute géoredondants ou que vous utilisez une connectivité de VPN IPSec de site à site comme solution de secours, l’activation de BFD aide à accélérer la bascule sur l’alternative de secours après une défaillance de la connectivité ExpressRoute.If you have configured Geo-redundant ExpressRoute circuits or use Site-to-Site IPSec VPN connectivity as backup; enabling BFD would help failover quicker following an ExpressRoute connectivity failure.

Étapes suivantesNext Steps

Pour plus d’informations ou d'aide, consultez les liens suivants :For more information or help, check out the following links: