Développer des travaux Edge Stream Analytics avec les outils Visual StudioDevelop Stream Analytics Edge jobs using Visual Studio tools

Dans ce tutoriel, découvrez comment utiliser les outils Stream Analytics pour Visual Studio.In this tutorial, you learn how to use Stream Analytics tools for Visual Studio. Vous apprenez à écrire, créer et déboguer vos travaux Stream Analytics Edge.You learn how to author, debug, and create your Stream Analytics Edge jobs. Après avoir créé et testé le travail, vous pourrez accéder au portail Azure pour le déployer sur vos appareils.After you create and test the job, you can go to the Azure portal to deploy it to your devices.

PrérequisPrerequisites

Pour effectuer ce didacticiel, vous avez besoin des prérequis suivants :You need the following prerequisites to complete this tutorial:

Créer un projet Stream Analytics EdgeCreate a Stream Analytics Edge project

Dans Visual Studio, sélectionnez Fichier > Nouveau > Projet.From Visual Studio, select File > New > Project. Accédez à la liste Modèles à gauche > développez Azure Stream Analytics > Stream Analytics Edge > Application Azure Stream Analytics Edge.Navigate to the Templates list on the left > expand Azure Stream Analytics > Stream Analytics Edge > Azure Stream Analytics Edge Application. Entrez le nom, l’emplacement et le nom de la solution pour votre projet, puis sélectionnez OK.Provide a Name, Location, and Solution name for your project and select OK.

Nouveau projet Stream Analytics Edge dans Visual Studio

Une fois que vous avez créé le projet, accédez à l’Explorateur de solutions pour afficher l’arborescence des dossiers.After the project gets created, navigate to the Solution Explorer to view the folder hierarchy.

Vue du travail de périphérie Stream Analytics dans l’Explorateur de solutions

Choisir le bon abonnementChoose the correct subscription

  1. Dans le menu Affichage de Visual Studio, sélectionnez Explorateur de serveurs.From your Visual Studio View menu, select Server Explorer.

  2. Cliquez avec le bouton droit sur Azure > Sélectionnez Se connecter à un abonnement Microsoft Azure > et connectez-vous avec votre compte Azure.Right click on Azure > Select Connect to Microsoft Azure Subscription > and then sign in with your Azure account.

Définir les entréesDefine inputs

  1. Dans l’Explorateur de solutions, développez le nœud Entrées pour afficher l’entrée EdgeInput.json.From the Solution Explorer, expand the Inputs node you should see an input named EdgeInput.json. Double-cliquez sur cette sortie pour afficher ses paramètres.Double-click to view its settings.

  2. Définissez le type de source sur Flux de données.Set Source Type to Data Stream. Ensuite, définissez la source sur Edge Hub, le format de sérialisation d’événement sur Jsonet l’encodage sur UTF8.Then set Source to Edge Hub, Event Serialization Format to Json, and Encoding to UTF8. Pour les besoins de cet exemple, laissez l’alias indiqué dans Alias d’entrée. Cet alias peut toutefois être renommé.Optionally, you can rename the Input Alias, let’s leave it as is for this example. Si vous renommez l’alias d’entrée, utilisez le nom que vous avez spécifié au moment de la définition de la requête.In case you rename the input alias, use the name you specified when defining the query. Sélectionnez Enregistrer pour enregistrer les paramètres.Select Save to save the settings.
    Configuration d’une entrée de travail Stream AnalyticsStream Analytics job input configuration

Définir les sortiesDefine outputs

  1. Dans l’Explorateur de solutions, développez le nœud Sorties pour afficher la sortie EdgeOutput.json.From the Solution Explorer, expand the Outputs node you should see an output named EdgeOutput.json. Double-cliquez sur cette sortie pour afficher ses paramètres.Double-click to view its settings.

  2. Veillez à définir le Récepteur pour sélectionner Edge Hub, puis définissez le format de sérialisation d’événement sur Json, la valeur d’encodage sur UTF8 et le format sur Tableau.Make sure to set Sink to select Edge Hub, set Event Serialization Format to Json, set Encoding to UTF8, and set Format Array. Pour les besoins de cet exemple, laissez l’alias indiqué dans Alias de sortie. Cet alias peut toutefois être renommé.Optionally, you can rename the Output Alias, let’s leave it as is for this example. Si vous renommez l’alias de sortie, utilisez le nom que vous avez spécifié au moment de la définition de la requête.In case you rename the output alias, use the name you specified when defining the query. Sélectionnez Enregistrer pour enregistrer les paramètres.Select Save to save the settings. Configuration d’une sortie de travail Stream AnalyticsStream Analytics job output configuration

Définir la requête de transformationDefine the transformation query

Les travaux Stream Analytics déployés dans les environnements Stream Analytics IoT Edge prennent en charge la plupart des références du langage de requête Stream Analytics.Stream Analytics jobs deployed in the Stream Analytics IoT Edge environments support most of Stream Analytics Query Language reference. Toutefois, les opérations suivantes ne sont pas encore prises en charge pour les travaux Stream Analytics Edge :However, the following operations aren't yet supported for Stream Analytics Edge jobs:

CatégorieCategory CommandeCommand
Autres opérateursOther operators
  • PARTITION BYPARTITION BY
  • TIMESTAMP BY OVERTIMESTAMP BY OVER
  • UDF JavaScriptJavaScript UDF
  • Agrégats définis par l’utilisateur – (UDA)User-defined aggregates (UDA)
  • GetMetadataPropertyValueGetMetadataPropertyValue
  • Utilisation de plus de 14 agrégats dans une seule étapeUsing more than 14 aggregates in a single step

Quand vous créez un travail Stream Analytics Edge dans le portail, le compilateur affiche automatiquement un avertissement si vous utilisez un opérateur non pris en charge.When you create a Stream Analytics Edge job in the portal, the compiler will automatically warn you if you aren't using a supported operator.

Dans Visual Studio, définissez la requête de transformation suivante dans l’éditeur de requête (fichier script.asaql)From your Visual Studio, define the following transformation query in the query editor (script.asaql file)

SELECT * INTO EdgeOutput
FROM EdgeInput 

Tester le travail localementTest the job locally

Pour tester la requête localement, vous devez charger les exemples de données.To test the query locally, you should upload the sample data. Pour obtenir les exemples de données, téléchargez les données d’inscription à partir du référentiel GitHub. Enregistrez-les sur votre ordinateur local.You can get sample data by downloading Registration data from the GitHub repository and save it to your local computer.

  1. Pour charger les exemples de données, cliquez avec le bouton droit sur le fichier EdgeInput.json et choisissez Ajouter une entrée localeTo upload sample data, right click on EdgeInput.json file and choose Add Local Input

  2. Dans la fenêtre indépendante qui s’affiche > sélectionnez Parcourir pour accéder aux exemples de données à partir de votre chemin local > sélectionnez Enregistrer.In the pop-up window > Browse the sample data from your local path > Select Save. Configuration d’une entrée locale dans Visual StudioLocal input configuration in Visual Studio

  3. Un fichier nommé local_EdgeInput.json est automatiquement ajouté à votre dossier d’entrées.A file named local_EdgeInput.json is added automatically to your inputs folder.

  4. Vous pouvez l’exécuter localement ou l’envoyer sur Azure.You can either run it locally or submit to Azure. Pour tester la requête, sélectionnez Exécuter localement.To test the query, select Run Locally.
    Options d’exécution de travail Stream Analytics dans Visual StudioStream Analytics job run options in Visual Studio

  5. La fenêtre d’invite de commandes affiche l’état du travail.The command prompt window shows the status of the job. Quand le travail s’exécute correctement, un dossier du type « 2018-02-23-11-31-42 » est créé dans le chemin du dossier de projet « Visual Studio 2015\Projects\MyASAEdgejob\MyASAEdgejob\ASALocalRun\2018-02-23-11-31-42 ».When the job runs successfully, it creates a folder that looks like "2018-02-23-11-31-42" in your project folder path "Visual Studio 2015\Projects\MyASAEdgejob\MyASAEdgejob\ASALocalRun\2018-02-23-11-31-42". Accédez à l’emplacement du dossier pour afficher les résultats dans le dossier local :Navigate to the folder path to view the results in the local folder:

    Vous pouvez également vous connecter au portail Azure pour vérifier que le travail a bien été créé.You can also sign in to the Azure portal and verify that the job is created.

    Dossier de résultat du travail Stream Analytics

Envoyer le travail sur AzureSubmit the job to Azure

  1. Avant d’envoyer le travail sur Azure, vous devez vous connecter à votre abonnement Azure.Before you submit the job to Azure, you must connect to your Azure Subscription. Ouvrez l’Explorateur de serveurs > cliquez avec le bouton droit sur Azure > Se connecter à un abonnement Microsoft Azure > connectez-vous à votre abonnement Azure.Open Server Explorer > right click on Azure > Connect to Microsoft Azure subscription > sign in to your Azure subscription.

  2. Pour envoyer le travail sur Azure, accédez à l’éditeur de requête > sélectionnez Envoyer sur Azure.To submit the job to Azure, navigate to the query editor > select Submit to Azure.

  3. Une fenêtre contextuelle s’ouvre.A pop-up window opens. Choisissez de mettre à jour un travail Stream Analytics Edge existant, ou créez-en un.Choose to update an existing Stream Analytics Edge job or create a new one. Quand vous mettez à jour un travail existant, le travail mis à jour remplace la configuration entière du travail existant. Dans ce scénario, vous allez créer un travail.When you update an existing job, it will replace all the job configuration, in this scenario, you'll publish a new job. Sélectionnez Créer un travail Azure Stream Analytics > entrez un nom pour votre travail (par exemple, MyASAEdgeJob) > choisissez les paramètres Abonnement, Groupe de ressources et Emplacement appropriés > sélectionnez Envoyer.Select Create a New Azure Stream Analytics Job > enter a name for your job something like MyASAEdgeJob > choose the required Subscription, Resource Group, and Location > Select Submit.

    Envoyer votre travail Stream Analytics sur Azure à partir de Visual Studio

    Votre travail Stream Analytics Edge est créé.Now your Stream Analytics Edge job has been created. Vous pouvez maintenant utiliser le tutoriel Exécuter des travaux sur IoT Edge pour apprendre à déployer ce travail sur vos appareils.You can refer to the Run jobs on IoT Edge tutorial to learn how to deploy it to your devices.

Gérer le travailManage the job

Vous pouvez afficher l’état et le diagramme du travail à partir de l’Explorateur de serveurs.You can view the status of job and the job diagram from the Server Explorer. À partir de Stream Analytics dans l’Explorateur de serveurs, développez l’abonnement et le groupe de ressources où vous avez déployé le travail Stream Analytics Edge.From Stream Analytics in Server Explorer, expand the subscription and the resource group where you deployed the Stream Analytics Edge job. Vous pouvez voir le travail MyASAEdgejob avec l’état Créé.You can view the MyASAEdgejob with status Created. Développez le nœud du travail et double-cliquez dessus pour afficher la vue du travail.Expand your job node and double-click on it to open the job view.

Options de gestion du travail dans l’Explorateur de serveurs

Dans la fenêtre de vue du travail, vous pouvez effectuer des opérations comme actualiser le travail, le supprimer et l’ouvrir à partir du portail Azure.The job view window provides you with operations such as refreshing the job, deleting the job, and opening the job from Azure portal.

Diagramme du travail et autres options dans Visual Studio

Étapes suivantesNext steps