Erreur lors du basculement d’un tenant en mode Teams uniquement

Symptômes

Lorsque vous essayez de basculer un tenant vers le mode Teams Uniquement au niveau de l’organisation à l’aide du Centre d’administration Microsoft Teams ou en exécutant la cmdlet, l’action ne se termine pas et vous recevez un message d’erreur qui ressemble à l’un des messages suivants, en fonction de l’interface utilisateur que vous Grant-CsTeamsUpgradePolicy utilisez.

Centre d’administration Microsoft Teams

Consultez les sections non notées en rouge ci-dessous.

Screenshot of unsaved section when switching o Teams Only mode.

Remarque : Si vous rencontrez cette erreur dans le centre d’administration Microsoft Teams, nous vous recommandons d’exécuter la cmdlet qui affichera le message d’erreur Grant-CsTeamsUpgradePolicy détaillé suivant.

PowerShell Teams

AVERTISSEMENT : tous* les utilisateurs de ce tenant sont désormais des utilisateurs Teams uniquement, à l’exception des utilisateurs qui ont une attribution de stratégie explicite * teamsUpgradePolicy. Teams utilisateurs ne peuvent pas utiliser Skype Entreprise tenant, sauf pour participer Skype Entreprise réunions. Pour plus d’informations, voir http://aka.ms/UpgradeToTeams . Cette organisation ne peut pas être mise à niveau vers le mode TeamsOnly. Un ou plusieurs domaines M365 ont un enregistrement DNS public qui pointe vers un déploiement Skype Entreprise Server local. Les enregistrements de domaine en panne sont {[lyncdiscover. <domain_name> . <IP_address> ];}. Pour mettre à niveau ce tenant vers TeamsOnly, terminez d’abord la migration de tous les utilisateurs de l’Skype Entreprise Server local vers le cloud (à l’aide), puis désactivez la configuration hybride Skype Entreprise pour ce tenant et mettez à jour les enregistrements DNS pour qu’ils pointent vers Move-CsUser M365. Une fois ces étapes terminées, vous pouvez exécuter cette commande, après quoi tous les utilisateurs et tous les nouveaux utilisateurs créés par la suite seront TeamsOnly.

Capture d’écran de l’erreur PowerShell lors du basculement d’o Teams mode Uniquement.

Remarque : Le message d’erreur réel spécifie le nom et l’adresse IP de chaque domaine dont les enregistrements de domaine sont incorrects. Cet exemple utilise du texte d’espace réservé pour un nom de domaine et une adresse IP affectés.

Cause

Lorsque vous lancez le processus de basculement de votre tenant en mode Teams Uniquement, l’enregistrement DNS lyncdiscover pour chaque domaine activé pour SIP dans le tenantt est vérifié. Si l’enregistrement DNS de découverte lyncdiscover pour un domaine est présent mais ne pointe pas vers Microsoft 365, toute tentative de basculement en mode Teams Seul échoue.

Résolution

Au minimum, les conditions suivantes doivent être remplies pour activer le mode Teams uniquement au niveau de l’organisation :

  • Pour tous les domaines activés pour SIP dans un tenant, l’enregistrement DNS de découverte lyncdiscover doit pointer vers Microsoft 365.
  • Pour tous les domaines activés pour SIP qui seront utilisés pour Skype Entreprise Online et Teams,tous les enregistrements DNS doivent être présents.

Pour corriger cette erreur, faites les choses suivantes :

  1. Déterminez l’état SIP de tous les domaines du tenant qui sont activés ou désactivés pour SIP :

    1. Connecter à Teams PowerShell.
    2. Exécutez l’cmdlet Get-CsOnlineSipDomain pour obtenir la liste de tous les domaines SIP en ligne et leur état comme activé ou désactivé.
  2. Pour chaque domaine dont l’état est Activé, déterminez s’il est en cours d’utilisation. Pour ce faire, exécutez l’cmdlet suivante dans Teams PowerShell :

    Get-CsOnlineUser -ResultSize Unlimited | select userprincipalname,sipaddress | Export-Csv C:\<Path>\allteamsusersexport.csv
    

    Remarque : Dans cette cmdlet, remplacez par l’emplacement du dossier où <Path> vous souhaitez enregistrer la sortie. La sortie sera exportée vers le fichierAllteamsusersexport.csv qui sera enregistré dans le chemin d’accès que vous spécifiez. Il liste tous les utilisateurs avec leurs noms d’utilisateur principaux (UPN) et adresses SIP. Vous pouvez filtrer le .csv par domaines SIP pour déterminer quels domaines activés pour SIP sont utilisés. Vous pouvez également déterminer le domaine activé pour SIP qui est affecté à chaque utilisateur.

  3. Pour chaque domaine activé pour SIP utilisé, vérifiez les enregistrements DNS existants :

    1. Connectez-vous au centre d’administration Microsoft 365.
    2. Accédez à Paramètres > domaines.
    3. Pour chaque domaine de la page Domaines, sélectionnez les paramètres DNS, puis vérifiez les enregistrements DNS répertoriés pour Skype Entreprise. Ajoutez les enregistrements DNS manquants. Pour plus d’informations sur la façon de vérifier et d’ajouter des enregistrements DNS, voir l’étape 6 dans Ajouter un domaine à Microsoft 365.

    Remarque : Les domaines activés pour SIP par défaut dans votre tenant sont soit onmicrosoft.com propriétaires, soit gérés par Microsoft. Vous n’avez pas besoin de vérifier leurs enregistrements DNS, car ces informations sont mises à jour automatiquement par Microsoft.

  4. Identifiez les domaines siP inutilisés en comparant la liste de tous les domaines activés pour SIP de l’étape 1b à la liste des domaines actuellement utilisés dans le fichier Allteamsusersexport.csv de l’étape 2. Les domaines qui sont dans la liste « 1b », mais pas dans le fichier .csv seront ceux qui ne sont pas utilisés.

  5. Pour chaque domaine activé sip inutilisé, utilisez la méthode 1 ou la méthode 2 :

    • Méthode 1 : Assurez-vous que l’enregistrement DNS lyncdiscover existe et pointe vers Microsoft 365.

    • Méthode 2 : Désactivez le domaine pour SIP en exécutant l’cmdlet Disable-CsOnlineSipDomain suivante :

      Disable-CsOnlineSipDomain -Domain <domain_name>
      

      Avertissement

      N’exécutez pas cette cmdlet sur les domaines qui contiennent des utilisateurs hébergés sur Skype Entreprise Online ou Teams. Si vous désactivez un domaine SIP en ligne, tous les comptes Skype Entreprise Online qui sont provisionn s dans ce domaine seront supprimés. Bien que Teams n’utilise pas la fonctionnalité SIP de la même manière que Skype Entreprise Online, il possède des dépendances qui reposent sur la fonctionnalité SIP et sur les comptes Skype Entreprise Online qui sont mis en service dans le domaine SIP.

  6. Essayez d’activer Teams mode Uniquement pour votre tenant à nouveau.