Vous recevez un message d’erreur « Le composant ActiveX ne peut pas créer d’objet » lors de l’utilisation d’Access

Numéro de la base de connaissances d’origine : 319844

Symptômes

Lorsque vous utilisez Microsoft Access, le message d’erreur suivant s’affiche :

Le composant ActiveX ne peut pas créer d’objet

Cet article décrit certaines causes courantes de ce message d’erreur et propose des méthodes que vous pouvez utiliser pour résoudre le problème.

Cause

Ce comportement peut se produire si l’une des conditions suivantes est remplie :

  • Data Access Objects (DAO) n’est pas correctement inscrit.
  • Une ou plusieurs références sont manquantes.
  • Il existe une référence de base de données utilitaire qui n’est pas valide.
  • Vous ne disposez pas des autorisations requises pour les bibliothèques requises.
  • Un fichier d’Assistant est endommagé.

Résolution

Cause 1 : DAO n’est pas correctement inscrit

Réinscrivez la bibliothèque DAO 3.6. Pour cela, procédez comme suit :

  1. Sur l’ordinateur sur lequel Microsoft Access est installé, ou sur l’ordinateur qui héberge Microsoft Terminal Windows Server, cliquez sur Démarrer, puis sur Exécuter. (Si vous ne voyez pas Exécuter, vous pouvez le rechercher ou ouvrir une invite de commandes).
  2. Dans la zone de texte Exécuter, tapez regsvr32 suivi du chemin d’accès à votre fichier DAO. Placez ce chemin entre guillemets. Par exemple, pour inscrire la bibliothèque DAO 3.6, utilisez la commande suivante, qui inclut le chemin d’accès par défaut au fichier de bibliothèque DAO : regsvr32 "C:\Program Files\Common Files\Microsoft Shared\DAO\DAO360.DLL".

Cause 2 : Une ou plusieurs références sont manquantes

Recherchez les références manquantes. Pour ce faire, procédez comme suit :

  1. Ouvrez la base de données pour laquelle vous recevez le message d’erreur.
  2. Appuyez sur Alt+F11 pour ouvrir le Rédacteur Microsoft Visual Basic.
  3. Dans le Rédacteur Visual Basic, cliquez sur Références dans le menu Outils.
  4. Passez en revue la liste des références disponibles qui sont vérifiées. Si l’un des éléments cochés affiche le mot « Manquant », décochez la référence.

Vous pouvez également cliquer sur le bouton Parcourir dans la boîte de dialogue Références pour accéder à l’emplacement du fichier de bibliothèque associé à la référence manquante.

Cause 3 : Il existe une référence de base de données utilitaire qui n’est pas valide

Depuis la version de Microsoft Access 2000, aucune référence à l’utilitaire n’est requise. Si vous avez converti une base de données à partir d’une version précédente, vous pouvez toujours voir une référence à l’utilitaire dans votre liste de références. Décochez toutes les références à Utility ou Utility.mda. Pour cela, procédez comme suit :

  1. Ouvrez la base de données pour laquelle vous recevez le message d’erreur.
  2. Appuyez sur ALT+F11 pour ouvrir le Rédacteur Visual Basic.
  3. Dans le Rédacteur Visual Basic, cliquez sur Références dans le menu Outils.
  4. Cliquez pour décochez la case case activée en regard de toute référence à Utility Database ou Utility.mda.

Cause 4 : Vous ne disposez pas des autorisations requises pour les bibliothèques requises

Tous les utilisateurs de Microsoft Access doivent disposer d’autorisations sur les dossiers système Windows.

  • Vérifiez que les utilisateurs disposent d’autorisations de lecture pour tous les fichiers dans les dossiers suivants.

    Système d’exploitation Emplacement
    32 bits ou (x86) \Windows\System32
    64 bits ou (x64) \Windows\SysWOW64
  • Si vous ne pouvez pas accorder d’autorisations de lecture, vous pouvez utiliser un utilitaire tel que Process Monitor pour déterminer le ou les fichiers que les utilisateurs ne disposent pas des autorisations requises pour utiliser. Pour obtenir process Monitor, visitez le site Web Sysinternals suivant : Sysinternals.

Cause 5 : Fichier de l’Assistant endommagé

Pour réparer les fichiers de l’Assistant endommagés, procédez comme suit :

  1. Utilisez Windows Explorer pour localiser les fichiers d’Assistant suivants : Acwzmain.mde, Acwztool.mde et Acwzlib.mde.
  2. Remplacez l’extension de nom de fichier de chaque fichier par « old ». Par exemple, remplacez Acwzmain.mde par Acwzmain.old.
  3. Réparez Microsoft Access ou Microsoft Office Professionnel pour réinstaller les fichiers de l’Assistant.

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