Message d’erreur lorsque vous cliquez sur un lien hypertexte dans Office : « Serveur ou proxy Internet introuvable »

Symptômes

Lorsque vous créez un lien hypertexte dans un document Office, puis cliquez sur le lien, l’un des messages d’erreur suivants peut s’afficher :

Impossible d’ouvrir <URL>. Impossible de localiser le serveur Internet ou le serveur proxy.

Impossible d’ouvrir <URL>. Impossible d’ouvrir le fichier spécifié.

<URL> = le lien hypertexte que vous avez inséré.

Remarque

L’hyperlien fonctionne si vous le tapez directement dans le navigateur ou dans la boîte de dialogue Ouvrir de la boîte de dialogue Exécuter (sélectionnez Démarrer, puis Exécuter).

Cause

Ce problème se produit lorsque les conditions suivantes sont remplies :

  • Vous utilisez Microsoft Internet Explorer :

    • En tant que serveur proxy -ou-
    • Avec un pare-feu qui n’autorise pas les requêtes HTTP à être placées sur votre réseau local
  • Internet Explorer n’est pas votre navigateur par défaut.

  • La clé de registre ForceShellExecute n’est pas présente à l’emplacement suivant ou n’est pas définie sur 1 :

    • Pour les versions 32 bits d’Office installées sur des systèmes d’exploitation 64 bits :

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Pour les versions 32 bits d’Office installées sur des systèmes d’exploitation 32 bits ou les versions 64 bits d’Office installées sur des systèmes d’exploitation 64 bits :

      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Internet

    Remarque

    Le chemin d’accès au registre ne dépend pas de votre version d’Office.

Solution de contournement

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro d’article ci-dessous pour afficher l’article correspondante dans la Base de connaissances Microsoft :

322756 Comment sauvegarder et restaurer le Registre dans Windows

Ajout de la sous-clé Internet au Registre et définition des données de la valeur

Pour résoudre ce problème, ajoutez la sous-clé ForceShellExecute, si elle n’est pas présente, et définissez les données de la valeur, ou si elle est présente, définissez les données de la valeur de la sous-clé ForceShellExecute.

  1. Fermez les programmes qui sont en cours d’exécution.

  2. Sélectionnez Démarrer, puis Exécuter. Tapez regedit dans la zone Ouvrir, puis sélectionnez OK.

  3. Dans l’Éditeur du Registre, accédez à l’une des sous-clés suivantes (créez les clés si elles n’existent pas) :

    • Pour une version 32 bits d’Office sur une version 64 bits de Windows :

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

    • Pour une version 32 bits d’Office sur une version 32 bits de Windows :

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

    • Pour une version 64 bits d’Office sur une version 64 bits de Windows :

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

  4. Assurez-vous que la sous-clé Internet est sélectionnée. Dans le menu Modifier, placez le cursus sur Nouveau, puis sélectionnez la valeur DWORD. Ajoutez la valeur de Registre suivante :

    Nom de la valeur : ForceShellExecute

  5. Double-cliquez sur ForceShellExecute, puis définissez les données de la valeur sur 1. Sélectionnez OK.

  6. Dans le menu Registre, cliquez sur Quitter.

Le problème est-il résolu ?

Vérifiez si le problème est résolu. Si le problème est résolu, vous en avez terminé avec cette section. Si le problème n’est pas résolu, contactez le support.

Informations supplémentaires

Un lien hypertexte peut ne pas diriger vers un document Microsoft Word ou une feuille de calcul Microsoft Excel après l’utilisation de cette solution de contournement.

Office utilise le fichier Urlmon.dll pour gérer toutes les transitions Internet.

Dans ce cas, le fichier Urlmon.dll envoie une demande pour obtenir un fichier http:// via le serveur proxy. Le serveur proxy voit que la demande provenait d’Internet Explorer, basé sur le champ HTTP User Agent (Agent utilisateur) de http://request. Il envoie ensuite une erreur 403, qui indique « Accès refusé ».

Le fichier Urlmon.dll obtient ceci et renvoie simplement le message d’erreur mentionné précédemment. L’erreur signifie que la demande a échoué, mais elle n’indique jamais pourquoi elle a échoué.

La solution de contournement est d’utiliser une commande ShellExecute() sur l’URL. Cela permet au système d’exploitation de démarrer l’URL sur le navigateur par défaut. Si le navigateur par défaut n’est pas limité par le serveur proxy, la page appropriée s’affiche.