Les informations sur les objets Active Directory modifiés ne sont pas mises à jour dans le carnet d’adresses dans Office 365 dédié/ITAR

Notes

Office 365 ProPlus est renommé Applications Microsoft 365 pour les entreprises. Pour plus d’informations sur ce changement, lisez ce billet de blog.

Symptômes

Lorsque vous modifiez ou mettez à jour les informations de l’objet Active Directory, vous remarquez que les informations ne sont pas mises à jour dans le carnet d’adresses de Microsoft Office 365 dédié/ITAR.

Cause

Ce problème se produit généralement lorsqu’une ou plusieurs des conditions suivantes sont vraies :

  1. L’objet n’est pas mis en service ou mis à jour dans le site Active Directory géré par le service Microsoft Online Services Identity and Provisioning Service (MMSSPP). 
  2. Le carnet d’adresses en mode hors connexion n’est pas à jour. Par conséquent, le client Microsoft Outlook ne dispose pas de la version la plus récente lorsqu’il utilise Outlook en mode mis en cache.

Résolution

Pour résoudre ce problème, recherchez le nouvel objet ou les informations mises à jour dans Microsoft Office Outlook Web App (Outlook Web App) ou Microsoft Outlook en mode en ligne. Outlook Web App et Outlook Web App en mode en ligne font référence directement aux informations à partir du site Active Directory géré. Cela permet de déterminer l’action suivante appropriée.

Si l’objet ou les informations mises à jour ne se trouvent pas dans Outlook Web App, reportez-vous à l’article suivant de la base de connaissances Microsoft pour résoudre les problèmes de provisionnement MMSSPP : 

2615447 MMSSPP ne synchronise pas les objets de boîte aux lettres et d’extension de messagerie Exchange avec l’environnement Office géré dédié Office 365

Si l’objet ou les informations mises à jour s’affichent correctement dans Outlook Web App mais sont introuvables lorsque vous utilisez Outlook en mode mis en cache, vous devez identifier le nombre d’utilisateurs concernés. Si le problème est limité à un petit groupe d’utilisateurs, procédez comme suit pour résoudre les problèmes du client :

  1. Vérifiez Outlook pour déterminer si un nouveau carnet d’adresses en mode hors connexion est nécessaire.Pour cela, procédez comme suit:

    1. Dans le menu Outils , pointez sur Envoyer/recevoir, puis cliquez sur Télécharger le carnet d’adresses.
    2. Sous informations à télécharger, cliquez sur tous les détails.
  2. Forcez le client Outlook à télécharger un carnet d’adresses en mode hors connexion complet.Pour ce faire, procédez comme suit :

    1. Quittez Outlook, Microsoft Lync et toutes les autres applications qui peuvent disposer d’une connexion à Outlook.
    2. Ouvrez Windows Explorer.
    3. Modifiez l’option pour afficher les éléments masqués.
    4. Recherchez C:\Users \ < user alias> carnets d’adresses \appdata\local\microsoft\outlook\offline Address. (AppData est un dossier masqué.)
    5. Supprimez le contenu du dossier carnets d’adresses en mode hors connexion.
    6. Redémarrez Outlook.

    Note Cette étape doit être utilisée uniquement pour la résolution des problèmes afin de déterminer s’il existe un problème potentiel dans le client Outlook.

Si le problème affecte tous les utilisateurs, déterminez si le temps écoulé pour la mise à jour du carnet d’adresses en mode hors connexion est suffisant.

Les serveurs Exchange dans Office 365 les environnements dédiés/ITAR sont configurés pour générer un fichier différentiel OAB toutes les huit heures. Ces fichiers, ainsi qu’un fichier OAB complet plus volumineux, sont distribués aux serveurs d’accès au client (CAS) dans l’environnement du client. Un client Outlook en mode mis en cache recherche un nouveau fichier OAB différentiel toutes les 24 heures. Si la taille du fichier différentiel est égale à la moitié de la taille du fichier de carnet d’adresses en mode hors connexion complet, le client télécharge le fichier de carnet d’adresses en mode hors connexion.

Pour qu’une modification apportée au site Active Directory atteigne l’ordinateur client, les événements suivants doivent se produire :

  • Les modifications apportées au site Active Directory du client sont répliquées sur un contrôleur de domaine préféré MMSSPP. 
  • Un temps suffisant a expiré pour que la modification soit synchronisée avec succès sur le site Active Directory géré par le processus de synchronisation MMSSPP. Cela prend généralement entre 30 et 60 minutes.
  • Suffisamment de temps a été passé pour que la modification atteigne le serveur de génération du carnet d’adresses en mode hors connexion et soit incluse dans un nouveau fichier différentiel. Cela prend généralement 8 heures.
  •  Suffisamment de temps a été passé pour que le client Outlook recherche un téléchargement complet du carnet d’adresses en mode hors connexion. Cela prend généralement 24 heures.