Vous ne pouvez pas attribuer un domaine fédéré à un utilisateur dans le centre d’administration Microsoft 365

Notes

Office 365 ProPlus est renommé Applications Microsoft 365 pour les entreprises. Pour plus d’informations sur ce changement, lisez ce billet de blog.

Problème

Vous créez un utilisateur dans le centre d’administration 365 de Microsoft Office 365. Toutefois, lorsque vous essayez d’affecter un domaine fédéré au nouvel utilisateur, le domaine fédéré n’est pas répertorié dans la liste des domaines de l’utilisateur. 

Voici un exemple de scénario de ce qui se produit lorsque vous êtes confronté à ce problème :

  • Dans le portail Office 365, la synchronisation SSO (Single Sign-On) et Active Directory sont activées.
  • Lorsque vous affichez les propriétés du domaine sur la page des propriétés du domaine, le type de domaine est signalé comme fédéré ou authentification unique. Par exemple, adatum.com est le domaine fédéré.
  • Lorsque vous créez un utilisateur, vous constatez que le domaine par défaut fourni par Office 365 est indiqué comme première option dans la zone de liste déroulante. Par exemple, le domaine par défaut est contoso.onmicrosoft.com.
  • Lorsque vous cliquez sur la zone de liste déroulante pour afficher la liste des domaines, le domaine fédéré n’est pas répertorié. Par exemple, adatum.com n’est pas indiqué.

Cause

Ce comportement est dû à la conception dans Office 365. Vous ne pouvez pas créer d’utilisateurs fédérés via le portail. Tous les utilisateurs fédérés doivent être créés en local et doivent être synchronisés à l’aide de l’outil de synchronisation Microsoft Azure Active Directory. 

Solution

Pour contourner ce problème, créez un compte d’utilisateur correspondant dans l’environnement des services de domaine Active Directory (AD DS) local, configurez le nom d’utilisateur principal (UPN) de façon appropriée, puis synchronisez le compte et Azure Active Directory à l’aide de la synchronisation d’annuaires. Pour cela, procédez comme suit :

  1. Obtenir l’adresse SMTP principale du compte d’utilisateur Office 365. Pour cela, procédez comme suit :

    1. Connectez-vous au portail Office 365 ( https://portal.office.com ) en tant qu’administrateur général.
    2. Cliquez sur administrateur, puis sur Exchange   pour ouvrir le centre d’administration Exchange.
    3. Recherchez le compte d’utilisateur, puis double-cliquez dessus.
    4. Dans le volet de navigation de gauche, cliquez sur adresse de messagerie, puis notez l’adresse SMTP principale du compte d’utilisateur.
  2. Démarrez utilisateurs et ordinateurs Active Directory, puis créez un compte d’utilisateur dans le domaine local qui correspond au compte d’utilisateur Office 365. Pour plus d’informations sur la procédure à suivre, consultez la rubrique créer un compte d’utilisateur dans utilisateurs et ordinateurs Active Directory.

  3. Assurez-vous que l’UPN du compte d’utilisateur est mis à jour vers le nom de domaine fédéré. Pour plus d’informations sur la procédure à suivre, consultez la rubrique Troubleshoot Active Directory User Accounts As Office 365 SSO-Enabled User ID.

  4. Utilisez ADSI (Active Directory Service Interfaces) Edit pour modifier l’attribut proxyAddresses de l’objet utilisateur de sorte qu’il corresponde à l’adresse SMTP principale que vous avez notée à l’étape 1d. Pour cela, procédez comme suit :

    Notes

    Pour plus d’informations sur l’installation d’ADSI Edit, voir Installing ADSI Edit.

    1. Cliquez sur Démarrer, sur exécuter, tapez Adsiedit. msc, puis cliquez sur OK.

    2. Cliquez avec le bouton droit sur modification ADSI, sélectionnez se connecter à, puis cliquez sur OK pour charger la partition de domaine.

    3. Dans le volet de navigation, recherchez l’objet utilisateur que vous souhaitez modifier, cliquez dessus avec le bouton droit, puis cliquez sur Propriétés.

    4. Dans la liste attributs , cliquez sur l’attribut proxyAddresses , puis cliquez sur modifier.

    5. Dans le champ valeur à ajouter , entrez l’adresse SMTP appropriée, puis cliquez sur Ajouter.

      Notes

      La valeur de l’adresse SMTP principale de l’objet utilisateur doit être précédée d’un indicateur « SMTP : » en majuscules pour que la valeur d’adresse soit correctement mise en forme pour le proxyAddressesattribute. Par exemple, « SMTP:username@contoso.com » est une valeur acceptable et « username@contoso.com » n’est pas une valeur acceptable.

    6. Cliquez sur OK à deux reprises, puis quittez ADSI Edit.

    Pour plus d’informations sur l’utilisation de l’Éditeur ADSI pour modifier des attributs Active Directory, reportez-vous au site Web Microsoft TechNet suivant : utilisation d’ADSI Edit

  5. Force la synchronisation d’annuaires.

Plus d’informations

Pour plus d’informations, voir résoudre les problèmes liés aux noms d’utilisateurs qui se produisent pour les utilisateurs fédérés lorsqu’ils se connectent à Office 365, Azure ou Intune.  

Encore besoin d’aide ? Accédez à Microsoft Community.