Outlook ne peut pas se connecter à un serveur Exchange qui utilise la validation de certificat sur un appareil réseau

Numéro de la ko d’origine :   4488049

Symptômes

Une fois que vous avez configuré un périphérique réseau pour exiger la validation de certificat entre Outlook et Exchange Server 2019, 2016 ou 2013, vous découvrez des échecs de connexion dans les clients Outlook.

Notes

Le périphérique réseau peut être un programme d’équilibrage de charge ou un autre périphérique réseau, comme décrit dans la sélection et la validation des certificats.

Ce problème se produit en particulier si le périphérique réseau est configuré pour exiger que le client présente un certificat lors de la mise en relation SSL dans la couche réseau au lieu de transmettre le trafic directement au serveur qui exécute Exchange Server.

Cause

Ce problème se produit car Outlook ne prend pas en charge l’utilisation du magasin de certificats Windows comme informations d’identification. Outlook utilise le Gestionnaire d’informations d’identification Windows pour fournir des informations d’identification aux serveurs.

Résolution

Pour configurer l’authentification par certificat dans Outlook 2016 et les versions ultérieures, nous vous recommandons d’utiliser l’authentification moderne. Pour plus d’informations sur l’authentification moderne, consultez les articles suivants :

Plus d’informations

Outlook prend en charge la connexion directement à l’authentification par carte à puce à l’aide d’une carte à puce physique ou d’une carte à puce virtuelle intégrée au TPM pour chaque utilisateur. L’authentification basée sur les certificats est prise en charge pour les clients Outlook Web App (OWA) et Exchange ActiveSync, mais pas dans Outlook qui s’exécute sur Windows. Pour plus d’informations, voir les articles suivants :