Certaines règles sont désactivées et vous recevez un message d’erreur lorsque vous essayez de créer ou d’activer des règles dans Outlook

Numéro de la base de connaissances initiale :   886616

Symptômes

Après avoir effectué une mise à niveau vers Office Outlook 2003 (ou version ultérieure), vous pouvez remarquer que certaines de vos règles sont désactivées et qu’elles ne peuvent pas être activées. D’autres règles fonctionnent correctement. Si vous essayez d’activer les règles qui sont désactivées, le message d’erreur suivant s’affiche :

Une ou plusieurs règles n’ont pas pu être chargées sur Exchange Server et ont été désactivées. Cela peut être dû au fait que certains des paramètres ne sont pas pris en charge ou qu’il n’y a pas suffisamment d’espace pour stocker toutes vos règles.

Cause

  • Boîtes aux lettres sur Microsoft Exchange Server 2007, Exchange Server 2010 ou Exchange Server 2013

    Ce comportement survient si les règles de votre boîte aux lettres dépassent le quota de règles établi pour votre boîte aux lettres. La limite de taille des règles pour les boîtes aux lettres dans Exchange Server 2007 (et versions ultérieures) a une taille par défaut de 64 Ko par boîte aux lettres. La limite de taille de règles total est également personnalisable jusqu’à 256 Ko par boîte aux lettres.

  • Boîtes aux lettres sur Exchange Server 2003

    Ce comportement survient si les règles de votre boîte aux lettres dépassent la taille de 32 kilo-octets (Ko). La limite de taille de règles totales pour les boîtes aux lettres sur Exchange Server 2003 est de 32 Ko. La limite de règles pour Exchange 2003 ne peut pas être modifiée.

Dans Outlook 2003 et les versions ultérieures, la taille des règles a augmenté principalement pour assurer la prise en charge du format Unicode.

Solution de contournement

Si votre boîte aux lettres se trouve sur Exchange Server 2007 ou version ultérieure, vous pouvez demander à votre administrateur Exchange d’augmenter le quota de règles pour votre boîte aux lettres.

L’exemple de commande suivant définit le quota de règles sur la valeur maximale de 256 Ko.

Set-Mailbox john@contoso.com -RulesQuota:256kb

L’exemple de commande suivant vous permet d’afficher le quota de règles actuel pour une boîte aux lettres.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Si votre administrateur Exchange ne peut pas augmenter le quota de règles pour votre boîte aux lettres, essayez l’une des solutions suivantes qui s’appliquent à toutes les versions d’Exchange.

Pour contourner ce problème de sorte que vos règles soient restaurées, utilisez une ou plusieurs des méthodes suivantes pour réduire la taille de vos règles existantes.

Méthode 1

Renommez vos règles en un nom plus court. Pour renommer une règle dans Outlook, procédez comme suit.

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur gérer les règles et les alertes.
  3. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur modifier les règles, puis sur Renommer la règle.
  5. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  6. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur règles et alertes.
  2. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez renommer.
  3. Dans la liste modifier la règle , cliquez sur Renommer la règle.
  4. Tapez un nouveau nom plus court pour la règle, puis cliquez sur OK.
  5. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Méthode 2

Supprimez toutes les anciennes règles. Pour supprimer une règle dans Outlook, procédez comme suit :

Pour Outlook 2010 et versions ultérieures :

  1. Dans l'onglet Fichier, cliquez sur Info.
  2. Cliquez sur gérer les règles et les alertes.
  3. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur le bouton supprimer , puis cliquez sur Oui pour confirmer la suppression.
  5. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur règles et alertes.
  2. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez supprimer.
  3. Cliquez sur supprimer, puis sur Oui pour confirmer la suppression.
  4. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Méthode 3

Combiner des règles similaires pour réduire la taille globale de vos règles. Si possible, combinez des règles similaires pour réduire la taille globale de vos règles. Une fois que vous avez combiné des règles similaires, supprimez les règles dont vous n’avez plus besoin. Pour modifier une règle existante dans Outlook, procédez comme suit.

Pour Outlook 2010 et versions ultérieures :

  1. Sous l’onglet fichier , cliquez sur informations.
  2. Cliquez sur gérer les règles et les alertes.
  3. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur modifier la règle, puis sur modifier les paramètres de la règle.
  5. Modifiez la règle en fonction de vos besoins.
  6. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur règles et alertes.

  2. Sous l’onglet règles du courrier électronique , cliquez sur la règle à modifier.

  3. Dans la liste modifier la règle , cliquez sur modifier les paramètres de la règle.

    Modifiez la règle en fonction de vos besoins.

  4. Lorsque vous avez terminé, cliquez sur Terminer, puis sur OK pour fermer la boîte de dialogue règles et alertes .

Notes

Si la règle est une règle client uniquement, vous devez cliquer deux fois sur OK pour fermer la boîte de dialogue règles et alertes .

Méthode 4

Déplacez votre fichier de dossiers personnels (. pst) vers un emplacement dont le chemin d’accès est le plus court. Si vous avez des règles qui déplacent les messages électroniques vers un fichier. pst, déplacez votre fichier. pst vers un emplacement dont le nom de chemin d’accès est le plus court possible. Par exemple, déplacez votre fichier. pst vers un emplacement tel que C : \<file_name>. pst. Pour déplacer votre fichier. pst dans Outlook, procédez comme suit :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur dossiers personnels ou sur le nom du dossier qui s’affiche pour votre fichier. pst, puis cliquez sur propriétés pour <folder_name>.

    Notes

    Ce dossier sera toujours un dossier de niveau supérieur dans le volet de navigation, dans courrier.

  2. Sous l’onglet général , cliquez sur avancé.

  3. Dans la zone de texte nom de fichier, notez le chemin d’accès complet et le nom du fichier. pst.

  4. Cliquez deux fois sur OK pour fermer la boîte de dialogue ** propriétés de<folder_name>** .

  5. Quittez Outlook.

  6. Utilisez l’Explorateur Microsoft Windows pour déplacer votre fichier. pst vers le nouvel emplacement.

    Par défaut, l’emplacement d’un fichier. pst est le suivant : \ Documents and Settings \<user_name> \Local Settings\Application Data\Microsoft\Outlook. Folder. L’emplacement par défaut est un dossier masqué. Pour accéder à ce dossier à l’aide de l’Explorateur Windows, vous devez d’abord activer l’affichage des dossiers cachés. Pour cela, procédez comme suit :

    1. Dans l’Explorateur Windows, cliquez sur Options des dossiers dans le menu Outils .

    2. Cliquez sur l’onglet affichage .

    3. Dans la section Paramètres avancés , cliquez sur afficher les fichiers et les dossiers cachés sous fichiers et dossiers cachés.

    4. Si vous souhaitez afficher toutes les extensions de nom de fichier, désactivez la case à cocher Masquer les extensions des fichiers dont le type est connu sous fichiers et dossiers.

      Notes

      Les dossiers masqués sont estompés pour indiquer qu’il ne s’agit pas de dossiers standard.

    5. Cliquez sur OK.

  7. Utilisez l’une des méthodes suivantes pour ouvrir l’élément de courrier dans le panneau de configuration :

    • Pour effectuer cette opération sur un ordinateur Windows XP ou Windows Server 2003, cliquez sur Démarrer, sur panneau de configuration, sur comptes d’utilisateurs, puis sur courrier.

      Notes

      Si vous utilisez l’affichage classique, cliquez sur Démarrer, puis sur panneau de configuration, puis double-cliquez sur courrier.

    • Pour effectuer cette opération sur un ordinateur Microsoft Windows 2000, cliquez sur Démarrer, pointez sur paramètres, cliquez sur panneau de configuration, puis double-cliquez sur courrier.

  8. Cliquez sur afficher les profils, puis cliquez sur le profil qui contient votre fichier. pst.

  9. Cliquez sur Propriétés, puis sur fichiers de données.

  10. Cliquez sur le fichier de données. pst que vous avez déplacé, puis cliquez sur paramètres.

  11. Lorsque vous êtes invité à indiquer que le fichier de données est introuvable à l’ancien emplacement, cliquez sur OK.

  12. Recherchez et cliquez sur votre fichier. pst dans le nouvel emplacement du dossier, puis cliquez sur ouvrir.

  13. Cliquez sur OK, puis cliquez deux fois sur Fermer .

  14. Cliquez sur OK.

  15. Quittez le panneau de configuration.

  16. Redémarrez Outlook.

Méthode 5

Désactivez la case à cocher sur cet ordinateur uniquement . Si vous utilisez une règle pour déplacer des messages électroniques vers un fichier. pst, désactivez la case à cocher sur cet ordinateur uniquement , sauf si vous accédez à votre courrier électronique de serveur Exchange à partir de différents ordinateurs clients. Pour effectuer cette opération dans Outlook, procédez comme suit :

Pour Outlook 2010 et versions ultérieures :

  1. Sous l’onglet fichier , cliquez sur informations.
  2. Cliquez sur gérer les règles et les alertes.
  3. Sous l’onglet règles du courrier électronique , cliquez sur la règle que vous souhaitez renommer.
  4. Cliquez sur modifier la règle, puis sur modifier les paramètres de la règle.
  5. Désactivez la case à cocher sur cet ordinateur uniquement si la case à cocher est activée.
  6. Terminez l' Assistant règles. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

Pour Outlook 2007 et Outlook 2003 :

  1. Dans le menu Outils , cliquez sur règles et alertes.

  2. Sous l’onglet règles du courrier électronique , cliquez sur la règle à modifier.

  3. Dans la liste modifier la règle , cliquez sur modifier les paramètres de la règle.

  4. Si ce champ est activé, désactivez la case à cocher sur cet ordinateur uniquement .

  5. Terminez l’Assistant règles.

  6. Cliquez sur OK pour fermer la boîte de dialogue règles et alertes .

    Notes

    Si vous utilisez des règles client uniquement qui pointent vers des fichiers de ressources locaux, par exemple, le transfert d’éléments vers un dossier dans un fichier. pst et l’utilisation de plusieurs ordinateurs pour accéder à Microsoft Outlook, des conflits de règle peuvent se produire. Par conséquent, certaines règles client uniquement peuvent être désactivées.