Vous recevez des erreurs de mémoire insuffisante lorsque vous développez une boîte aux lettres ou un dossier public dans Outlook

Numéro de la base de connaissances d’origine : 2968387

Symptômes

Lorsque vous développez une boîte aux lettres ou un dossier public (à l’exception de la boîte de réception) dans Microsoft Outlook ou que vous sélectionnez Carnet d’adresses dans la barre d’outils, vous pouvez recevoir l’une des erreurs suivantes :

Impossible d’afficher le dossier. Il n’y a pas assez de mémoire libre pour exécuter ce programme. Quittez un ou plusieurs programmes, puis réessayez.

Impossible de développer le dossier. La mémoire disponible est insuffisante pour effectuer l’opération.

Impossible d’accéder à la liste d’adresses. Vous avez besoin de davantage de mémoire ou de ressources système. Fermez certaines fenêtres et réessayez.

Lorsque vous recevez l’une de ces erreurs, le courrier sortant peut être bloqué dans le dossier Boîte d’envoi et ne pas être envoyé tant que vous n’avez pas redémarré Outlook.

Cause

Ce problème se produit lorsque votre profil de messagerie Outlook inclut un compte Microsoft Exchange configuré pour utiliser le mode Exchange mis en cache, que l’option Télécharger les favoris des dossiers publics est activée et que vous avez un grand nombre de dossiers publics mis en cache. En règle générale, ce problème se produit lorsque vous avez plus de 1 000 dossiers publics environ, ou lorsque les dossiers publics mis en cache consomment un gigaoctet d’espace.

Résolution

Pour éviter ce problème, désactivez l’option Télécharger les favoris des dossiers publics ou conservez le nombre de favoris de dossiers publics mis en cache à moins de 1 000. Si le problème persiste avec moins de 1 000 favoris de dossiers publics, réduisez le nombre de dossiers jusqu’à ce que vous arrêtiez de recevoir l’erreur ou les erreurs. Vous pouvez généralement réduire le nombre de favoris de dossiers publics en les supprimant à l’aide du client Outlook. Toutefois, dans certains cas où vous avez trop de favoris de dossiers publics, il se peut que vous ne puissiez pas supprimer les dossiers à l’aide du client Outlook, car l’erreur se produit lorsque vous sélectionnez le dossier public Favoris. Si cela se produit, vous pouvez supprimer les favoris des dossiers publics à l’aide de MFCMapi à la place.

Pour résoudre ce problème en désactivant l’option Télécharger les favoris des dossiers publics , procédez comme suit :

  1. Dans Outlook, sélectionnez Fichier, Paramètres du compte, puis Paramètres du compte.

  2. Sélectionnez votre compte Microsoft Exchange, puis sélectionnez Modifier.

  3. Sélectionnez Paramètres supplémentaires.

  4. Sous l’onglet Avancé, désactivez la zone Télécharger les favoris des dossiers publics case activée.

  5. Sélectionnez OK.

  6. Vous êtes invité à redémarrer Outlook pour que ces modifications prennent effet. Sélectionnez OK.

  7. Sélectionnez Suivant, Terminer, puis Fermer.

  8. Quittez Outlook, puis redémarrez Outlook.

Pour supprimer les favoris des dossiers publics à l’aide de MFCMapi, procédez comme suit :

  1. Téléchargez MFCMAPI.

  2. Exécutez MFCMAPI.exe.

  3. Dans le menu Session, cliquez sur Ouverture de session.

  4. Sélectionnez le nom de votre profil Outlook, puis sélectionnez OK.

  5. Dans le volet supérieur, recherchez la ligne qui correspond à votre boîte aux lettres, puis double-cliquez dessus.

  6. Dans le volet de navigation (volet gauche), développez Racine - Boîte aux lettres, puis sélectionnez le dossier Raccourcis.

  7. Dans le volet d’informations (volet droit), recherchez les propriétés PR_FOLDER_CHILD_COUNT. La colonne Valeur contient le nombre de favoris de dossiers publics.

  8. Si vous souhaitez supprimer tous vos favoris de dossiers publics, procédez comme suit :

    1. Dans le volet de navigation. Cliquez avec le bouton droit sur le dossier Raccourcis, sélectionnez Avancé, puis sélectionnez Éléments et sous-dossiers vides à partir du dossier.

      Capture d’écran de l’option Vider les éléments et sous-dossiers du dossier dans le menu contextuel.

    2. Conservez les options par défaut, puis sélectionnez OK.

  9. Si vous souhaitez supprimer des favoris de dossiers publics spécifiques, procédez comme suit :

    1. Dans le volet de navigation, développez le dossier Raccourcis, cliquez avec le bouton droit sur le favori Dossier public que vous souhaitez supprimer, puis sélectionnez Supprimer le dossier.

      Capture d’écran de l’option Supprimer le dossier dans le menu contextuel.

    2. Conservez les options par défaut, puis sélectionnez OK.