Utilisation du langage R dans l’Éditeur de requêteUsing R in Query Editor

Vous pouvez utiliser le langage de programmation R largement utilisé par les analystes de données, les scientifiques de données et les statisticiens dans l’Éditeur de requête Power BI Desktop.You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. Cette intégration de R dans l’Éditeur de requête permet de procéder au nettoyage des données à l’aide de R et d’effectuer une mise en forme et des analyses avancées des données dans les jeux de données, y compris la saisie de données manquantes, les prévisions et le clustering pour ne citer que quelques exemples.This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R est un langage puissant. Il peut être utilisé dans l’Éditeur de requête pour préparer votre modèle de données et créer des rapports.R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

Installation de RInstalling R

Pour utiliser R dans l’Éditeur de requête Power BI Desktop, vous devez installer R sur votre ordinateur local.To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. Vous pouvez télécharger et installer R gratuitement à partir de nombreux emplacements, dont les pages Download Revolution R Open et CRAN Repository.You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

Utilisation du langage R dans l’Éditeur de requêteUsing R in Query Editor

Pour vous montrer comment utiliser R dans l’Éditeur de requête, nous allons utiliser un exemple provenant d’un jeu de données boursières basé sur un fichier CSV que vous pouvez télécharger ici.To show how to use R in Query Editor, we'll use an example from a stock market dataset, based on a .CSV file that you can download from here and follow along. Les étapes de cet exemple sont les suivantes :The steps for this example are the following:

  1. Tout d’abord, entrez des données dans Power BI Desktop.First, load your data into Power BI Desktop. Dans cet exemple, nous allons charger le fichier EuStockMarkets_NA.csv.In this example we'll load the EuStockMarkets_NA.csv file. Sélectionnez Obtenir des données > CSV dans le ruban Accueil de Power BI Desktop.Select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. Sélectionnez le fichier et choisissez Ouvrir. Le fichier CSV s’affiche dans la boîte de dialogue Fichier CSV.Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. Une fois que les données sont chargées, elles s’affichent dans le volet Champs de Power BI Desktop.Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Ouvrez l’Éditeur de requête en sélectionnant Modifier les requêtes dans le ruban Accueil de Power BI Desktop.Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. Sous l’onglet Transformation, sélectionnez Exécuter un script R. L’éditeur Exécuter un script R apparaît (voir l’étape suivante).In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). Notez que les lignes 15 et 20 ont des données manquantes, comme les autres lignes qui ne figurent pas dans l’image suivante.Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. Les étapes ci-dessous montrent comment R peut compléter ces lignes pour vous.The steps below show how R can (and will) complete those rows for you.

  6. Pour cet exemple, nous allons entrer le code de script suivant :For this example, we'll enter the following script code:

    library(mice)
    tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
    completedData <- complete(tempData,1)
    output <- dataset
    output$completedValues <- completedData$"SMI missing values"
    

    Note

    La bibliothèque mice doit être installée dans votre environnement R pour que le code de script précédent fonctionne correctement.You'll need to have the mice library installed in your R environment for the previous script code to work properly. Pour installer mice, exécutez la commande suivante dans votre installation de R : | > install.packages('mice')To install mice, run the following in your R installation: | > install.packages('mice')

    Lorsqu’il est placé dans la boîte de dialogue Exécuter un script R, le code ressemble à ce qui suit :When put into the Run R Script dialog, the code looks like the following:

  7. Lorsque vous sélectionnez OK, l’Éditeur de requête affiche un avertissement concernant la confidentialité des données.When we select OK, Query Editor displays a warning about data privacy.

  8. Pour que les scripts R fonctionnent correctement dans le service Power BI, toutes les sources de données doivent être définies comme étant publiques.For the R scripts to work properly in the Power BI service, all data sources need to be set to public. Pour plus d’informations sur les paramètres de confidentialité et leurs implications, consultez Niveaux de confidentialité.For more information about privacy settings and their implications, see Privacy Levels.

    Une fois que cela est fait, nous voyons une nouvelle colonne dans la zone Champs, appelée completedValues.Once we do so, we see a new column in the Fields well called completedValues. Il existe quelques éléments de données manquants, par exemple sur les lignes 15 et 18.Notice there are a few missing data elements, such as on row 15 and 18. Nous verrons comment R gère cela dans la section suivante.We'll see how R handles that in the next section.

Avec seulement cinq lignes de script R, l’Éditeur de requête a renseigné les valeurs manquantes à l’aide d’un modèle de prévision.With just five lines of R script, Query Editor filled in the missing values with a predictive model.

Création d’éléments visuels à partir des données de script RCreating visuals from R script data

Maintenant, nous pouvons créer un élément visuel pour voir comment le script R a complété les valeurs manquantes à l’aide de la bibliothèque mice, comme illustré dans l’image suivante.Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image.

Une fois que l’élément visuel et les autres éléments visuels que nous pouvons créer à l’aide de Power BI Desktop sont terminés, nous pouvons enregistrer le fichier Power BI Desktop (au format .pbix), puis utiliser le modèle de données, y compris les scripts R associés, dans le service Power BI.Once that visual is complete, and any other visuals we might want to create using Power BI Desktop, we can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

Note

Vous voulez voir un fichier .pbix complété une fois les étapes ci-dessus terminées ?Want to see a completed .pbix file with these steps completed? Vous pouvez télécharger le fichier Power BI Desktop complet utilisé dans ces exemples ici.You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

Une fois que vous avez téléchargé le fichier .pbix vers le service Power BI, quelques étapes supplémentaires sont nécessaires pour activer l’actualisation des données (dans le service) et pour mettre à jour les éléments visuels dans le service (pour cela, les données doivent accéder à R).Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). Les étapes supplémentaires sont les suivantes :The additional steps are the following:

  • Activer l’actualisation planifiée pour le jeu de données : pour activer l’actualisation planifiée pour le classeur qui contient votre jeu de données avec des scripts R, consultez Configuration d’une actualisation planifiée, qui inclut également des informations sur Personal Gateway.Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • Installer Personal Gateway : vous devez installer Personal Gateway sur l’ordinateur où se trouvent le fichier et R. Le service Power BI doit accéder à ce classeur et restituer de nouveau les éléments visuels mis à jour.Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. Vous pouvez obtenir plus d’informations sur l’installation et la configuration de Personal Gateway.You can get more information on how to install and configure Personal Gateway.

LimitesLimitations

Il existe certaines limitations pour les requêtes qui incluent des scripts R créés dans l’Éditeur de requête :There are some limitations to queries that include R scripts created in Query Editor:

  • Tous les paramètres de source de données R doivent être définis comme étant publics et toutes les autres étapes d’une requête créée dans l’Éditeur de requête doivent également être publiques.All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. Pour accéder aux paramètres de la source de données, dans Power BI Desktop, sélectionnez Fichier > Options et paramètres > Paramètres de la source de données.To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    Dans la boîte de dialogue Paramètres de la source de données, sélectionnez la ou les sources de données, puis Modifier les autorisations... et vérifiez que le niveau de confidentialité est défini sur Public.From the Data Source Settings dialog, select the the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • Pour activer l’actualisation planifiée de vos éléments visuels R ou d’un jeu de données, vous devez activer l’actualisation planifiée et installer Personal Gateway sur l’ordinateur qui héberge le classeur et l’installation de R.To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. Pour plus d’informations à ce sujet, consultez les liens indiqués dans la section précédente de cet article.For more information on both, see the previous section in this article, which provides links to learn more about each.

Il existe toutes sortes d’opérations que vous pouvez faire avec R et les requêtes personnalisées. Par conséquent, explorez et mettez en forme vos données de la façon dont vous souhaitez qu’elles apparaissent.There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.