Formules de champ calculé

Dernière modification : mercredi 4 juillet 2012

S’applique à : SharePoint Foundation 2010

Dans cet article
Remarques importantes
Formules conditionnelles
Formules de date et d'heure
Formules mathématiques
Formules texte

Les tableaux suivants fournissent des informations sur les différents types de formules que vous pouvez implémenter dans un champ calculé à l'aide du Formula de la classe Microsoft.SharePoint.SPFieldCalculated.

Remarques importantes

Note

Les formules Microsoft SharePoint Foundation des champs calculés sont basées sur les fonctions et la syntaxe Microsoft Excel. Cependant, Microsoft ne prend en charge que les fonctions mentionnées sur cette page pour les champs calculés SharePoint Foundation. Par exemple, la fonction Excel MID (MILIEU) n'est pas prise en charge.

Important

Tous les exemples de formule dans cette rubrique utilisent la virgule "," comme caractère de délimitation des paramètres. Dans certains pays, la virgule est réservée à l'usage de signe décimal. Dans ces pays, les utilisateurs créant un champ calculé doivent utiliser le point-virgule ";" comme caractère de délimitation. Indépendamment du caractère utilisé à la création du champ, la formule travaille sur des listes dans des sites web SharePoint n'importe où dans le monde. SharePoint remplace automatiquement le caractère de délimitation par celui approprié à la langue/culture de la page actuelle. Par exemple, supposons que la formule suivante est créée sur un site web dont le paramètre de culture est fr-fr (France) : =IF(Number1>Number2;5;10). Si la culture du site web devient ensuite en-us (États-Unis), la formule devient automatiquement : =IF(Number1>Number2,5,10).

Formules conditionnelles

Vous pouvez utiliser les formules suivantes pour tester la condition d'une instruction et retourner une valeur Oui ou Non, pour tester une valeur de remplacement telle que OK ou Pas OK, ou pour retourner une valeur vide ou un tiret pour représenter une valeur NULL.

Déterminer si un nombre est supérieur à ou inférieur à un autre

Utilisez la fonction SI pour effectuer cette comparaison.

Colonne1

Colonne2

Formule

Description (résultat possible)

15000

9000

=[Colonne1]>[Colonne2]

Colonne1 est-elle supérieure à Colonne2 ? (Oui)

15000

9000

=SI([Colonne1]<=[Colonne2], "OK", "Pas OK")

Colonne1 est-elle inférieure ou égale à Colonne2 ? (Pas OK)

Retourner une valeur logique après comparaison du contenu des colonnes

Pour un résultat qui est une valeur logique (Oui ou Non), utilisez les fonctions ET, OU et NON.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 et inférieur à 8 ? (Non)

15

9

8

=OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 ou inférieur à 8 ? (Oui)

15

9

8

=NON([Colonne1]+[Colonne2]=24)

15 plus 9 n'est-il pas égal à 24 ? (Non)

Pour un résultat qui est un autre calcul, ou toute valeur autre que Oui ou Non, utilisez les fonctions SI, ET et OU.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=SI([Colonne1]=15, "OK", "Pas OK")

Si la valeur dans Colonne1 est égale à 15, retourner "OK". (OK)

15

9

8

=SI(ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 et inférieur à 8, retourner "OK". (Pas OK)

15

9

8

=SI(OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), "OK", "Pas OK")

Si 15 est supérieur à 9 ou inférieur à 8, retourner "OK". (OK)

Afficher des zéros comme des espaces ou des tirets

Pour afficher un zéro, effectuez un calcul simple. Pour afficher un vide ou un tiret, utilisez la fonction SI.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

10

=[Colonne1]-[Colonne2]

Deuxième nombre soustrait du premier. (0)

15

9

=SI([Colonne1]-[Colonne2],[Colonne1]-[Colonne2],"-")

Retourne un tiret lorsque la valeur est égale à zéro. (-)

Masquer les valeurs d'erreur dans les colonnes

Pour afficher un tiret, #N/A ou NA à la place d'une valeur d'erreur, utilisez la fonction ESTERREUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

0

=[Colonne1]/[Colonne2]

Entraîne une erreur (# DIV/0)

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"NA",[Colonne1]/[Colonne2])

Retourne NA lorsque la valeur est une erreur

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"-",[Colonne1]/[Colonne2])

Retourne un tiret lorsque la valeur est une erreur

Formules de date et d'heure

Vous pouvez utiliser les formules suivantes pour effectuer des calculs qui reposent sur les dates et heures, notamment ajouter un nombre de jours, mois ou années à une date, calculer la différence entre deux dates et convertir une heure en une valeur décimale.

Ajouter des dates

Pour ajouter un nombre de jours à une date, utilisez l'opérateur d'addition (+).

Note

Lorsque vous manipulez des dates, le type de retour de la colonne calculée doit être défini à date et heure.

Colonne1

Colonne2

Formule

Description (résultat possible)

9/6/2007

3

=[Colonne1]+[Colonne2]

Ajoute 3 jours au 9/6/2007 (12/6/2007)

10/12/2008

54

=[Colonne1]+[Colonne2]

Ajoute 54 jours au 10/12/2008 (2/2/2009)

Pour ajouter un nombre de mois à une date, utilisez les fonctions DATE, ANNÉE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

9/6/2007

3

=DATE(ANNÉE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 3 mois à 9/6/2007 (9/9/2007)

10/12/2008

25

=DATE(ANNÉE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 25 mois à 10/12/2008 (10/1/2011)

Pour ajouter un nombre d'années à une date, utilisez les fonctions DATE, ANNÉE, MOIS et JOUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

9/6/2007

3

=DATE(ANNÉE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 3 ans à 9/6/2007 (9/6/2010)

10/12/2008

25

=DATE(ANNÉE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 25 ans à 10/12/2008 (10/12/2033)

Pour ajouter une combinaison de jours, mois et années à une date, utilisez les fonctions DATE, ANNÉE, MOIS et JOUR.

Colonne1

Formule

Description (résultat possible)

9/6/2007

=DATE(ANNÉE([Colonne1])+3,MOIS([Colonne1])+1,JOUR([Colonne1])+5)

Ajoute trois ans, un mois et cinq jours à 9/6/2007 (14/7/2010)

10/12/2008

=DATE(ANNÉE([Colonne1])+1,MOIS([Colonne1])+7,JOUR([Colonne1])+5)

Ajoute un an, sept mois et cinq jours à 10/12/2008 (15/7/2010)

Calculer la différence entre deux dates

Utilisez la fonction DATEDIF pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat possible)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"d")

Retourne le nombre de jours entre les deux dates (1626)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"ym")

Retourne le nombre de mois entre les dates, en ignorant la partie Années (5)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"yd")

Retourne le nombre de jours entre les dates, en ignorant la partie Années (165)

Calculer la différence entre deux heures

Pour présenter le résultat au format d'heure standard heures:minutes:secondes), utilisez l'opérateur de soustraction (-) et la fonction TEXTE. Pour que cette méthode fonctionne, les heures ne doivent pas dépasser 24, et les minutes et les secondes ne doivent pas dépasser 60.

Colonne1

Colonne2

Formule

Description (résultat possible)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h")

Heures entre deux heures (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm")

Heures et minutes entre deux heures (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm:ss")

Heures, minutes et secondes entre deux heures (4:55:00)

Pour présenter le résultat dans un total qui repose sur une unité de temps, utiliser la fonction ENT, ou la fonction HEURE, MINUTE ou SECONDE.

Colonne1

Colonne2

Formule

Description (résultat possible)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*24)

Nombre total d'heures entre deux heures (28)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*1440)

Nombre total de minutes entre deux heures (1735)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*86400)

Nombre total de secondes entre deux heures (104100)

09/06/2007 10:35

10/06/2007 15:30

=HEURE([Colonne2]-[Colonne1])

Heures entre deux heures, lorsque la différence n'excède pas 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTE([Colonne2]-[Colonne1])

Minutes entre deux heures, lorsque la différence n'excède pas 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SECONDE([Colonne2]-[Colonne1])

Secondes entre deux heures, lorsque la différence n'excède pas 60 (0)

Convertir des heures

Pour convertir des heures du format d'heure standard en nombre décimal, utilisez la fonction ENT.

Colonne1

Formule

Description (résultat possible)

10:35

=([Colonne1]-ENT([Colonne1]))*24

Nombre d'heures depuis 12:00 (10.583333) )

24:15

=([Colonne1]-ENT([Colonne1]))*24

Nombre d'heures depuis 12:00 (12.25)

Pour convertir des heures à partir d'un nombre décimal au format horaire standard (heures :minutes:secondes), utilisez l'opérateur de division et la fonction TEXTE.

Colonne1

Formule

Description (résultat possible)

23:58

=TEXTE(Colonne1/24, "hh:mm:ss")

Heures, minutes et secondes depuis 12:00 (00:59:55)

2:06

=TEXTE(Colonne1/24, "h:mm")

Heures et minutes depuis 12:00 (0:05)

Insérer des dates au format ordinal

Une date au format ordinal fait référence à un format de date qui est une combinaison de l'année en cours et du nombre de jours depuis le début de l'année. Par exemple, le 1er janvier 2007 est représenté en tant que 2007001 et le 31 décembre 2007, est représenté sous la forme 2007365. Ce format n'est pas basé sur le calendrier julien.

Pour convertir une date en une date au format ordinal, utilisez les fonctions TEXTE et DATEVAL.

Colonne1

Formule

Description (résultat possible)

23/6/2007

=TEXTE([Colonne1],"yy")&TEXTE(([Colonne1]-DATEVAL("1/1/"& TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à deux chiffres (07174)

23/6/2007

=TEXTE([Colonne1],"yyyy")&TEXTE(([Colonne1]-DATEVAL("1/1/"&TEXTE([Colonne1],"yy"))+1),"000")

Date au format ordinal, avec une année à quatre chiffres (2007174)

Pour convertir une date en une date au format ordinal qui est utilisée en astronomie, utilisez la constante 2415018.50. Cette formule ne fonctionne que pour les dates postérieures au 1/3/1901, et si vous utilisez le système de date 1900.

Colonne1

Formule

Description (résultat possible)

23/6/2007

=[Colonne1]+2415018.50

Date au format ordinal, utilisée en astronomie (2454274.50)

Afficher les dates en tant que jour de la semaine

Pour convertir des dates en texte pour le jour de la semaine, utilisez les fonctions TEXTE et JOURSEM.

Colonne1

Formule

Description (résultat possible)

19-févr.-2007

=TEXTE(JOURSEM([Colonne1]), "dddd")

Calcule le jour de la semaine pour la date et retourne le nom complet du jour (Lundi)

3-janv.-2008

=TEXTE(JOURSEM([Colonne1]), "ddd")

Calcule le jour de la semaine pour la date et retourne le nom abrégé du jour (Lun)

Formules mathématiques

Vous pouvez utiliser les formules suivantes pour effectuer des calculs mathématiques, tels que l'ajout, la soustraction, la multiplication et la division de nombres ; calculer la moyenne ou médiane des nombres ; arrondir un nombre ; et compter des valeurs.

Ajouter des nombres

Pour ajouter des nombres dans plusieurs colonnes d'une ligne, utilisez l'opérateur d'addition (+) ou la fonction SOMME.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

6

5

4

=[Colonne1]+[Colonne2]+[Colonne3]

Ajoute les valeurs des trois premières colonnes (15)

6

5

4

=SOMME([Colonne1],[Colonne2],[Colonne3])

Ajoute les valeurs des trois premières colonnes (15)

6

5

4

=SOMME(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieur à Colonne2, ajoute la différence et Colonne3. Sinon ajoute 10 et Colonne3 (5)

Soustraire des nombres

Pour soustraire des nombres dans plusieurs colonnes d'une ligne, utilisez l'opérateur de soustraction (-) ou la fonction SOMME avec des nombres négatifs.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15000

9000

-8000

=[Colonne1]-[Colonne2]

Soustrait 9000 à 15000 (6000)

15000

9000

-8000

=SOMME([Colonne1], [Colonne2], [Colonne3])

Ajoute les nombres des trois premières colonnes, y compris les valeurs négatives (16000)

Calculer la différence entre deux nombres sous forme de pourcentage

Utilisez les opérateurs de soustraction (-) et de division (/) et la fonction ABS.

Colonne1

Colonne2

Formule

Description (résultat possible)

2342

2500

=([Colonne2]-[Colonne1])/ABS([Colonne1])

Variation en pourcentage (6,75 % ou 0,06746)

Multiplier des nombres

Pour multiplier les nombres de plusieurs colonnes d'une ligne, utilisez l'opérateur de multiplication (*) ou la fonction PRODUIT.

Colonne1

Colonne2

Formule

Description (résultat possible)

5

2

=[Colonne1]*[Colonne2]

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1], [Colonne2])

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1],[Colonne2],2)

Multiplie les nombres des deux premières colonnes et le nombre 2 (20)

Diviser des nombres

Pour diviser les nombres de plusieurs colonnes d'une ligne, utilisez l'opérateur de division (/).

Colonne1

Colonne2

Formule

Description (résultat possible)

15000

12

=[Colonne1]/[Colonne2]

Divise 15000 par 12 (1250)

15000

12

=([Colonne1]+10000)/[Colonne2]

Ajoute 15000 et 10000, et divise le total par 12 (2083)

Pour calculer la moyenne des nombres

Pour calculer la moyenne des nombres de plusieurs colonnes d'une ligne, utilisez la fonction MOYENNE.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

6

5

4

=MOYENNE([Colonne1], [Colonne2],[Colonne3])

Moyenne des nombres des trois premières colonnes (5)

6

5

4

=MOYENNE(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieur à Colonne2, calculer la moyenne de la différence et Colonne3. Sinon calculer la moyenne de la valeur 10 et Colonne3 (2,5)

Calculer la médiane des nombres

La médiane est la valeur au centre d'une plage ordonnée de nombres. Utilisez la fonction MEDIANE pour calculer la médiane d'un groupe de nombres.

A

B

C

D

E

F

Formule

Description (résultat)

10

7

9

27

0

4

=MEDIANE(A, B, C, D, E, F)

Médiane des nombres des 6 premières colonnes (8)

Pour calculer le plus petit ou le plus grand nombre d'une plage

Pour calculer le plus petit ou le plus grand nombre de plusieurs colonnes d'une ligne, utilisez les fonctions MIN et MAX.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

10

7

9

=MIN([Colonne1], [Colonne2], [Colonne3])

Plus petit nombre (7)

10

7

9

=MAX([Colonne1], [Colonne2], [Colonne3])

Plus grand nombre (10)

Compter des valeurs

Pour compter des valeurs numériques, utilisez la fonction NB.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

Pomme

12/12/2007

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques. Exclut les valeurs de date et heure, texte et NULL (0)

$12

#DIV/0!

1.01

=NB([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques, mais exclut les valeurs d'erreur et les valeurs logiques (2)

Augmenter ou réduire un nombre par un pourcentage

Utilisez l'opérateur de pourcentage (%) pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat possible)

23

3%

=[Colonne1]*(1+5%)

Augmente le nombre dans Colonne1 de 5 % (24,15)

23

3%

=[Colonne1]*(1+[Colonne2])

Augmente le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (23,69)

23

3%

=[Colonne1]*(1-[Colonne2])

Diminue le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (22,31)

Élever un nombre à une puissance

Utilisez l'opérateur exponentiel (^) ou la fonction PUISSANCE pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat possible)

5

2

=[Colonne1]^[Colonne2]

Calcule cinq au carré (25)

5

3

=PUISSANCE([Colonne1], [Colonne2])

Calcule cinq au cube (125)

Arrondir un nombre

Pour arrondir un nombre, utilisez la fonction ARRONDI.SUP, IMPAIR ou PAIR.

Colonne1

Formule

Description (résultat possible)

20,3

=ARRONDI.SUP([Colonne1],0)

Arrondit 20,3 au nombre entier le plus proche (21)

-5,9

=ARRONDI.SUP([Colonne1],0)

Arrondit -5.9 au nombre entier le plus proche (-5)

12,5493

=ARRONDI.SUP([Colonne1],2)

Arrondit 12,5493 au centième le plus proche, à deux décimales (12,55)

20,3

=PAIR([Colonne1])

Arrondit 20,3 au nombre pair le plus proche (22)

20,3

IMPAIR([Colonne1])

Arrondit 20,3 au nombre impair le plus proche (21)

Pour arrondir à un nombre inférieur, utilisez la fonction ARRONDI.INF.

Colonne1

Formule

Description (résultat possible)

20,3

=ARRONDI.INF([Colonne1],0)

Arrondit 20,3 au nombre entier inférieur le plus proche (20)

-5,9

=ARRONDI.INF([Colonne1],0)

Arrondit -5.9 au nombre entier inférieur le plus proche (-6)

12,5493

=ARRONDI.INF([Colonne1],2)

Arrondit 12,5493 au centième inférieur le plus proche, à deux décimales (12,54)

Pour arrondir un nombre au nombre ou à la fraction les plus proches, utilisez la fonction ARRONDI.

Colonne1

Formule

Description (résultat possible)

20,3

=ARRONDI([Colonne1],0)

Arrondit 20,3 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (20)

5,9

=ARRONDI([Colonne1],0)

Arrondit 5,9 au nombre supérieur, car la partie fractionnaire est supérieure à 0,5 (6)

-5,9

=ARRONDI([Colonne1],0)

Arrondit -5,9 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (-6)

1,25

=ARRONDI([Colonne1]1)

Arrondit le nombre au dixième le plus proche (une décimale). Étant donné que la partie à arrondir est supérieure ou égale à 0,05, le nombre est arrondi au nombre supérieur (résultat : 1,3)

30,452

=ARRONDI([Colonne1]2)

Arrondit le nombre au centième le plus proche (deux décimales). Étant donné que la partie à arrondir, 0,002, est inférieure à 0,005, le nombre est arrondi au nombre inférieur (résultat : 30,45)

Pour arrondir un nombre afin qu'il soit un chiffre significatif supérieure à 0, utilisez les fonctions ARRONDI, ARRONDI.SUP, ARRONDI.INF, ENT et NBCAR.

Colonne1

Formule

Description (résultat possible)

5492820

=ARRONDI([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit le nombre à trois chiffres significatifs (5490000)

22230

=ARRONDI.INF([Colonne1],3-NBCAR(ENT([Colonne1])))

Arrondit le nombre à 3 chiffres significatifs (22200)

5492820

=ARRONDI.SUP([Colonne1], 5-NBCAR(ENT([Colonne1])))

Arrondit au nombre supérieur à 5 chiffres significatifs (5492900)

Formules texte

Vous pouvez utiliser les formules suivantes pour manipuler le texte, notamment combiner ou concaténer les valeurs de plusieurs colonnes, comparer le contenu de colonnes, supprimer des caractères ou des espaces et des caractères extensibles.

Modifier la casse du texte

Pour modifier la casse du texte, utilisez la fonction MAJUSCULE, MINUSCULE ou NOMPROPRE.

Colonne1

Formule

Description (résultat possible)

nina Vietzen

=MAJUSCULE([Colonne1])

Change le texte en majuscules (NINA VIETZEN)

nina Vietzen

=MINUSCULE([Colonne1])

Change le texte en minuscules (nina vietzen)

nina Vietzen

=NOMPROPRE([Colonne1])

Change le texte en casse de titre (Nina Vietzen)

Combiner le prénom et le nom

Pour combiner le prénom et le nom, utilisez l'opérateur « et commercial » (&) ou la fonction CONCATENER.

Colonne1

Colonne2

Formule

Description (résultat possible)

Carlos

Carvallo

=[Colonne1]&[Colonne2]

Combine les deux chaînes (CarlosCarvallo)

Carlos

Carvallo

=[Colonne1]&" "&[Colonne2]

Combine les deux chaînes, en les séparant par un espace (Carvallo Carlos)

Carlos

Carvallo

=[Colonne2]&", "&[Colonne1]

Combine les deux chaînes, en les séparant par une virgule et un espace (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENER([Colonne2], ",", [Colonne1])

Combine les deux chaînes, en les séparant par une virgule (Carvallo,Carlos)

Combiner le texte et les chiffres de différentes colonnes

Pour combiner texte et chiffres, utilisez la fonction CONCATENER, l'opérateur « et commercial (&), ou la fonction TEXTE et l'opérateur « et commercial ».

Colonne1

Colonne2

Formule

Description (résultat possible)

Yang

28

=[Colonne1]&" a vendu "&[Colonne2]&" unités."

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Dubois

40%

=[Colonne1]&" a réalisé "&TEXTE([Colonne2],"0%")&" des ventes totales."

Combine le contenu en une phrase (Dubois a réalisé 40 % des ventes totales.)

Remarque   La fonction TEXTE ajoute la valeur mise en forme de Colonne2 au lieu de la valeur sous-jacente, qui est 0,4.

Yang

28

=CONCATENER([Colonne1]," a vendu ",[Colonne2]," unités.")

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Combiner du texte avec une date ou heure

Pour combiner du texte avec une date ou heure, utilisez la fonction TEXTE et l'opérateur « et commercial » (&).

Colonne1

Colonne2

Formule

Description (résultat possible)

Date de facturation

5-juin-2007

="Date déclaration : "&TEXTE([Colonne2], "d-mmm-yyyy")

Combine du texte avec une date (Date déclaration : 5-juin-2007)

Date de facturation

5-juin-2007

=[Colonne1]&" "&TEXTE([Colonne2], "mmm-dd-yyyy")

Combine de texte et les dates de différentes colonnes dans une colonne (Date de facturation 05-juin-2007)

Comparer le contenu des colonnes

Pour comparer une colonne à une autre colonne ou une liste de valeurs, utilisez les fonctions EXACT et OU.

Colonne1

Colonne2

Formule

Description (résultat possible)

BD122

BD123

=EXACT([Colonne1],[Colonne2])

Compare le contenu des deux premières colonnes (Non)

BD122

BD123

=EXACT([Colonne1], "BD122")

Compare le contenu de Colonne1 et la chaîne « BD122 » (Oui)

Déterminer si une valeur de colonne ou une partie de celle-ci correspond à un texte spécifique

Pour déterminer si une valeur de colonne ou une partie de celle-ci correspond à un texte spécifique, utilisez les fonctions SI, TROUVE, CHERCHE et ESTNUM.

Colonne1

Formule

Description (résultat possible)

Vietzen

=IF([Colonne1]="Vietzen", "OK", "Pas OK")

Détermine si Colonne1 est Vietzen (Oui)

Vietzen

=SI(ESTNUM(TROUVE("v",[Colonne1])), "OK", "Pas OK")

Détermine si Colonne1 contient la lettre v (Oui)

BD123

=ESTNUM(TROUVE("BD",[Colonne1]))

Détermine si Colonne1 contient BD (Oui)

Compter les colonnes non vides

Pour compter les colonnes non vides, utilisez la fonction NBVAL.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

Ventes

19

=NBVAL([Colonne1], [Colonne2])

Compte le nombre de colonnes non vides (2)

Ventes

19

=NBVAL([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes non vides (2)

Supprimer les caractères de texte

Pour supprimer des caractères du texte, utilisez les fonctions NBCAR, GAUCHE et DROITE.

Colonne1

Formule

Description (résultat possible)

Vitamine A

=GAUCHE([Colonne1],NBCAR([Colonne1])-2)

Retourne 8 caractères (10-2), à partir de la gauche (Vitamine)

Vitamine B1

=DROITE([Colonne1], NBCAR([Colonne1])-8)

Retourne 2 caractères (10-8), en commençant à droite (B1)

Supprimer les espaces de début et fin d'une colonne

Pour supprimer des espaces d'une colonne, utilisez la fonction SUPPRESPACE.

Colonne1

Formule

Description (résultat possible)

Bonjour !

=SUPPRESPACE([Colonne1])

Supprime les espaces de début et de fin (Bonjour !)

Répéter un caractère dans une colonne

Pour répéter un caractère dans une colonne, utilisez la fonction REPT.

Formule

Description (résultat possible)

=REPT(".",3)

Répète un point 3 fois (...)

=REPT("-",10)

Répète un tiret 10 fois (----------)

Voir aussi

Référence

SPFieldCalculated