Guide d’utilisation de l’Inspecteur de compatibilité du code Microsoft Office

 

S’applique à : Office 2010

Dernière rubrique modifiée : 2016-11-29

L’Inspecteur de compatibilité du code Microsoft Office vous aide à résoudre les problèmes de compatibilité dans vos macros et compléments Microsoft Visual Basic pour Application (VBA).

Utilisez cet outil pour inspecter un code VBA que vous avez créé dans les versions précédentes de Microsoft Office et pour vous aider à rendre les appels API Windows compatibles avec l’édition 64 bits de Microsoft Office 2010.

Dans cet article :

  • À propos de l'Inspecteur

  • Installation

  • Inspection du code VBA

  • Inspection de code Visual Studio

  • Utilisation de l’Inspecteur

  • Ressources supplémentaires

À propos de l’Inspecteur

L’Inspecteur de compatibilité du code Microsoft Office a pour but d’aider les entreprises ou PME à mettre à jour le code Visual Basic pour Applications (VBA) et Visual Studio Tools pour Office de sorte qu’il soit compatible avec Office 2010. Il ne corrige pas le code ; il l’inspecte, puis commente les lignes de code spécifiques qui font référence à des éléments du modèle objet qui ont changé ou sont désapprouvés. Dans le code VBA, l’outil commente également les instructions Declare pour la compatibilité 64 bits. Vous pouvez ensuite modifier le code en fonction des commentaires ou utiliser les liens fournis dans les commentaires pour afficher des rubriques sur le Web traitant d’une ligne de code particulière.

Là encore, il vous incombe de modifier le code si vous déterminez qu’une modification est nécessaire.

Les principales fonctionnalités de l’Inspecteur de compatibilité du code Office sont les suivantes :

  • Il se compose de quatre compléments qui se chargent, un complément par application, dans Excel 2010, PowerPoint 2010, Word 2010 et Visual Studio 2008.

  • Il s’exécute sur la base de chaque utilisateur ou document. Pour VBA, les utilisateurs ouvre un document et exécutent l’outil à partir de l’onglet Développeur. Pour les projets Visual Studio, le développeur exécute l’outil à partir du menu Outils.

  • Il analyse les projets dans la solution Visual Studio ou le document actif au moyen d’une simple recherche de texte, à la recherche de combinaisons parentObject.Property, et analyse les instructions Declare à des fins de compatibilité 64 bits (dans VBA).

  • Il ajoute des commentaires dans le code aux emplacements où il détecte des problèmes potentiels.

  • Il affiche un résumé et un rapport détaillé de ses résultats une fois son inspection terminée.

Vous ne pouvez pas utiliser cet outil pour inspecter du code à partir de Microsoft Outlook ou Microsoft Access. Cependant, vous pouvez l’utiliser pour inspecter du code Excel, PowerPoint et Word pour ce qui est de l’interaction avec le modèle objet Outlook.

Installation

Pour installer l’Inspecteur de compatibilité du code Office, procédez comme suit :

  1. Téléchargez la version Mise à jour 1 d’OCCI à partir de Outil Office 2010 : Inspecteur de compatibilité (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=171093\&clcid=0x40C) (éventuellement en anglais). Enregistrez-la sur votre bureau ou à tout autre emplacement pratique, puis accédez au fichier et ouvrez-le pour démarrer l’installation.

    • Vous pouvez choisir d’installer uniquement le complément Visual Studio.

    • Vous pouvez choisir d’installer seulement les compléments Office.

    • Sinon, vous pouvez installer tous les compléments.

  2. Suivez les invites, puis cliquez sur Terminer pour terminer l’installation.

Affichage de l’onglet Développeur

Pour chaque application Office dans laquelle vous prévoyez d’utiliser l’outil, procédez comme suit :

  1. Ouvrez Excel 2010, PowerPoint 2010 ou Word 2010 si ce n’est déjà fait.

  2. Sous l’onglet Fichier, choisissez Options.

  3. Choisissez Personnaliser le Ruban.

  4. Sous Choisir les commandes dans les catégories suivantes sur le côté gauche de la boîte de dialogue, choisissez Commandes courantes.

  5. Sous Personnaliser le Ruban sur le côté droit de la boîte de dialogue, choisissez Onglets principaux, puis activez la case à cocher Développeur.

  6. Choisissez OK.

Activer l’accès aux projets VBA

Pour chaque application Office dans laquelle vous prévoyez d’utiliser l’outil, procédez comme suit :

  1. Ouvrez Excel 2010, PowerPoint 2010 ou Word 2010 si ce n’est déjà fait.

  2. Sous l’onglet Fichier, choisissez Options.

  3. Choisissez Centre de gestion de la confidentialité.

  4. Choisissez Paramètres du Centre de gestion de la confidentialité.

  5. Dans l’onglet Paramètres de macros, sélectionnez Accès approuvé au modèle d’objet du projet VBA.

Inspection du code VBA

Pour inspecter un document à des fins de compatibilité, procédez comme suit :

  1. Ouvrez le document dans Excel 2010, PowerPoint 2010 ou Word 2010.

  2. Sous l’onglet Développeur, choisissez Inspect VBA Code (Inspecter le code VBA).

    Figure 1. Options de l’Inspecteur de compatibilité du code sous l’onglet Développeur

    Options d’inspecteur sous l’onglet Développeur

  3. Dans la boîte de dialogue Inspect VBA Project, activez ou désactivez les options de votre choix, puis choisissez Inspect (Inspecter).

    Figure 2. Boîte de dialogue Inspect VBA Project

    Boîte de dialogue Inspect VBA Project

    1. Choisissez Inspect Visual Basic for Application Projects (Inspecter Visual Basic pour des projets d’applications) pour inspecter votre projet VBA à la recherche d’éléments du modèle objet qui ont changé ou qui ont été supprimés.

    2. Choisissez Inspect Declare statements (Inspecter les instructions Declare) si votre projet doit s’exécuter uniquement sur Office 2010 ou s’il est susceptible de s’exécuter sur un système exécutant Office 2010 64 bits.

    3. Choisissez Add comments (Ajouter des commentaires) pour placer des commentaires dans votre code aux emplacements où l’outil identifie des problèmes de compatibilité potentiels. Les commentaires ajoutés par l’Inspecteur sont semblables à ceux de l’exemple suivant.

      '<VBA_INSPECTOR>
      '      <DEPRECATION>
      '        <MESSAGE>Potentially contains ... </MESSAGE>
      '        <ITEM>AnswerWizard.ResetFileList</ITEM>
      '        <URL>http://go.microsoft.com/fwlink/?linkid=171730&clcid=0x40C
      
    4. Choisissez Detailed Report (Rapport détaillé) pour créer un rapport à l’issue du processus d’inspection. Ce rapport est un fichier texte qui ressemble à l’exemple suivant.

      SUMMARY:
      ========
      
      Document scanned:        c:\TestFile.xls
      Date Scanned:            Thursday, November 12, 2009
      Total lines scanned:     101
      Total items found:       1
      Deprecated items:        0
      Changed items:           1
      Redesigned items:        0
      Declare statements:      0
      
      DETAILS:
      ========
      
      MODULE:            Module1
      FUNCTION:          Macro1
      LINE:              19
      TYPE:              CHANGE
      ITEM:              Workbook.VBProject
      URL:               http://go.microsoft.com/fwlink/?linkid=170116&clcid=0x40C:              For Each comp In
      ActiveWorkbook.VBProject.VBComponents
      
  4. Après avoir terminé l’analyse, l’Inspecteur affiche un rapport résumé semblable au suivant.

    Figure 2a. Résumé de l’Inspecteur de compatibilité du code

    Résumé de l’inspecteur de compatibilité du code

    • Total lines scanned – Nombre total de lignes de code VBA analysées dans le document.

    • Total items found – Nombre total d’éléments problématiques détectés par l’Inspecteur dans le code, y compris les instructions Declare à mettre à jour, les éléments modifiés, les éléments désapprouvés et les éléments affectés par des modifications de conception.

    • Deprecated items – Éléments dans le code qui ne sont plus pris en charge par le modèle objet ou qui ont été supprimés de celui-ci. Si votre code dépend d’un élément désapprouvé, vous devez récrire cette partie du code.

    • Éléments modifiés – Éléments dans le code qui utilisent une commande dont la syntaxe a changé. Si votre code utilise de la syntaxe obsolète, vous devez le mettre à jour.

    • Éléments redéfinis ou repensés – Éléments dans le code dont la syntaxe est identique et existe encore, mais dont la conception mise à jour peut provoquer des résultats inattendus sur votre code. Par exemple, la mise en forme d’une zone de texte spécifique peut avoir changé à cause de nouveaux services de texte et, en conséquence, votre code risque de créer une zone de texte où la disposition du texte peut différer des versions précédentes.

    • Instructions Declare – Nombre total d’instructions d’API Windows détectées dans le code VBA puis mises à jour à des fins de compatibilité 64 bits grâce à l’ajout du mot clé PTRSAFE.

Inspection de code Visual Studio

Pour inspecter un document à des fins de compatibilité, procédez comme suit :

  1. Ouvrez la solution à inspecter dans Visual Studio Tools pour Office.

  2. Dans le menu Outils, choisissez Inspect VSTO Code.

    Figure 3. Menu Outils de VSTO

    Menu Outils VSTO

  3. Dans la boîte de dialogue Inspect VSTO Project, activez ou désactivez les options de votre choix, puis choisissez Inspect.

    Figure 4. Boîte de dialogue Inspect VSTO Project

    boîte de dialogue Inspect VSTO Project

    1. Sélectionnez Inspect Visual Studio Tools for Office Source (VB.NET and C#) pour inspecter votre projet Visual Studio Tools pour Office à la recherche d’éléments du modèle objet qui ont changé ou ont été supprimés.

    2. Choisissez Add comments pour placer des commentaires dans votre code aux emplacements où l’outil identifie des problèmes de compatibilité potentiels. Les commentaires ajoutés par l’Inspecteur sont semblables à ceux de l’exemple suivant.

      //<VSTO_INSPECTOR>
      //  <DEPRECATION>
      //      <MESSAGE>Potentially contains removed items...</MESSAGE>
      //      <ITEM>[mso]AnswerWizard.ResetFileList</ITEM>
      //      <URL>http://go.microsoft.com/fwlink/?linkid=171730&clcid=0x40C
      
    3. Choisissez Detailed Report pour créer un rapport à l’issue du processus d’inspection. Ce rapport est un fichier texte qui ressemble à l’exemple suivant.

      SUMMARY:
      ========
      
      Solution scanned:        ExcelAddIn1
      Date scanned:            Thursday, November 12, 2009
      Total lines scanned:     43
      Total items found:       3
      Deprecated items:        3
      Changed items:           0
      Redesigned items:        0
      
      DETAILS:
      ========
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        17
      TYPE:        DEPRECATION
      APP:         mso
      ITEM:        AnswerWizard
      URL:         http://go.microsoft.com/fwlink/?linkid=171730&clcid=0x40C:        xlApp.AnswerWizard.ResetFileList();
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        19
      TYPE:        DEPRECATION
      APP:         xls
      ITEM:        SmartTagRecognizers
      URL:         http://go.microsoft.com/fwlink/?linkid=170614&clcid=0x40C:        xlApp.SmartTagRecognizers.Recognize = true;
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        22
      TYPE:        DEPRECATION
      APP:         xls
      ITEM:        SmartTags
      URL:         http://go.microsoft.com/fwlink/?linkid=170617&clcid=0x40C:        MessageBox.Show(r.SmartTags.Count.ToString());
      
    4. Choisissez Sauvegarder pour sauvegarder vos fichiers de projet avant d’inspecter votre code.

  4. Après avoir terminé l’analyse, l’Inspecteur affiche un rapport résumé semblable au suivant.

    Figure 5. Résumé de l’Inspecteur de compatibilité du code

    Résumé de l’inspecteur de compatibilité du code

    • Total lines scanned – Nombre total de lignes de code Visual Basic .NET ou C# analysées dans le document.

    • Total items found – Nombre total d’éléments problématiques détectés par l’Inspecteur dans le code, y compris les éléments modifiés, les éléments désapprouvés et les éléments affectés par des modifications de conception.

    • Deprecated items – Éléments dans le code qui ne sont plus pris en charge par le modèle objet ou qui ont été supprimés de celui-ci. Si votre code dépend d’un élément désapprouvé, vous devez récrire cette partie du code.

    • Éléments modifiés – Éléments dans le code qui utilisent une commande dont la syntaxe a changé. Si votre code utilise de la syntaxe obsolète, vous devez le mettre à jour.

    • Éléments redéfinis ou repensés – Éléments dans le code dont la syntaxe est identique et existe encore, mais dont la conception mise à jour peut provoquer des résultats inattendus sur votre code. Par exemple, la mise en forme d’une zone de texte spécifique peut avoir changé à cause de nouveaux services de texte et, en conséquence, votre code risque de créer une zone de texte où la disposition du texte peut différer des versions précédentes.

    • Instructions Declare – Nombre total d’instructions d’API Windows détectées dans le code VBA puis mises à jour à des fins de compatibilité 64 bits grâce à l’ajout du mot clé PTRSAFE.

Utilisation de l’Inspecteur

Si l’Inspecteur trouve des éléments Changed, Deprecated ou Redesigned dans votre code, vous devez le déboguer et résoudre tous les problèmes. Nous vous recommandons d’effectuer une passe de test complète sur votre code et d’inspecter chaque fonction. À mesure que vous déboguez votre code, vérifiez les commentaires de l’Inspecteur de compatibilité du code au-dessus des lignes qui provoquent une rupture du code. Ces commentaires doivent vous aider à déterminer le problème sous-jacent lié à cette ligne de code spécifique. Si le problème ne vous saute pas aux yeux immédiatement, collez l’URL fournie dans les commentaires dans votre navigateur pour obtenir des informations supplémentaires.

Suppression de commentaires dans VBA

Pour supprimer les commentaires du code une fois que vous avez terminé de vérifier la compatibilité de votre code avec Office 2010, choisissez Remove Comments (Supprimer les commentaires) sous l’onglet Développeur de votre application Office 2010.

L’Inspecteur supprime tous les commentaires qu’il a placés dans votre projet VBA, puis vous informe du nombre d’éléments supprimés.

Figure 6. Message qui indique le nombre d’éléments supprimés.

Message qui spécifie le nombre d’éléments supprimés

Suppression de commentaires dans Visual Studio

Pour supprimer les commentaires du code une fois que vous avez terminé de vérifier la compatibilité de votre code avec Office 2010, choisissez Remove VSTO Inspector Comments (Supprimer les commentaires de l’inspecteur VSTO) dans le menu Outils dans Visual Studio.

L’Inspecteur supprime tous les commentaires qu’il a placés dans votre projet Visual Studio Tools pour Office, puis vous informe du nombre d’éléments supprimés.

Figure 6a. Message qui indique le nombre d’éléments supprimés.

Message qui spécifie le nombre d’éléments supprimés