Enregistrement orphelin pour la base de données d’application de service PowerPivot

Cet article a été écrit par Zakir Haveliwala, ingénieur senior de l’escalade de support.

Symptômes

Vous pouvez recevoir l’erreur suivante dans windows observateur d'événements ou les journaux du service de journalisation unifiée (ULS) SharePoint :

Impossible d’ouvrir la base de données « Nom de la base de données de l’application de service PowerPivot » demandée par la connexion. Échec de la connexion. Échec de la connexion pour l’utilisateur « username ».

Cause

Il s’agit d’une indication d’un enregistrement orphelin sur la base de données d’application de service PowerPivot dans SharePoint. Ce problème peut se produire après la suppression d’une application de service PowerPivot. Les enregistrements de la base de données d’application de service PowerPivot supprimée ne sont parfois pas supprimés de la base de données de configuration SharePoint. Par conséquent, SharePoint génère une erreur lorsqu’il ne peut pas ouvrir la base de données d’application de service PowerPivot, car elle n’existe plus.

Résolution

Pour résoudre ce problème, supprimez ces enregistrements orphelins. Vous pouvez ouvrir SharePoint Management Shell sur un serveur SharePoint et exécuter la commande suivante :

Get-SPDatabase | où {$_.exists -eq $false}

Cette opération affiche la liste des bases de données qui n’existent plus sur le serveur de base de données SharePoint. La base de données PowerPivot référencée dans l’erreur précédente doit apparaître dans cette liste. Après avoir confirmé cela, vous pouvez supprimer l’enregistrement orphelin en exécutant cette commande :

Get-SPDatabase | where {$.exists -eq $false} | foreach {$.delete()}

Ensuite, l’enregistrement orphelin qui pointe vers l’ancienne base de données d’application de service PowerPivot sera supprimé et l’erreur que vous avez remarquée précédemment cessera de se produire.