Enregistrement orphelin pour la base de données PowerPivot d’application de service
Cet article a été rédigé par Zakir Haveliwala,ingénieur senior de l’escalade du support technique.
Symptômes
Vous pouvez recevoir l’erreur suivante dans Windows’observateur d’événements ou dans SharePoint journaux ULS (Unified Logging Service) :
Impossible d’ouvrir la base de données « Nom de la base PowerPivot application de service» demandée par la connexion. La connexion a échoué. Échec de la connexion de l’utilisateur « username ».
Cause
Il s’agit d’une indication d’un enregistrement orphelin sur la base de données PowerPivot’application de service dans SharePoint. This issue may occur after you delete a PowerPivot service application. Les enregistrements de la base de données d PowerPivot’application de service supprimée ne sont parfois pas supprimés de la base de données SharePoint de configuration. Par conséquent, SharePoint une erreur lorsqu’il ne peut pas ouvrir la base de données PowerPivot’application de service, car elle n’existe plus.
Résolution
Pour résoudre ce problème, supprimez ces enregistrements orphelins. Vous pouvez ouvrir l’SharePoint Management Shell sur un serveur SharePoint et exécuter la commande suivante :
Get-SPDatabase | où {$_.exists -eq $false}
Cette liste affiche la liste des bases de données qui n’existent plus sur SharePoint base de données. La PowerPivot de données référencé dans l’erreur précédente doit s’afficher dans cette liste. Après avoir confirmé cela, vous pouvez supprimer l’enregistrement orphelin en exécutant cette commande :
Get-SPDatabase | où {$.exists -eq $false} | foreach {$.delete()}
Ensuite, l’enregistrement orphelin qui pointe vers l’ancienne base de données d’application de service PowerPivot sera supprimé et l’erreur que vous avez remarquée précédemment cessera de se produire.