Les documents ne sont pas affichés dans le navigateur web lorsque vous utilisez TLS 1.2

Symptômes

Lorsque vous utilisez des applications web dans Microsoft Office Online Server, les documents ne sont pas affichés dans le navigateur web comme prévu. Au lieu de cela, vous recevez un message d’erreur semblable à ce qui suit :

Nous sommes désolés, nous avons rencontré un problème lors de l’exécution de votre demande...

En outre, vous découvrez que TLS 1.0 a été désactivé sur les serveurs web frontaux SharePoint via l’entrée de Registre fournie dans l’article suivant de la Base de connaissances Microsoft :

Comment désactiver PCT 1.0, SSL 2.0, SSL 3.0 ou TLS 1.0 dans Internet Information Services

Cause

TLS 1.2 n’est pas pris en charge actuellement, car Office Online Server (et Office Web Apps Server) utilisent .NET Framework 4. x pour établir des connexions réseau. Par défaut, .NET Framework 4. x ne prend pas en charge TLS 1.2.

Résolution

Microsoft a publié la mise à jour de sécurité facultative suivante .NET Framework 4. x, qui modifie les protocoles de chiffrement par défaut :

Avis de sécurité Microsoft 2960358

Cette mise à jour modifie les protocoles de chiffrement par défaut de SSL 3.0 ou TLS 1.0 sur les protocoles suivants : TLS 1.0 ou TLS 1.1 ou TLS 1.2

Remarque Cette mise à jour de sécurité ne sera pas publiée pour Windows Server 2016 ou une version ultérieure. À partir de Windows 2016, les clés de Registre que la mise à jour de sécurité facultative définit automatiquement doivent être configurées manuellement sur chaque ordinateur Office Online Server. Ces clés de Registre et paramètres sont les suivants :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]  
"SchUseStrongCrypto"=dword:00000001  

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]  
"SchUseStrongCrypto"=dword:00000001

Informations supplémentaires

Encore besoin d’aide ? Go to SharePoint Community.