La barre des messages du serveur est manquante pour Office documents ouverts via un lien hypertexte

Symptômes

Les utilisateurs de Office 2007 ou Office 2010 sur un système d’exploitation client cliquent sur un lien hypertexte qui pointe vers un document Office, qui se trouve dans une bibliothèque de documents SharePoint Server 2010. Le lien hypertexte lui-même se trouve dans un Outlook message électronique. Au lieu d’ouvrir le document à partir du serveur dans l’application cliente Office, le document s’ouvre dans l’application Office à partir du cache de fichiers Internet temporaires de l’ordinateur local. Par conséquent, il n’est pas traité comme un document serveur. L’utilisateur peut voir les symptômes suivants :

  • Word : il n’existe aucune barre de serveur avec un bouton « Modifier le document »
  • Excel : il n’existe aucune barre de serveur avec un bouton « Modifier le workbook »
  • PowerPoint : il n’existe aucune barre de serveur avec un bouton « Modifier la présentation »

Ou, si la bibliothèque de documents nécessite une vérification :

  • Word : il n’existe aucune barre de serveur avec le bouton « Consulter le document »
  • Excel : il n’existe aucune barre de serveur avec le bouton « Consulter le workbook »
  • PowerPoint : il n’existe aucune barre de serveur avec le bouton « Consulter la présentation »

En outre, le document ne peut pas être enregistré à nouveau sur le site SharePoint’il est ouvert dans l’application Office web. Les utilisateurs peuvent enregistrer les modifications, mais elles sont enregistrées dans le fichier dans le dossier Fichiers Internet temporaires, et non dans le serveur SharePoint.

En outre, si le document fait partie d’un flux de travail, le bouton Modifier cette tâche ou Ouvrir cette tâche et tous les autres boutons associés au flux de travail seront manquants, ce qui entraîne le non-début du flux de travail. En règle générale, les utilisateurs reçoivent les tâches de flux de travail par courrier électronique et le courrier électronique contient un lien hypertexte vers le document situé sur SharePoint serveur.

Cela se produit uniquement avec les formats de Office plus nouveaux : .docx, .pptx et .xlsx. Elle ne se produit pas avec les anciens formats de Office hérités : .doc, .ppt et .xls. En outre, cela se produit uniquement dans les cas ci-après :

Le serveur est un serveur SharePoint server 2010 et

  • Lorsque l’ordinateur client Office 2007, le problème se produit avec .docx, .dotx, .xlsx et .pptx documents
    ou
  • Lorsque l’ordinateur client Office 2010, le problème se produit .pptx documents.

Ce problème ne se produit pas lorsque le serveur exécute Office SharePoint Server 2007 et que l’ordinateur client exécute Office 2007 ou Office 2010.

REMARQUE : cela se produit uniquement lors de l’ouverture du document Office EN cliquant sur UN LIEN HYPERTEXTe dans un message électronique Outlook et que le document Office se trouve dans une bibliothèque de documents SharePoint 2010. Si l’utilisateur navigue vers la bibliothèque SharePoint 2010 et ouvre le fichier à partir de là, ce problème ne se produit pas.

Cause

SharePoint 2010 implémente une nouvelle fonctionnalité de sécurité appelée « Gestion permissive ou stricte des fichiers de navigateur ». Chaque type de fichier remis à partir d’un serveur web est associé à un type MIME (également appelé « content-type ») qui décrit la nature du contenu (par exemple, image, texte, application, etc.). Internet Explorer (IE) dispose d’une fonctionnalité de détection MIME qui tentera de déterminer le type de contenu pour chaque ressource téléchargée. Pour les fichiers Office, si le type de contenu envoyé par le serveur n’est pas trouvé dans la base de données MIME dans le Registre de l’ordinateur client, IE « renifle » les types de contenu MIME pour voir s’il existe un autre type MIME similaire dans la base de données MIME de l’ordinateur client et ouvre le fichier à l’aide du type MIME similaire. Toutefois, la gestion stricte des fichiers de navigateur est activée sur chaque application web dans SharePoint 2010 par défaut et cela interdit la détection des types de contenu. Ainsi, si aucune correspondance exacte du type de contenu envoyé dans la réponse du serveur n’est trouvée dans la base de données MIME du client dans le Registre, le fichier s’ouvre à partir des fichiers Internet temporaires de l’ordinateur client au lieu d’être ouvert à partir du serveur. La détection MIME peut également entraîner des problèmes de sécurité pour les serveurs hébergeant du contenu non sécurisé.

Par exemple : lors de l’ouverture d’un fichier .docx à partir d’un lien hypertexte pointant vers un document situé dans une bibliothèque de documents SharePoint 2010, le type de contenu envoyé par le serveur SharePoint 2010 dans la réponse est « vnd.ms-word.document.12 » avec un en-tête « X-Content-Type-Options: nosniff » qui ressemble à ceci :

HTTP/1.1 200 OK   
Content-Length: 108   
Date: Day, [Date and Time] GMT   
Content-Type: vnd.ms-word.document.12   
X-Content-Type-Options: nosniff   

Étant donné que ce type de contenu exact n’est pas présent dans la zone MIME du Registre de l’ordinateur client Office et qu’aucune détection MIME n’est effectuée, le document s’ouvre à partir des fichiers Internet temporaires.

D’autres causes peuvent être mentionnées ci-dessous dans la section Plus d’informations.

Résolution

Utilisez l’une des solutions suivantes :

Solution de contournement côté serveur

Éliminer l’en-tête sans détection envoyé depuis SharePoint 2010

  • Accédez au site Administration centrale, cliquez sur Gérer les applications Web sous Gestion des applications.
  • Sélectionnez l’application web, puis cliquez sur Paramètres dans le ruban
  • Faites défiler vers le bas jusqu’à gestion des fichiers du navigateur, puis choisissez Permissif au lieu de Strict.

REMARQUE : cela réduit la sécurité. La gestion des fichiers du navigateur spécifie si des en-têtes de sécurité supplémentaires sont ajoutés aux documents servis aux navigateurs web. Ces en-têtes spécifient qu’un navigateur doit afficher une invite de téléchargement pour certains types de fichiers (par exemple, .html) et utiliser le type MIME spécifié du serveur pour d’autres types de fichiers. « Permissif » spécifie qu’aucun en-tête n’est ajouté, ce qui offre une expérience utilisateur plus compatible. « Strict » ajoute des en-têtes qui forcent le navigateur à télécharger certains types de fichiers. Le téléchargement forcé améliore la sécurité du serveur en désallont l’exécution automatique du contenu Web téléchargé par les collaborateurs.

Solutions de contournement côté client

Important

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

322756 comment restaurer le Registre dans Windows.

Mettez à jour le Registre de l’ordinateur client Office pour installer les types de contenu nécessaires dans la base de données MIME du Registre à l’aide de l’une des deux méthodes suivantes. Cette mise à jour du Registre fonctionne Office 2007 ou Office 2010.

  1. Pour mettre à jour le Registre manuellement, copiez ce qui suit dans un fichier texte, nommez-le avec une extension .reg et exécutez-le.

    Windows Registry Editor Version 5.00  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.12]  
    "Extension"=".xlsx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.presentation.12]  
    "Extension"=".pptx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-word.document.12]  
    "Extension"=".docx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-word.template.12]  
    "Extension"=".dotx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.template.12]  
    "Extension"=".potx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.show.macroEnabled.12]  
    "Extension"=".ppsm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.show.12]  
    "Extension"=".ppsx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.macroEnabled.12]  
    "Extension"=".pptm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-mspublisher]  
    "Extension"=".pub"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.binary.12]  
    "Extension"=".xlsb"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.macroEnabled.12]  
    "Extension"=".xlsm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.macroEnabledTemplate.12]  
    "Extension"=".xltm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.template.12]  
    "Extension"=".xltx"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-word.document.macroEnabled.12]  
    "Extension"=".docm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-word.template.macroEnabled.12]  
    "Extension"=".dotm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.template.macroEnabled.12]  
    "Extension"=".potm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-powerpoint.presentation.macroEnabled.12]  
    "Extension"=".pptm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.sheet.macroEnabled.12]  
    "Extension"=".xlsm"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/vnd.ms-excel.addin.12]  
    "Extension"=".xlam"  
    [HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/onenote]  
    "Extension"=".one"  
    
  2. Pour installer automatiquement les types de contenu dans la base de données MIME du Registre sur Office ordinateurs, rendez-vous dans la section « Voici un correctif simple ».

Informations supplémentaires

SharePoint boutons de tâche de flux de travail peuvent être manquants dans Office documents pour d’autres raisons que celles décrites dans cet article. D’autres raisons peuvent être les suivantes :

  • La barre des messages est désactivée dans le Centre de Paramètres.

  • Vous utilisez une licence à faible valeur Office (Famille et Petite Entreprise, Famille et Étudiant) ou un autre produit du canal de vente au détail. Voir tout sur les flux de travail d’approbation.

  • Le flux de travail du document que vous avez ouvert n’a pas encore démarré.

  • L’utilisateur ne peut pas modifier les éléments. Ils peuvent également avoir besoin d’autorisations Gérer les listes en fonction des paramètres de flux de travail.

  • La barre serveur en lecture seule avec la barre de boutons [Modifier le document] ou [Modifier le livre] ou [Modifier la présentation] peut être manquante pour d’autres raisons lorsque vous cliquez sur un lien hypertexte vers un document Office 2010 stocké sur un site SharePoint pour la première fois. Les clics suivants sur le lien rendent la barre serveur en lecture seule.

    Capture d’écran de la barre Serveur en lecture seule sous le ruban de Word 2010.

Pour forcer la barre serveur en lecture seule à s’afficher lors du premier clic du lien hypertexte, ajoutez la clé de Registre ci-dessous à l’ordinateur client.

Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet   
Name: OptimisticBHO   
Type: DWORD   
Value: 1  

Si la barre du serveur n’apparaît toujours pas avec le bouton [Modifier le document] même après l’utilisation de la clé OptimisticBHO, assurez-vous que le module ajout « Office Document Cache Handler » est activé dans Outils d’Internet Explorer>Gérer les modules.

Encore besoin d’aide ? Accédez au site de la Communauté SharePoint.