Leçon 1 : Créer un projet de modèle tabulaireLesson 1: Create a New Tabular Model Project

S’APPLIQUE À :ouiSQL Server Analysis Services (à partir de la version 2016)ouiAzure Analysis ServicesAPPLIES TO:yesSQL Server Analysis Services (starting with 2016)yesAzure Analysis Services

Dans cette leçon, vous allez créer un nouveau projet de modèle tabulaire vide dans Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT).In this lesson, you will create a new, blank tabular model project in Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT). Une fois que votre projet est créé, vous pouvez commencer à ajouter des données à l'aide de l'Assistant Importation de table.Once your new project is created, you can begin adding data by using the Table Import Wizard. Cette leçon vous donne une brève introduction à l’environnement de création dans SSDT de modèle tabulaire.This lesson also gives you a brief introduction to the tabular model authoring environment in SSDT.

Durée estimée pour effectuer cette leçon : 10 minutesEstimated time to complete this lesson: 10 minutes

Conditions préalablesPrerequisites

Cette rubrique constitue la première leçon du didacticiel de conception de modèle tabulaire.This topic is the first lesson in a tabular model authoring tutorial. Pour effectuer cette leçon, vous devez disposer de la base de données exemple AdventureWorksDW installée sur une instance de SQL Server.To complete this lesson, you must have the AdventureWorksDW sample database installed on a SQL Server instance. Pour plus d’informations, consultez de modélisation tabulaire ( Didacticiel Adventure Works ) .To learn more, see Tabular Modeling (Adventure Works Tutorial).

Créer un projet de modèle tabulaireCreate a new tabular model project

Pour créer un projet de modèle tabulaireTo create a new tabular model project

  1. Dans SSDT, sur le fichier menu, cliquez sur nouveau > projet.In SSDT, on the File menu, click New > Project.

  2. Dans le nouveau projet boîte de dialogue, développez installé > Business Intelligence > Analysis Services, puis cliquez sur projet tabulaire Analysis Services.In the New Project dialog box, expand Installed > Business Intelligence > Analysis Services, and then click Analysis Services Tabular Project.

  3. Dans nom, type AW Internet Sales, puis spécifiez un emplacement pour les fichiers de projet.In Name, type AW Internet Sales, and then specify a location for the project files.

    Par défaut, Nom de solution est le même que le nom du projet ; toutefois, vous pouvez taper un autre nom pour la solution.By default, Solution Name will be the same as the project name; however, you can type a different solution name.

  4. Cliquez sur OK.Click OK.

  5. Dans le Générateur de modèles tabulaires boîte de dialogue, sélectionnez espace de travail intégré.In the Tabular model designer dialog box, select Integrated workspace.

    L’espace de travail destiné à héberger une base de données de modèle tabulaire avec le même nom que le projet lors de la création du modèle.The workspace will host a tabular model database with the same name as the project during model authoring. Espace de travail intégré signifie que SSDT utilise une instance intégrée, éliminant le besoin d’installer une instance distincte de serveur Analysis Services uniquement pour la création d’un modèle.Integrated workspace means SSDT will use a built-in instance, eliminating the need to install a separate Analysis Services server instance just for model authoring. Pour plus d’informations, consultez base de données de l’espace de travail.To learn more, see Workspace Database.

  6. Dans Niveau de compatibilité, vérifiez que SQL Server 2016 (1200) est sélectionné, puis cliquez sur OK.In Compatibility level, verify SQL Server 2016 (1200) is selected, and then click OK.

    en tant que-tabulaire-lesson1-tmd

    Si vous ne voyez pas SQL Server 2016 RTM (1200) dans la zone de liste de niveau de compatibilité, vous n’utilisez pas la dernière version de SQL Server Data Tools.If you don’t see SQL Server 2016 RTM (1200) in the Compatibility level listbox, you’re not using the latest version of SQL Server Data Tools. Pour obtenir la version la plus récente, consultez Installer les outils de données SQL Server.To get the latest version, see Install SQL Server Data tools.

    Si vous utilisez la version la plus récente de SSDT, vous pouvez également choisir SQL Server 2017 (1400).If you're using the latest version of SSDT, you can also choose SQL Server 2017 (1400). Toutefois, pour la leçon 13 : déploiement, vous aurez besoin d’un serveur SQL Server 2017 ou Azure pour déployer sur.However, to complete lesson 13: Deploy, you'll need a SQL Server 2017 or Azure server to deploy to.

    Sélection d’un niveau de compatibilité est recommandée uniquement si vous envisagez de déployer votre modèle tabulaire terminé pour une autre instance d’Analysis Services exécute une version antérieure de SQL Server.Selecting an earlier compatibility level is only recommended if you intend on deploying your completed tabular model to a different Analysis Services instance running an earlier version of SQL Server. Espace de travail intégré n’est pas prise en charge pour les niveaux de compatibilité antérieurs.Integrated workspace is not supported for earlier compatibility levels. Pour en savoir plus, consultez Niveau de compatibilité.To learn more see, Compatibility level.

Présentation de l’environnement de création de modèles tabulaires SSDTUnderstanding the SSDT tabular model authoring environment

Maintenant que vous avez créé un nouveau projet de modèle tabulaire, prenons un moment pour Explorer le modèle tabulaire, environnement de création dans SSDT.Now that you’ve created a new tabular model project, let’s take a moment to explore the tabular model authoring environment in SSDT.

Une fois votre projet est créé, il s’ouvre dans SSDT.After your project is created, it opens in SSDT. Sur le côté droit, dans l’Explorateur de modèles tabulaires, vous verrez une arborescence des objets dans votre modèle.On the right side, in Tabular Model Explorer, you'll see a tree view of the objects in your model. Étant donné que vous n’avez pas encore importé des données, les dossiers sera vides.Since you haven't yet imported data, the folders will be empty. Vous pouvez cliquer sur un dossier de l’objet pour effectuer des actions, similaires à la barre de menus.You can right-click an object folder to perform actions, similar to the menu bar. À mesure que vous parcourez ce didacticiel, vous utiliserez l’Explorateur de modèles tabulaires pour naviguer dans différents objets dans votre projet de modèle.As you step through this tutorial, you'll use the Tabular Model Explorer to navigate different objects in your model project.

en tant que tableau-lesson1-durée

Cliquez sur le l’Explorateur de solutions onglet. Ici, vous verrez votre Model.bim fichier.Click the Solution Explorer tab. Here, you'll see your Model.bim file. Si vous ne voyez pas la fenêtre du concepteur vers la gauche (la fenêtre vide avec l’onglet Model.bim), dans l’Explorateur de solutions, sous projet AW Internet Sales, double-cliquez sur le Model.bim fichier.If you don’t see the designer window to the left (the empty window with the Model.bim tab), in Solution Explorer, under AW Internet Sales Project, double-click the Model.bim file. Le fichier Model.bim contient toutes les métadonnées pour votre projet de modèle.The Model.bim file contains all of the metadata for your model project.

en tant que-tabulaire-lesson1-se

Examinons les propriétés du modèle.Let’s look at the model properties. Cliquez sur Model.bim.Click Model.bim. Dans le propriétés fenêtre, vous verrez la des propriétés de modèle, qui est plus important le DirectQuery Mode propriété.In the Properties window, you'll see the model properties, most important of which is the DirectQuery Mode property. Cette propriété indique si le modèle est déployé en mode In-Memory (désactivé) ou en mode DirectQuery (activé).This property specifies whether or not the model is deployed in In-Memory mode (Off) or DirectQuery mode (On). Pour ce didacticiel, vous allez créer et déployer votre modèle en mode In-Memory.For this tutorial, you will author and deploy your model in In-Memory mode.

en tant que-tabulaire-lesson1-propriétés

Lorsque vous créez un nouveau modèle, certaines de ses propriétés sont définies automatiquement en fonction des paramètres de modélisation des données qui peuvent être spécifiés dans le outils > Options boîte de dialogue.When you create a new model, certain model properties are set automatically according to the Data Modeling settings that can be specified in the Tools > Options dialog box. Les propriétés de sauvegarde de données, de rétention de l'espace de travail et du serveur de l'espace de travail spécifient comment et où la base de données d'espace de travail (votre base de données de conception de modèle) est sauvegardée, conservée en mémoire et construite.Data Backup, Workspace Retention, and Workspace Server properties specify how and where the workspace database (your model authoring database) is backed up, retained in-memory, and built. Vous pouvez modifier ces paramètres ultérieurement si nécessaire, mais pour le moment, laissez ces propriétés telles qu'elles sont.You can change these settings later if necessary, but for now, just leave these properties as they are.

Dans l’Explorateur de solutions, avec le bouton droit AW Internet Sales (projet), puis cliquez sur propriétés.In Solution Explorer, right-click AW Internet Sales (project), and then click Properties. Le Pages de propriétés de AW Internet Sales boîte de dialogue s’affiche.The AW Internet Sales Property Pages dialog box appears. Il s’agit avancées propriétés de projet.These are the advanced project properties. Vous définirez ultérieurement certaines de ces propriétés lorsque vous serez prêt à déployer votre modèle.You will set some of these properties later when you are ready to deploy your model.

Lorsque vous avez installé SSDT, plusieurs nouveaux éléments de menu ont été ajoutés à l’environnement Visual Studio.When you installed SSDT, several new menu items were added to the Visual Studio environment. Examinons spécifiques sur la création de modèles tabulaires.Let’s look at those specific to authoring tabular models. Cliquez sur le menu Modèle .Click on the Model menu. À ce stade, vous pouvez lancer l’Assistant Importation de Table, afficher modifier les connexions existantes, actualiser les données de l’espace de travail, parcourir votre modèle dans Excel avec la fonctionnalité analyser dans Excel, créer des perspectives et des rôles, la vue de modèle et sélectionnez Définir les options de calcul.From here, you can launch the Table Import Wizard, view and edit existing connections, refresh workspace data, browse your model in Excel with the Analyze in Excel feature, create perspectives and roles, select the model view, and set calculation options.

Cliquez sur le menu Table .Click on the Table menu. Ici, vous pouvez créer et gérer des relations entre des tables, créer, gérer et spécifier des paramètres de table Date, créer des partitions et modifier les propriétés de la table.Here, you can create and manage relationships between tables, create and manage, specify date table settings, create partitions, and edit table properties.

Cliquez sur le menu Colonne .Click on the Column menu. Ici, vous pouvez ajouter et supprimer des colonnes dans une table, figer des colonnes et spécifier l'ordre de tri.Here, you can add and delete columns in a table, freeze columns, and specify sort order. Vous pouvez également utiliser la fonction Somme automatique pour créer une mesure standard d'agrégation pour une colonne sélectionnée.You can also use the AutoSum feature to create a standard aggregation measure for a selected column. D'autres boutons de la barre d'outils permettent d'accéder rapidement aux fonctionnalités et aux commandes fréquemment utilisées.Other toolbar buttons provide quick access to frequently used features and commands.

Explorez les boîtes de dialogue et les emplacements des fonctionnalités spécifiques à la création des modèles tabulaires.Explore some of the dialogs and locations for various features specific to authoring tabular models. Bien que certains éléments ne soient pas toujours actifs, vous pouvez avoir une bonne idée de l'environnement de création des modèles tabulaires.While some items will not yet be active, you can get a good idea of the tabular model authoring environment.

Ressources supplémentairesAdditional resources

Pour en savoir plus sur les différents types de projets de modèles tabulaires, consultez Projets de modèles tabulaires (SSAS Tabulaire).To learn more about the different types of tabular model projects, see Tabular Model Projects (SSAS Tabular). Pour en savoir plus sur l’environnement de création de modèles tabulaires, consultez Générateur de modèles tabulaires (SSAS).To learn more about the tabular model authoring environment, see Tabular Model Designer (SSAS).

Étape suivanteWhat's next?

Accédez à la leçon suivante : leçon 2 : ajouter des données.Go to the next lesson: Lesson 2: Add data.