Leçon 2 : Ajouter des donnéesLesson 2: Add Data

S’APPLIQUE À :ouiSQL Server Analysis Services (à partir de la version 2016)ouiAzure Analysis ServicesAPPLIES TO:yesSQL Server Analysis Services (starting with 2016)yesAzure Analysis Services

Dans cette leçon, vous utiliserez l’Assistant Importation de Table dans SSDT pour se connecter à la base de données SQL AdventureWorksDW, sélectionnez données, afficher un aperçu et filtrer les données et puis importer les données dans votre espace de travail modèle.In this lesson, you'll use the Table Import Wizard in SSDT to connect to the AdventureWorksDW SQL sample database, select data, preview and filter the data, and then import the data into your model workspace.

À l'aide de l'Assistant Importation de Table, vous pouvez importer des données provenant de diverses sources relationnelles : Access, SQL, Oracle, Sybase, Informix, DB2, Teradata et bien plus encore.By using the Table Import Wizard, you can import data from a variety of relational sources: Access, SQL, Oracle, Sybase, Informix, DB2, Teradata, and more. Les étapes d'importation de données à partir des différentes sources relationnelles sont très semblables à celles qui suivent.The steps for importing data from each of these relational sources are very similar to what is described below. Les données peuvent également être sélectionnées à l’aide d’une procédure stockée.Data can also be selected using a stored procedure. Pour en savoir plus sur l’importation de données et les différents types de sources de données que vous pouvez importer à partir de, consultez des Sources de données.To learn more about importing data and the different types of data sources you can import from, see Data Sources.

Durée estimée pour effectuer cette leçon : 20 minutesEstimated time to complete this lesson: 20 minutes

Conditions préalablesPrerequisites

Cette rubrique fait partie d'un didacticiel de modélisation tabulaire, qui doit être suivi dans l'ordre.This topic is part of a tabular modeling tutorial, which should be completed in order. Avant d’effectuer les tâches de cette leçon, vous devez avoir terminé la leçon précédente : Leçon 1 : Créer un projet de modèle tabulaire.Before performing the tasks in this lesson, you should have completed the previous lesson: Lesson 1: Create a New Tabular Model Project.

Créer une connexionCreate a connection

Pour créer une connexion à une base de données de la AdventureWorksDW2014To create a connection to a the AdventureWorksDW2014 database

  1. Dans l’Explorateur de modèles tabulaires, cliquez sur des Sources de données > importer à partir de la Source de données.In Tabular Model Explorer, right-click Data Sources > Import from Data Source.

    Cette opération lance l’Assistant d’importation de Table, qui vous guide tout au long de la configuration d’une connexion à une source de données.This launches the Table Import Wizard, which guides you through setting up a connection to a data source. Si vous ne voyez pas l’Explorateur de modèles tabulaires, double-cliquez sur Model.bim dans l’Explorateur de solutions pour ouvrir le modèle dans le concepteur.If you don't see Tabular Model Explorer, double click Model.bim in Solution Explorer to open the model in the designer.

    en tant que tableau-lesson2-durée

    Remarque : Si vous créez votre modèle au niveau de compatibilité 1400, vous verrez la nouvelle expérience d’obtenir des données au lieu de l’Assistant Importation de Table.Note: If you're creating your model at the 1400 compatibility level, you'll see the new Get Data experience instead of the Table Import Wizard. Les boîtes de dialogue seront affiche un peu différentes de la procédure ci-dessous, mais vous serez toujours en mesure de suivre son déroulement.The dialogs will appear a little different from the steps below, but you'll still be able to follow along.

  2. Dans l’Assistant Importation de Table, sous bases de données relationnelles, cliquez sur Microsoft SQL Server > suivant.In the Table Import Wizard, under Relational Databases, click Microsoft SQL Server > Next.

  3. Dans la page de Connexion à une base de données Microsoft SQL Server , dans Nom convivial de la connexion, tapez Base de données Adventure Works depuis SQL.In the Connect to a Microsoft SQL Server Database page, in Friendly Connection Name, type Adventure Works DB from SQL.

  4. Dans nom du serveur, tapez le nom du serveur où vous avez installé la base de données AdventureWorksDW.In Server name, type the name of the server where you installed the AdventureWorksDW database.

  5. Dans le nom de la base de données champ, sélectionnez AdventureWorksDW, puis cliquez sur suivant.In the Database name field, select AdventureWorksDW, and then click Next.

    en tant que-tabulaire-lesson2-tiw-name

  6. Dans la page Informations d'emprunt d'identité , vous devez spécifier les informations d'identification qu'Analysis Services utilisera pour se connecter à la source de données lors de l'importation et du traitement des données.In the Impersonation Information page, you need to specify the credentials Analysis Services will use to connect to the data source when importing and processing data. Vérifiez que l'option Nom d'utilisateur et mot de passe Windows spécifiques est sélectionnée, puis, dans Nom d'utilisateur et Mot de passe, entrez vos informations d'identification de connexion Windows, puis cliquez sur Suivant.Verify Specific Windows user name and password is selected, and then in User Name and Password, enter your Windows logon credentials, and then click Next.

    Note

    L'utilisation d'un compte d'utilisateur et d'un mot de passe Windows est la méthode la plus sûre pour se connecter à une source de données.Using a Windows user account and password provides the most secure method of connecting to a data source. Pour plus d’informations, consultez l’emprunt d’identité.For more information, see Impersonation.

  7. Dans la page Choisir comment importer les données , vérifiez que l'option Sélectionner les données à importer dans une liste de tables et de vues est sélectionnée.In the Choose How to Import the Data page, verify Select from a list of tables and views to choose the data to import is selected. Vous souhaitez choisir dans une liste de tables et de vues et vous devez donc cliquer sur Suivant pour afficher la liste de toutes les tables sources dans la base de données source.You want to select from a list of tables and views, so click Next to display a list of all the source tables in the source database.

  8. Dans la page Sélectionner des Tables et des vues , activez la case à cocher pour les tables suivantes : DimCustomer, DimDate, DimGeography, DimProduct, DimProductCategory, DimProductSubcategoryet FactInternetSales.In the Select Tables and Views page, select the check box for the following tables: DimCustomer, DimDate, DimGeography, DimProduct, DimProductCategory, DimProductSubcategory, and FactInternetSales.

    NE CLIQUEZ PAS sur Terminer.DO NOT click Finish.

Filter the table dataFilter the table data

La table DimCustomer que vous importez à partir de la base de données exemple contient un sous-ensemble des données à partir de la base de données d’origine de SQL Server Adventure Works.The DimCustomer table that you're importing from the sample database contains a subset of the data from the original SQL Server Adventure Works database. Vous allez filtrer d’autres colonnes de la table DimCustomer qui ne sont pas nécessaires lors de l’importation dans votre modèle.You will filter out some more of the columns from the DimCustomer table that aren’t necessary when imported into your model. Lorsque cela est possible, que vous souhaitez filtrer les données qui ne seront pas utilisées afin d’économiser de l’espace mémoire utilisé par le modèle.When possible, you'll want to filter out data that won't be used in order to save in-memory space used by the model.

Pour filtrer les données de table avant l'importationTo filter the table data prior to importing

  1. Sélectionnez la ligne de la DimCustomer de table, puis cliquez sur aperçu et filtrer.Select the row for the DimCustomer table, and then click Preview & Filter. La fenêtre Aperçu de la table sélectionnée s'affiche en présentant toutes les colonnes de la table source DimCustomer.The Preview Selected Table window opens with all the columns in the DimCustomer source table displayed.

  2. Désactivez la case à cocher en haut des colonnes suivantes : SpanishEducation, FrenchEducation, SpanishOccupation, FrenchOccupation.Clear the checkbox at the top of the following columns: SpanishEducation, FrenchEducation, SpanishOccupation, FrenchOccupation.

    en tant que-tabulaire-lesson2-tiw-clair

    Étant donné que les valeurs de ces colonnes ne sont pas appropriées à l'analyse des ventes sur Internet, il est inutile de les importer.Since the values for these columns are not relevant to Internet sales analysis, there is no need to import these columns. Éliminer les colonnes inutiles réduira votre modèle plus petites et plus efficace.Eliminating unnecessary columns will make your model smaller and more efficient.

  3. Vérifiez que toutes les autres colonnes sont cochées, puis cliquez sur OK.Verify that all other columns are checked, and then click OK.

    Remarquez que les mots Filtres appliqués s'affichent maintenant dans la colonne Détails du filtre dans la ligne DimCustomer ; si vous cliquez sur ce lien, vous verrez une description textuelle des filtres que vous venez d'appliquer.Notice the words Applied filters are now displayed in the Filter Details column in the DimCustomer row; if you click on that link you’ll see a text description of the filters you just applied.

    en tant que-tabulaire-lesson2--filtres appliqués

  4. Filtrez les autres tables en désactivant les cases à cocher des colonnes suivantes dans chaque table :Filter the remaining tables by clearing the checkboxes for the following columns in each table:

    DimDateDimDate

    ColonneColumn
    DateKeyDateKey
    SpanishDayNameOfWeekSpanishDayNameOfWeek
    FrenchDayNameOfWeekFrenchDayNameOfWeek
    SpanishMonthNameSpanishMonthName
    FrenchMonthNameFrenchMonthName

    DimGeographyDimGeography

    ColonneColumn
    SpanishCountryRegionNameSpanishCountryRegionName
    FrenchCountryRegionNameFrenchCountryRegionName
    IpAddressLocatorIpAddressLocator

    DimProductDimProduct

    ColonneColumn
    SpanishProductNameSpanishProductName
    FrenchProductNameFrenchProductName
    FrenchDescriptionFrenchDescription
    ChineseDescriptionChineseDescription
    ArabicDescriptionArabicDescription
    HebrewDescriptionHebrewDescription
    ThaiDescriptionThaiDescription
    GermanDescriptionGermanDescription
    JapaneseDescriptionJapaneseDescription
    TurkishDescriptionTurkishDescription

    DimProductCategoryDimProductCategory

    ColonneColumn
    SpanishProductCategoryNameSpanishProductCategoryName
    FrenchProductCategoryNameFrenchProductCategoryName

    DimProductSubcategoryDimProductSubcategory

    ColonneColumn
    SpanishProductSubcategoryNameSpanishProductSubcategoryName
    FrenchProductSubcategoryNameFrenchProductSubcategoryName

    FactInternetSalesFactInternetSales

    ColonneColumn
    OrderDateKeyOrderDateKey
    DueDateKeyDueDateKey
    ShipDateKeyShipDateKey

Import the selected tables and column dataImport the selected tables and column data

Maintenant que vous avez prévisualisé et filtré les données inutiles, vous pouvez importer les données que vous ne souhaitez pas que les autres.Now that you've previewed and filtered out unnecessary data, you can import the rest of the data you do want. L'Assistant importe les données de la table avec toutes les relations entre les tables.The wizard imports the table data along with any relationships between tables. Nouvelles tables et colonnes sont créées dans le modèle et les données filtrées ne seront pas importées.New tables and columns are created in the model and data that you filtered out will not be imported.

Pour importer les tables sélectionnées et les données de colonneTo import the selected tables and column data

  1. Vérifiez vos sélections.Review your selections. Si tout semble OK, cliquez sur Terminer.If everything looks okay, click Finish.

    Pendant l'importation des données, l'Assistant affiche le nombre de lignes qui ont été extraites.While importing the data, the wizard displays how many rows have been fetched. Lorsque toutes les données ont été importées, un message de réussite s'affiche.When all the data has been imported, a message indicating success is displayed.

    en tant que-tabulaire-lesson2-réussite

    Conseil

    Pour afficher les relations qui ont été créées automatiquement entre les tables importées, sur la ligne Préparation des données , cliquez sur Détails.To see the relationships that were automatically created between the imported tables, on the Data preparation row, click Details.

  2. Cliquez sur Fermer.Click Close.

    L’Assistant se ferme et le Générateur de modèles affiche maintenant votre tables importées.The wizard closes and the model designer now shows your imported tables.

Enregistrer votre projet de modèleSave your model project

Il est important de sauvegarder fréquemment votre projet de modèle.It's important to frequently save your model project.

Pour enregistrer le projet de modèleTo save the model project

  • Click Fichier > Enregistrer tout.Click File > Save All.

Étape suivanteWhat's next?

Accédez à la leçon suivante : leçon 3 : marquer en tant que Table de dates.Go to the next lesson: Lesson 3: Mark as Date Table.