Utilisez Visual Studio pour créer des bases de données pour SQL Server sur LinuxUse Visual Studio to create databases for SQL Server on Linux

CETTE RUBRIQUE S’APPLIQUE À :nonSQL Server sur WindowsouiSQL Server sur LinuxnonAzure SQL DatabasenonAzure SQL Data Warehouse nonParallel Data Warehouse THIS TOPIC APPLIES TO: noSQL Server on WindowsyesSQL Server on LinuxnoAzure SQL DatabasenoAzure SQL Data WarehousenoParallel Data Warehouse

SQL Server Data Tools (SSDT), Visual Studio se transforme en un environnement de gestion (DLM) du cycle de vie de développement et de base de données puissantes, pour SQL Server sur Linux.SQL Server Data Tools (SSDT) turns Visual Studio into a powerful development and database lifecycle management (DLM) environment for SQL Server on Linux. Vous pouvez développer, créer, tester et publier votre base de données à partir d’un projet de contrôle de code source, tout comme vous développez votre code d’application.You can develop, build, test and publish your database from a source controlled project, just like you develop your application code.

Installer Visual Studio et SQL Server Data ToolsInstall Visual Studio and SQL Server Data Tools

  1. Si vous n’avez pas déjà installé Visual Studio sur votre ordinateur Windows, télécharger et installer Visual Studio.If you have not already installed Visual Studio on your Windows machine, [Download and Install Visual Studio]. Si vous n’avez pas une licence de Visual Studio, Visual Studio Community edition est un IDE gratuit et complet pour les étudiants, les développeurs open source et individuels.If you do not have a Visual Studio license, Visual Studio Community edition is a free, fully-featured IDE for students, open-source and individual developers.

  2. Pendant l’installation de Visual Studio, sélectionnez personnalisé pour le choisir le type d’installation option.During the Visual Studio installation, select Custom for the Choose the type of installation option. Cliquez sur Suivant.Click Next

  3. Sélectionnez Microsoft SQL Server Data Tools, Git pour Windows, et GitHub Extension pour Visual Studio dans la liste de sélection de fonctionnalité.Select Microsoft SQL Server Data Tools, Git for Windows, and GitHub Extension for Visual Studio from the feature selection list.

    ssdt setup

  4. Continuer et terminer l’installation de Visual Studio.Continue and finish the installation of Visual Studio. Il peut prendre quelques minutes.It can take a few minutes.

Mise à niveau de SQL Server Data Tools vers la version RC de 17,0 SSDTUpgrade SQL Server Data Tools to SSDT 17.0 RC release

SQL Server 2017 RC2 sur Linux est prise en charge par SSDT version 17,0 RC ou version ultérieure.SQL Server 2017 RC2 on Linux is supported by SSDT version 17.0 RC or later.

Créer un nouveau projet de base de données dans le contrôle de code sourceCreate a new database project in source control

  1. Lancez Visual Studio.Launch Visual Studio.

  2. Sélectionnez Team Explorer sur la vue menu.Select Team Explorer on the View menu.

  3. Cliquez sur nouveau dans référentiel Git Local section sur le Connect page.Click New in Local Git Repository section on the Connect page.

    local repository

  4. Cliquez sur Créer.Click Create. Une fois le référentiel Git local est créé, double-cliquez sur SSDTRepo.After the local Git repository is created, double click SSDTRepo.

  5. Cliquez sur nouveau dans les Solutions section.Click New in the Solutions section. Sélectionnez SQL Server sous autres langages nœud dans le nouveau projet boîte de dialogue.Select SQL Server under Other Languages node in the New Project dialog.

    local repository

  6. Tapez dans TutorialDB pour le nom et cliquez sur OK pour créer un nouveau projet de base de données.Type in TutorialDB for the name and click OK to create a new database project.

Créer une nouvelle table dans le projet de base de donnéesCreate a new table in the database project

  1. Sélectionnez l’Explorateur de solutions sur la vue menu.Select Solution Explorer on the View menu.

  2. Ouvrez le menu de projet de base de données en cliquant sur TutorialDB dans l’Explorateur de solutions.Open the database project menu by right-clicking on TutorialDB in Solution Explorer.

  3. Sélectionnez Table sous ajouter.Select Table under Add.

    create table

  4. À l’aide du Concepteur de tables, ajouter deux colonnes, nom nvarchar(50) et l’emplacement nvarchar(50), comme illustré dans l’image.Using table designer, add two columns, Name nvarchar(50) and Location nvarchar(50), as shown in the picture. SSDT génère le CREATE TABLE de script que vous ajoutez les colonnes dans le concepteur.SSDT generates the CREATE TABLE script as you add the columns in the designer.

    add columns

  5. Enregistrer le Table1.sql fichier.Save the Table1.sql file.

Générer et valider la base de donnéesBuild and validate the database

  1. Ouvrez le menu de projet de base de données sur TutorialDB et sélectionnez Build.Open the database project menu on TutorialDB and select Build. SSDT compile les fichiers de code source .sql dans votre projet et crée un fichier de package (dacpac) d’Application de couche données.SSDT compiles .sql source code files in your project and builds a Data-tier Application package (dacpac) file. Cela permet de publier une base de données à votre instance de SQL Server 2017 sur Linux.This can be used to publish a database to your SQL Server 2017 instance on Linux.

    add columns

  2. Archiver le message de réussite du build sortie fenêtre dans Visual Studio.Check the build success message in Output window in Visual Studio.

Publier la base de données à l’instance de SQL Server 2017 sur LinuxPublish the database to SQL Server 2017 instance on Linux

  1. Ouvrez le menu de projet de base de données sur TutorialDB et sélectionnez publier.Open the database project menu on TutorialDB and select Publish.

  2. Cliquez sur modifier pour sélectionner votre instance de SQL Server sur Linux.Click Edit to select your SQL Server instance on Linux.

    publish dialog

  3. Dans la boîte de dialogue de connexion, tapez le nom d’hôte ou adresse IP de votre instance de SQL Server sur Linux, nom d’utilisateur et mot de passe.On the connection dialog, type in the IP address or host name of your SQL Server instance on Linux, user name and password.

    connection dialog

  4. Cliquez sur le publier bouton dans la boîte de dialogue Publier.Click the Publish button on the publish dialog.

  5. Vérifier l’état de la publication dans le opérations des outils de données fenêtre.Check the publish status in the Data Tools Operations window.

  6. Cliquez sur vue Reulst ou afficher le Script pour afficher les détails de la Microsoft Azure à publier les résultats sur votre serveur SQL Server sur Linux.Click View Reulst or View Script to see details of the databsae publish result on your SQL Server on Linux.

    publish result

Vous avez créé une base de données sur l’instance SQL Server sur Linux et appris les notions de base du développement d’une base de données avec un projet de base de données de contrôle de code source.You have successfully created a new database on SQL Server instance on Linux and learned the basics of developing a database with a source controlled database project.

Étapes suivantesNext steps

Si vous utilisez T-SQL, consultez didacticiel : écriture d’instructions Transact-SQL et de référence Transact-SQL (moteur de base de données).If you're new to T-SQL, see [Tutorial: Writing Transact-SQL Statements] and the [Transact-SQL Reference (Database Engine)].

Pour plus d’informations sur le développement d’une base de données avec les outils de données SQL, consultez documents de MSDN SSDTFor more information about developing a database with SQL Data Tools, see [SSDT MSDN documents]