Enregistrer les événements Showplan XML Statistics Profile séparément (SQL Server Profiler)Save Showplan XML Statistics Profile events separately (SQL Server Profiler)

S’applique à :Applies to: ouiSQL ServerSQL Server (toutes les versions prises en charge) yesSQL ServerSQL Server (all supported versions) S’applique à :Applies to: ouiSQL ServerSQL Server (toutes les versions prises en charge) yesSQL ServerSQL Server (all supported versions)

Cette rubrique décrit comment enregistrer dans des fichiers .SQLPlan séparés les événements Showplan XML Statistics Profile capturés dans les traces à l'aide du SQL Server ProfilerSQL Server Profiler.This topic describes how to save Showplan XML Statistics Profile events that are captured in traces into separate .SQLPlan files by using SQL Server ProfilerSQL Server Profiler. Vous pouvez ouvrir les fichiers des événements Showplan XML Statistics Profile dans SQL Server Management StudioSQL Server Management Studio, qui vous permet d’afficher le plan d’exécution graphique de chaque événement.You can open the Showplan XML Statistics Profile event files in SQL Server Management StudioSQL Server Management Studio so that you can view the graphical execution plan for each event.

Enregistrer séparément les événements Showplan XML Statistics ProfileSave Showplan XML Statistics Profile events separately

  1. Dans le menu Fichier, sélectionnez Nouvelle trace, puis connectez-vous à une instance de SQL ServerSQL Server.On the File menu, select New Trace, and then connect to an instance of SQL ServerSQL Server.

    La boîte de dialogue Propriétés de la trace s'affiche.The Trace Properties dialog box appears.

    Notes

    Si vous cochez l’option Démarrer le suivi juste après avoir établi la connexion, la boîte de dialogue Propriétés de la trace ne s’affiche pas et le suivi est lancé.If you select Start tracing immediately after making connection, the Trace Properties dialog box doesn't appear, and the trace begins instead. Pour désactiver ce paramètre, dans le menu Outils, sélectionnez Options, puis décochez la case Démarrer le suivi juste après avoir établi la connexion.To turn off this setting, on the Tools menu, select Options, and clear the Start tracing immediately after making connection check box.

  2. Dans la zone Nom de la trace de la boîte de dialogue Propriétés de la trace , entrez le nom de la trace.In the Trace Properties dialog box, type a name for the trace in the Trace name box.

  3. Dans la liste Utiliser le modèle, sélectionnez un modèle de trace sur lequel baser le suivi.In the Use the template list, select a trace template on which to base the trace. Si vous ne souhaitez pas utiliser de modèle, sélectionnez Vide.If you don't want to use a template, select Blank.

  4. Effectuez l’une des actions suivantes :Do one of the following:

    • Pour capturer la trace dans un fichier, cochez la case Enregistrer dans le fichier.To capture the trace to a file, select the Save to file check box. Spécifiez une valeur dans Définir la taille de fichier maximale.Specify a value for Set maximum file size.

      Au besoin, activez les cases à cocher Activer la substitution de fichier et Le serveur traite les données de trace .Optionally, select the Enable file rollover and Server processes trace data check boxes.

    • Pour capturer la trace dans une table de base de données, cochez la case Enregistrer dans la table.To capture the trace to a database table, select the Save to table check box.

      Au besoin, sélectionnez Définir le nombre de lignes maximal, puis spécifiez une valeur.Optionally, select Set maximum rows, and specify a value.

  5. Le cas échéant, activez la case à cocher Activer l'heure d'arrêt de la trace et indiquez une date et une heure d'arrêt.Optionally, select the Enable trace stop time check box, and specify a stop date and time.

  6. Sélectionnez l’onglet Sélection des événements.Select the Events Selection tab.

  7. Dans la colonne de données Événements, développez la catégorie d’événements Performances, puis cochez la case Showplan XML Statistics Profile.In the Events data column, expand the Performance event category, and then select the Showplan XML Statistics Profile check box. Si la catégorie d’événements Performances n’est pas visible, cochez la case Afficher tous les événements pour l’afficher.If the Performance event category isn't available, check Show all events to display it.

    L’onglet Paramètres d’extraction des événements est ajouté à la boîte de dialogue Propriétés de la trace.The Events Extraction Settings tab is added to the Trace Properties dialog box.

  8. Sous l’onglet Paramètres d’extraction des événements, sélectionnez Enregistrer les événements Showplan XML séparément.On the Events Extraction Settings tab, select Save XML Showplan events separately.

  9. Dans la boîte de dialogue Enregistrer sous , entrez le nom du fichier qui stocke les événements Showplan XML Statistics Profile .In the Save As dialog box, enter the file name to store the Showplan XML Statistics Profile events.

  10. Sélectionnez Tous les lots dans un seul fichier pour enregistrer tous les événements Showplan XML Statistics Profile dans un même fichier XML.Select All batches in a single file to save all Showplan XML Statistics Profile events in a single XML file. Sinon, vous pouvez sélectionner l’option Chaque lot Showplan XML dans un fichier différent afin de créer un fichier XML pour chaque événement Showplan XML Statistics Profile.Or select Each XML Showplan batch in a distinct file to create a new XML file for each Showplan XML Statistics Profile event.

  11. Pour afficher le fichier des événements Showplan XML Statistics Profile dans SQL Server Management Studio, dans le menu Fichier, pointez sur Ouvrir, puis sélectionnez Fichier.To view the Showplan XML Statistics Profile event file in SQL Server Management Studio, on the File menu, point to Open, and select File. Accédez au répertoire où vous avez enregistré le ou les fichiers des événements Showplan XML Statistics Profile pour en sélectionner un et l’ouvrir.Browse to the directory where you saved the Showplan XML Statistics Profile event file or files to select one and open it. Les fichiers des événements Showplan XML Statistics Profile possèdent l'extension .SQLPlan.Showplan XML Statistics Profile event files have a .SQLPlan file extension.

Voir aussiSee also

Analyser des requêtes avec des résultats Showplan dans SQL Server ProfilerAnalyze queries with Showplan results in SQL Server Profiler