Utiliser une connexion de données Office (.odc) avec les rapportsUse an Office Data Connection (.odc) with Reports

Pour certains scénarios, vous pouvez utiliser un fichier .odc (Office Data Connection) existant pour fournir des informations de connexion à un rapport Reporting ServicesReporting Services .For limited scenarios, you can use an existing Office Data Connection (.odc) file to provide connection information to a Reporting ServicesReporting Services report. Un fichier .odc peut être utilisé à la place d’un fichier .rsds quand vous créez une source de données partagée.An .odc file can be used in place of an .rsds file when you create a shared data source. Le serveur de rapports utilise le fichier .odc de la même manière qu'un fichier .rsds ; il le lit pour obtenir le type de sources de données, une chaîne de connexion et les informations d'identification.The report server uses an .odc file in the same way it uses an .rsds file; it reads the file for the data source type, a connection string, and credential information.

Tous les fichiers .odc ne peuvent pas être utilisés avec un rapport Reporting ServicesReporting Services .Not all .odc files can be used with a Reporting ServicesReporting Services report. L'extension pour le traitement des données et les caractéristiques du rapport et du fichier .odc déterminent si un fichier .odc peut être utilisé :The data processing extension and characteristics of the report and .odc file determine whether an .odc can be used:

  • Le rapport doit être conçu pour fonctionner avec un fournisseur de données OLE DB ou ODBC.The report must be designed to work with an OLE DB or ODBC data provider. Si vous avez utilisé une autre extension de traitement des données pour créer le rapport, le rapport ou ses requêtes peuvent inclure des fonctionnalités non prises en charge par le fournisseur de données OLE DB ou ODBC.If you used a different data processing extension to create the report, the report or its queries might include functionality that is not supported by the OLE DB or ODBC data provider.

  • Le fichier .odc doit présenter les éléments et la structure attendus.The .odc file must have the expected elements and structure. Les paramètres du fournisseur de données et des informations d'identification doivent être explicitement définis dans le fichier pour que le serveur de rapports puisse les lire.The data provider and credential settings must be set explicitly in the file so that they can be read by the report server. La meilleure méthode pour définir ces valeurs consiste à exporter le fichier .odc avant de le télécharger vers la bibliothèque SharePoint.The best way to set these values is to export the .odc file before uploading it to the SharePoint library.

  • Le fichier .odc doit spécifier un type de connexion OLE DB ou ODBC.The .odc file must specify a connection type of OLE DB or ODBC.

  • Le fichier .odc doit spécifier une chaîne de connexion.The .odc file must specify a connection string.

  • Les informations d’identification peuvent être définies avec la valeur None, Storedou Integrated.Credentials can be set to None, Stored, or Integrated. Si la méthode relative aux informations d’identification a la valeur Stored, le serveur de rapports invite l’utilisateur à fournir ses informations d’identification au lieu d’utiliser les informations d’identification stockées.If the credentials method is set to Stored, the report server will prompt the user for credentials instead of using the stored credentials. Le serveur de rapports ne peut pas utiliser les informations d'identification stockées telles qu'elles sont définies dans le fichier .odc.The report server cannot use stored credentials as defined in the .odc file.

  • La source de données doit contenir un schéma identique à celui utilisé pour créer le rapport.The data source must have schema that is identical to the one used to create the report. Si les structures de données diffèrent, le rapport ne s'exécutera pas.If the data structures are different, the report will not run.

  • Le fichier .odc doit être créé dans MicrosoftMicrosoft Office 2007 (les versions antérieures du fichier .odc ne sont pas compatibles avec les fichiers de définitions de rapports).The .odc file must be created in MicrosoftMicrosoft Office 2007 (older versions of .odc are not compatible with report definition files).

    Vous ne pouvez pas utiliser de fichiers .odc qui spécifient des connexions à des sources de données que le serveur de rapports ne peut pas traiter, même si les types de source de données .odc sont similaires à ceux pris en charge.You cannot use .odc files that specify connections to data sources that cannot be processed on a report server, even if the .odc data source types look similar to supported data source types. En particulier, si vous avez créé un fichier .odc dans Microsoft Excel 2007 qui récupère des données de Microsoft Access, du Web ou d'un fichier texte, vous ne pouvez pas utiliser ce fichier .odc pour fournir des données à un rapport.Specifically, if you created an .odc file in Microsoft Excel 2007 that retrieves data from Microsoft Access, the Web, or a text file, you cannot use that .odc file to provide data to a report.

    Les rapports et les modèles du Générateur de rapports ne fonctionnent pas avec le fichier .odc.Report Builder reports and models do not work with .odc file. Vous ne pouvez pas utiliser un fichier .odc pour créer un modèle, ni configurer le modèle pour qu'il utilise une source de données partagée qui se lie à un fichier .odc.You cannot use an .odc file to generate a model, and you cannot configure the model to use a shared data source that links to an .odc file.

    Si vous n'êtes pas familier des fichiers .odc, vous pouvez utiliser les instructions suivantes pour en créer un et l'exporter.If you are not familiar with .odc files, you can use the following instructions to create and export one. Pour créer facilement un fichier .odc pour une source de données OLE DB, un des moyens consiste à utiliser Excel 2007 et l'Assistant Connexion de données.One easy way to create an .odc file for an OLE DB data source is to use Excel 2007 and the Data Connection Wizard. Notez que l'Assistant ne crée pas de source de données ; une source de données externe doit être déjà définie.Note that the wizard does not create a data source; you must have an external data source that is already defined.

    Un fichier .odc doit être utilisé uniquement s'il est totalement compatible avec le rapport et les requêtes.An existing .odc file should only be used if it is fully compatible with the report and queries. Si vous rencontrez des erreurs qui imposent d'importantes modifications au rapport ou au fichier .odc, vous devez créer un nouveau fichier .rsds pour le rapport.If you run into errors that require significant modifications to either the report or to the .odc file, you should create a new .rsds file for the report. Pour plus d’informations sur la manière de créer une source de données partagée qui utilise un fichier .rsds, consultez Créer et gérer des sources de données partagées (Reporting Services en mode intégré SharePoint).For more information about how to create a shared data source that uses an .rsds file, see Create and Manage Shared Data Sources (Reporting Services in SharePoint Integrated Mode).

Pour créer et exporter un fichier .odcTo create and export an .odc file

  1. Démarrez Excel 2007.Start Excel 2007.

  2. Sous l’onglet Données , dans le groupe Obtenir des données externes , cliquez sur À partir d’autres sources, puis sur Provenance : Assistant Connexion de données.On the Data tab, in the Get External Data group, click From Other Sources, and then click From Data Connection Wizard.

  3. Sélectionnez Autres/Avancés, puis cliquez sur Suivant.Select Other/Advanced, and then click Next.

  4. Sélectionnez Fournisseur Microsoft OLE DB pour SQL Server, puis cliquez sur Suivant.Select Microsoft OLE DB Provider for SQL Server, and then click Next.

  5. Entrez le nom du serveur (par défaut, il s'agit du nom réseau de l'ordinateur) et un compte d'utilisateur disposant d'autorisations valides sur la connexion et la base de données.Enter the name of the server (by default, it is the network name of the computer) and a user account that has a valid login and database permissions. Cliquez sur Suivant.Click Next.

  6. Sélectionnez une base de données, puis cliquez sur OK pour fermer la boîte de dialogue Liaison de données .Select a database, and then click OK to close the Data Link dialog box.

  7. La case Connexion à une table spécifique est cochée par défaut.The Connect to specific table check box is selected by default. Elle sert à récupérer des données d'une table particulière.It is used to retrieve data from a specific table. Le serveur de rapports ignore toutes les requêtes dans un fichier .odc et il n'est donc pas important que vous activiez ou non cette case à cocher.The report server ignores all queries in an .odc file, so it does not matter whether you select or clear the check box. Les requêtes qui extraient des données pour un rapport sont incluses dans un fichier de définition de rapport et non dans les fichiers externes.Queries that retrieve data for a report are included in a report definition file and not in external files.

  8. Tant que la connexion est ouverte, vous pouvez en modifier les propriétés et l'exporter.While the connection is open, you can edit properties and export it. Dans le groupe Connexions sous l’onglet Données , cliquez sur Propriétés, puis sur le bouton Propriétés de connexion en regard du nom de la connexion.On the Data tab, in the Connections group, click Properties, and then click the Connection Properties button next to the connection name.

  9. Sous l’onglet Définition , cliquez sur Exporter le fichier de connexion.On the Definition tab, click Export Connection File.

  10. Donnez un nom au fichier, puis cliquez sur Enregistrer.Enter a name for the file, and then click Save. Fermez l'application et tous les fichiers ouverts.Close the application and all open files.

Pour télécharger et utiliser un fichier .odcTo upload and use an .odc file

  1. Ouvrez la bibliothèque dans laquelle télécharger le fichier de connexion.Open the library into which you want to upload the connection file.

  2. Dans le menu Télécharger , cliquez sur Télécharger un document.On the Upload menu, click Upload document.

  3. Cliquez sur Parcourir.Click Browse.

  4. Sélectionnez le fichier .odc créé.Select the .odc file you created. Par défaut, le fichier .odc se trouve dans le dossier My Documents, dans Mes sources de données.By default, the .odc file is in the My Documents folder, in My Data Sources.

  5. Cliquez sur Ouvrir pour sélectionner le fichier, puis sur OK pour enregistrer la sélection.Click Open to select the file, click OK to save the selection. La page des propriétés du nouvel élément s'ouvre automatiquementThe properties page for the new item opens automatically.

  6. Dans Type de contenu, sélectionnez Source de données du rapport, puis cliquez sur OK.In Content Type, select Report Data Source, and then click OK.

  7. Pointez sur un rapport.Point to a report.

  8. Cliquez sur la flèche orientée vers le bas et sélectionnez Gérer les sources de données.Click the down arrow, and select Manage Data Sources.

  9. Cliquez sur le nom de la source de données.Click the data source name.

  10. Si le rapport utilise des informations de source de données personnalisées, cliquez sur Partagé.If the report uses custom data source information, click Shared.

  11. Dans Lien de source de données, cliquez sur le bouton Parcourir (...).In Data Source Link, click the browse (...) button.

  12. Sélectionnez le fichier .odc que vous venez de télécharger.Select the .odc file you just uploaded.

  13. Cliquez sur OK pour sélectionner le fichier, puis sur OK pour enregistrer les modifications.Click OK to select the file, and then click OK to save your changes.

    Si vous appliquez cette procédure avec l'exemple de base de données et les exemples de rapports AdventureWorks2012AdventureWorks2012 , soyez conscient que seul le rapport Company Sales fonctionnera immédiatement avec un fichier .odc.If you are trying these steps with the AdventureWorks2012AdventureWorks2012 sample database and sample reports, be aware that only the Company Sales report will work out-of-the-box with an .odc file. Les autres rapports exemple contiennent des paramètres de requête et des fonctionnalités non compatibles avec le fournisseur OLE DB.The other sample reports contain query parameters and features that do not work with the OLE DB provider. Vous pouvez cependant les faire fonctionner avec le fournisseur OLE DB si vous les modifiez au préalable dans le Concepteur de rapports.However, you can make the reports work with the OLE DB provider if you modify them first in Report Designer.

Voir aussiSee Also

Créer, modifier et supprimer des sources de données partagées (SSRS)Create, Modify, and Delete Shared Data Sources (SSRS)