Rechercher la version du schéma de définition de rapport (SSRS)Find the Report Definition Schema Version (SSRS)

Un fichier de définition de rapport spécifie l'espace de noms RDL de la version du schéma de définition de rapport qui est utilisée pour valider le fichier rdl.A report definition file specifies the RDL namespace for the version of the report definition schema that is used to validate the rdl file. Lorsque vous ouvrez un fichier .rdl dans un environnement de création de rapports, tel que le Concepteur de rapports de Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT) ou le Générateur de rapports, si le rapport a déjà été créé pour un espace de noms, un fichier de sauvegarde est automatiquement créé et le rapport est mis à niveau d'après l'espace de noms actuel.When you open an .rdl file in a report authoring environment such as Report Designer in Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT) or Report Builder, if the report was created for a previous namespace, a backup file is automatically created, and the report is upgraded to the current namespace. Si vous enregistrez la définition de rapport mise à niveau, vous enregistrez le fichier .rdl converti.If you save the upgraded report definition, you have saved the converted .rdl file. Il s'agit de la seule façon de mettre à niveau une définition de rapport.This is the only way to upgrade a report definition. La définition de rapport proprement dite n'est pas mise à niveau sur un serveur de rapports.The report definition itself is not upgraded on a report server. Le rapport compilé est mis à niveau sur un serveur de rapports.The compiled report is upgraded on a report server. Pour plus d'informations, consultez Mettre à niveau des rapports.For more information, see Upgrade Reports.

Procédure : identifier la version du schéma RDL d'un rapportHow to: Identify the RDL Schema Version of a Report

  1. Ouvrez le fichier de rapport .rdl dans une application, telle que le Bloc-notes ou XML Notepad 2007, dans laquelle vous pouvez visualiser le fichier xml.Open the report .rdl file in an application such as Notepad or XML Notepad 2007 in which you can view the xml.

    L'élément de rapport XML indique l'espace de noms du schéma.The XML Report element specifies the schema namespace. Par exemple, l'élément de rapport suivant indique l'espace de noms pour le Concepteur de rapports et l'espace de noms pour la définition du rapport.For example, the following Report element specifies the namespace for Report Designer and the namespace for the report definition.

    <Report xmlns:rd=http://schemas.microsoft.com/SQLServer/reporting/reportdesigner   
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition">  
    

    L'espace de noms de la définition de rapport est spécifié par l'URL suivante : http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition.The report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition.

Procédure : identifier la version du schéma RDL du Concepteur de rapportsHow to: Identify the RDL Schema Version of Report Designer

  1. Ouvrez un nouveau projet.Open a new project. La version du projet que vous choisissez détermine la version du schéma RDL.The version of the project that you choose determines the version of the RDL schema. Dans SQL Server, plusieurs versions de schéma sont prise en charge.In SQL Server, more than one schema version is supported. Pour plus d’informations, consultez déploiement et prise en charge de la Version de SQL Server Data Tools.For more information, see Deployment and Version Support in SQL Server Data Tools.

  2. Dans le menu Projet , cliquez sur Ajouter un nouvel élément.On the Project menu, click Add New Item. La boîte de dialogue Ajouter un nouvel élément s’ouvre.The Add New Item dialog box opens.

  3. Dans le volet Modèles , cliquez sur Rapport.In the Templates pane, click Report.

  4. Dans la zone Nom, tapez un nom de rapport ou acceptez la valeur par défaut.In Name, type a report name or accept the default.

  5. Cliquez sur Ajouter.Click Add. Le Concepteur de rapports ouvre un rapport vide en mode Création.Report Designer opens a new blank report in Design view.

  6. Dans le menu Affichage , cliquez sur Code.On the View menu, click Code. La définition du rapport s'affiche sous forme de fichier XML.The report definition is displayed as an XML file.

    L'élément de rapport XML indique l'espace de noms du schéma.The XML Report element specifies the schema namespace. Par exemple, l'élément de rapport suivant indique l'espace de noms pour le Concepteur de rapports et l'espace de noms pour la définition du rapport.For example, the following Report element specifies the namespace for Report Designer and the namespace for the report definition.

    <Report xmlns:rd=http://schemas.microsoft.com/SQLServer/reporting/reportdesigner  
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition">  
    

    L'espace de noms de la définition de rapport est spécifié par l'URL suivante : http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinitionThe report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition

Procédure : identifier la version du schéma RDL sur Report ServerHow to: Identify the RDL Schema Version on the Report Server

  • Dans le Gestionnaire de rapports, tapez l'URL du serveur de rapports.In Report Manager, type the URL for the report server. Par exemple, l'URL suivante spécifie un serveur de rapports sur l'ordinateur local :For example, the following URL specifies a report server on the local computer:

    http://localhost/reportserver/reportdefinition.xsd

    Le fichier .xsd s'ouvre dans le navigateur.The .xsd file opens in the browser.

    L'élément de schéma XML indique l'espace de noms du schéma.The XML schema element specifies the schema namespace. Par exemple, l’élément de schéma suivant indique trois espaces de noms : la référence targetNamespace utilisée en interne par Visual StudioVisual Studio, la référence xsd pour le schéma lui-même (xsd) et la référence de définition de rapport.For example, the following schema element specifies three namespaces: the targetNamespace reference that is used internally by Visual StudioVisual Studio, the xsd reference for the schema itself (xsd), and the report definition reference.

    <xsd:schema   
    targetNamespace="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition"   
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"   
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition"   
    elementFormDefault="qualified">  
    

    L'espace de noms de la définition de rapport est spécifié par l'URL suivante : http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinitionThe report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition

Étapes suivantesNext steps

Rapports de mise à niveau Upgrade Reports
Langage de définition de rapportReport Definition Language

D’autres questions ?More questions? Essayez de poser le forum Reporting ServicesTry asking the Reporting Services forum