Reporting Services dans les outils de données SQL Server (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT) est un environnement MicrosoftMicrosoft Visual StudioVisual Studio pour créer des solutions d’aide à la décision. is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. SSDT comprend l’environnement de création Concepteur de rapports, où vous pouvez ouvrir, modifier, afficher un aperçu, enregistrer et déployer des définitions de rapport paginés Reporting ServicesReporting Services , des sources de données partagées, des datasets partagés et des parties de rapports.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT) n’est pas fourni avec SQL Server. is not included with SQL Server. Téléchargez SQL Server Data Tools.Download SQL Server Data Tools.

Cette rubrique décrit les solutions, les projets, les modèles de projet, et les configurations de Outils de données SQL ServerSQL Server Data Tools utilisés pour Reporting ServicesReporting Services, ainsi que les vues, les menus, les barres d'outils et les raccourcis que vous pouvez utiliser dans le Concepteur de rapports.This topic describes Outils de données SQL ServerSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

Pour commencer à concevoir des rapports, consultez Concevoir des rapports à l’aide du Concepteur de rapports (SSRS).To get started designing reports, see Design Reports with Report Designer (SSRS).

Solutions et projetsSolutions and Projects

Un projet de rapport fonctionne comme un conteneur de définitions de rapports et de ressources.A report project acts as a container for report definitions and resources. Tous les fichiers du projet de rapport sont publiés sur le serveur de rapports lors du déploiement du projet.Every file in the report project is published to the report server when the project is deployed. Lorsque vous créez un projet pour la première fois, une solution est également créée comme conteneur pour le projet.When you create a project for the first time, a solution is also created as a container for the project. Vous pouvez ajouter plusieurs projets dans une solution unique.You can add multiple projects to a single solution.

ConfigurationsConfigurations

Pour créer plusieurs jeux de propriétés du projet pour diverses opérations de déploiement (par exemple, des tests en entreprise ou des serveurs de rapports de production), utilisez le Gestionnaire de configuration.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. Pour plus d’informations, consultez Déploiement et prise en charge des versions dans les outils de données SQL Server (SSRS).For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

Projets Report ServerReport Server Projects

Lorsque vous installez Reporting ServicesReporting Services, les modèles de projet suivants sont disponibles dans Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT):When you install Reporting ServicesReporting Services, the following project templates are made available in Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT):

  • Projet Report Server.Report Server Project. Lorsque vous sélectionnez un projet Report Server, le Concepteur de rapports s'ouvre.When you select a Report Server Project, Report Designer opens. Un projet Report Server est un modèle de projets Business Intelligence installé par Visual StudioVisual Studio et disponible dans la boîte de dialogue Nouveaux projets .A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. Pour plus d’information, consultez Ajouter un nouveau rapport ou un rapport existant à un projet de rapport (SSRS). Les propriétés du projet Report Server s’appliquent à tous les rapports et à toutes les sources de données partagées au sein d’un projet Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT).For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT) project. Ces propriétés incluent l'URL du serveur de rapports et les noms des dossiers des rapports et des sources de données partagées.These properties include the URL for the report server and the folder names for reports and shared data sources. Pour afficher les propriétés actuelles du projet, ouvrez la boîte de dialogue Pages de propriétés du projet .Use the Project Property Pages dialog box to view the current property values. Pour ce faire, dans le menu Projet , cliquez sur Propriétés.To open this dialog box, on the Project menu, click Properties.

  • Assistant Projet Report Server.Report Server Project Wizard. Lorsque vous sélectionnez l'Assistant Projet Report Server, un projet de serveur de rapports est automatiquement créé et l'Assistant Rapport s'ouvre.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. Dans l'Assistant, pour créer un rapport, suivez les instructions de chaque page pour créer une chaîne de connexion dans une source de données, définir les informations d'identification de la source de données, créer une requête, ajouter une région de données de table ou de matrice, spécifier des données de rapport et des groupes, choisir une police et un style de couleur, publier le rapport sur un serveur de rapports et afficher un aperçu local du rapport.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. Après avoir créé un rapport au moyen de l'Assistant, vous pouvez modifier les données du rapport et le Concepteur de rapports à l'aide de l'outil Concepteur de rapports dans le projet Report Server.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

    Modèles Nouveau projet dans SSDTNew Project templates in SSDT

Fenêtres et volets du Concepteur de rapportsReport Designer Windows and Panes

Le Concepteur de rapports prend en charge deux modes : le mode Conception définit les données et la mise en page du rapport ; le mode Aperçu affiche un rendu du rapport.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the the report. Chaque mode vous permet d'afficher plusieurs fenêtres pour vous aider à concevoir un rapport ou générer son rendu.In each view, you can display multiple windows to help you design or view a rendered report.

Données du rapport, voletReport Data Pane

Le volet des données de rapport affiche des champs intégrés, des sources de données, des datasets, des collections de champs, des paramètres de rapport et des images.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

Utilisez le volet des données du rapport pour afficher :Use the Report Data pane to view:

  • Champs intégrés Informations prédéfinies sur les rapports, telles que leur nom ou l’heure à laquelle ils ont été traités.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • Sources de données La source des données représente un nom et une connexion à une source de données.Data sources A data source represents a name and connection to a source of data.

  • Datasets Chaque dataset comprend une requête qui spécifie les données à extraire de la source de données.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. Développez le dataset pour afficher la collection de champs définie par la requête du dataset.Expand the dataset to view the collection of fields specified by the dataset query.

    Dans certains concepteurs de requêtes pour les datasets multidimensionnels, vous pouvez spécifier des filtres dans le volet des filtres et indiquer s'il faut créer des paramètres de rapport.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. Si vous spécifiez l'option de paramètre de rapport, un dataset particulier est créé automatiquement pour remplir la liste des valeurs valides du paramètre.If you specify the report parameter option, a special dataset is automatically created to populate the parameter’s valid values list. Par défaut, le dataset n'apparaît pas dans le volet des données de rapport.By default, the dataset does not appear in the Report Data Pane. Pour plus d’informations, consultez Afficher des datasets masqués pour les valeurs de paramètres des données multidimensionnelles (Générateur de rapports et SSRS).For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • Paramètres de rapport La liste des paramètres de rapport.Report parameters The list of report parameters. Les paramètres peuvent être créés manuellement ou automatiquement lorsqu'une requête de dataset comprend des paramètres de requête.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • Images La liste des images disponibles à inclure comme élément de rapport image dans un rapport.Images The list of images that are available to include as an Image report item in a report.

    Les sources de données et datasets dans le volet des données du rapport représentent les éléments dans la définition de rapport.Data sources and datasets in the Report Data pane represent the elements in the report definition. Le volet des données du rapport est une fonctionnalité prise en charge par plusieurs environnements de création de rapports.The Report Data pane is a feature supported by multiple report authoring environments. Dans le Générateur de rapports, il s'agit du seul volet disponible pour gérer des sources de données et datasets.In Report Builder, it is the only pane available for managing data sources and datasets. Dans le Concepteur de rapports, le volet des données du rapport s'exécute avec l'explorateur de solutions, qui répertorie les sources de données partagées et des datasets partagés en tant que fichiers.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. Les sources de données partagées et des datasets partagés dans le volet des données du rapport doivent indiquer leurs sources de données partagées et les datasets partagés correspondants dans l'explorateur de solutions.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. Les éléments du volet des données du rapport contiennent ensuite une référence aux fichiers de données dans l'explorateur de solutions.The Report Data pane elements then contain a reference to the data files in Solution Explorer. Les propriétés du projet déterminent si les sources de données partagées et des datasets partagés sont déployés sur le serveur de rapports ou site SharePoint.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. Pour plus d’informations, consultez Convertir des sources de données (Générateur de rapports et SSRS).For more information, see Convert Data Sources (Report Builder and SSRS).

Note

Si le volet des données de rapport n’est pas visible, cliquez dans la zone de conception, puis sur Données du rapport dans le menu Affichage.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. Si le volet des données de rapport est flottant, vous pouvez l'ancrer.If the Report Data pane is floating, you can anchor it. Pour plus d’informations, consultez Ancrer le volet des données de rapport dans le Concepteur de rapports (SSRS).For more information, see Dock the Report Data Pane in Report Designer (SSRS).

Volet de regroupementGrouping Pane

Utilisez le volet de regroupement pour définir les groupes d'une région de données de tableau matriciel.Use the Grouping pane to define groups for a tablix data region. Vous pouvez définir des groupes de lignes et de détails pour les tables et des groupes de lignes et de colonnes pour les matrices.You can define row groups and detail groups for tables and row and column groups for matrices. Vous ne pouvez pas utiliser le volet de regroupement pour définir des groupes pour les graphiques ou d'autres régions de données.You cannot use the Grouping pane to define groups for Charts or other data regions. Pour plus d’informations, consultez Fonctionnement des groupes(Générateur de rapports et SSRS).For more information, see Understanding Groups (Report Builder and SSRS).

Le volet de regroupement comporte deux modes :The Grouping pane has two modes:

  • Valeur par défaut.Default. Pour afficher les propriétés actuelles du projet, ouvrez la boîte de dialogue Par défaut pour afficher tous les groupes de lignes et de colonnes dans un format hiérarchique qui montre la relation des groupes parents, des groupes enfants, des groupes adjacents et des groupes de détails.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. Un groupe enfant apparaît au niveau de retrait suivant, en dessous de son groupe parent.A child group appears under and at the next indent level compared to its parent group. Un groupe adjacent apparaît au même niveau de retrait que ses groupes homologues ou frères.An adjacent group appears at the same indent level as its peer or sibling groups.

    Utilisez le mode par défaut pour ajouter, modifier ou supprimer des groupes.Use default mode to add, edit, or delete groups. Pour les groupes basés sur un champ de dataset unique, faites glisser le champ du volet Groupes de lignes vers le volet Groupes de colonnes.For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. Vous pouvez insérer le groupe au-dessus ou en dessous d'un groupe existant.You can insert the group above or below an existing group. Pour ajouter un groupe adjacent, cliquez avec le bouton droit sur le groupe frère et utilisez le menu contextuel.To add an adjacent group, right-click the sibling group, and use the shortcut menu. Pour afficher les cellules de tableau matriciel qui appartiennent à un groupe, sélectionnez le groupe dans le volet de regroupement.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • Avancé.Advanced. Pour afficher les propriétés actuelles du projet, ouvrez la boîte de dialogue Avancé , affichez des membres statiques et dynamiques de groupes de lignes et de colonnes de la région de données du tableau matriciel sélectionné.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. Vous devez utiliser des membres de groupe pour définir les propriétés qui contrôlent la visibilité des lignes et des colonnes associées à un groupe ou à un membre d'un groupe, ou bien les règles que les convertisseurs utilisent pour tenter de maintenir des groupes ensemble sur une page.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. Les membres de groupe apparaissent sur l'aire de conception en tant que cellules des groupes de lignes et des groupes de colonnes.Group members appear on the design surface as cells in the row group and column group areas.

Note

Pour basculer entre le mode Par défaut et le mode Avancé , cliquez avec le bouton droit sur la flèche vers le bas à droite de l’icône Groupes de colonnes .To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

Pour plus d'informations, consultez Grouping Pane.For more information, see Grouping Pane.

Boîte à outilsToolbox

La boîte à outils contient des éléments de rapport que vous pouvez faire glisser vers l'aire de conception.The Toolbox contains report items that you can drag to the design surface. Les régions de données sont des éléments de rapport qui vous permettent d'organiser des données dans le rapport.Data regions are report items that you use to organize data on the report. Table, Matrice, Liste, Graphique, Jauge, Barre de données, Graphique sparkline et Indicateur sont des régions de données.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. Carte, Zone de texte, Rectangle, Graphique en courbe, Image et Sous-rapport sont également des éléments de rapport.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. Des éléments de rapport personnalisés peuvent également figurer dans cette liste s'ils ont été installés et enregistrés par votre administrateur système.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

Volet PropriétésProperties Pane

Le volet Propriétés est une fenêtre standard de Visual StudioVisual Studio qui précise les noms et les valeurs des propriétés de l'élément de rapport actuellement sélectionné dans l'aire de conception.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. Dans la plupart des cas, les noms des propriétés correspondent à des éléments et à des attributs au sein du fichier RDL (Report Definition Language).In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. Les propriétés les plus fréquemment employées peuvent être définies au moyen de la boîte de dialogue Propriétés de l'élément sélectionné.The most commonly used properties can be set by using the Properties dialog box for the selected item. Pour ouvrir la boîte de dialogue correspondante, cliquez sur le bouton Pages de propriétés dans la barre d'outils du volet Propriétés.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. Les utilisateurs expérimentés peuvent définir des valeurs de propriété directement dans le volet Propriétés.Advanced users can set property values directly in the Properties pane.

Utilisez le volet Propriétés pour :Use the Properties pane to:

  • définir les propriétés pour l'élément actuellement sélectionné dans l'aire de conception.Set properties for the currently selected item on the design surface. Certaines propriétés affichent une liste déroulante de valeurs.Some properties provide a drop-down list of values. Vous pouvez aussi taper la valeur directement dans la cellule.You can also type the value directly in the cell. Certaines propriétés contiennent une collection de valeurs désignée par la valeur (Collection).Some properties contain a collection of values, indicated by the value (Collection). La plupart des propriétés peuvent accepter une expression ; les expressions complexes sont signalées par la valeur <Expression>.Most properties can accept an expression; complex expressions are indicated by the value <Expression>. Cliquez sur <Expression> pour ouvrir la boîte de dialogue Expression.Click <Expression> to open the Expression dialog box. Pour plus d'informations, consultez Expression Dialog Box.For more information, see Expression Dialog Box.

  • Utilisez les boutons de la barre d'outils du volet Propriétés pour modifier la grille et la faire basculer de l'affichage des catégories vers un affichage alphabétique.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. En affichage des catégories, vous devrez peut-être développer une catégorie pour afficher toutes ses propriétés en dessous.In category view, you may need to expand a category to see all the properties under it. Pour ouvrir la boîte de dialogue Propriétés d’un élément, cliquez sur le bouton Pages de propriétés de la barre d’outils, ou cliquez avec le bouton droit sur l’élément, puis cliquez sur Propriétés.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • Dans le volet de regroupement, définissez les propriétés pour le membre du groupe sélectionné actuellement.Set properties for the currently selected group member in the Grouping pane. Les propriétés de membre de groupe aident à contrôler la répétition des lignes statiques d'en-tête de groupe et de pied de page pour chaque instance de groupe.Group member properties help control how static group header and footer rows repeat for each group instance. Pour plus d’informations, consultez Afficher des en-têtes et des pieds de page avec un groupe (Générateur de rapports et SSRS).For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

    Pour afficher le volet Propriétés, dans le menu Affichage , cliquez sur Fenêtre Propriétés.To display the Properties pane, from the View menu, click Properties Window. Vous pouvez détacher ce volet et le déplacer vers une autre zone de la fenêtre Outils de données SQL ServerSQL Server Data Toolsou bien l'afficher sous forme de fenêtre à onglets dans l'aire de conception.You can undock this pane and move it to another area of the Outils de données SQL ServerSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

Explorateur de solutionsSolution Explorer

L'Explorateur de solutions est un composant Visual StudioVisual Studio standard qui affiche tous les éléments de votre projet.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. Pour un projet Report Server, cela inclut des dossiers pour organiser des sources de données partagées, des datasets partagés, des rapports et des ressources.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. Lorsque vous ouvrez le fichier des solutions, les dossiers sont automatiquement classés par ordre alphabétique.Folder items are automatically alphabetized when you open the solution file. Pour afficher les propriétés d'un élément dans le volet propriétés, sélectionnez l'élément.To view item properties in the Properties pane, select the item.

SortieOutput

La fenêtre Sortie affiche les erreurs de traitement lorsque vous visualisez un rapport, ainsi que les erreurs de publication lors du déploiement d'un rapport ou d'une source de données partagée.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

Pour déboguer des erreurs dans les expressions, utilisez la sortie et les fenêtres Structure du document.Use the Output and the Document Outline windows to help debug errors in expressions.

Structure du documentDocument Outline

La fenêtre Structure du document affiche une liste hiérarchique de tous les éléments de rapport dans la définition du rapport.The Document Outline window displays a hierarchical list of all report items in the report definition. Pour l'ouvrir, dans le menu Affichage , pointez sur Autres fenêtres , puis cliquez sur Structure du document.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

Utilisez le volet Structure du document pour identifier les zones de texte et autres éléments de rapport par nom.Use the Document Outline pane to help identify text boxes and other report items by name. Lorsque vous sélectionnez un élément dans la Structure du document, l'élément est également sélectionné dans l'Aire de conception.When you select an item in the Document Outline, the item is also selected on the Design Surface.

Liste des tâchesTask List

La fenêtre Liste des tâches affiche les erreurs de build pour les fonctionnalités non prises en charge lorsque vous importez un rapport depuis une autre application, telle que MicrosoftMicrosoft Access.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

Mode conception du Concepteur de rapportsReport Designer Design View

Par défaut, lorsque vous créez un projet Report Server, le Concepteur de rapports s'ouvre en mode création et affiche l'aire de conception.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. Par défaut, l'aire de conception affiche le corps du rapport et son arrière-plan.By default, the design surface displays the report body and the report background.

Le menu contextuel dans l'arrière-plan propose des options permettant d'ajouter un en-tête et un pied de page, puis, à partir du menu Affichage, d'afficher une règle et le volet de regroupement.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

Utilisez le contrôle de zoom pour augmenter ou diminuer l'agrandissement du rapport.Use the zoom control to increase or decrease the magnification of the report.

Pour concevoir un rapport, faites glisser les éléments de la boîte à outils vers l'aire de conception, puis configurez leurs propriétés et modifiez leur agencement au sein du rapport.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

Aperçu du Concepteur de rapportsReport Designer Preview

Utilisez le mode Aperçu pour exécuter le rapport et afficher un rendu du rapport dans la visionneuse de rapports.Use Preview to run the report and view the rendered report in the report viewer. Le mode Aperçu permet de mettre en cache localement les données du rapport.Preview caches report data locally. Vous pouvez également définir les propriétés de configuration pour exécuter le rapport en mode débogage à l'aide d'un navigateur.You can also set configuration properties to run the report in debug view, using a browser.

Lorsque vous affichez l'aperçu d'un rapport, le Concepteur de rapports se connecte aux sources de données du rapport, exécute des requêtes de dataset, met en cache les données sur l'ordinateur local, traite le rapport pour fusionner les données et la mise en page, puis restitue le rapport.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. Vous pouvez afficher le rapport dans l'onglet Aperçu ou bien définir les propriétés du projet afin de visualiser le rapport en mode débogage et le consulter directement dans un navigateur.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • Aperçu des rapports paramétrables.Previewing Parameterized Reports. Lors de l'aperçu d'un rapport, ce dernier est automatiquement traité si l'ensemble de ses paramètres possèdent des valeurs valides par défaut.When you preview a report, the report is processed automatically if all report parameters have valid default values. Si un ou plusieurs paramètres du rapport ne sont pas dotés de valeurs valides par défaut, vous devez choisir une valeur pour chaque paramètre non attribué, puis cliquer sur Afficher le rapportdans la barre d'outils du rapport.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • Présentation du cache de données local Lors de l’aperçu d’un rapport, le processeur de rapports exécute toutes les requêtes pour les datasets dans le rapport à l’aide des paramètres par défaut actuels, puis enregistre les résultats dans un fichier de cache de données local (.rdl.data).Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. Vous pouvez toujours concevoir votre rapport sans avoir à récupérer de nouveau ces données si vous n'apportez aucune modification aux requêtes de dataset du rapport ou à ses paramètres.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • Aperçu du rapport via le Gestionnaire de configuration et l'outil de débogage.Previewing the Report using Configuration Manager and Debug. Dans Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT), les propriétés du projet définissent la manière dont vous souhaitez déployer et déboguer vos rapports.In Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. Ces propriétés s'appliquent à tous les rapports et à toutes les sources de données partagées au sein du projet .These properties apply to all reports and shared data sources in the project. Pour définir les propriétés du projet, dans le menu Projet , cliquez sur Propriétés.To set the project properties, from the Project menu, click Properties. Testez vos rapports au moyen de ces paramètres et publiez-les sur le serveur de rapports.Use these settings to test your reports and publish them to the report server.

  • Contrôle des messages d'erreur dans le volet Sortie.Monitoring the Output Pane for Error Messages. Lorsque vous affichez l'aperçu d'un rapport et que le processeur de rapports détecte un problème, il génère des messages d'erreur dans le volet Sortie.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

Menus du Concepteur de rapportsReport Designer Menus

Quand un projet du Concepteur de rapports est actif dans Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT), les barres d'outils suivantes apparaissent dans la barre d'outils principale.When a Report Designer project is active in Outils de données SQL Server (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. Les menus du Concepteur de rapports sont visibles uniquement en mode Conception.The Report Designer menus are visible only when in Design view.

Menu FormatFormat Menu

Lorsque vous sélectionnez un élément dans l'aire de conception, le menu Format dévoile les options suivantes :When you select an item on the design surface, the Format menu contains the following options:

  • Couleur de premier plan Sélectionnez la couleur d'un texte.Foreground Color Select a text color. Le noir est la couleur par défaut.Black is the default text color.

  • Couleur d'arrière-plan Choisissez une couleur d'arrière-plan pour vos zones de texte et les régions de données.Background Color Select a background color for your text boxes and data regions.

  • Police Spécifiez si le texte doit apparaître en gras, en italique ou souligné.Font Specify whether the text is bold, italic, or underlined.

  • Justifier Indiquez si le texte est aligné à droite, centré ou aligné à gauche.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • Aligner Précisez comment les objets sélectionnés sont alignés les uns par rapport aux autres au sein du rapport.Align Specify how the selected objects are aligned in relation to one another within the report.

  • Uniformiser la taille Ajustez la taille des objets sélectionnés au sein du rapport.Make Same Size Adjust the size of the selected objects within the report.

  • Espacement horizontal Ajustez l'espacement horizontal entre les objets sélectionnés au sein du rapport.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • Espacement vertical Ajustez l'espacement vertical entre les objets sélectionnés au sein du rapport.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • Centrer sur le formulaire Centrez l'objet choisi verticalement et horizontalement par rapport à la fenêtre du Concepteur de rapports.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • Ordre Déplacez les objets sélectionnés à l'arrière-plan ou au premier plan.Order Move selected objects into the background or foreground.

Menu RapportReport Menu

Lorsque l'aire de conception du rapport est active, le menu Rapport comprend les options suivantes :When the report design surface has focus, the Report menu contains the following options:

  • Propriétés du rapport Sélectionnez cette option pour ouvrir la boîte de dialogue Propriétés du rapport .Report Properties Select to open the Report Properties dialog box. Dans cette boîte de dialogue, vous pouvez affecter les propriétés générales du rapport, telles que le nom de l'auteur et l'espacement de la grille, et définir des propriétés pour sa mise en page, notamment le nombre de colonnes et la taille de la page.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. Vous pouvez également inclure du code personnalisé, des références à des assemblys et à des classes, ainsi que les noms d'éléments de sortie des données, des transformations de données et des schémas de données.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • Vue Basculez entre les deux onglets du Concepteur de rapports : Conception et aperçu.View Switch between the two Report Designer tabs: Design and Preview.

  • En-tête de page Ajoutez ou supprimez un en-tête de page dans le rapport.Page Header Add or delete a page header to the report. Lorsque vous supprimez un en-tête de page, tous les éléments qu'il contient sont supprimés.When you delete a page header, all items in the page header are deleted.

  • Pied de page Ajoutez ou supprimez un pied de page dans le rapport.Page Footer Add or delete a page footer to the report. Lorsque vous supprimez un pied de page, tous les éléments qu'il contient sont supprimés.When you delete a page footer, all items in the page footer are deleted.

  • Volet de regroupement Affichez ou masquez le volet de regroupement.Grouping Pane Show or hide the Grouping pane.

Menu AfficherView Menu

Le menu Affichage permet d'afficher les fenêtres et les barres d'outils du Concepteur de rapports.Use the View menu to display Report Designer windows and toolbars

  • Liste d'erreurs Utilisez cette option pour afficher des erreurs détectées lors de la publication ou de l'aperçu d'un rapport.Error List Use this option to display errors detected when publishing or previewing a report.

  • Sortie Utilisez cette option pour afficher les erreurs détectées lors de la publication ou du traitement d’un rapport, ou pour obtenir de plus amples informations sur les erreurs d’expression quand un rapport affiche le texte « #Erreur ».Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • Fenêtre Propriétés Utilisez cette option pour afficher les valeurs des propriétés de l'élément de rapport actuellement sélectionné dans l'aire de conception.Properties Window Use this option to display the property values for the currently selected report item on the design surface. Pour afficher les propriétés des éléments de rapport imbriqués, vous devez cliquer plusieurs fois sur un élément de rapport pour parcourir sa hiérarchie et ses membres imbriqués.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. Vérifiez le nom de l'élément de rapport qui apparaît en haut du volet Propriétés pour savoir lesquelles parmi ses propriétés sont affichées.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • Boîte à outils Utilisez cette option pour afficher la boîte à outils.Toolbox Use this option to display the Toolbox.

  • Autres fenêtres Utilisez cette option pour afficher le volet suivant :Other Windows Use this option to display the following pane:

    • Structure du document Utilisez cette option pour afficher une vue hiérarchique des éléments de rapport et leurs collections de zones de texte dans un rapport.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • Barres d'outils Utilisez cette option pour afficher les barres d'outils qui prennent en charge les fonctionnalités du Concepteur de rapports, notamment Bordures du rapport et Formatage du rapport.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. Pour plus d'informations, consultez Barres d'outils du Concepteur de rapports.For more information, see Report Designer Toolbars.

  • Données du rapport Utilisez cette option pour afficher le volet des données de rapport où vous pouvez ajouter des paramètres de rapport, des sources de données, des datasets et des images.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

Menu ProjetProject Menu

Utilisez le menu Projet pour gérer des sources de données partagées et des rapports dans un projet.Use the Project menu to manage shared data sources and reports in a project. Lorsque vous ajoutez ou supprimez des éléments du projet, l'affichage hiérarchique des éléments du projet dans l'Explorateur de solutions est automatiquement mis à jour.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • Ajouter un nouvel élément Ajoutez une nouvelle source de données partagée ou un nouveau rapport au projet.Add New Item Add a new shared data source or new report to the project.

  • Ajouter un élément existant Ajoutez une source de données partagée existante ou un rapport existant au projet.Add Existing Item Add an existing shared data source or an existing report to the project.

  • Importer des rapports Importez des rapports d'une autre application (par exemple, Microsoft Access).Import Reports Import reports from another application, for example, Microsoft Access.

  • Exclure du projet Excluez des éléments du projet.Exclude from Project Exclude items from the project. Cette option ne supprime pas l'élément de votre système de fichiers.This option does not delete the item from your file system.

  • Afficher tous les fichiers Affichez l'ensemble des fichiers dans un projet.Show All Files Show all files in a project.

  • Actualiser les éléments de boîte à outils du projet Actualisez le cache de boîte à outils lorsque vous installez de nouveaux éléments de rapport personnalisés dans votre projet.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • Propriétés Ouvrez la boîte de dialogue Pages de propriétés du projet concerné.Properties Open the Property Pages dialog box for this project. Pour plus d’informations, consultez Pages de propriétés du projet, boîte de dialogue.For more information, see Project Property Pages Dialog Box.

Barres d'outils du Concepteur de rapportsReport Designer Toolbars

Le Concepteur de rapports propose les barres d'outils spécialisées suivantes pour la création de rapports :Report Designer provides the following specialized toolbars to use when designing reports:

  • Rapport Ajoutez un en-tête ou un pied de page, définissez les propriétés du rapport, basculez vers la règle ou le volet de regroupement ou modifiez l'affichage du rapport à l'aide du contrôle de zoom.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • Bordures du rapport Définissez la couleur, le style et la largeur de toutes les lignes sélectionnées, ainsi que les bordures de tous les éléments de rapport choisis.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • Formatage du rapport Définissez le format des éléments de rapport sélectionnés.Report Formatting Set the format of selected report items. Pour les zones de texte, les types de mise en forme suivants peuvent être modifiés à l'aide de la barre d'outils : propriétés de la police et couleur du texte, couleur d'arrière-plan et justification du texte.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • Mise en page Définissez l'ordre de dessin des éléments de rapport et la fusion des cellules dans une région de données.Layout Set the drawing order of report items and merging cells within a data region.

  • Standard Ouvrez ou enregistrez des projets et des fenêtres d'affichage et sélectionnez la configuration du débogage.Standard Open or save projects, display windows, and select the Debug configuration.

    Utilisez le menu Affichage pour choisir ou non d'afficher ces barres d'outils.Use the View menu to control whether to display these toolbars. D'autres barres d'outils de Visual StudioVisual Studio peuvent être désactivées si leurs fonctionnalités ne s'appliquent pas à celles du Concepteur de rapports.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

contrôle de code source ;Source Control

Outils de données SQL ServerSQL Server Data Tools peut intégrer des plug-ins de source. Utilisez les pages Projets et Solutions de la boîte de dialogue Options pour spécifier le plug-in et configurer les paramètres. can integrate with source plug-ins. Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

Modèles de rapports personnalisésCustom Report Templates

Pour utiliser des rapports personnalisés comme modèles pour de nouveaux rapports, il suffit de les copier dans le dossier ReportProject sur l'ordinateur sur lequel Outils de données SQL ServerSQL Server Data Tools est installé.To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which Outils de données SQL ServerSQL Server Data Tools is installed. Par défaut, ce dossier se trouve dans l’emplacement suivant : <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. Lorsque vous ajoutez un nouvel élément au projet de rapport, votre rapport personnalisé s'affiche dans le volet Modèles.When you add a new item to the report project, your custom report appears in the Templates pane.

Vous pouvez également ajouter des styles personnalisés à l'Assistant de rapport.You can also add custom styles to the report wizard.

Prise en charge de la ligne de commandes pour les outils de données SQL ServerCommand Line Support for SQL Server Data Tools

Outils de données SQL ServerSQL Server Data Tools est basé sur MicrosoftMicrosoft Visual StudioVisual Studio et sur l’application devenv.exe sous-jacente. is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. Pour pouvoir utiliser ces options, vous devez définir des valeurs valides pour les deux éléments suivants :Before you can use these options, you must set valid values for following two items:

  • Propriétés de projet pour OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder et TargetServerURL.Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • Au moins un jeu de propriétés de configuration, par exemple, Debug ou Release.At least one set of configuration properties, for example, Debug or Release.

    Pour plus d'informations, consultez Publishing Data Sources and Reports.For more information, see Publishing Data Sources and Reports.

    Pour un projet de serveur de rapports, vous pouvez spécifier les options suivantes à partir de la ligne de commande :For a report server project, you can specify the following options from the command line:

  • /deploy Permet de déployer des rapports à l’aide des propriétés de projet spécifiées dans un fichier de configuration./deploy Deploy reports by using the project properties specified in a configuration file. Par exemple, la commande suivante déploie les rapports spécifiés par le fichier solution Reports.sln en utilisant les paramètres de configuration Release spécifiés dans les propriétés de projet :For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build Permet de générer le fichier solution, mais pas de le déployer./build Build the solution file, but do not deploy it. Par exemple, la commande suivante génère les rapports spécifiés par le fichier solution Reports.sln en utilisant les paramètres de configuration Debug spécifiés dans les propriétés de projet :For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out Permet de rediriger la sortie générée en créant une solution dans le fichier spécifié./out Redirect the output generated by building a solution to the specified file. Par exemple, la commande suivante redirige la sortie générée dans l'exemple précédent vers un fichier nommé mybuildlog.txt.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Raccourcis clavier dans Reporting ServicesKeyboard Shortcuts in Reporting Services

Utilisez les raccourcis clavier pour :Use keyboard shortcuts to:

  • Contrôler les fenêtres et les modes dans Outils de données SQL ServerSQL Server Data Tools:Control windows and modes in Outils de données SQL ServerSQL Server Data Tools:

    DescriptionDescription Combinaison de touchesKey Combination
    Génération du projet sélectionnéBuild the selected project CTRL+MAJ+BCTRL+SHIFT+B
    Affichage de la fenêtre PropriétésDisplay Properties window F4F4
    Affichage de la fenêtre DonnéesDisplay Data window CTRL+Alt+DCTRL+Alt+D
    Démarrage du débogageStart debugging F5F5
    Passage d'une fenêtre ouverte à la suivanteMove from one open window to the next F6F6
  • contrôler les éléments sur l'aire de conception du rapport :Control items on the report design surface:

    DescriptionDescription Combinaison de touchesKey Combination
    Déplacer le focus d'un élément de rapport vers l'élément de rapport suivantMove focus from one report item to the next report item TabTAB
    Déplacer l'élément de rapport sélectionnéMove selected report item Touches de directionArrow keys
    Déplacer l'élément de rapport sélectionnéNudge selected report item CTRL+Touches de directionCTRL+Arrow keys
    Augmenter ou diminuer la taille de l'élément de rapport sélectionnéIncrease or decrease the size of the selected report item CTRL+MAJ+Touches de directionCTRL+SHIFT+Arrow keys
    Dans une zone de texte, déplacer le curseur au début du texte d'affichage visibleIn a text box, move cursor to the beginning of the display text that is visible Ctrl+OrigineCTRL+HOME
    Dans une zone de texte, déplacer le curseur à la fin du texte d'affichage visibleIn a text box, move cursor to the end of the display text that is visible Ctrl+FinCTRL+END
    Dans une zone de texte, sélectionner le texte à partir de la position actuelle du curseur jusqu'au début du texte d'affichage visibleIn a text box, select text from the current cursor position to the beginning of the display text that is visible Maj+OrigineSHIFT+HOME
    Dans une zone de texte, sélectionner le texte à partir de la position actuelle du curseur jusqu'à la fin du texte d'affichage visibleIn a text box, select text from the current cursor position to the end of the display text that is visible Maj+FinSHIFT+END
    Dans une zone de texte, sélectionner le texte à partir de la position actuelle du curseur jusqu'au début de l'expressionIn a text box, select text from the current cursor position to the beginning of the expression CTRL+MAJ+ORIGINECTRL+SHIFT+HOME
    Dans une zone de texte, sélectionner le texte à partir de la position actuelle du curseur jusqu'à la fin de l'expressionIn a text box, select text from the current cursor position to the end of the expression Ctrl+Maj+FinCTRL+SHIFT+END
    Ouvrir le menu contextuel de l'élément de rapport sélectionnéOpen the shortcut menu for the selected report item MAJ+F10+Clé de propriété sur les claviers récentsSHIFT+F10+Property Key on newer keyboards

Étapes suivantesNext steps

Télécharger SQL Server Data Tools Explorateur de solutions Download SQL Server Data Tools Solution Explorer
Rapports Reporting Services Reporting Services Reports
Langage de définition des rapports Report Definition Language
Prise en charge du déploiement et de la version dans les outils de données de serveur SQLDeployment and Version Support in SQL Server Data Tools

D’autres questions ?More questions? Essayez de poser une question dans le forum Reporting ServicesTry asking the Reporting Services forum