Erreur dans les diagnostics de démarrage VM dans le portail Azure : impossible d’obtenir le contenu du journal.

Cet article fournit une solution à un problème dans lequel l’erreur « Échec de l’obtention du contenu du journal » se produit lorsque vous affichez une capture d’écran d’ordinateur virtuel dans le panneau Diagnostics de démarrage dans le portail Azure.

Version du produit d’origine :   Ordinateur virtuel exécutant Windows, ordinateur virtuel exécutant Linux
Numéro de la base de connaissances initiale :   4094480

Symptômes

Lorsque vous essayez d’afficher une capture d’écran d’ordinateur virtuel dans le panneau Diagnostics de démarrage dans le portail Azure, une erreur se produit et l’entrée suivante est consignée dans la zone de notification :

Échec de l’obtention du contenu du journal « » de la machine virtuelle « /subscriptions/ /resourceGroups/ /providers/Microsoft.Compute/virtualMachines/ ». Message d’erreur : « Description : échec de l’exécution de l’appel RPC pour le message «getExtendedInfoBlob » : échec de la fin de l’appel RPC pour la pile « getExtendedInfoBlob » : # # #RPC_Exception# # # de RPC : Microsoft_Azure_Compute-> Microsoft_Azure_Storage (getExtendedInfoBlob) (la capture de la pile des appels n’est pas activée. Utilisez ? trace = Diagnostics pour l’activer.) '

Cause

Ce problème peut se produire pour l’une des raisons suivantes :

  • Les machines virtuelles qui s’exécutent sur Windows Server 2008 R2 ou versions antérieures * * * * ne produisent pas de rapport d’intégrité de la machine virtuelle. Par conséquent, il est prévu qu’aucun fichier SerialConsole. log n’est produit dans le compte de stockage de diagnostic de démarrage et le message d’erreur mentionné dans la section « symptômes » s’affiche. Pour vérifier la version du système d’exploitation, ouvrez une fenêtre d’invite de commandes, tapez winver, puis appuyez sur entrée. (Voir la solution de contournement 1)

  • Les machines virtuelles disposant d’une ancienne version de l’agent invité VM (antérieure à 2.7.1198.806) installées ne sont pas censées produire un rapport d’intégrité des machines virtuelles. Par conséquent, il est prévu qu’aucun fichier SerialConsole. log n’est produit dans le compte de stockage de diagnostic de démarrage et le message d’erreur mentionné dans la section « symptômes » s’affiche. Pour vérifier la version de l’agent invité VM, ouvrez le C:\WindowsAzure\logs\WaAppAgent.log dossier, puis recherchez les éléments suivants :

    Démarrage de WindowsAzureGuestAgent. Version 2.7.1198.802 (voir solution 2)

  • La génération automatique du rapport d’intégrité de la machine virtuelle par l’agent invité VM peut échouer. Dans ce cas, aucun fichier SerialConsole. log n’est créé. Ce Trigger déclenche le message d’erreur e e mentionné dans la section « symptômes ». Par exemple, ce rapport n’est pas généré s’il existe des SID non résolus signalés en tant que membres du groupe d’administrateurs locaux de l’ordinateur virtuel.Pour rechercher ce type de problème, examinez le fichier C:\WindowsAzure\logs\TransparentInstaller.log. (Voir la solution de contournement 3)

Solution de contournement

Pour contourner ce problème, essayez les méthodes suivantes.

Solution de contournement 1

Mettez à niveau votre système d’exploitation vers une version plus récente.

Solution de contournement 2

Mettez à jour l’agent invité VM en installant la version 2.7.1198.822 à partir du téléchargement. msi suivant : https://go.microsoft.com/fwlink/?LinkID=394789&clcid=0x409 .

Solution de contournement 3

Vérifiez si l’utilisateur associé a été supprimé du domaine.

Par ailleurs, vous pouvez supprimer les SID non résolus (par exemple, S-1-5-21-XYZ-XYZ) du groupe Administrateurs local.

Vérifiez également si vous avez une stratégie de domaine qui verrouille le groupe Administrateurs local ou si le compte administrateur intégré a été supprimé (indiqué par « 0x80005004 » dans le journal d’installation transparent).

Solution de contournement 4

Si vous pensez qu’un problème affecte le port série sur l’hôte, vous pouvez essayer de redéployer la machine virtuelle pour la déplacer vers un autre hôte.

Avertissement

Cette action déclenche un redémarrage de la machine virtuelle.

Statut

Nous travaillons sur la résolution de ce problème. Notre objectif est d’améliorer la découverte des cas dans lesquels le fichier SerialConsole. log n’est pas produit et empêcher cette erreur de devenir trop intrusive.