Vous ne pouvez pas accéder à votre environnement Dynamics 365 à l'aide de l'URL ci-dessus. Un message d'erreur s'affiche lorsque vous accédez à votre environnement common data service pour la première fois

Cet article fournit une solution à une erreur qui se produit lorsque vous accédez à votre environnement Common Data Service pour la première fois.

S'applique à :   Microsoft Dynamics 365 Customer Engagement Online
Numéro de la ko d'origine :   4541747

Introduction

Pour améliorer le service et la disponibilité, nous sommes en train de mettre à niveau notre protocole d'authentification en remplaçant le service de redirection d'URL. Le service de redirection d'URL remplacé sera supprimé le 31 mars 2020.

Lorsque vous accédez à votre environnement Common Data Service pour la première fois ou à chaque fois après vous être passé d'une session précédente, vous êtes dirigé vers Azure AD pour vous y inscrire. Dans l'URL de la page de connexion, elle contient un ensemble de valeurs/codes internes qui incluent un lien vers le service de redirection d'URL. Une fois la signature réussie, le service de redirection d'URL vous dirige vers votre environnement de service de données commun.

Le service de redirection d'URL a été remplacé en septembre 2019. Cette modification vous aurait un impact si vous avez créé un signet de la page de connexion avant septembre 2019 contenant le lien du service de redirection d'URL remplacé.

Certaines valeurs/codes internes sont sensibles au temps et ne sont valides que pour une courte période. Nous vous recommandons de signer la page d'environnement Common Data Service au lieu de la page de signature.

Notes

Seul un petit groupe d'utilisateurs est touché par cette modification et les utilisateurs touchés voient une page de notification avec des instructions sur la façon de résoudre le problème.

Symptômes

Lorsque vous accédez pour la première fois à votre environnement, vous êtes dirigé vers une page de connexion (ci-dessous) pour entrer vos informations d'identification.

Boîte de dialogue de signature d'authentification.

Lorsque vous entrez vos informations d'identification, vous voyez cette page de notification :

Erreur de la signature d'authentification.

Notes

L'URL du service de données communes présentée dans la capture d'écran ci-dessus n'est qu'un exemple: l'URL réelle de votre environnement s'affiche dans le message.

Cause

Dans l'URL de la page de connexion, le lien de l'ancien service de redirection est incorporé.

Exemple (ancien) :

Exemple de l'ancienne URL.

Le service de redirection supprimé est appelé <cloudredirector.crm.dynamics.com>.

Et il est remplacé par quelque chose comme bn1 -- namcrlivesg614.crm.dynamics.com .

Notes

Ce n'est qu'un exemple et cette URL est différente en fonction de la région où réside votre client.

Exemple (nouveau) :

Exemple de la nouvelle URL.

Pour éviter les interruptions d'utilisateur et d'entreprise avec cette mise à niveau, nous avons créé une page de notification pour les utilisateurs qui ont accédé à l'environnement avec une URL de page de sign-in qui contient l'URL de redirecteur désaffectée.

Notes

Notez que tous vos utilisateurs ne voient pas cette page de notification : seuls les utilisateurs suivants peuvent voir la page de notification :

  1. Les utilisateurs qui avaient enregistré la page de signature dans leur signet avant septembre 2019 et
  2. Les utilisateurs qui accèdent à leur environnement via le portail de leur entreprise qui contient un lien contenant l'URL du redirecteur déprécié.

Résolution

La page de notification sera déployée à partir de la semaine du 17 février 2020.

  1. Pour un scénario de signet :

    Corrigez votre signet en suivant les instructions de la page de notification.

  2. Pour le portail d'entreprise ou Single-SignOn scénario (SSO) :

    Elle s'applique généralement aux clients qui utilisent leur propre service STS (Secure Token Service) qui se fédéré avec Azure AD pour fournir une expérience d' utilisateur unique à leurs utilisateurs.

    Pour fournir une expérience DSO, vous pouvez avoir un lien DSO qui ressemble à ceci :

    https://sts.contoso.com/adfs/ls/?client-request-id=...&wa=wsignin1.0&wtrealm=urn%3afederation%3aMicrosoftOnline&wctx=LoginOptions%3D3%26estsredirect%3d2%26estsrequest%3d<encodedPayload>&cbcxt=&mkt=&lc=&RedirectToIdentityProvider=...

    Vous avez probablement capturé l'url en enregistrant le processus de sign-in lorsque vous vous connectez à l'URL de votre organisation dans <encodedPayload> une nouvelle session de navigateur.

    Bien que nous comprenions que cette méthode vous permet d'atténuer certaines limitations de l'authentification unique STS, elle n'est officiellement pas prise en charge car elle utilise la charge utile codée capturée à ce moment-là. Certaines données ont une durée de vie courte dans la charge utile encodée et une fois qu'elle expire, vous devrez en resserrez une nouvelle charge utile. La charge utile codée capturée peut également être facilement invalidée avec les modifications apportées à notre service back-end. Il n'est pas recommandé, car il entraîne une interruption de l'expérience de la connectez-vous de l'utilisateur.

    Une meilleure approche consiste à transmettre votre nom de domaine comme dans l'URL de votre organisation ?whr=contoso.com Dynamics 365 (voir ci-dessous). Ce qui indique à Azure AD d'ignorer la phase de découverte de domaine d'accueil et passe directement à votre service STS. Elle peut obtenir l'ation SSO en fonction de votre configuration STS.

    Exemple : https://contoso.crm.dynamics.com/?whr=contoso.com
    (remplacez l'URL de contoso.com l'organisation et par votre nom de domaine)

  3. Si vous exécutez des scripts d'automatisation, vous avez peut-être également enregistré l'URL de redirection désaffectée. Ces scripts échouent et doivent être mis à jour.