Données d’entreprise non enregistrées dans le travail en cours-applications autorisées sur un appareil de co-gestion ou de jonction Azure AD hybride dans Intune

Cet article vous aide à résoudre un problème dans lequel vous ne pouvez pas enregistrer de données d’entreprise dans les applications autorisées pour les travaux en cours sur un appareil Windows qui est enregistré dans Microsoft Intune via une participation ou une co-gestion hybride Azure AD.

Version du produit d’origine :   Microsoft Intune
Numéro de la base de connaissances initiale :   4496680

Symptôme

Prenons l’exemple du scénario suivant :

  • Vous utilisez un appareil Windows.
  • L’appareil est intégré à Intune via une co-gestion hybride de l’Association Azure AD ou de la configuration.
  • Une stratégie de protection des informations Windows (WIP) est appliquée à l’appareil.

Dans ce scénario, lorsque vous utilisez des applications qui sont autorisées pour les travaux en cours, telles que Microsoft Word et Microsoft Excel, vous rencontrez les problèmes suivants :

  • Lorsque vous essayez d’enregistrer le document en tant que fichier de travail , vous recevez le message d’erreur suivant :

    Word ne peut pas terminer l’enregistrement en raison d’une erreur d’autorisation de fichier.

    Erreur d’autorisation de fichier

  • Tout fichier téléchargé à partir de ressources Cloud est automatiquement enregistré en tant que fichier personnel. Lorsque vous essayez de modifier le fichier pour qu’il fonctionne, vous recevez le message d’erreur suivant :

    Une erreur inattendue vous empêche d’appliquer des propriétés au fichier. Si vous continuez à recevoir cette erreur, vous pouvez utiliser le code d’erreur pour rechercher de l’aide sur ce problème.
    Erreur 0x8007177C : la stratégie de récupération configurée pour ce système contient un certificat de récupération non valide.

    Capture d’écran de l’erreur 0x8007177C.

  • Lorsque vous essayez de créer un document professionnel, vous recevez le message d’erreur suivant : Word ne peut pas terminer l’enregistrement.

    Impossible d’exécuter l’erreur d’enregistrement

Cause

Ces problèmes se produisent si le certificat DRA (agent de récupération de données EFS) de la stratégie de votre organisation dans la stratégie de groupe a expiré. Dans ce cas, vous ne pouvez pas chiffrer vos fichiers à l’aide du certificat.

Résolution

Pour résoudre le problème, procédez comme suit :

  1. Exportez l’ancien certificat DRA et la clé privée pour le cas où vous devriez déchiffrer les fichiers qui ont été chiffrés à l’aide de ce certificat.
  2. Créez et vérifiez un certificat DRA EFS.
  3. Mettez à jour la stratégie dans la stratégie de groupe pour utiliser le nouveau certificat DRA.