L’inscription GPM échoue avec une erreur 0xcaa9001f pour les appareils Windows cogérés
Cet article résout un problème dans lequel l’inscription MDM échoue et génère des erreurs 0xcaa9001f pour les appareils Windows cogérés qui sont Microsoft Entra joints et gérés hybrides à l’aide de Configuration Manager.
Symptômes
L’inscription mdm échoue pour les appareils Windows cogérés qui sont Microsoft Entra hybrides joints et gérés à l’aide de Microsoft System Center Configuration Manager. Les messages d’erreur suivants sont enregistrés :
Dans
%WinDir%\CCM\logs\CoManagementHandler.log
:Échec de l’inscription mdm avec le code d’erreur 0xcaa9001f « Les Authentification Windows intégrées prises en charge uniquement dans le flux de fédération. » Réessayera dans 15 minutes...
Dans les journaux sous Applications et services Journaux>Microsoft>Windows>DeviceManagement-Enterprise-Diagnostic-Provider>Administration dans le observateur d'événements :
Tâche de migration du système démarrée.
Résultat de l’emprunt d’identité. Résultat : (Une tentative a été effectuée pour référencer un jeton qui n’existe pas.).
Inscription GPM automatique : Échec (Code d’erreur Win32 inconnu : 0xcaa9001f)Dans les journaux sous Applications et services Journaux>Microsoft>Windows>Microsoft Entra ID>Operational dans le observateur d'événements :
Requête HTTP status : 400. Méthode : URI du point de terminaison POST : https://login.microsoftonline.com/\<AADTenantID>/oauth2/token ID de corrélation : <ID>
Erreur de réponse OAuth : invalid_grant
Description de l’erreur : AADSTS70002 : Erreur lors de la validation des informations d’identification. AADSTS50155 : l’appareil n’est pas authentifié.
Remarque
L’inscription byOD (Bring your own device) ou l’inscription automatique à l’aide de stratégie de groupe fonctionne correctement.
Cause
Ce problème se produit lorsque l’Authentification Windows intégrée est tentée par le client Configuration Manager sur Microsoft Entra ID alors que le domaine vérifié n’est pas fédéré.
Ce problème se produit dans l’une des situations suivantes :
- Le service Azure Gestion cloud n’est pas configuré dans Configuration Manager.
- La découverte d’utilisateurs AD ou la découverte d’utilisateurs Microsoft Entra n’est pas activée pour les utilisateurs concernés. Les deux méthodes de découverte doivent être activées.
Solution
Pour résoudre le problème, configurez les services Azure pour la gestion cloud et assurez-vous que la découverte d’utilisateurs AD et la découverte d’utilisateurs Microsoft Entra sont activées pour les utilisateurs.
Commentaires
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