Message d’erreur « erreur 633 : le modem (ou un autre périphérique de connexion) est déjà utilisé » lorsque vous essayez d’établir une connexion VPN

Cet article fournit une solution de contournement pour le problème dans lequel vous pouvez ne pas être en mesure d’établir une connexion VPN en raison d’un conflit de port TCP.

Version du produit d’origine :   Windows Server 2003
Numéro de la base de connaissances initiale :   885959

Important

Cet article contient des informations sur la modification du Registre. Avant de modifier le registre, veillez à le sauvegarder et assurez-vous que vous comprenez comment restaurer le registre en cas de problème. Pour plus d’informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows

Symptômes

Lorsque vous essayez d’utiliser une connexion de réseau privé virtuel (VPN) sur un ordinateur Microsoft Windows Server 2003, le message d’erreur suivant peut s’afficher :

Erreur 633 : le modem (ou un autre périphérique de connexion) est déjà en cours d’utilisation ou n’est pas configuré correctement.

Cause

Ce problème peut se produire si le port TCP utilisé par la connexion VPN est déjà utilisé par un autre programme. La connexion VPN utilise le port TCP 1723 pour établir une connexion. Si un autre programme utilise déjà ce port, vous ne pouvez pas établir de connexion VPN.

Solution de contournement

Avertissement

Si vous utilisez l’éditeur du registre de manière incorrecte, vous risquez de rencontrer des problèmes sérieux pouvant vous amener à réinstaller votre système d’exploitation. Microsoft ne peut pas garantir que vous puissiez résoudre les problèmes résultant d’une utilisation incorrecte de l’éditeur du Registre. Utilisez l’éditeur du Registre à vos propres risques.

Pour contourner ce problème, utilisez l’une des méthodes suivantes :

  • Réservez explicitement le port TCP utilisé pour la connexion VPN. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer, sur exécuter, tapez regedit.exe dans la zone ouvrir , puis cliquez sur OK.
    2. Dans l’éditeur du Registre, recherchez la sous-clé de Registre suivante, puis cliquez dessus : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    3. Dans le menu Edition , pointez sur nouveau, puis cliquez sur valeur de chaîne multiple.
    4. Renommez la valeur de chaînes multiples en « ReservedPorts », puis double-cliquez sur ReservedPorts.
    5. Dans la zone données de la valeur , tapez 1723-1723, puis cliquez sur OK.
    6. Quittez l’Éditeur du Registre.
  • Utilisez la commande netstat pour rechercher le programme qui utilise le port 1723. Ensuite, terminez le processus pour ce programme. Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer, sur exécuter, tapez cmd.exe dans la zone ouvrir , puis cliquez sur OK.

    2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      netstat -aon

    3. Dans la sortie affichée, identifiez l’ID de processus du programme, le cas échéant, qui utilise le port TCP 1723.

    4. À l'invite de commandes, tapez la commande suivante, puis appuyez sur Entrée :
      taskkill /PID PID /F

      Notes

      La commande taskkill termine le processus qui correspond au numéro d’ID de processus. L' /F option est utilisée pour forcer le processus à se terminer.

    5. À l’invite de commandes, tapez exit, puis appuyez sur entrée pour quitter l’invite de commandes.

  • Restart your computer. Le programme qui utilise le port TCP 1723 peut utiliser un autre port.