Cloner un dépôt de code Python dans Visual StudioClone a repository of Python code in Visual Studio

Une fois que vous avez installé Visual Studio Tools pour IA, vous pouvez facilement cloner un dépôt de code Python et créer un projet à partir de celui-ci.Once you've installed Visual Studio Tools for AI, you can easily clone a repository of Python code and create a project from it.

  1. Pour vous connecter à des dépôts GitHub, exécutez le programme d’installation de Visual Studio, sélectionnez Modifier, puis sélectionnez l’onglet Composants individuels. Faites défiler jusqu’à la section Outils de code, sélectionnez Extension GitHub pour Visual Studio, puis sélectionnez Modifier.To connect to GitHub repositories, run the Visual Studio installer, select Modify, and select the Individual components tab. Scroll down to the Code tools section, select GitHub extension for Visual Studio, and select Modify.

    Sélection de l’extension GitHub dans le programme d’installation de Visual Studio

  2. Lancez Visual Studio.Launch Visual Studio.

  3. Sélectionnez Affichage > Team Explorer... pour ouvrir la fenêtre Team Explorer, dans laquelle vous pouvez vous connecter à GitHub ou à Visual Studio Team Services, ou cloner un dépôt.Select View > Team Explorer... to open the Team Explorer window in which you can connect to GitHub or Visual Studio Team Services, or clone a repository.

    Fenêtre Team Explorer montrant Visual Studio Team Services, GitHub et le clonage d’un dépôt

  4. Dans le champ URL, sous Dépôts Git locaux, entrez https://github.com/Microsoft/samples-for-ai, entrez un dossier pour les fichiers clonés, puis sélectionnez Cloner.In the URL field under Local Git Repositories, enter https://github.com/Microsoft/samples-for-ai, enter a folder for the cloned files, and select Clone.

    Conseil

    Le dossier que vous spécifiez dans Team Explorer est le dossier spécifique pour recevoir les fichiers clonés.The folder you specify in Team Explorer is the specific folder to receive the cloned files. Contrairement à la commande git clone, la création d’un clone dans Team Explorer ne crée pas automatiquement un sous-dossier avec le nom du dépôt.Unlike the git clone command, creating a clone in Team Explorer does not automatically create a subfolder with the name of the repository.

  5. Quand le clonage est terminé, double-cliquez sur le dossier du dépôt dans le bas de Team Explorer pour accéder au tableau de bord du dépôt.When cloning is complete, double-click the repository folder at the bottom of Team Explorer to navigate to the repository dashboard. Sous Solutions, sélectionnez Nouveau....Under Solutions, select New....

    Fenêtre Team Explorer, création d’un projet à partir d’un clone

  6. Dans la boîte de dialogue Nouveau projet qui s’affiche, sélectionnez « À partir de code Python existant », spécifiez un nom pour le projet, définissez Emplacement sur le même dossier que le dépôt, puis sélectionnez OK.In the New Project dialog that appears, select "From Existing Python Code", specify a name for the project, set Location to the same folder as the repository, and select OK. Dans l’Assistant qui apparaît, sélectionnez Terminer.In the wizard that appears, select Finish.

  7. Sélectionnez Affichage > Explorateur de solutions dans le menu.Select View > Solution Explorer from the menu.

  8. Dans l’Explorateur de solutions, développez le nœud TensorFlow Examples> MNIST, cliquez avec le bouton droit sur convolutional.py, puis sélectionnez Définir comme fichier de démarrage.In Solution Explorer, expand the TensorFlow Examples> MNIST node, right-click convolutional.py, and select Set as Startup File. Cette étape indique à Visual Studio quel fichier utiliser quand vous exécutez le projet.This step tells Visual Studio which file it should use when running the project.

  9. Appuyez sur Ctrl+F5 ou sélectionnez Déboguer > Démarrer sans débogage pour exécuter le programme.Press Ctrl+F5 or select Debug > Start Without Debugging to run the program. Si vous voyez une `, revérifiez la valeur du répertoire de travail de l’étape précédente.If you see an `, re-check the working directory setting in the previous step.

  10. Lorsque le programme s’exécute correctement, vous le voyez commencer à télécharger votre jeu de données d’apprentissage et de test, puis effectuer l’apprentissage du modèle et générer votre taux d’erreur.When the program runs successfully, you'll see it start to download your training and test dataset, then train the model and output your error rate. Vous voulez que le taux d’erreur diminue au fil du tempsYou want error rate to decrease over time

    Première sortie du programme Python MNIST

Si vous utilisez Anaconda et obtenez une erreur relative à l’absence de numpy, vous devrez peut-être modifier votre environnement Python pour utiliser Anaconda.If you are using Anaconda and get an error about missing numpy, you may need to change your Python environment to use Anaconda.

  1. Vous pouvez visualiser la progression avec TensorBoard.You can visualize the progress with TensorBoard. Cliquez avec le bouton droit sur votre projet et cliquez sur Exécuter TensorBoard, puis sélectionnez le répertoire de vos journaux TensorBoard de sortie.Right click your project and click Run TensorBoard then select the directory of your output TensorBoard logs.

    exécuter tensorboard

  2. Remarquer que l’erreur diminue au fil du temps, ce qui signifie que la qualité s’amélioreNotice the error decreasing overtime, which means the quality is improving

    exécuter tensorboard