Utilisation de Visual Studio Tools pour UnityUsing Visual Studio Tools for Unity

Dans cette section, vous allez apprendre à utiliser les fonctionnalités d’intégration et de productivité de Visual Studio Tools pour Unity, ainsi qu’à utiliser le débogueur Visual Studio pour le développement Unity.In this section, you'll learn how to use Visual Studio Tools for Unity's integration and productivity features, and how to use the Visual Studio debugger for Unity development.

Intégration et productivité d'UnityUnity Integration and Productivity

Visual Studio Tools pour Unity s'intègre à l'éditeur Unity pour vous aider à être plus productif.Visual Studio Tools for Unity integrates with the Unity Editor to help you be more productive. Ces fonctionnalités d'amélioration de la productivité automatisent les tâches de script courantes et importent les informations Unity dans Visual Studio afin que vous ne soyez pas obligé de basculer sur l'éditeur Unity pour y accéder.These productivity-enhancing features automate common scripting tasks and bring information from Unity into Visual Studio so that you don't have to switch to the Unity Editor to find it.

Accès à la documentation UnityUnity documentation access

Vous pouvez accéder rapidement à la documentation sur les scripts Unity à partir de Visual Studio.You can access the Unity scripting documentation quickly from Visual Studio. Si Visual Studio Tools pour Unity ne trouve pas la documentation de l'API en local, il la recherche en ligne.If Visual Studio Tools for Unity doesn't find the API documentation locally, it will try to find it online.

Pour accéder à la documentation UnityTo access Unity documentation
  • Dans Visual Studio, placez le curseur sur l’API Unity pour laquelle vous souhaitez obtenir des informations ou sélectionnez-la, puis appuyez sur Ctrl+Alt+M, Ctrl+H.In Visual Studio, highlight or place the cursor over the Unity API you want to learn about, then press Ctrl+Alt+M, Ctrl+H

Assistant de script MonoBehavior d'UnityUnity MonoBehavior scripting wizard

Dans Unity, la plupart des scripts sont implémentés en dérivant de la classe MonoBehavior et par substitution de certaines de ses méthodes.In Unity, most scripts are implemented by deriving from the MonoBehavior class and overriding some of its methods. Vous pouvez utiliser l'Assistant MonoBehavior pour créer rapidement des définitions vides des méthodes MonoBehavior que vous souhaitez surcharger.You can use the MonoBehavior wizard to quickly create empty definitions of the MonoBehavior methods you want to overload. À l'aide de cet Assistant, vous pouvez spécifier une ou plusieurs méthodes que vous voulez surcharger à partir de la liste des méthodes disponibles, choisir où elles vont être insérées dans le code et décider s'il faut inclure des commentaires sur leur utilisation.Using this wizard, you can specify one or more methods that you want to overload from the list of available methods, choose where they will be inserted into your code, and decide whether to include comments about how they are used.

La boîte de dialogue de l’Assistant Monobehavior.The monobehavior wizard dialog.

Pour créer des définitions de méthode MonoBehavior vides à l'aide de l'Assistant MonoBehaviorTo create empty MonoBehavior method definitions by using the MonoBehavior wizard
  1. Dans Visual Studio, placez le curseur à l’endroit où vous souhaitez insérer les méthodes, puis appuyez sur Ctrl+Maj+M pour lancer l’Assistant MonoBehavior.In Visual Studio, position the cursor where you might want the methods to be inserted, then press Ctrl+Shift+M to launch the MonoBehavior wizard. Si vous voulez insérer les nouvelles méthodes après une méthode déjà implémentée, vous pouvez le spécifier ultérieurement ; appuyez simplement sur Ctrl+Maj+M.Or, if you want to insert the new methods after one that's already been implemented, you can specify that later; just press Ctrl+Shift+M.

  2. Sélectionnez les méthodes que vous souhaitez surcharger.Select the methods you want to overload. Dans la fenêtre Créer des méthodes de script, sous Sélectionner des méthodes à créer, cochez la case en regard du nom de chaque méthode que vous voulez surcharger.In the Create script methods window, under Select methods to create, mark the checkbox next to the name of each method you want to overload.

  3. Vérifiez que la version du .NET Framework affichée dans la liste déroulante Version du Framework correspond à celle que vous utilisez.Ensure that the framework version displayed in the Framework version dropdown matches the version you're using. Dans le cas contraire, remplacez la valeur de la liste déroulante par la version que vous souhaitez utiliser.If it doesn't match, change the value of the dropdown to the version you want to use.

  4. Choisissez à quel endroit les méthodes vont être insérées.Choose where the methods will be inserted. Par défaut, les méthodes sont insérées à l'emplacement du curseur. Si vous souhaitez les insérer ailleurs, vous pouvez choisir de le faire après une méthode déjà implémentée dans votre classe.By default, the methods are inserted at the position of the cursor; if you want to insert them somewhere else, you can choose to insert them after any method that's already implemented in your class. Pour choisir un de ces emplacements, remplacez la valeur de la liste déroulante Point d’insertion par l’emplacement de votre choix.To choose one of these locations, change the value of the Insertion point drop down to the location you want.

  5. Si vous voulez que l’Assistant génère des commentaires pour les méthodes que vous avez sélectionnées, cochez la case Générer des commentaires de méthode.If you want the wizard to generate comments for the methods you selected, mark the Generate method comments checkbox. Ces commentaires ont pour but de vous aider à comprendre à quel moment la méthode est appelée et quelles sont ses responsabilités générales.These comments are meant to help you understand when the method is called and what its general responsibilities are.

  6. Cliquez sur le bouton OK pour quitter l’Assistant et insérer les méthodes dans votre code.Choose the OK button to exit the wizard and insert the methods into your code.

    L'Assistant MonoBehavior est particulièrement utile pendant votre apprentissage de l'API Unity, ou lorsque vous devez surcharger une méthode dont vous n'êtes pas familier.The MonoBehavior wizard is especially helpful while you're still learning the Unity API, or when you need to overload a method you're not familiar with. Lorsque vous serez plus expérimenté avec l'API Unity, vous préférerez probablement l'Assistant MonoBehavior rapide pour créer rapidement des méthodes que vous connaissez déjà.As you become more experienced with the Unity API, you might prefer the Quick MonoBehavior wizard for quickly creating methods you're already familiar with.

Assistant de script MonoBehavior rapideQuick MonoBehavior scripting wizard

Lorsque vous êtes déjà familiarisé avec l'API Unity, vous pouvez implémenter les méthodes surchargées encore plus rapidement à l'aide de l'Assistant MonoBehavior rapide.When you're already familiar with the Unity API, you can implement overloaded methods even more quickly by using the Quick MonoBehavior Wizard. À l'aide de cet Assistant, vous ne pouvez spécifier qu'une seule méthode qui soit insérée sans commentaires de méthode à l'emplacement du curseur.Using this wizard, you can specify just one method that's inserted without method comments at the cursor location.

La boîte de dialogue de l’Assistant Monobehavior rapide.The quick monobehavior wizard dialog.

Pour créer une définition de méthode MonoBehavior vide à l'aide de l'Assistant MonoBehavior rapideTo create an empty MonoBehavior method definition by using the Quick MonoBehavior wizard
  1. Dans Visual Studio, placez le curseur à l’endroit où vous voulez insérer les méthodes, puis appuyez sur Ctrl+Maj+M pour lancer l’Assistant MonoBehavior rapide.In Visual Studio, position the cursor where you want the method to be inserted, then press Ctrl+Shift+Q to launch the Quick MonoBehavior wizard. Contrairement à l'autre Assistant MonoBehavior, vous devez positionner le curseur à l'endroit de votre choix lorsque vous utilisez cet Assistant, car c'est toujours là que la nouvelle méthode est insérée.Unlike the other MonoBehavior wizard, you must position the cursor intentionally when using this wizard because the new method is always inserted there.

  2. Vérifiez que la version du Framework affichée dans le coin supérieur droit de la fenêtre Créer une méthode de script correspond à la version que vous utilisez.Ensure that the framework version displayed in the upper right-hand corner of the Create script method window matches the version you're using. Dans le cas contraire, remplacez la valeur de la liste déroulante par la version que vous souhaitez utiliser.If it doesn't match, change the value of the dropdown to the version you want to use.

  3. Recherchez la méthode que vous souhaitez surcharger.Find the method that you want to overload. Dans la fenêtre Créer une méthode de script, commencez par taper le nom de la méthode dans la zone de texte.In the Create script method window, begin typing the name of the method in the textbox. La liste des méthodes dont les noms correspondent à ceux que vous avez entrés s'affiche.A list of the methods whose names match what you've entered will appear.

  4. Sélectionnez la méthode que vous souhaitez surcharger.Choose the method you want to overload. Quand la méthode voulue apparaît dans la liste, sélectionnez-la avec la souris ou les touches fléchées, puis appuyez sur Entrée.When the method you want is displayed in the list, select it with the mouse or arrow keys, then press Enter. Si c’est la seule méthode de la liste, appuyez simplement sur Entrée.If it's the only method in the list, you can just press Enter. La méthode vient s'insérer dans votre code.The method is inserted into your code.

Explorateur de projets de UnityUnity Project Explorer

Vous pouvez utiliser l'Explorateur de projets Unity pour parcourir votre projet Unity à l'intérieur de Visual Studio.You can use the Unity Project Explorer to navigate your Unity project inside Visual Studio.

La fenêtre Explorateur de projet Unity.The Unity Project Explorer window.

Pour afficher l'Explorateur de projets UnityTo view the Unity Project Explorer
  • Dans Visual Studio, dans le menu principal, choisissez Affichage, Explorateur de projets Unity.In Visual Studio, on the main menu, choose View, Unity Project Explorer. Clavier : Alt+Maj+EKeyboard: Alt+Shift+E

    Afficher la fenêtre Explorateur de projet Unity.View the Unity Project Explorer window.

    L’Explorateur de projets Unity affiche l’ensemble de vos répertoires et fichiers projet Unity de la même façon que l’éditeur Unity : il en va différemment de la navigation dans vos scripts Unity avec l’Explorateur de solutions, qui ne contient que vos fichiers script et les affiche, car les projets et solutions générés par Visual Studio Tools pour Unity les organise.The Unity Project Explorer shows all of your Unity project files and directories in the same way that the Unity Editor does - this is different than navigating your unity scripts with the Solution Explorer, which contains only your script files and displays them as the projects and solution generated by Visual Studio Tools for Unity organizes them. En particulier dans les projets volumineux, il est souvent plus facile de localiser le script que vous souhaitez modifier à l'aide de l'Explorateur de projets Unity. Il est alors également aisé de modifier d'autres types de fichiers, comme les fichiers de configuration texte, dans Visual Studio sans les ajouter à l'un des projets de la solution Visual Studio.Especially in large projects, it's often easier to locate the script you want to modify by using the Unity Project Explorer; it also makes it easy to modify other kinds of files—for example, text-based configuration files—in Visual studio without adding them to one of the projects in the Visual Studio solution.

Liste d'erreurs UnityUnity Error List

Vous pouvez afficher les messages à partir de la console Unity à l'intérieur de Visual Studio lorsqu'il est connecté à une instance Unity.You can view messages from the Unity console inside Visual Studio when it's connected to a Unity instance. Les erreurs et les avertissements Unity sont inclus.This includes errors and warnings from Unity. Les messages sont affichés dans la fenêtre Liste d’erreurs de Visual Studio ; les messages d’erreur Unity s’affichent sous l’onglet Erreurs, les messages d’avertissement sous l’onglet Avertissements et les autres messages, comme ceux envoyés à l’aide de l’API Unity Debug.Log, sous l’onglet Messages.The messages are displayed in Visual Studio's Error List window; error messages from Unity are displayed on the Errors tab, warning messages on the Warnings tab, and other messages—for example, messages sent by using the Debug.Log Unity API—are displayed on the Messages tab.

Pour que les messages soient visibles, votre projet Unity doit être débogué dans un lecteur Unity pour prendre en charge le débogage de script et pour importer le package Visual Studio Tools pour Unity adapté à votre version Visual Studio. De plus, Visual Studio doit être connecté à Unity.In order to see the messages, your Unity project must be Debugging your project in a Unity Player to support Script Debugging and to import the Visual Studio Tools for Unity package that's right for your version of Visual Studio, and Visual Studio must be Connecting Visual Studio to Unity.

Si vous ne voulez pas voir les erreurs, avertissements et messages Unity dans la fenêtre Liste d’erreurs de Visual Studio, vous pouvez les désactiver dans le menu Configuration.If you don't want to see errors, warnings, and messages from Unity in Visual Studio's Error List window, you can disable them in the Configuration menu.

Raccourcis clavierKeyboard shortcuts

Vous pouvez accéder rapidement aux fonctionnalités des outils Unity pour Visual Studio à l'aide de leurs raccourcis clavier.You can quickly access the Unity Tools for Visual Studio functionality by using their keyboard shortcuts. Voici un résumé des raccourcis disponibles.Here's a summary of the shortcuts that are available.

CommandeCommand RaccourciShortcut Nom de la commande du raccourciShortcut command name
Ouvrir l'Assistant MonoBehaviorOpen the MonoBehavior Wizard Ctrl+Maj+MCtrl+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Ouvrir l'Assistant MonoBehavior rapideOpen the Quick MonoBehavior Wizard Ctrl+Maj+QCtrl+Shift+Q EditorContextMenus.CodeWindow.QuickMonoBehavioursEditorContextMenus.CodeWindow.QuickMonoBehaviours
Ouvrir l'Explorateur de projets UnityOpen the Unity Project Explorer Alt+Maj+EAlt+Shift+E View.UnityProjectExplorerView.UnityProjectExplorer
Accéder à la documentation UnityAccess Unity documentation Ctrl+Alt+M, Ctrl+HCtrl+Alt+M, Ctrl+H Help.UnityAPIReferenceHelp.UnityAPIReference
Attacher au débogueur Unity (lecteur ou éditeur)Attach to Unity debugger (player or editor) Pas de valeur par défautno default Debug.AttachUnityDebuggerDebug.AttachUnityDebugger

Vous pouvez modifier les combinaisons de touches de raccourci si vous n'aimez pas la valeur par défaut.You can change the shortcut key combinations if you don't like the default. Pour plus d’informations sur la modification des combinaisons par défaut, consultez Identification et personnalisation des raccourcis clavier dans Visual Studio.For information on how to change it, see Identifying and Customizing Keyboard Shortcuts in Visual Studio.

Débogage UnityUnity Debugging

Visual Studio Tools pour Unity vous permet de déboguer les scripts de l'éditeur et de jeu de votre projet Unity à l'aide du puissant débogueur de Visual Studio.Visual Studio Tools for Unity lets you debug both editor and game scripts for your Unity project using Visual Studio's powerful debugger.

Connexion de Visual Studio à UnityConnecting Visual Studio to Unity

Visual Studio Tools pour Unity communique avec Unity via une connexion UDP.Visual Studio Tools for Unity communicates with Unity through a UDP connection. Cela signifie que vous pouvez vous connecter à une instance Unity s'exécutant localement ou sur votre réseau de la même façon.This means that you can connect to a Unity instance running locally or anywhere on your network in exactly the same way. Vous pouvez vous connecter aux instances Unity visibles sur votre réseau à l’aide de la boîte de dialogue Sélectionner l’instance Unity.You can connect to any of the Unity instances you can see on your network by using the Select Unity Instance dialog.

Pour ouvrir la boîte de dialogue Sélectionner l'instance UnityTo open the Select Unity Instance dialog
  • Dans Visual Studio, dans le menu principal, choisissez Déboguer, Attacher le débogueur Unity.In Visual Studio, on the main menu, choose Debug, Attach Unity Debugger.

    Attacher le débogueur Unity.Attach the debugger of Unity.

  • Autre possibilité : dans Visual Studio, dans la barre d’état, cliquez sur l’icône de connexion dans le coin inférieur droit de Visual Studio.Or, in Visual Studio, on the status bar, choose the plug icon in the lower right-hand corner of Visual Studio.

    Cette icône indique que VSTU est connecté à Unity.This icon shows VSTU is connected to Unity.

Conseil

Si l'icône de connexion contient une coche, vous êtes déjà connecté à une instance Unity.If the plug icon shows a checkmark, you're already connected to a Unity instance.

La boîte de dialogue Sélectionner l’instance Unity affiche des informations sur chaque instance Unity à laquelle vous pouvez vous connecter.The Select Unity Instance dialog displays some information about each Unity instance that you can connect to.

Choisissez une instance de Unity à laquelle vous connecter.Choose an instance of Unity to connect to.

Projet Nom du projet Unity qui s’exécute dans cette instance Unity.Project The name of the Unity project that's running in this instance of Unity.

Machine Nom de l’ordinateur ou de l’appareil sur lequel cette instance Unity est en cours d’exécution.Machine The name of the computer or device that this instance of Unity is running on.

Type Éditeur si cette instance Unity est en cours d’exécution dans l’éditeur Unity ; Lecteur si cette instance Unity est un lecteur autonome.Type Editor if this instance of Unity is running as part of the Unity Editor; Player if this instance of Unity is a stand-alone player.

Port Numéro de port du socket UDP sur lequel communique cette instance Unity.Port The port number of the UDP socket that this instance of Unity is communicating over.

Important

Étant donné que Visual Studio Tools pour Unity et l'instance Unity communiquent via un socket réseau UDP, votre pare-feu peut l'interroger.Because Visual Studio Tools for Unity and the Unity instance are communicating over a UDP network socket, your firewall might ask about it. Dans ce cas, vous devez autoriser la connexion de telle sorte que VSTU et Unity puissent communiquer.If this happens, you'll have to authorize the connection so that VSTU and Unity can communicate.

Résolution des problèmes de connexion entre Unity et Visual StudioTroubleshooting the connection between Unity and Visual Studio

Vérifier que l’attachement de l’éditeur est activéConfirm Editor Attaching is enabled

Dans le menu Unity, sélectionnez Edit (Edition) > Preferences (Préférences), puis sélectionnez l’onglet External Tools (Outils externes). Vérifiez que la case Editor Attaching (Attachement de l’éditeur) est cochée.In the Unity Menu, select Edit > Preferences and then select the External Tools tab. Confirm that the Editor Attaching checkbox is enabled. Pour plus d’informations, consultez la documentation sur les préférences d’Unity.For more information, consult the Unity Preferences documentation.

Débogage de votre projet dans un lecteur UnityDebugging your project in a Unity Player

Vous pouvez connecter directement Visual Studio Tools pour Unity à votre application Unity s'exécutant dans un lecteur autonome lorsque vous n'exécutez pas l'éditeur Unity ou pour déboguer des problèmes spécifiques à la plateforme.You can connect Visual Studio Tools for Unity directly to your Unity app running in a stand-alone player when you are not running Unity Editor, or to debug problems that are platform specific.

Pour activer le débogage de script dans un lecteur UnityTo enable script debugging in a Unity player
  • Assurez-vous de créer une version de développement avec le débogage de script activé.Make sure you are creating a development build with script debugging enabled. Dans les paramètres de build de votre projet Unity, cochez les cases Version de développement et Débogage de script.In the build settings of your Unity project, mark the Development Build and Script Debugging checkboxes.

    Configurez les paramètres de build Unity pour le débogage.Configure the Unity build settings for debugging.

    En outre, pour déboguer une application Unity en cours d’exécution dans le Lecteur web Unity, vous devez également la configurer pour qu’elle utilise le Canal des versions de développement.Additionally, to debug a Unity app running in the Unity Web Player, you also need to configure it to use the Development Release Channel.

Pour configurer le canal des mises en production de développement dans le lecteur web UnityTo configure the Development Release Channel in Unity Web Player
  • Dans le lecteur web Unity, dans le menu contextuel, choisissez Canal des versions et vérifiez que l’option Développement est activée.In the Unity Web Player, on the context menu, choose Release Channel and make sure that the Development option is enabled.

    Important

    Dans Unity 4.2 et ultérieur, l’élément du menu contextuel Canal des versions est disponible dans le menu contextuel du lecteur web seulement quand vous appuyez sur la touche Alt tandis que le menu contextuel est ouvert.In Unity 4.2 and later, the Release Channel context menu item is only available on the Web Player context menu when the Alt key is pressed as the context menu is opened. Si le lecteur web s’exécute sur Mac OS X, appuyez à la place sur la touche Option.If the Web Player is running on Mac OS X, press the Option key instead.

    Enfin, assurez-vous que vous êtes connecté à l'instance Unity que vous souhaitez déboguer.Finally, make sure you're connected to the Unity instance that you want to debug. Pour plus d’informations sur la procédure à suivre, consultez la section Connexion de Visual Studio à Unity.For information on how to do that, see the Connecting Visual Studio to Unity section.

Débogage d'une DLL dans votre projet UnityDebugging a DLL in your Unity project

De nombreux développeurs Unity écrivent des composants de code en tant que DLL externes afin que les fonctionnalités qu'ils développent puissent être facilement partagées avec d'autres projets.Many Unity developers are writing code components as external DLLs so that the functionality they develop can be easily shared with other projects. Visual Studio Tools pour Unity facilite le débogage du code dans ces DLL, sans heurt avec tout autre code de votre projet Unity.Visual Studio Tools for Unity makes it easy to debug code in these DLLs seamlessly with other code in your Unity project.

Note

À ce stade, Visual Studio Tools pour Unity prend uniquement en charge les DLL managées.At this time, Visual Studio Tools for Unity only supports managed DLLs. Il ne gère pas le débogage des DLL de code natif, telles que celles écrites en C++.It does not support debugging of native code DLLs, such as those written in C++.

Notez que le scénario décrit ici suppose que vous disposiez du code source, autrement dit, que vous développiez ou réutilisez votre propre code tiers, ou que vous ayez le code source d'une bibliothèque tierce et que vous prévoyiez de le déployer dans votre projet Unity en tant que DLL.Note that the scenario described here assumes that you have the source code—that is, you are developing or re-using your own first-party code, or you have the source code to a third-party library, and plan to deploy it in your Unity project as a DLL. Ce scénario ne décrit pas le débogage d'une DLL pour laquelle vous n'avez pas le code source.This scenario does not describe debugging a DLL for which you do not have the source code.

Pour déboguer un projet DLL managée utilisé dans votre projet UnityTo debug a managed DLL project used in your Unity project
  1. Ajoutez votre projet DLL existant à la solution Visual Studio générée par Visual Studio Tools pour Unity.Add your existing DLL project to the Visual Studio solution generated by Visual Studio Tools for Unity. Moins couramment, vous pouvez aussi démarrer un nouveau projet de DLL managée pour qu'il contienne les composants de code de votre projet Unity ; si tel est le cas, vous pouvez à la place ajouter un nouveau projet DLL managée à la solution Visual Studio.Less commonly, you might be starting a new managed DLL project to contain code components in your Unity project; if that's the case, you can add a new managed DLL project to the Visual Studio solution instead. Pour plus d’informations sur l’ajout d’un projet nouveau ou existant à une solution, consultez Comment : ajouter des projets à une solution.For more information on adding a new or existing project to a solution, see How to: Add Projects to a Solution.

    Ajoutez votre projet DLL existant à la solution.Add your existing DLL project to the solution.

    Dans les deux cas, Visual Studio Tools pour Unity conserve la référence de projet, même s'il doit régénérer les fichiers projet et solution ; par conséquent, vous ne devez effectuer ces étapes qu'une seule fois.In either case, Visual Studio Tools for Unity maintains the project reference, even if it has to regenerate the project and solution files again, so you only need to perform these steps once.

  2. Référencez le bon profil du framework Unity dans le projet DLL.Reference the correct Unity framework profile in the DLL project. Dans Visual Studio, dans les propriétés du projet DLL, définissez la propriété Framework cible avec la version du Framework Unity que vous utilisez.In Visual Studio, in the DLL project's properties, set the Target framework property to the Unity framework version you're using. Il s'agit de la bibliothèque des classes de base Unity qui correspond à la compatibilité d'API ciblée par votre projet, comme les bibliothèques de classes de base Unity complètes, micro ou web.This is the Unity Base Class Library that matches the API compatibility that your project targets, such as the Unity full, micro, or web base class libraries. De cette façon, votre DLL ne peut pas appeler les méthodes du framework qui existent dans d'autres frameworks ou niveaux de compatibilité, mais qui n'existent peut-être pas dans la version du framework Unity que vous utilisez.This prevents your DLL from calling framework methods that exist in other frameworks or compatibility levels, but which might not exist in the Unity framework version you're using.

    Définissez Unity comme framework cible de la DLL.Set the DLL's target framework to Unity framework.

  3. Copiez la DLL dans le dossier Composants de votre projet Unity.Copy the DLL to your Unity project's Asset folder. Dans Unity, les composants désignent les fichiers regroupés et déployés au même titre que votre application Unity afin de pouvoir être chargés au moment de l'exécution.In Unity, assets are files that are packaged and deployed together with your Unity app so that they can be loaded at run-time. Comme les DLL sont liées à l'exécution, elles doivent être déployées en tant que composants.Since DLLs are linked at runtime, DLLs must be deployed as assets. Pour que la DLL soit déployée comme composant, l'éditeur Unity requiert que les DLL soient placées dans le dossier Composants de votre projet Unity.To be deployed as an asset, the Unity Editor requires the DLLs to be put inside the Assets folder in your Unity project. Il existe deux façons de procéder :There are two ways you can do this:

    • Modifier les paramètres de génération de votre projet DLL pour inclure une tâche post-génération qui copie les fichiers DLL et PDB résultants de son dossier de sortie vers le dossier Composants de votre projet Unity.Modify the build settings of your DLL project to include a post-built task that copies the output DLL and PDB files from its output folder to the Assets folder of your Unity project.

    • Modifier les paramètres de génération de votre projet DLL pour définir son dossier de sortie comme dossier Composants de votre projet Unity.Modify the build settings of your DLL project to set its output folder to be the Assets folder of your Unity project. Les fichiers DLL et PDB seront placés dans le dossier Composants.Both DLL and PDB files will be placed in the Assets folder.

      Les fichiers PDB sont nécessaires pour le débogage, car ils contiennent les symboles de débogage de la DLL et mappent le code de la DLL sur la forme de son code source.The PDB files are needed for debugging because they contain the DLL's debugging symbols, and map the DLL code to its source code form. Visual Studio Tools pour Unity utilise les informations à partir de la DLL et des fichiers PDB pour créer un fichier DLL.MDB, qui est le format des symboles de débogage utilisé par le moteur de script Unity.Visual Studio Tools for Unity will use information from the DLL and PDB to create a DLL.MDB file, which is the debug symbol format used by the Unity scripting engine.

  4. Déboguez votre code.Debug your code. Vous pouvez maintenant déboguer le code source de votre DLL ainsi que le code source de votre projet Unity, et utiliser toutes les fonctionnalités de débogage auxquelles vous êtes habitué, telles que les points d'arrêt et le parcours du code pas à pas.You can now debug your DLL source code together with your Unity project's source code, and use all the debugging features you are used to, such as breakpoints and stepping through code.