Vérifier votre environnement XamarinVerify your Xamarin environment

Une fois les programmes d’installation terminés (voir Setup and install), passez quelques minutes à vérifier que tout est prêt pour expérimenter le développement Xamarin.Once the installers have completed (see Setup and install), spend a few minutes to verify that everything is ready to experience Xamarin development.

Quand vous avez terminé la vérification de l’installation, vous pouvez effectuer l’une des procédures pas à pas suivantes, ou les deux :Once you have finished verifying the installation, try either or both of the following walkthroughs:

Toutes les plateformesAll platforms

Dans Visual Studio, sélectionnez d’abord Outils > Extensions et mises à jour, puis vérifiez si des composants Xamarin nécessitent des mises à jour.In Visual Studio, first select Tools > Extensions and Updates and check if any of the Xamarin components require updates.

Créez ensuite une solution Xamarin.Forms dans Visual Studio en sélectionnant Fichier > Nouveau projet.Then, create a new Xamarin.Forms solution in Visual Studio using File > New Project. Dans la boîte de dialogue, développez Visual C# > Multiplateforme, sélectionnez Application mobile (Xamarin.Forms), puis cliquez sur OK.In the dialog, expand Visual C# > Cross-Platform, select Mobile App (Xamarin.Forms), and click OK. Dans la boîte de dialogue suivante, sélectionnez Application vide.In the dialog that follows, select Blank App. Sous Stratégie de partage de code, sélectionnez .NET Standard.Under Code Sharing Strategy, select .NET Standard. Cliquez sur OK.Click OK.

Ces actions créent une solution avec quatre projets : un projet de bibliothèque .NET Standard 2.0 partagé et des projets d’application pour Android, iOS et la plateforme Windows universelle (UWP) :These actions create a solution with four projects: a shared .NET Standard 2.0 library project and application projects for Android, iOS, and the Universal Windows Platform (UWP):

Résultats de la création d’un projet à partir du modèle Xamarin.Forms Application videResults of creating a new project from the Blank App Xamarin.Forms template

AndroidAndroid

  1. Vérifiez que les derniers outils Android SDK sont installés en accédant à Outils > Android > Android SDK Manager.Check that you have the latest Android SDK tools installed by going to Tools > Android > Android SDK Manager. Installez la dernière version du composant Android SDK Tools ainsi que des outils de plateforme Android SDK et de génération Android SDK.Install the newest versions of the Android SDK Tools, Android SDK Platform tools, and Android SDK Build tools. Il n’est pas nécessaire de toujours installer le dernier niveau d’API Android.It is not necessary to always install the latest Android API level. Le niveau d’API dont vous avez besoin dépend du niveau de plateforme à cibler.The API level you need depends on the platform level you want to target. En général, l’installation de la plateforme Xamarin entraîne celle du niveau de plateforme Android nécessaire.In general, installing the Xamarin platform will install the Android platform level it requires.

  2. Vérifiez la génération et le débogage sur un appareil ou émulateur :Validate building and debugging on a device or emulator:

    • Cliquez avec le bouton droit sur le projet Android dans l’Explorateur de solutions et sélectionnez Définir comme projet de démarrage.Right-click the Android project in Solution Explorer and select Set as Startup Project.

    • Dans la barre d’outils, vous devez voir un menu déroulant contenant une liste d’émulateurs et d’appareils Android disponibles.In the toolbar, you should see a drop-down containing a list of available Android devices and emulators.

    Les appareils Android doivent être activés pour le débogage USB dans les options pour développeurs de la page des paramètres de l’appareil.Android devices must be enabled for USB debugging in the Developer options of the device's Settings page. L’appareil est alors attaché à l’ordinateur par un câble USB.The device is then attached to the computer by USB cable.

    Les émulateurs sont également répertoriés.Also listed are emulators. Sélectionnez l’un des appareils ou émulateurs Visual Studio :Select one of the devices or Visual Studio emulators:

    Sélectionnez l’émulateur Visual Studio pour Android comme cible de débogageSelect the Visual Studio Emulator for Android as a debug target

    Pour plus d’informations, consultez Présentation de l’émulateur pour Android de Visual Studio sur le blog Microsoft DevOps.For more detailed information, see Introducing Visual Studio's Emulator for Android on the Microsoft DevOps blog. Si vous avez des difficultés à faire fonctionner l’émulateur, consultez Résoudre les problèmes de l’émulateur Visual Studio pour Android.If you encounter problems getting the emulator to work, see Troubleshoot the Visual Studio Emulator for Android. Vous pouvez aussi créer des profils d’appareil pour l’émulateur en sélectionnant Outils > Android > Gestionnaire d’émulateur Android.You can also create new device profiles for the emulator by selecting Tools > Android > Android Emulator Manager.

  3. Appuyez sur F5 pour compiler et déployer le programme sur l’émulateur ou l’appareil Android.Press F5 to compile and deploy the program to the Android device or emulator.

WindowsWindows

  1. Cliquez avec le bouton droit sur le projet Windows universel dans l’Explorateur de solutions et sélectionnez Définir comme projet de démarrage.Right-click the Universal Windows project in Solution Explorer and select Set as Startup Project.

  2. Dans la liste déroulante Plateformes solution, sélectionnez x86 ou x64.In the Solution Platforms drop-down, select x86 or x64. Sélectionnez Ordinateur local.Select Local Machine.

  3. Appuyez sur F5 pour déployer le programme sur le bureau.Press F5 to deploy the program to the desktop.

iOSiOS

  1. Vérifiez que votre Mac est disponible sur le réseau et associé à Visual Studio, comme décrit dans Connexion au Mac.Make sure your Mac is available on the network and paired with Visual Studio as described on Connecting to the Mac.

  2. Cliquez avec le bouton droit sur le projet iOS dans l’Explorateur de solutions et sélectionnez Définir comme projet de démarrage.Right-click the iOS project in Solution Explorer and select Set as Startup Project.

  3. Sélectionnez la cible iPhoneSimulator dans la liste déroulante des builds de Visual Studio, comme illustré ci-dessous, ou la cible iPhone si un appareil est attaché au Mac.Select the iPhoneSimulator target from Visual Studio's build drop-down as shown below, or the iPhone target if you have a device tethered to the Mac.

    Sélection de la cible de génération iPhoneSimulatorSelecting the iPhoneSimulator build target

    Si aucun simulateur ne figure dans la liste, lancez Xcode sur votre Mac, sélectionnez Xcode > Préférences, puis cliquez sur Télécharger.If no simulators are listed, launch Xcode on your Mac, select Xcode > Preferences, and click Download. Sous le titre Composants, vous devez voir les versions de simulateur qui sont disponibles en téléchargement.Under the Components heading you should see the simulator versions that are available to download. Vous trouverez des instructions supplémentaires pour le débogage dans la page Débogage iOS.Additional instructions for debugging can be found on the iOS Debugging page.

  4. Sélectionnez une cible d’appareil d’émulateur dans la liste déroulante Visual Studio :Select an emulator device target from the Visual Studio drop-down:

    Sélection d’une cible de débogage iPhoneSelecting an iPhone debug target

  5. Démarrez le débogueur en appuyant sur F5.Start the debugger by pressing F5. Le simulateur est lancé sur le Mac où vous allez interagir avec l’application, alors que le débogage se déroule dans Visual Studio.The simulator is launched on the Mac where you'll interact with the app, while debugging happens in Visual Studio. Si vous avez un iPhone ou iPad physique connecté au Mac, il apparaît dans la liste et vous pouvez le sélectionner à la place.If you have a physical iPhone or iPad connected to the Mac, it will appear on the list and you can select it instead. Si aucun appareil ni simulateur ne figure dans la liste, vérifiez la connexion au Mac.If you do not see any devices or simulators listed, check the connection to the Mac. Consultez l’article lié à l’étape 1 ci-dessus ou accédez à Outils > iOS > Coupler au MacReview the article linked in step 1 above, or go to Tools > iOS > Pair to Mac

  6. Si vous rencontrez des problèmes pour vous connecter au Mac, consultez Résolution des problèmes de connexion.If you encounter problems connecting to the Mac, read Connection troubleshooting.

  7. Si vous recevez un message d’erreur indiquant qu’aucun profil de provisionnement installé ne correspond aux clés de signature iOS installées, essayez les suggestions suivantes :If you see an error saying "No installed provisioning profiles match the installed iOS signing keys," try the following suggestions:

    • Vérifiez que votre compte ID Apple est ajouté à Xcode sur votre Mac, comme décrit dans Ajouter votre compte à Xcode (apple.com).Check that your Apple Id account is added in Xcode on your Mac as described on Add your account to Xcode (apple.com). Si vous ajoutez votre compte, redémarrez ensuite Visual Studio et Xcode.After adding your account, be sure to restart both Visual Studio and Xcode.

    • Vérifiez que, dans les propriétés de votre projet iOS, sous l’onglet Signature d’ensemble d’applications iOS, le champ Droits personnalisés est vide pour la configuration Debug activée.Verify that in your iOS project properties in the iOS bundle signing tab, that the Custom entitlement field is empty for the active debug configuration. Remarque : Vous pouvez essayer de supprimer ce paramètre uniquement si vous avez rencontré le message d’erreur ci-dessus.Note: you should only try removing this setting if you've encountered the above error message.

    CrossPlat Xamarin Verify 8CrossPlat Xamarin Verify 8