Procédure pas à pas : création d'un groupe de données avec le Concepteur de DataSetWalkthrough: Creating a Dataset with the Dataset Designer

Dans cette procédure pas à pas, vous allez créer un jeu de données à l’aide de la Concepteur de Dataset.In this walkthrough you will create a dataset using the Dataset Designer. Il vous guidera le processus de création d’un projet et l’ajout d’un nouveau DataSet élément lui.It will take you through the process of creating a new project and adding a new DataSet item to it. Vous allez apprendre à créer des tables basées sur les tables dans une base de données sans utiliser d’Assistant.You will learn how to create tables based on tables in a database without using a wizard.

Cette procédure pas à pas décrit notamment les tâches suivantes :Tasks illustrated in this walkthrough include:

  • Création d’un Application Windows Forms projet.Creating a new Windows Forms Application project.

  • Ajout de vide DataSet élément au projet.Adding an empty DataSet item to the project.

  • Création et configuration d’une source de données dans votre application en générant un dataset avec le Concepteur de Dataset.Creating and configuring a data source in your application by building a dataset with the Dataset Designer.

  • Création d’une connexion à la base de données Northwind l’Explorateur de serveurs.Creating a connection to the Northwind database in Server Explorer.

  • Création de tables avec des TableAdapters dans le jeu de données basée sur des tables dans la base de données.Creating tables with TableAdapters in the dataset based on tables in the database.

Note

Il est possible que pour certains des éléments de l'interface utilisateur de Visual Studio, votre ordinateur affiche des noms ou des emplacements différents de ceux indiqués dans les instructions suivantes.Your computer might show different names or locations for some of the Visual Studio user interface elements in the following instructions. L'édition de Visual Studio dont vous disposez et les paramètres que vous utilisez déterminent ces éléments.The Visual Studio edition that you have and the settings that you use determine these elements. Pour plus d'informations, consultez Personnalisation de l'IDE.For more information, see Personalizing the IDE.

PrérequisPrerequisites

Cette procédure pas à pas utilise SQL Server Express LocalDB et la base de données Northwind.This walkthrough uses SQL Server Express LocalDB and the Northwind sample database.

  1. Si vous n’avez pas SQL Server Express LocalDB, installez-le à partir de la page de téléchargement de SQL Server Express, ou via le le programme d’installation de Visual Studio.If you don't have SQL Server Express LocalDB, install it either from the SQL Server Express download page, or through the Visual Studio Installer. Dans le programme d’installation Visual Studio, SQL Server Express LocalDB peut être installé dans le cadre de la stockage de données et de traitement charge de travail, ou sous la forme d’un composant individuel.In the Visual Studio Installer, SQL Server Express LocalDB can be installed as part of the Data storage and processing workload, or as an individual component.

  2. Installer la base de données Northwind en procédant comme suit :Install the Northwind sample database by following these steps:

    1. Dans Visual Studio, ouvrez le l’Explorateur d’objets SQL Server fenêtre.In Visual Studio, open the SQL Server Object Explorer window. (Explorateur d’objets SQL Server est installé dans le cadre de la stockage de données et de traitement charge de travail dans le programme d’installation Visual Studio.) Développez le SQL Server nœud.(SQL Server Object Explorer is installed as part of the Data storage and processing workload in the Visual Studio Installer.) Expand the SQL Server node. Avec le bouton droit sur votre instance de base de données locale et sélectionnez nouvelle requête... .Right-click on your LocalDB instance and select New Query....

      Une fenêtre d’éditeur de requête s’ouvre.A query editor window opens.

    2. Copie le script Transact-SQL de Northwind dans le Presse-papiers.Copy the Northwind Transact-SQL script to your clipboard. Ce script T-SQL crée la base de données Northwind à partir de zéro et la remplit avec des données.This T-SQL script creates the Northwind database from scratch and populates it with data.

    3. Collez le script T-SQL dans l’éditeur de requête, puis choisissez le Execute bouton.Paste the T-SQL script into the query editor, and then choose the Execute button.

      Après une courte période, la requête est terminée et la base de données Northwind est créé.After a short time, the query finishes executing and the Northwind database is created.

Création d’un nouveau projet d’Application Windows FormsCreating a New Windows Forms Application Project

Pour créer un nouveau projet d’Application Windows FormsTo create a new Windows Forms Application project

  1. Dans Visual Studio, sur le fichier menu, sélectionnez nouveau, projet... .In Visual Studio, on the File menu, select New, Project....

  2. Développez le Visual C# ou Visual Basic dans le volet gauche, puis sélectionnez Windows Desktop.Expand either Visual C# or Visual Basic in the left-hand pane, then select Windows Desktop.

  3. Dans le volet central, sélectionnez le l’application Windows Forms type de projet.In the middle pane, select the Windows Forms App project type.

  4. Nommez le projet DatasetDesignerWalkthrough, puis choisissez OK.Name the project DatasetDesignerWalkthrough, and then choose OK.

    Visual Studio ajoute le projet l’Explorateur de solutions et afficher un nouveau formulaire dans le concepteur.Visual Studio adds the project to Solution Explorer and display a new form in the designer.

Ajout d’un nouveau jeu de données à l’ApplicationAdding a New Dataset to the Application

Pour ajouter un nouvel élément dataset au projetTo add a new dataset item to the project

  1. Sur le projet menu, sélectionnez ajouter un nouvel élément... .On the Project menu, select Add New Item....

    La boîte de dialogue Ajouter un nouvel élément s’affiche.The Add New Item dialog box appears.

  2. Dans le volet gauche, sélectionnez données, puis sélectionnez DataSet dans le volet central.In the left-hand pane, select Data, then select DataSet in the middle pane.

  3. Nom du jeu de données NorthwindDataset, puis choisissez ajouter.Name the Dataset NorthwindDataset, and then choose Add.

    Visual Studio ajoute un fichier appelé NorthwindDataset.xsd au projet et l’ouvre dans le Concepteur de Dataset.Visual Studio adds a file called NorthwindDataset.xsd to the project and opens it in the Dataset Designer.

Création d’une connexion de données dans l’Explorateur de serveursCreating a Data Connection in Server Explorer

Pour créer une connexion à la base de données NorthwindTo create a connection to the Northwind database

  1. Sur le vue menu, cliquez sur l’Explorateur de serveurs.On the View menu, click Server Explorer.

  2. Dans l’Explorateur de serveurs, cliquez sur le se connecter à la base de données bouton.In Server Explorer, click the Connect to Database button.

  3. Créer une connexion à la base de données Northwind.Create a connection to the Northwind sample database.

Création des Tables dans le jeu de donnéesCreating the Tables in the Dataset

Cette section explique comment ajouter des tables au jeu de données.This section explains how to add tables to the dataset.

Pour créer la table CustomersTo create the Customers table

  1. Développez la connexion de données que vous avez créé dans l’Explorateur de serveurs, puis développez le Tables nœud.Expand the data connection you created in Server Explorer, and then expand the Tables node.

  2. Faites glisser le clients à partir de la table l’Explorateur de serveurs sur la Concepteur de Dataset.Drag the Customers table from Server Explorer onto the Dataset Designer.

    A clients table de données et CustomersTableAdapter sont ajoutées au jeu de données.A Customers data table and CustomersTableAdapter are added to the dataset.

Pour créer la table OrdersTo create the Orders table

  • Faites glisser le commandes à partir de la table l’Explorateur de serveurs sur la Concepteur de Dataset.Drag the Orders table from Server Explorer onto the Dataset Designer.

    Un commandes table de données, OrdersTableAdapteret la relation de données entre le clients et commandes tables sont ajoutées à la jeu de données.An Orders data table, OrdersTableAdapter, and data relation between the Customers and Orders tables are added to the dataset.

Pour créer la table OrderDetailsTo create the OrderDetails table

  • Faites glisser le Order Details à partir de la table l’Explorateur de serveurs sur la Concepteur de Dataset.Drag the Order Details table from Server Explorer onto the Dataset Designer.

    Un Order Details table de données, OrderDetailsTableAdapteret une relation de données entre le commandes et OrderDetails tables sont ajoutés au jeu de données.An Order Details data table, OrderDetailsTableAdapter, and a data relation between the Orders and OrderDetails tables are added to the dataset.

Étapes suivantesNext Steps

Pour ajouter une fonctionnalité à votre applicationTo add functionality to your application

Voir aussiSee also