Procédure pas à pas : Création d’un DataTable dans le Concepteur de DatasetWalkthrough: Create a DataTable in the Dataset Designer

Cette procédure pas à pas explique comment créer un DataTable (sans TableAdapter) à l’aide de la Concepteur de Dataset.This walkthrough explains how to create a DataTable (without a TableAdapter) using the Dataset Designer. Pour plus d’informations sur la création de tables de données comprenant des TableAdapters, consultez créer et configurer des TableAdapters.For information on creating data tables that include TableAdapters, see Create and configure TableAdapters.

Créez une application Windows FormsCreate a new Windows Forms application

  1. Dans Visual Studio, sur le fichier menu, sélectionnez New > projet.In Visual Studio, on the File menu, select New > Project.

  2. Développez le Visual C# ou Visual Basic dans le volet gauche, puis sélectionnez Windows Desktop.Expand either Visual C# or Visual Basic in the left-hand pane, then select Windows Desktop.

  3. Dans le volet central, sélectionnez le Windows Forms application type de projet.In the middle pane, select the Windows Forms App project type.

  4. Nommez le projet DataTableWalkthrough, puis choisissez OK.Name the project DataTableWalkthrough, and then choose OK.

    Le DataTableWalkthrough projet est créé et ajouté à l’Explorateur de solutions.The DataTableWalkthrough project is created and added to Solution Explorer.

Ajouter un nouveau jeu de données à l’applicationAdd a new Dataset to the application

  1. Sur le projet menu, sélectionnez ajouter un nouvel élément.On the Project menu, select Add New Item.

    La boîte de dialogue Ajouter un nouvel élément s’affiche.The Add New Item dialog box appears.

  2. Dans le volet gauche, sélectionnez données, puis sélectionnez DataSet dans le volet central.In the left-hand pane, select Data, then select DataSet in the middle pane.

  3. Sélectionnez Ajouter.Choose Add.

    Visual Studio ajoute un fichier appelé DataSet1.xsd au projet et l’ouvre dans le Concepteur de Dataset.Visual Studio adds a file called DataSet1.xsd to the project and opens it in the Dataset Designer.

Ajoutez un nouveau DataTable au DatasetAdd a new DataTable to the Dataset

  1. Faites glisser un DataTable à partir de la DataSet onglet de la boîte à outils sur le Concepteur de Dataset.Drag a DataTable from the DataSet tab of the Toolbox onto the Dataset Designer.

    Une table nommée DataTable1 est ajouté au jeu de données.A table named DataTable1 is added to the dataset.

  2. Cliquez sur la barre de titre de DataTable1 et renommez-le Music.Click the title bar of DataTable1 and rename it Music.

Ajouter des colonnes à la table de donnéesAdd columns to the DataTable

  1. Cliquez sur le musique table.Right-click the Music table. Pointez sur ajouter, puis cliquez sur colonne.Point to Add, and then click Column.

  2. Nom de la colonne SongID.Name the column SongID.

  3. Dans le propriétés fenêtre, définissez la DataType propriété System.Int16.In the Properties window, set the DataType property to System.Int16.

  4. Répétez ce processus et ajoutez les colonnes suivantes :Repeat this process and add the following columns:

    SongTitle: System.StringSongTitle: System.String

    Artist: System.StringArtist: System.String

    Genre: System.StringGenre: System.String

Définissez la clé primaire pour la tableSet the Primary Key for the table

Toutes les tables de données doivent avoir une clé primaire.All data tables should have a primary key. Une clé primaire identifie de façon unique un enregistrement spécifique dans une table de données.A primary key uniquely identifies a specific record in a data table.

Pour définir la clé primaire, cliquez sur le SongID colonne, puis cliquez sur définir la clé primaire.To set the primary key, right-click the SongID column, and then click Set Primary Key. Une icône de clé s’affiche en regard du SongID colonne.A key icon appears next to the SongID column.

Enregistrer votre projetSave Your Project

Pour enregistrer le DataTableWalkthrough projet, dans le fichier menu, sélectionnez Enregistrer tout.To save the DataTableWalkthrough project, on the File menu, select Save All.

Voir aussiSee also