Général, Débogage, boîte de dialogue OptionsGeneral, Debugging, Options Dialog Box

Le Outils > Options > Débogage > Général page vous permet de définir les options décrites dans cet article.The Tools > Options > Debugging > General page lets you set the options described in this article.

Si vous avez besoin restaurer les paramètres par défaut, vous pouvez effectuer à l’aide de ce outils > importation et exportation de paramètres > réinitialiser tous les paramètres.If you need to restore default settings, you can do that using Tools > Import and Export Settings > Reset all settings. Si vous souhaitez uniquement un sous-ensemble de paramètres de réinitialisation, enregistrez vos paramètres dans le Assistant Importation et exportation paramètres avant d’apporter les modifications que vous souhaitez tester, puis importer vos paramètres enregistrés ultérieurement.If you only want to reset a subset of settings, save your settings in the Import and Export Settings Wizard before making the changes that you want to test, then import your saved settings later.

Demander avant de supprimer tous les points d’arrêt exige une confirmation avant la fin de la supprimer tous les points d’arrêt commande.Ask before deleting all breakpoints Requires confirmation before completing the Delete All Breakpoints command.

Arrêter tous les processus lorsqu’un processus s’arrête arrête simultanément tous les processus auxquels le débogueur est attaché, lorsqu’un arrêt se produit.Break all processes when one process breaks Simultaneously breaks all processes to which the debugger is attached, when a break occurs.

Arrêter lorsque des exceptions dépassent les limites AppDomain ou managées/natives lors du débogage managé ou en mode mixte, le common language runtime peut intercepter les exceptions qui traversent les limites du domaine d’application ou les limites managées/natives lorsque les éléments suivants conditions sont remplies :Break when exceptions cross AppDomain or managed/native boundaries In managed or mixed-mode debugging, the common language runtime can catch exceptions that cross application domain boundaries or managed/native boundaries when the following conditions are true:

1) lorsque le code natif appelle du code managé à l’aide de COM Interop et le code managé lève une exception.1) When native code calls managed code by using COM Interop and the managed code throws an exception. Consultez Introduction à COM Interop.See Introduction to COM Interop.

2) lorsque le code managé exécuté dans le domaine d’application 1 appelle du code managé dans le domaine d’application 2, et le code dans le domaine d’application 2 lève une exception.2) When managed code running in application domain 1 calls managed code in application domain 2, and the code in application domain 2 throws an exception. Consultez Programming with Application Domains.See Programming with Application Domains.

3) lorsque code appelle une fonction en utilisant la réflexion, et la fonction lève une exception.3) When code calls a function by using reflection, and the function throws an exception. Consultez réflexion.See Reflection.

Dans la condition 2 et 3, l’exception est quelquefois interceptée par le code managé dans mscorlib au lieu du common language runtime.In condition 2 and 3, the exception is sometimes caught by managed code in mscorlib instead of the common language runtime. Cette option n'a aucune incidence sur l'arrêt sur les exceptions interceptées par mscorlib.This option does not affect breaking on exceptions caught by mscorlib.

Activer le débogage au niveau des adresses Active les fonctionnalités avancées pour le débogage au niveau de l’adresse (la désassemblage fenêtre, le inscrit fenêtre et les points d’arrêt de l’adresse).Enable address-level debugging Enables advanced features for debugging at the address level (the Disassembly window, the Registers window, and address breakpoints).

  • Afficher le code machine si la source n’est pas disponible affiche automatiquement le désassemblage fenêtre lorsque vous tentez de déboguer du code pour lequel la source n’est pas disponible.Show disassembly if source is not available Automatically shows the Disassembly window when you try to debug code for which source is unavailable.

Activer les filtres de point d’arrêt vous permet de définir des filtres sur des points d’arrêt afin qu’ils affectent uniquement des processus, threads ou ordinateurs.Enable breakpoint filters Enables you to set filters on breakpoints so that they will affect only specific processes, threads, or computers.

La nouvelle assistance d’Exception permet à l’assistance d’Exception (Visual Studio 2017) qui remplace l’assistant exception.Use the new Exception Helper Enables the Exception Helper (Visual Studio 2017) that replaces the exception assistant.

Note

Pour le code managé, cette option s’appelait précédemment activer l’assistant exception .For managed code, this option was previously called Enable the exception assistant .

Activer uniquement mon Code le débogueur affiche et les étapes dans le code utilisateur (« mon Code ») uniquement, en ignorant le code système et tout autre code optimisé ou qui n’a pas de symboles de débogage.Enable Just My Code The debugger displays and steps into user code ("My Code") only, ignoring system code and other code that is optimized or that does not have debugging symbols.

  • Avertir si aucun code utilisateur au lancement (managé uniquement) au démarrage du débogage avec uniquement mon Code est activée, cette option vous avertit s’il n’existe aucun code utilisateur (« mon Code »).Warn if no user code on launch (Managed only) When debugging starts with Just My Code enabled, this option warns you if there is no user code ("My Code").

Activer .NET Framework pas à pas détaillé de la source permet au débogueur d’étape dans la source du .NET Framework.Enable .NET Framework source stepping Allows the debugger to step into .NET Framework source. L'activation de cette option désactive automatiquement Uniquement mon code. Les symboles .NET Framework sont téléchargés dans un emplacement du cache.Enabling this option automatically disables Just My Code .NET Framework symbols will be downloaded to a cache location. Vous pouvez modifier l’emplacement du cache dans le Options boîte de dialogue, débogage catégorie, symboles page.You can change the cache location in the Options dialog box, Debugging category, Symbols page.

Pas à pas principal des propriétés et les opérateurs (managé uniquement) empêche le débogueur d’exécution pas à pas détaillé des propriétés et des opérateurs en code managé.Step over properties and operators (Managed only) Prevents the debugger from stepping into properties and operators in managed code.

Activer l’évaluation de la propriété et d’autres appels de fonction implicite Active l’évaluation automatique de propriétés et de fonction implicite appels dans des fenêtres de variables et les Espion express boîte de dialogue.Enable property evaluation and other implicit function calls Turns on automatic evaluation of properties and implicit function calls in variables windows and the QuickWatch dialog box.

  • Appelez la fonction de conversion de chaînes sur des objets dans des fenêtres de variables (C# et JavaScript uniquement) exécute un appel de conversion de chaînes implicite lors de l’évaluation d’objets dans des fenêtres de variables.Call string conversion function on objects in variables windows (C# and JavaScript only) Executes an implicit string conversion call when evaluating objects in variables windows. Le résultat est affiché sous forme de chaîne au lieu du nom de type.The result is displayed as a string instead of the type name. S'applique uniquement lors du débogage en code C#.Only applies while debugging in C# code. Ce paramètre peut être substitué par l’attribut DebuggerDisplay (consultez à l’aide de l’attribut DebuggerDisplay).This setting may be overridden by the DebuggerDisplay attribute (see Using the DebuggerDisplay Attribute).

Activer le support du serveur source indique au débogueur Visual Studio pour obtenir des fichiers de code source à partir de serveurs sources qui implémentent le fichier SrcSrv (srcsrv.dll) protocole.Enable source server support Tells the Visual Studio debugger to get source files from source servers that implement the SrcSrv (srcsrv.dll) protocol. Team Foundation Server et les outils de débogage pour Windows sont deux serveurs sources qui implémentent le protocole.Team Foundation Server and the Debugging Tools for Windows are two source servers that implement the protocol. Pour plus d’informations sur l’installation de SrcSrv, consultez la SrcSrv documentation.For more information about SrcSrv setup, see the SrcSrv documentation. En outre, voir spécifier de symboles (.pdb) et les fichiers Source.In addition, see Specify Symbol (.pdb) and Source Files.

Important

Étant donné que la lecture de .pdb fichiers peut exécuter du code arbitraire dans les fichiers, assurez-vous que vous approuvez le serveur.Because reading .pdb files can execute arbitrary code in the files, make sure that you trust the server.

  • Afficher les messages de diagnostic du serveur source dans la fenêtre sortie lors de la prise en charge du serveur source est activée, ce paramètre Active l’affichage de diagnostic.Print source server diagnostic messages to the Output window When source server support is enabled, this setting turns on diagnostic display.

  • Autoriser le serveur source pour les assemblys de confiance partielle (managé uniquement) lors de la prise en charge du serveur source est activée, ce paramètre remplace le comportement par défaut de récupération des sources de ne pas pour les assemblys de confiance partielle.Allow source server for partial trust assemblies (Managed only) When source server support is enabled, this setting overrides the default behavior of not retrieving sources for partial trust assemblies.

Activer la prise en charge de la liaison de la Source indique au débogueur Visual Studio pour télécharger les fichiers source pour les fichiers .pdb qui contiennent des informations de liaison de la Source.Enable Source Link support Tells the Visual Studio debugger to download source files for .pdb files that contain Source Link information. Pour plus d’informations sur la Source de liaison, consultez la spécification de liaison de Source.For more information about Source Link, see the Source Link Specification.

> [!IMPORTANT]
>  Because Source Link will download files using http or https, make sure you trust the .pdb file.  

Mettez en surbrillance la ligne entière pour les points d’arrêt et l’instruction actuelle (C++ seulement) lorsque le débogueur met en surbrillance un point d’arrêt et l’instruction actuelle, il met en surbrillance la ligne entière.Highlight entire line for breakpoints and current statement (C++ only) When the debugger highlights a breakpoint or current statement, it highlights the entire line.

Nécessite des fichiers source à respecter exactement la version d’origine indique au débogueur de vérifier qu’un fichier source correspond à la version du code source utilisé pour générer le fichier exécutable que vous déboguez.Require source files to exactly match the original version Tells the debugger to verify that a source file matches the version of the source code used to build the executable you are debugging. Si la version ne correspond pas, vous allez être invité à rechercher une source correspondante.If the version does not match, you'll be prompted to find a matching source. Si aucune source correspondante n'est trouvée, le code source n'est pas affiché pendant le débogage.If a matching source is not found, the source code will not be displayed during debugging.

Rediriger tout le texte fenêtre Sortie vers la fenêtre exécution envoie tous les messages du débogueur qui seraient affichent normalement dans les sortie fenêtre à la immédiate fenêtre à la place.Redirect all Output window text to the Immediate window Sends all debugger messages that would ordinarily appear in the Output window to the Immediate window instead.

Afficher la structure brute des objets dans des fenêtres de variables désactive toutes les personnalisations d’affichage de structure objet.Show raw structure of objects in variables windows Turns off all object structure view customizations. Pour plus d’informations sur les personnalisations d’affichage, consultez créer des vues personnalisées des objets de .managed.For more information about view customizations, see Create custom views of .managed objects.

Supprimer l’optimisation JIT lors du chargement du module (managé uniquement) désactive l’optimisation JIT du code managé lorsqu’un module est chargé et que JIT est compilé pendant que le débogueur est attaché.Suppress JIT optimization on module load (Managed only) Disables the JIT optimization of managed code when a module is loaded and JIT is compiled while the debugger is attached. La désactivation de l'optimisation peut simplifier le débogage de certains problèmes, mais elle se fait au détriment des performances.Disabling optimization may make it easier to debug some problems, although at the expense of performance. Si vous utilisez Uniquement mon code, la suppression de l'optimisation JIT peut entraîner l'affichage du code non-utilisateur comme du code utilisateur (« Mon code »).If you are using Just My Code, suppressing JIT optimization can cause non-user code to appear as user code ("My Code"). Pour plus d’informations, consultez l’optimisation JIT et débogage.For more information, see JIT Optimization and Debugging.

Activer le débogage de JavaScript pour ASP.NET (Chrome et IE) permet au débogueur de script pour les applications ASP.NET.Enable JavaScript debugging for ASP.NET (Chrome and IE) Enables the script debugger for ASP.NET apps. À la première utilisation de Chrome, vous devrez peut-être vous connecter dans le navigateur lors de la première utilisation pour activer les extensions de Chrome que vous avez installée.On first use in Chrome, you may need to sign into the browser on first use to enable Chrome extensions that you have installed. Désactivez cette option pour rétablir le comportement hérité.Disable this option to revert to legacy behavior.

Charger les exportations de la dll charge les tables d’exportation de dll.Load dll exports Loads dll export tables. Les informations symboliques de tables d’exportation de dll peuvent être utiles si vous utilisez des messages Windows, des procédures Windows (WindowProcs), des objets COM, le marshaling ou toute dll pour laquelle vous n’avez pas de symbole.Symbol information from dll export tables can be useful if you are working with Windows messages, Windows procedures (WindowProcs), COM objects, or marshaling, or any dll for which you do not have symbols. La lecture des informations d’exportation des dll implique une certaine charge mémoire.Reading dll export information involves some overhead. Par conséquent, cette fonctionnalité est désactivée par défaut.Therefore, this capability is turned off by default.

Pour savoir quels symboles sont disponibles dans la table d’exportation d’une dll, utilisez dumpbin /exports.To see what symbols are available in the export table of a dll, use dumpbin /exports. Il existe des symboles pour toutes les dll système 32 bits.Symbols are available for any 32-bit system dll. En lisant le résultat de dumpbin /exports , vous apprenez le nom exact de la fonction, y compris les caractères non alphanumériques.By reading the dumpbin /exports output, you can see the exact function name, including non-alphanumeric characters. Cette information peut être utile pour définir un point d'arrêt sur une fonction.This is useful for setting a breakpoint on a function. Les noms de fonctions provenant de tables d’exportation de dll peuvent s’afficher sous une forme tronquée dans les autres parties du débogueur.Function names from dll export tables might appear truncated elsewhere in the debugger. Les appels sont répertoriés dans l'ordre chronologique inverse, la fonction en cours (la plus profondément imbriquée) apparaissant en tête de liste.The calls are listed in the calling order, with the current function (the most deeply nested) at the top. Pour plus d'informations, consultez dumpbin /exports.For more information, see dumpbin /exports.

Diagramme ascendant des piles parallèles de la Show contrôle la direction dans laquelle les piles sont affichées dans le piles parallèles fenêtre.Show parallel stacks diagram bottom-up Controls the direction in which stacks are displayed in the Parallel Stacks window.

Ignorer les exceptions d’accès mémoire GPU si les données écrites n’a pas modifié la valeur ignore les conditions de concurrence qui ont été détectées lors du débogage si les données n’ont pas changé.Ignore GPU memory access exceptions if the data written didn't change the value Ignores race conditions that were detected during debugging if the data didn't change. Pour plus d’informations, consultez débogage du Code GPU.For more information, see Debugging GPU Code.

Utiliser le Mode de compatibilité gérée remplace la valeur par défaut de moteur avec une version héritée pour activer ces scénarios de débogage :Use Managed Compatibility Mode Replaces the default debugging engine with a legacy version to enable these scenarios:

  • Vous utilisez un langage .NET Framework autre que C#, VB ou F# qui fournit son propre évaluateur d'expression (y compris C++/CLI).You are using a .NET Framework language other than C#, VB, or F# that provides its own Expression Evaluator (this includes C++/CLI).

  • Vous souhaitez activer Modifier & Continuer pour les projets C++ pendant le débogage en mode mixte.You want to enable Edit and Continue for C++ projects while mixed mode debugging.

Note

Choix de compatibilité de gestion mode désactive certaines fonctionnalités qui sont mises en œuvre uniquement dans le moteur de débogage par défaut.Choosing Managed Compatibility mode disables some features that are implemented only in the default debugging engine.

Utilisez les évaluateurs d’expression C# et VB hérités le débogueur utilisera les évaluateurs d’expression /VB valide de Visual Studio C# de 2013 au lieu des évaluateurs d’expression basée sur les Roslyn de 2015 de Visual Studio.Use the legacy C# and VB expression evaluators The debugger will use the Visual Studio 2013 C#/VB expression evaluators instead of the Visual Studio 2015 Roslyn-based expression evaluators.

Avertir en cas d’utilisation de visualiseurs de débogueur personnalisés avec des processus potentiellement unsafe (managé uniquement) Visual Studio vous avertit lorsque vous utilisez un visualiseur du débogueur personnalisé qui exécute le code dans le processus du programme débogué, car il peut être en cours d’exécution unsafe code.Warn when using custom debugger visualizers against potentially unsafe processes (Managed only) Visual Studio warns you when you are using a custom debugger visualizer that is running code in the debuggee process, because it could be running unsafe code.

Activer l’allocateur de tas de débogage Windows (natif uniquement) permet le tas de débogage windows améliorer les diagnostics de segment de mémoire.Enable Windows debug heap allocator (Native only) Enables the windows debug heap to improve heap diagnostics. L’activation de cette option affecte les performances de débogage.Enabling this option will impact debugging performance.

Activer les outils de débogage de l’interface utilisateur pour XAML le Live Visual Tree et les fenêtres d’Explorateur de propriétés en direct seront affiche lorsque vous démarrez le débogage (F5) un type de projet pris en charge.Enable UI Debugging Tools for XAML The Live Visual Tree and the Live Property Explore windows will appear when you start debugging (F5) a supported project type. Pour plus d’informations, consultez propriétés XAML inspecter pendant le débogage.For more information, see Inspect XAML properties while debugging.

  • Afficher un aperçu des éléments sélectionnés dans l’arborescence d’éléments visuels en direct élément le XAML dont le contexte est sélectionné est également sélectionné dans le Live Visual Tree fenêtre.Preview selected elements in Live Visual Tree The XAML element whose context is selected is also selected in the Live Visual Tree window.

  • Afficher les outils de runtime dans application montre le Live Visual Tree commandes dans une barre d’outils de la fenêtre principale de l’application XAML en cours de débogage.Show runtime tools in application Shows the Live Visual Tree commands in a toolbar on the main window of the XAML application that is being debugged. Cette option a été introduite dans Visual Studio 2015 Update 2.This option was introduced in Visual Studio 2015 Update 2.

  • Activer XAML modifier et continuer vous permet d’utiliser Modifier & Continuer la fonction pour le code XAML.Enable XAML Edit and Continue Allows you to use Edit and Continue feature for XAML code.

Activer les outils de Diagnostic pendant le débogage le outils de Diagnostic fenêtre s’affiche lorsque vous déboguez.Enable Diagnostic Tools while debugging The Diagnostic Tools window appears while you are debugging.

Afficher le PerfTip du temps écoulé durant le débogage la fenêtre de code affiche le temps écoulé d’un appel de méthode donné lors du débogage.Show elapsed time PerfTip while debugging The code window displays the elapsed time of a given method call when you are debugging.

Activer Modifier & Continuer vous pouvez utiliser le modifier et continuer de fonctionnalité lors du débogage.Enable Edit and Continue You can use the Edit and Continue functionality while debugging.

  • Activer Modifier et continuer natif vous pouvez utiliser le modifier et continuer de fonctionnalité lors du débogage du code C++ natif.Enable Native Edit and Continue You can use the Edit and Continue functionality while debugging native C++ code. Pour plus d’informations, consultez Modifier & Continuer (Visual C++).For more information, see Edit and Continue (Visual C++).

  • Appliquer les changements en continuant (natif uniquement) Visual Studio compile automatiquement et applique les modifications de code en attente apportées lors de la poursuite du processus à partir d’un état d’arrêt.Apply changes on continue (Native only) Visual Studio automatically compiles and applies any outstanding code changes you have made when continuing the process from a break state. Si ne pas sélectionnée, vous pouvez choisir d’appliquer les modifications à l’aide de l’élément « Appliquer les modifications du Code » dans le menu Déboguer.If not selected, you can choose to apply changes using the "Apply Code Changes" item under the Debug menu.

  • Signaler le code périmé (natif uniquement) obtenir des avertissements concernant le code périmé.Warn about stale code (Native only) Get warnings about stale code.

Afficher et cliquez sur dans l’éditeur de débogage afin de lorsque cette option est sélectionnée, le exécuter jusqu’au clic bouton s’affichera lors du débogage.Show run to click button in editor while debugging When this option is selected, the Run to Click button will be shown while debugging.

Options prises en charge dans les versions antérieures de Visual StudioOptions supported in older versions of Visual Studio

Si vous utilisez une version antérieure de Visual Studio, des options supplémentaires peuvent être présentes.If you are using an older version of Visual Studio, some additional options might be present.

Activer l’assistant exception pour le code managé, activé l’assistant exception.Enable the exception assistant For managed code, enabled the exception assistant. Dans Visual Studio 2017, l’assistance d’Exception remplacé l’assistant exception.In Visual Studio 2017, the Exception Helper replaced the exception assistant.

Dérouler la pile des appels sur les exceptions non gérées provoque la pile des appels fenêtre restaure la pile des appels au point qui précède l’exception non gérée s’est produite.Unwind the call stack on unhandled exceptions Causes the Call Stack window to roll back the call stack to the point before the unhandled exception occurred.

Avertir si aucun symbole au lancement (natif uniquement) affiche une boîte de dialogue d’avertissement lorsque vous essayez de déboguer un programme pour lequel le débogueur ne possède aucune information de symbole.Warn if no symbols on launch (native only) Displays a warning dialog box when you try to debug a program for which the debugger has no symbol information.

Avertir si le débogage de script est désactivé au lancement affiche une boîte de dialogue d’avertissement lorsque le débogueur est lancé avec le débogage de script est désactivé.Warn if script debugging is disabled on launch Displays a warning dialog box when the debugger is launched with script debugging disabled.

Utilisez le Mode de compatibilité natif lorsque cette option est sélectionnée, le débogueur utilise le débogueur natif Visual Studio 2010 au lieu du nouveau débogueur natif.Use Native Compatibility Mode When this option is selected, the debugger uses the Visual Studio 2010 native debugger instead of the new native debugger.

Vous devez utiliser cette option quand vous déboguez le code .NET C++, car le nouveau moteur de débogage ne prend pas en charge l’évaluation des expressions .NET C++.You should use this option when you are debugging .NET C++ code, because the new debugging engine does not support evaluating .NET C++ expressions. Toutefois, l’activation du mode de compatibilité natif désactive de nombreuses fonctionnalités qui dépendent de l’implémentation du débogueur actuel pour fonctionner.However, enabling Native Compatibility Mode disables many features that depend on the current debugger implementation to operate. Par exemple, le moteur hérité ne dispose pas de nombreux visualiseurs pour les types intégrés tels que std::string dans les projets Visual Studio 2015.For example, the legacy engine lacks many visualizers for built-in types like std::string in Visual Studio 2015 projects. Utiliser des projets Visual Studio 2013 pour l’expérience de débogage optimale dans ces cas.Use Visual Studio 2013 projects for the optimal debugging experience in these cases.

Voir aussiSee also

Débogage dans Visual StudioDebugging in Visual Studio
Visite guidée des fonctionnalités du débogueurDebugger Feature Tour