Spécifiez les fichiers de symbole (.pdb) et les fichiers source dans le débogueur Visual Studio.Specify symbol (.pdb) and source files in the Visual Studio debugger

Base de données de programme (.pdb) fichiers, également appelés fichiers de symboles, mappent des identificateurs et des instructions dans le code source de votre projet pour les identificateurs correspondants dans compilé des applications.Program database (.pdb) files, also called symbol files, map identifiers and statements in your project's source code to corresponding identifiers and instructions in compiled apps.

Lorsque vous générez un projet à partir de l’IDE de Visual Studio avec la norme de configuration de build de débogage, le compilateur crée les fichiers de symboles appropriés.When you build a project from the Visual Studio IDE with the standard Debug build configuration, the compiler creates the appropriate symbol files. Vous pouvez également définir les options de symbole dans le code.You can also set symbol options in code.

Le .pdb fichier conserve des informations d’état de débogage et de projet qui permet la liaison incrémentielle d’une configuration Debug de votre application.The .pdb file holds debugging and project state information that allows incremental linking of a Debug configuration of your app. Le débogueur Visual Studio utilise .pdb fichiers afin de déterminer les deux éléments clés d’informations pendant le débogage :The Visual Studio debugger uses .pdb files to determine two key pieces of information while debugging:

  • La source fichier nom et numéro de ligne à afficher dans l’IDE Visual Studio.The source file name and line number to display in the Visual Studio IDE.
  • Emplacement dans l’application pour s’arrêter pour un point d’arrêt.Where in the app to stop for a breakpoint.

Fichiers de symboles indiquent également l’emplacement des fichiers sources et éventuellement, le serveur pour les récupérer à partir de.Symbol files also show the location of the source files, and optionally, the server to retrieve them from.

Le débogueur charge uniquement .pdb les fichiers qui correspondent exactement à la .pdb fichiers créés quand une application a été générée (autrement dit, la version d’origine .pdb fichiers ou des copies).The debugger only loads .pdb files that exactly match the .pdb files created when an app was built (that is, the original .pdb files or copies). Cette duplication exacte est nécessaire, car la disposition des applications peut changer même si le code lui-même n’a pas changé.This exact duplication is necessary because the layout of apps can change even if the code itself has not changed. Pour plus d’informations, consultez pourquoi Visual Studio requièrent des symboles de débogueur fichiers doivent correspondre exactement aux fichiers binaires qui elles ont été générées avec ?For more information, see Why does Visual Studio require debugger symbol files to exactly match the binary files that they were built with?

Tip

Pour déboguer le code en dehors de votre code source du projet, telles que le code de Windows ou tiers appelé par votre projet de code, vous devez spécifier l’emplacement du code externe .pdb fichiers (et éventuellement, les fichiers sources), qui doit correspondre exactement à les builds dans votre application.To debug code outside your project source code, such as Windows code or third-party code your project calls, you must specify the location of the external code's .pdb files (and optionally, the source files), which must exactly match the builds in your app.

Emplacements des fichiers de symboles et le comportement de chargementSymbol file locations and loading behavior

Note

Lorsque vous déboguez du code managé sur un périphérique distant, tous les fichiers de symboles doivent être situés sur l’ordinateur local ou dans un emplacement spécifié dans les options du débogueur.When debugging managed code on a remote device, all symbol files must be located either on the local machine, or in a location specified in the debugger options.

Lorsque vous déboguez un projet dans l’IDE Visual Studio, le débogueur charge automatiquement les fichiers de symboles qui sont trouvent dans le dossier du projet.When you debug a project in the Visual Studio IDE, the debugger automatically loads symbol files that are located in the project folder.

Le débogueur recherche également les fichiers de symboles dans les emplacements suivants :The debugger also searches for symbol files in the following locations:

  1. L’emplacement spécifié à l’intérieur de la DLL ou le fichier exécutable (.exe) fichier.The location that is specified inside the DLL or the executable (.exe) file.

    Par défaut, si vous avez créé une DLL ou un .exe fichier sur votre ordinateur, l’éditeur de liens place le chemin d’accès complet et le nom de fichier associé .pdb fichier dans la DLL ou .exe fichier.By default, if you have built a DLL or an .exe file on your computer, the linker places the full path and filename of the associated .pdb file in the DLL or .exe file. Le débogueur vérifie si le fichier de symboles existe à cet emplacement.The debugger checks to see if the symbol file exists in that location.

  2. Le même dossier que la DLL ou .exe fichier.The same folder as the DLL or .exe file.

  3. Tous les emplacements spécifiés dans les options du débogueur pour les fichiers de symboles.Any locations specified in the debugger options for symbol files. Pour ajouter et activer des emplacements de symboles, consultez configurer des emplacements de symboles et options de chargement.To add and enable symbol locations, see Configure symbol locations and loading options.

    • N’importe quel dossier de cache de symboles local.Any local symbol cache folder.

    • Réseau spécifié, internet, ou les serveurs de symboles local et emplacements, tels que les serveurs de symboles Microsoft si sélectionné.Specified network, internet, or local symbol servers and locations, such as the Microsoft Symbol Servers if selected. Visual StudioVisual Studio peut télécharger des fichiers de symboles de débogage à partir de serveurs de symboles qui implémentent le symsrv protocole. can download debugging symbol files from symbol servers that implement the symsrv protocol. Visual Studio Team Foundation Server et outils de débogage pour Windows sont deux outils qui peuvent utiliser des serveurs de symboles.Visual Studio Team Foundation Server and the Debugging Tools for Windows are two tools that can use symbol servers.

      Vous pouvez utiliser des serveurs de symboles sont les suivantes :Symbol servers you might use include:

      Serveurs de symboles publics Microsoft: pour déboguer un incident qui se produit lors d’un appel à une DLL système ou à une bibliothèque tierce, vous devez souvent système .pdb fichiers.Public Microsoft Symbol Servers: To debug a crash that occurs during a call to a system DLL or to a third-party library, you often need system .pdb files. Système .pdb fichiers contiennent les symboles pour les DLL de Windows, .exe fichiers et pilotes de périphérique.System .pdb files contain symbols for Windows DLLs, .exe files, and device drivers. Vous pouvez obtenir les symboles pour les systèmes d’exploitation Windows, MDAC, IIS, ISA et le .NET Framework.NET Framework à partir de serveurs de symboles publics de Microsoft.You can get symbols for Windows operating systems, MDAC, IIS, ISA, and the .NET Framework.NET Framework from the public Microsoft Symbol Servers.

      Sur un réseau interne ou sur votre ordinateur local de serveurs de symboles: votre équipe ou votre entreprise peut créer des serveurs de symboles de vos propres produits et en tant que cache de symboles provenant de sources externes.Symbol servers on an internal network or on your local machine: Your team or company can create symbol servers for your own products, and as a cache for symbols from external sources. Vous pouvez avoir un serveur de symboles sur votre propre ordinateur.You might have a symbol server on your own machine.

      Serveurs de symboles tiers: les fournisseurs tiers de bibliothèques et des applications de Windows permettent d’accéder au serveur de symboles sur internet.Third-party symbol servers: Third-party providers of Windows applications and libraries can provide access to symbol server on the internet.

      Warning

      Si vous utilisez un serveur de symboles autres que les serveurs de symboles publics Microsoft, assurez-vous que le serveur de symboles et son chemin d’accès sont dignes de confiance.If you use a symbol server other than the public Microsoft Symbol Servers, make sure that the symbol server and its path are trustworthy. Étant donné que les fichiers de symboles peuvent contenir du code exécutable arbitraire, vous pouvez être exposées aux menaces de sécurité.Because symbol files can contain arbitrary executable code, you can be exposed to security threats.

Configurer des emplacements de symboles et les options de chargementConfigure symbol locations and loading options

Sur le outils > Options > débogage > symboles page, vous pouvez :On the Tools > Options > Debugging > Symbols page, you can:

  • Spécifier et sélectionnez des chemins de recherche et serveurs de symboles pour Microsoft, Windows ou composants tiers.Specify and select search paths and symbol servers for Microsoft, Windows, or third-party components.
  • Spécifier les modules que vous n’ou que vous ne souhaitez pas que le débogueur charge automatiquement des symboles.Specify modules that you do or don't want the debugger to automatically load symbols for.
  • Modifier ces paramètres lorsque vous déboguez activement.Change these settings while you are actively debugging. Consultez gérer les symboles lors du débogage.See Manage symbols while debugging.

Pour spécifier des emplacements de symboles et les options de chargement :To specify symbol locations and loading options:

  1. Dans Visual Studio, ouvrez outils > Options > débogage > symboles (ou Déboguer > Options > symboles).In Visual Studio, open Tools > Options > Debugging > Symbols (or Debug > Options > Symbols).

    Outils - Options - débogage - page symbolesTools - Options - Debugging - Symbols page

  2. Sous emplacements du fichier (.pdb) de symboles,Under Symbol file (.pdb) locations,

    • Pour utiliser le serveurs de symboles Microsoft, activez la case à cocher.To use the Microsoft Symbol Servers, select the checkbox.

    • Pour ajouter un nouvel emplacement du serveur de symbole,To add a new symbol server location,

      1. Sélectionnez le + symbole dans la barre d’outils.Select the + symbol in the toolbar.
      2. Dans le champ de texte, tapez le chemin d’accès URL ou un dossier du serveur de symboles ou du magasin de symboles.Type the URL or folder path of the symbol server or symbol location in the text field. La saisie semi-automatique des instructions vous aide à rechercher le format correct.Statement completion helps you find the correct format.

      Note

      Uniquement dans le dossier spécifié est recherché.Only the specified folder is searched. Vous devez ajouter des entrées pour tous les sous-dossiers que vous souhaitez rechercher.You must add entries for any subfolders that you want to search.

    • Pour ajouter un nouvel emplacement de serveur de symboles VSTSTo add a new VSTS Symbol Server location,

      1. Sélectionnez le outils/ Options/ débogage/icône du nouveau serveur de symboles icône dans la barre d’outils.Select the Tools/ Options/ Debugging/Symbols new server icon icon in the toolbar.
      2. Dans le se connecter au serveur de symboles VSTS boîte de dialogue, choisissez un des serveurs de symboles disponibles, puis sélectionnez Connect.In the Connect to VSTS Symbol Server dialog, choose one of the available symbol servers, and select Connect.
    • Pour modifier l’ordre de chargement pour les emplacements de symboles, utilisez Ctrl+des et Ctrl+vers le bas, ou le des et vers le bas icônes fléchées.To change the loading order for the symbol locations, use Ctrl+Up and Ctrl+Down, or the Up and Down arrow icons.

    • Pour modifier une URL ou un chemin d’accès, double-cliquez sur l’entrée, ou sélectionnez-le et appuyez sur F2.To edit a URL or path, double-click the entry, or select it and press F2.
    • Pour supprimer une entrée, sélectionnez-la, puis sélectionnez le - icône.To remove an entry, select it, and then select the - icon.
  3. (Facultatif) Pour améliorer les performances de chargement de symboles, sous mettre en Cache les symboles dans ce répertoire, un chemin d’accès du dossier local qui peuvent copier des serveurs de symboles pour les symboles de type.(Optional) To improve symbol loading performance, under Cache symbols in this directory, type a local folder path that symbol servers can copy symbols to.

    Note

    Ne placez pas le cache de symboles local dans un dossier protégé, tel que C:\Windows ou un sous-dossier.Do not place the local symbol cache in a protected folder, like C:\Windows or a subfolder. Utilisez plutôt un dossier en lecture-écriture.Use a read-write folder instead.

    Note

    Pour les projets C++, si vous avez le _NT_SYMBOL_PATH set variable d’environnement, il remplace la valeur définie sous mettre en Cache les symboles dans ce répertoire.For C++ projects, if you have the _NT_SYMBOL_PATH environment variable set, it will override the value set under Cache symbols in this directory.

  4. Spécifiez les modules que vous souhaitez que le débogueur à charger à partir de la emplacements du fichier (.pdb) de symboles lorsqu’il démarre.Specify the modules that you want the debugger to load from the Symbol file (.pdb) locations when it starts.

    • Sélectionnez charger tous les modules, sauf exclus (la valeur par défaut) pour charger tous les symboles pour tous les modules dans l’emplacement du fichier de symboles, à l’exception des modules que vous excluez spécifiquement.Select Load all modules, unless excluded (the default) to load all the symbols for all modules in the symbol file location, except modules you specifically exclude. Pour exclure certains modules, sélectionnez spécifier les modules exclus, sélectionnez le + icône, tapez les noms des modules à exclure, puis sélectionnez OK.To exclude certain modules, select Specify excluded modules, select the + icon, type the names of the modules to exclude, and select OK.

    • Pour charger uniquement les modules que vous spécifiez à partir des emplacements de fichier de symboles, sélectionnez charge les modules spécifiés uniquement.To load only modules you specify from the symbol file locations, select Load only specified modules. Sélectionnez spécifier les modules inclus, sélectionnez le + icône, tapez les noms des modules à inclure, puis sélectionnez OK.Select Specify included modules, select the + icon, type the names of the modules to include, and then select OK. Les fichiers de symboles pour les autres modules ne sont pas chargés.The symbol files for other modules are not loaded.

  5. Sélectionnez OK.Select OK.

Autres options de symbole de débogageOther symbol options for debugging

Vous pouvez sélectionner les options de symbole supplémentaires dans outils > Options > débogage > général (ou déboguer > Options > général) :You can select additional symbol options in Tools > Options > Debugging > General (or Debug > Options > General):

  • Charger les exportations de DLL (natif uniquement)Load dll exports (Native only)

    Tables d’exportation de DLL des charges pour C/C++.Loads DLL export tables for C/C++. Pour plus d’informations, consultez tables d’exportation de DLL.For details, see DLL export tables. Informations d’exportation de DLL de lecture implique une surcharge, donc le chargement des tables d’exportation est désactivé par défaut.Reading DLL export information involves some overhead, so loading export tables is turned off by default. Vous pouvez également utiliser dumpbin /exports dans une ligne de commande de génération C/C++.You can also use dumpbin /exports in a C/C++ build command line.

  • Activer le débogage au niveau de l’adresse et afficher le code machine si la source non disponibleEnable address level debugging and Show disassembly if source not available

    Affiche toujours le code machine lorsque les fichiers sources ou de symboles sont introuvables.Always shows the disassembly when source or symbol files are not found.

    Options / débogage / général code machine optionsOptions / Debugging  / General disassembly options

  • Activer la prise en charge du serveur sourceEnable source server support

    Utilise le serveur Source pour aider à déboguer une application lorsqu’il n’existe pas de code source sur l’ordinateur local, ou le .pdb fichier ne correspond pas à du code source.Uses Source Server to help debug an app when there is no source code on the local machine, or the .pdb file does not match the source code. Serveur source prend les demandes de fichiers et retourne les fichiers réels à partir du contrôle de code source.Source Server takes requests for files and returns the actual files from source control. Serveur source s’exécute à l’aide d’une DLL nommée srcsrv.dll pour lire l’application .pdb fichier.Source Server runs by using a DLL named srcsrv.dll to read the app's .pdb file. Le .pdb fichier contient des pointeurs vers le référentiel de code source, ainsi que les commandes utilisées pour extraire le code source à partir du référentiel.The .pdb file contains pointers to the source code repository, as well as commands used to retrieve source code from the repository.

    Vous pouvez limiter les commandes qui srcsrv.dll peuvent exécuter à partir de l’application .pdb fichier en répertoriant les commandes autorisées dans un fichier nommé srcsrv.ini.You can limit the commands that srcsrv.dll can execute from the app's .pdb file by listing the allowed commands in a file named srcsrv.ini. Place le srcsrv.ini fichier dans le même dossier que srcsrv.dll et devenv.exe.Place the srcsrv.ini file in the same folder as srcsrv.dll and devenv.exe.

    Important

    Des commandes arbitraires peuvent être incorporées dans une application .pdb de fichiers, veillez à placer uniquement les commandes que vous souhaitez exécuter dans un srcsrv.ini fichier.Arbitrary commands can be embedded in an app's .pdb file, so make sure to put only the commands you want to execute into a srcsrv.ini file. Toute tentative d’exécuter une commande pas dans le srcsvr.ini fichier entraîne une zone de boîte de dialogue de confirmation s’affiche.Any attempt to execute a command not in the srcsvr.ini file will cause a confirmation dialog box to appear. Pour plus d'informations, consultez Security Warning: Debugger Must Execute Untrusted Command.For more information, see Security Warning: Debugger Must Execute Untrusted Command.

    Aucune validation n’est effectuée sur les paramètres de commande, soyez donc prudent avec les commandes de confiance.No validation is done on command parameters, so be careful with trusted commands. Par exemple, si vous avez mis cmd.exe dans votre srcsrv.ini, un utilisateur malveillant peut spécifier des paramètres sur cmd.exe qui rendrait dangereux.For example, if you listed cmd.exe in your srcsrv.ini, a malicious user might specify parameters on cmd.exe that would make it dangerous.

    Sélectionnez cet élément et les éléments enfants souhaités.Select this item and the child items you want. Autoriser le serveur source pour les assemblys de confiance partielle (managé uniquement) et toujours exécuter les commandes du serveur source non fiables sans demander confirmation peuvent augmenter les risques de sécurité.Allow source server for partial trust assemblies (Managed only) and Always run untrusted source server commands without prompting can increase the security risks.

    Activer les options du serveur sourceEnable source server options

Options de symbole du compilateurCompiler symbol options

Quand vous générez un projet à partir de l’IDE de Visual Studio avec la norme déboguer configuration de build, C++ et les compilateurs managés créent les fichiers de symboles appropriés pour votre code.When you build a project from the Visual Studio IDE with the standard Debug build configuration, the C++ and managed compilers create the appropriate symbol files for your code. Vous pouvez également définir des options du compilateur dans le code.You can also set compiler options in code.

Options C/C++C/C++ options

  • VC<x > .pdb et <projet > .pdb fichiersVC<x>.pdb and <project>.pdb files

    Un .pdb de fichier pour C/C++ est créé quand vous générez avec /ZI ou /Zi.A .pdb file for C/C++ is created when you build with /ZI or /Zi. Dans Visual C++Visual C++, le /Fd option noms le .pdb le compilateur crée des fichiers.In Visual C++Visual C++, the /Fd option names the .pdb file the compiler creates. Lorsque vous créez un projet dans Visual StudioVisual Studio à l’aide de l’IDE, le /Fd option est définie pour créer un .pdb fichier nommé <projet > .pdb.When you create a project in Visual StudioVisual Studio using the IDE, the /Fd option is set to create a .pdb file named <project>.pdb.

    Si vous générez votre application C/C++ à l’aide d’un makefile, et que vous spécifiez /Zi ou /Zi sans utiliser /Fd, le compilateur crée deux .pdbfichiers :If you build your C/C++ application using a makefile, and you specify /ZI or /Zi without using /Fd, the compiler creates two .pdb files:

    • VC<x > .pdb, où <x > représente la version de Visual C++, par exemple VC11.pdbVC<x>.pdb, where <x> represents the version of Visual C++, for example VC11.pdb

      Le VC<x > .pdb fichier stocke toutes les informations de débogage pour les fichiers objets individuels et réside dans le même répertoire que le makefile du projet.The VC<x>.pdb file stores all debugging information for the individual object files, and resides in the same directory as the project makefile. Chaque fois qu’il crée un fichier objet, le compilateur C/C++ fusionne les informations de débogage dans VC<x > .pdb.Each time it creates an object file, the C/C++ compiler merges debug information into VC<x>.pdb. Par conséquent, même si chaque fichier source inclut des fichiers d’en-tête courants tels que <windows.h >, les typedefs de ces en-têtes sont stockés qu’une seule fois, plutôt que dans chaque fichier objet.So even if every source file includes common header files such as <windows.h>, the typedefs from those headers are stored only once, rather than in every object file. Les informations insérées inclut des informations de type, mais n’incluent pas les informations de symboles, tels que des définitions de fonction.The inserted information includes type information, but does not include symbol information, such as function definitions.

    • <projet > .pdb<project>.pdb

      Le <projet > .pdb fichier stocke toutes les informations de débogage pour le projet .exe de fichiers et se trouve dans le \debug sous-répertoire.The <project>.pdb file stores all debug information for the project's .exe file, and resides in the \debug subdirectory. Le <projet > .pdb fichier contient des informations de débogage complètes, y compris les prototypes de fonction, pas seulement les informations de type trouvent dans VC<x > .pdb.The <project>.pdb file contains full debug information, including function prototypes, not just the type information found in VC<x>.pdb.

    Les deux le VC<x > .pdb et <projet > .pdb fichiers autorisent les mises à jour incrémentielles.Both the VC<x>.pdb and <project>.pdb files allow incremental updates. L’éditeur de liens incorpore également le chemin d’accès à la .pdb des fichiers dans le .exe ou .dll fichier qu’il crée.The linker also embeds the path to the .pdb files in the .exe or .dll file that it creates.

  • Tables d’exportation de DLLDLL export tables

    Utilisez dumpbin /exports pour afficher les symboles disponibles dans la table d’exportation d’une DLL.Use dumpbin /exports to see the symbols available in the export table of a DLL. Informations symboliques de tables d’exportation de DLL peuvent être utiles pour travailler avec les messages Windows, des procédures Windows (WindowProcs), COM des objets, marshaling ou toute DLL que vous n’avez pas les symboles pour.Symbolic information from DLL export tables can be useful for working with Windows messages, Windows procedures (WindowProcs), COM objects, marshaling, or any DLL you don't have symbols for. Il existe des symboles pour toutes les DLL système 32 bits.Symbols are available for any 32-bit system DLL. Les appels sont répertoriés dans l'ordre chronologique inverse, la fonction en cours (la plus profondément imbriquée) apparaissant en tête de liste.The calls are listed in the calling order, with the current function (the most deeply nested) at the top.

    En lisant le dumpbin /exports de sortie, vous pouvez voir les noms de fonction exact, y compris les caractères non alphanumériques.By reading the dumpbin /exports output, you can see the exact function names, including non-alphanumeric characters. Voir les noms de fonction exact est utile pour définir un point d’arrêt sur une fonction, étant donné que les noms de fonction peuvent être tronqués ailleurs dans le débogueur.Seeing exact function names is useful for setting a breakpoint on a function, because function names can be truncated elsewhere in the debugger. Pour plus d'informations, consultez dumpbin /exports.For more information, see dumpbin /exports.

Options du .NET Framework.NET Framework options

Générer avec /debug pour créer un .pdb fichier.Build with /debug to create a .pdb file. Vous pouvez générer des applications avec /debug:full ou /debug:pdbonly.You can build applications with /debug:full or /debug:pdbonly. La génération avec /debug:full génère du code pouvant être débogué.Building with /debug:full generates debuggable code. Génération avec pdbonly génère .pdb des fichiers, mais ne génère pas le DebuggableAttribute indiquant au compilateur JIT que des informations de débogage sont disponibles.Building with /debug:pdbonly generates .pdb files, but does not generate the DebuggableAttribute that tells the JIT compiler that debug information is available. Utilisez pdbonly si vous souhaitez générer .pdb fichiers pour une version de génération que vous ne souhaitez pas être déboguée.Use /debug:pdbonly if you want to generate .pdb files for a release build that you do not want to be debuggable. Pour plus d’informations, consultez /Debug (options du compilateur C#) ou /debug (Visual Basic).For more information, see /debug (C# compiler options) or /debug (Visual Basic).

Applications WebWeb applications

Définir le web.config fichier de votre application ASP.NET en mode débogage.Set the web.config file of your ASP.NET application to debug mode. En mode débogage, ASP.NET génère des symboles pour les fichiers générés dynamiquement et le débogueur peut être attaché à l'application ASP.NET.Debug mode causes ASP.NET to generate symbols for dynamically generated files and enables the debugger to attach to the ASP.NET application. Visual Studio définit cela automatiquement lorsque vous commencez le débogage, si vous avez créé votre projet à partir du modèle de projets web.Visual Studio sets this automatically when you start to debug, if you created your project from the web projects template.

Gérer les symboles lors du débogageManage symbols while debugging

Vous pouvez utiliser la Modules, pile des appels, variables locales, automatique, ou n’importe quel espion fenêtre à charger symboles ou modifier les options de symbole lors du débogage.You can use the Modules, Call Stack, Locals, Autos, or any Watch window to load symbols or change symbol options while debugging. Pour plus d’informations, consultez vous familiariser avec la façon dont le débogueur s’attache à votre application.For more information, see Get more familiar with how the debugger attaches to your app.

Utiliser la fenêtre ModulesUse the Modules window

Pendant le débogage, le Modules fenêtre affiche les modules de code que le débogueur est en traitant comme code de l’utilisateur, ou mon Code et leur état le chargement des symboles.During debugging, the Modules window shows the code modules the debugger is treating as user code, or My Code, and their symbol loading status. Vous pouvez également surveiller l’état de chargement de symboles, charger des symboles et modifier les options de symbole dans le Modules fenêtre.You can also monitor symbol loading status, load symbols, and change symbol options in the Modules window.

Pour surveiller ou modifier des options ou des emplacements de symboles lors du débogage :To monitor or change symbol locations or options while debugging:

  1. Pour ouvrir le Modules fenêtre, pendant le débogage, sélectionnez déboguer > Windows > Modules.To open the Modules window, while debugging, select Debug > Windows > Modules.
  2. Dans le Modules fenêtre, avec le bouton droit le état du symbole ou fichier de symboles en-têtes ou n’importe quel module.In the Modules window, right-click the Symbol Status or Symbol File headers, or any module.
  3. Dans le menu contextuel, sélectionnez une des options suivantes :In the context menu, select one of the following options:
OptionOption DescriptionDescription
Charger les symbolesLoad Symbols S’affiche pour les modules avec des symboles ignorés, introuvables ou non chargés.Appears for modules with skipped, not found, or not loaded symbols. Tente de charger les symboles d’emplacements spécifiés sur le Options > débogage > symboles page.Attempts to load symbols from locations specified on the Options > Debugging > Symbols page. Si le fichier de symboles est introuvable ou n’a pas chargé, lance Explorateur de fichiers afin de pouvoir spécifier un nouvel emplacement de recherche.If the symbol file is not found or not loaded, launches File Explorer so you can specify a new location to search.
Informations sur le chargement de symbolesSymbol Load Information Indique l’emplacement d’un fichier de symboles chargé, ou les emplacements de recherche si le débogueur ne peut pas trouver le fichier.Shows the location of a loaded symbol file, or the locations that were searched if the debugger cannot find the file.
Paramètres des symbolesSymbol Settings Ouvre le Options > débogage > symboles page, où vous pouvez modifier et ajouter des emplacements de symboles.Opens the Options > Debugging > Symbols page, where you can edit and add symbol locations.
Toujours charger automatiquementAlways Load Automatically Ajoute le fichier de symboles sélectionnés à la liste des fichiers qui sont chargés automatiquement par le débogueur.Adds the selected symbol file to the list of files that are automatically loaded by the debugger.

Utilisez les pages aucune symboles Loaded/No Source a été chargéeUse the No Symbols Loaded/No Source Loaded pages

Il existe plusieurs façons pour le débogueur s’arrête dans du code qui n’a pas de fichiers sources ou de symboles disponibles :There are several ways for the debugger to break into code that does not have symbol or source files available:

  • Pas à pas détaillé de code.Step into code.
  • Arrêter dans le code à partir d’un point d’arrêt ou une exception.Break into code from a breakpoint or exception.
  • Basculer vers un autre thread.Switch to a different thread.
  • Modifier le frame de pile en double-cliquant sur un frame dans la pile des appels fenêtre.Change the stack frame by double-clicking a frame in the Call Stack window.

Dans ce cas, le débogueur affiche le chargé des symboles non ou aucune Source a été chargée pages pour vous aider à trouver et charger les symboles nécessaires ou la source.When this happens, the debugger displays the No Symbols Loaded or No Source Loaded pages to help you find and load the necessary symbols or source.

Aucune page symboles chargésNo Symbols Loaded page

Pour utiliser la page de document aucun symbole chargé pour aider à trouver et charger des symboles manquants :To use the No Symbols Loaded document page to help find and load missing symbols:

  • Pour modifier le chemin de recherche, sélectionnez un chemin d’accès non sélectionné, ou nouveau chemin d’accès ou nouveau chemin VSTS et entrez ou sélectionnez un nouveau chemin d’accès.To change the search path, select an unselected path, or select New Path or New VSTS Path and enter or select a new path. Sélectionnez charger pour effectuer une nouvelle recherche les chemins d’accès et de charger le fichier de symboles s’il est trouvé.Select Load to search the paths again and load the symbol file if it is found.
  • Pour remplacer les options de symbole et réessayer les chemins de recherche, sélectionnez Parcourir et rechercher <exécutable-name >.To override any symbol options and retry the search paths, select Browse and find <executable-name>. Le fichier de symboles est chargé s’il est trouvé, ou Explorateur de fichiers s’ouvre pour vous pouvez de sélectionner manuellement le fichier de symboles.The symbol file is loaded if it is found, or File Explorer opens so you can manually select the symbol file.
  • Pour ouvrir le Options > débogage > symboles page, sélectionnez modifier les paramètres de symbole.To open the Options > Debugging > Symbols page, select Change Symbol Settings.
  • Pour afficher le code machine dans une nouvelle fenêtre une fois, sélectionnez afficher le code machine, ou sélectionnez boîte de dialogue Options pour définir l’option pour toujours afficher le code machine lorsque les fichiers sources ou de symboles sont introuvables.To show the disassembly in a new window one time, select view disassembly, or select Options dialog to set the option to always show the disassembly when source or symbol files are not found.
  • Pour afficher les emplacements de recherche et le résultat, développez les informations de chargement de symboles.To show the locations searched and the outcome, expand Symbol load information.

Si le débogueur recherche le .pdb fichier une fois que vous exécutez une des options et pouvez extraire le fichier source en utilisant les informations dans le .pdb fichier, il affiche la source.If the debugger finds the .pdb file after you execute one of the options, and can retrieve the source file using the information in the .pdb file, it displays the source. Sinon, elle affiche un aucune Source a été chargée page qui décrit le problème, avec des liens vers les actions susceptibles de résoudre le problème.Otherwise, it displays a No Source Loaded page that describes the issue, with links to actions that might resolve the issue.

Pour ajouter des chemins de recherche du fichier source à une solution :To add source file search paths to a solution:

Vous pouvez spécifier les emplacements que le débogueur recherche les fichiers source et exclure des fichiers spécifiques de la recherche.You can specify the locations the debugger searches for source files, and exclude specific files from the search.

  1. Sélectionnez la solution dans l’Explorateur de solutions, puis sélectionnez le propriétés icône, appuyez sur Alt+entrée, ou avec le bouton droit et sélectionnez propriétés.Select the solution in Solution Explorer, and then select the Properties icon, press Alt+Enter, or right-click and select Properties.

  2. Sélectionnez déboguer les fichiers sources.Select Debug Source Files.

  3. Sous répertoires contenant du code source, tapez ou sélectionnez les emplacements de code source à rechercher.Under Directories containing source code, type or select source code locations to search. Utilisez le nouvelle ligne icône pour ajouter d’autres emplacements, le des et vers le bas icônes fléchées pour les réorganiser, ou le X icône pour les supprimer.Use the New Line icon to add more locations, the Up and Down arrow icons to reorder them, or the X icon to delete them.

    Note

    Le débogueur recherche uniquement dans le répertoire spécifié.The debugger searches only the specified directory. Vous devez ajouter des entrées pour tous les sous-répertoires à explorer.You must add entries for any subdirectories that you want to search.

  4. Sous ne pas rechercher ces fichiers sources, tapez les noms des fichiers sources à exclure de la recherche.Under Do not look for these source files, type the names of source files to exclude from search.

  5. Sélectionnez OK ou appliquer.Select OK or Apply.

Voir aussiSee also

Comprendre les fichiers de symboles et les paramètres des symboles de Visual StudioUnderstand symbol files and Visual Studio symbol settings

Modifications dans Visual Studio 2012 et 2013 du chargement des symboles distants .NET.NET remote symbol loading changes in Visual Studio 2012 and 2013