<compatibleFrameworks> , élément (déploiement ClickOnce)<compatibleFrameworks> element (ClickOnce deployment)

Identifie les versions du .NET Framework pour lesquelles cette application peut s'installer et s'exécuter.Identifies the versions of the .NET Framework where this application can install and run.

Note

MageUI.exe ne prend pas en charge la compatibleFrameworks élément lors de l’enregistrement d’un manifeste d’application qui a déjà été signé avec un certificat à l’aide MageUI.exe.MageUI.exe does not support the compatibleFrameworks element when saving an application manifest that has already been signed with a certificate using MageUI.exe. Au lieu de cela, vous devez utiliser Mage.exe.Instead, you must use Mage.exe.

SyntaxeSyntax

<compatibleFrameworks  
      SupportUrl>   
   <framework  
      targetVersion  
      profile  
      supportedRuntime  
   />   
</ compatibleFrameworks>  

Éléments et attributsElements and attributes

Le compatibleFrameworks élément est requis pour les manifestes de déploiement qui ciblent le ClickOnceClickOnce runtime fourni par .NET Framework 4 ou version ultérieure.The compatibleFrameworks element is required for deployment manifests that target the ClickOnceClickOnce runtime provided by .NET Framework 4 or later. Le compatibleFrameworks élément contient un ou plusieurs framework éléments qui spécifient les versions du .NET Framework sur laquelle cette application peut s’exécuter.The compatibleFrameworks element contains one or more framework elements that specify the .NET Framework versions on which this application can run. Le ClickOnceClickOnce runtime exécutera l’application sur le premier disponible framework dans cette liste.The ClickOnceClickOnce runtime will run the application on the first available framework in this list.

Le tableau suivant répertorie l’attribut qui le compatibleFrameworks élément prend en charge.The following table lists the attribute that the compatibleFrameworks element supports.

AttributAttribute DescriptionDescription
S upportUrlS upportUrl Facultatif.Optional. Spécifie l’URL où la version de .NET Framework compatible par défaut peut être téléchargée.Specifies a URL where the preferred compatible .NET Framework version can be downloaded.

infrastructureframework

Obligatoire.Required. Le tableau suivant répertorie les attributs qui la framework élément prend en charge.The following table lists the attributes that the framework element supports.

AttributAttribute DescriptionDescription
targetVersion Obligatoire.Required. Spécifie le numéro de version du .NET Framework cible.Specifies the version number of the target .NET Framework.
profile Obligatoire.Required. Spécifie le profil du .NET Framework cible.Specifies the profile of the target .NET Framework.
supportedRuntime Obligatoire.Required. Spécifie le numéro de version du runtime associé à la cible de .NET Framework.Specifies the version number of the runtime associated with the target .NET Framework.

NotesRemarks

ExempleExample

Le code suivant montre l’exemple un compatibleFrameworks élément dans un ClickOnceClickOnce manifeste de déploiement.The following code example shows a compatibleFrameworks element in a ClickOnceClickOnce deployment manifest. Ce déploiement peut s’exécuter sur le .NET Framework 4 Client Profile.This deployment can run on the .NET Framework 4 Client Profile. Il peut également s’exécuter le .NET Framework 4 , car il est un sur-ensemble de la .NET Framework 4 Client Profile.It can also run on the .NET Framework 4 because it is a superset of the .NET Framework 4 Client Profile.

<compatibleFrameworks xmlns="urn:schemas-microsoft-com:clickonce.v2">  
  <framework   
      targetVersion="4.0"   
      profile="Client"   
      supportedRuntime="4.0.30319" />  
</compatibleFrameworks>  

Voir aussiSee also

Manifeste de déploiement ClickOnceClickOnce deployment manifest