Créer des solutions et des projetsCreate solutions and projects

Les projets sont des conteneurs logiques dans Visual Studio qui regroupent tous les éléments dont vous avez besoin pour générer votre application, tels que les fichiers de code source, les bitmaps, les icônes, et les références de composant et de service.Projects are logical containers in Visual Studio that hold the items needed to build your app, such as source code files, bitmaps, icons, and component and service references. Quand vous créez un projet, Visual Studio crée une solution dans laquelle est placé votre projet.When you create a new project, Visual Studio creates a solution to contain the project. Vous pouvez ensuite ajouter d’autres projets nouveaux ou existants à la solution.You can then add other new or existing projects to the solution if you want. Les solutions peuvent également contenir des fichiers qui ne sont pas associés à un projet spécifique.Solutions can also contain files that aren't connected to any specific project.

Hiérarchie de projet/solution

Vous pouvez afficher vos solutions et projets dans une fenêtre Outil appelée Explorateur de solutions.You can view your solutions and projects in a tool window called Solution Explorer. La capture d’écran suivante montre un exemple de solution dans l’Explorateur de solutions (BikeSharing.Xamarin-UWP), qui contient deux projets : BikeSharing.Clients.Core et BikeSharing.Clients.Windows.The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. Chaque projet contient plusieurs fichiers, dossiers et références.Each project contains multiple files, folders, and references. Le nom du projet en gras est le projet de démarrage, c’est-à-dire le projet qui démarre quand vous exécutez l’application.The project name in bold is the startup project; that is, the project that starts when you run the app. Vous pouvez spécifier le projet à utiliser comme projet de démarrage.You can specify which project is the startup project.

Explorateur de solutions avec des projets

Vous pouvez créer un projet vous-même en y ajoutant les fichiers nécessaires ou créer un projet à partir d’un des modèles de projet disponibles dans Visual Studio.While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. Quand vous créez un projet à partir d’un modèle, votre projet contient les éléments essentiels pour le type de projet choisi. Vous pouvez ensuite renommer les fichiers et ajouter du code nouveau ou existant et d’autres ressources selon vos besoins.Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

Cela étant dit, le développement d’applications dans Visual Studio peut se faire sans solutions ni projets.That being said, solutions and projects are not required to develop apps in Visual Studio. Vous pouvez simplement ouvrir du code que vous avez cloné à partir de Git ou téléchargé d’une source de votre choix.You can also just open code that you have cloned from Git or downloaded elsewhere. Pour plus d’informations, consultez Développer du code dans Visual Studio sans projets ni solutions.For more information, see Develop code in Visual Studio without projects or solutions.

Note

Les descriptions de cette rubrique sont basées sur l'édition Visual Studio Community.The descriptions in this topic are based on the Visual Studio Community edition. Les boîtes de dialogue et les commandes de menu affichées peuvent différer de celles décrites ici, selon vos paramètres ou votre version de Visual Studio.The dialog boxes and menu commands you see might differ from those described here, depending on your settings or Visual Studio edition. Pour changer vos paramètres, par exemple pour définir les paramètres Général ou Visual C++, choisissez Outils, Importation et exportation de paramètres, puis choisissez Réinitialiser tous les paramètres.To change your settings, for example to General or Visual C++ settings, choose Tools, Import and Export Settings, and then choose Reset all settings.

Pour créer un projet à partir d’un modèle de projetTo create a project from a project template

  1. Il existe plusieurs façons de créer un projet dans Visual Studio.There are multiple ways to create a new project in Visual Studio. Dans la Page de démarrage, entrez le nom d’un modèle de projet dans la zone Rechercher dans les modèles de projet, ou choisissez le lien Créer un projet pour ouvrir la boîte de dialogue Nouveau projet.On the Start Page, enter the name of a project template in the Search project templates box, or choose the Create new project link to open the New Project dialog box. Vous pouvez également choisir Fichier > Nouveau > Projet... dans la barre de menus ou le bouton Nouveau projet dans la barre d’outils.You can also choose File > New > Project... on the menu bar, or choose the New Project button on the toolbar.

    Page de démarrage

    Dans la boîte de dialogue Nouveau projet, les modèles de projet disponibles sont répertoriés sous la catégorie Modèles.In the New Project dialog box, available project templates appear in a list under the Templates category. Les modèles sont organisés par langage de programmation et type de projet, par exemple, Visual C#, JavaScript et Azure Data Lake.Templates are organized by programming language and project type, such as Visual C#, JavaScript, and Azure Data Lake.

    Nouveau projet, boîte de dialogue

    Note

    La liste des langages de programmation et des modèles de projet disponibles dépend de la version de Visual Studio que vous utilisez et des charges de travail qui sont installées.The list of available languages and project templates that appears depends on the version of Visual Studio you are running and the workloads that are installed. Pour découvrir comment installer des charges de travail supplémentaires, consultez Modifier Visual Studio 2017 en ajoutant ou supprimant des charges de travail et des composants.To learn about how to install additional workloads, see Modify Visual Studio 2017 by adding or removing workloads and components.

  2. Affichez la liste des modèles disponibles pour le langage de programmation souhaité en choisissant la flèche à côté du nom du langage, puis en choisissant un type de projet.Show the list of templates for the programming language you want to use by choosing the triangle next to the language name, and then choose a project type.

    L’exemple suivant montre les modèles de projet disponibles pour des projets .NET Core Visual C#.The following example shows the project templates available for Visual C# .NET Core projects.

    Modèles de projet

  3. Entrez le nom du nouveau projet dans la zone Nom.Enter a name for the new project in the Name box. Vous pouvez enregistrer le projet à l’emplacement par défaut sur votre système, ou choisir le bouton Parcourir pour rechercher un autre emplacement.You can choose to save the project in the default location on your system, or choose the Browse button to find another location.

    Vous pouvez également choisir de changer le nom de la solution, ou d’ajouter le nouveau projet à un référentiel Git en choisissant Ajouter au contrôle de code source.You can also optionally choose to change the solution name, or add the new project to a Git repository by choosing Add to Source Control.

  4. Choisissez le bouton OK pour créer la solution et le projet.Choose the OK button to create the solution and project.

  5. Si vous souhaitez ajouter un projet supplémentaire à la solution, choisissez le nœud de la solution dans l’Explorateur de solutions puis, dans la barre de menus, choisissez Projet > Ajouter un nouvel élément.If you want to add an additional project to the solution, choose the solution node in Solution Explorer, and then on the menu bar, choose Project > Add New Item.

Créer un projet à partir de fichiers de code existantsCreate a project from existing code files

Si vous avez déjà une collection de fichiers de code source, vous pouvez facilement les ajouter à un projet.If you have a collection of code source files, you can easily add them to a project.

  1. Dans le menu, choisissez Fichier > Nouveau > Projet à partir de code existant.On the menu, choose File > New > Project From Existing Code.

  2. Dans l’Assistant Créer un projet à partir de fichiers de code existants, choisissez le type de projet souhaité dans la zone de liste déroulante Quel type de projet voulez-vous créer ?, puis choisissez le bouton Suivant.In the Create Project from Existing Code Files wizard, choose the project type you want in the What type of project would you like to create? drop-down list box, and then choose the Next button.

  3. Dans l’Assistant, accédez à l’emplacement des fichiers, puis entrez le nom du nouveau projet dans la zone Nom.In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. Quand vous avez terminé, choisissez le bouton Terminer.When you are done, choose the Finish button.

Note

Cette option est la plus appropriée pour une collection de fichiers relativement simple.This option works best for a relatively simple collection of files. Actuellement, seuls les types de projet Visual C++, Apache Cordova, Visual Basic et C# sont pris en charge.Currently, only Visual C++, Apache Cordova, Visual Basic, and C# project types are supported.

Ajouter des fichiers à une solutionAdd files to a solution

Si vous utilisez des fichiers qui s’appliquent à plusieurs projets, comme un fichier Lisezmoi pour la solution, ou d’autres fichiers qui sont logiquement associés à la solution globale plutôt qu’à un projet particulier, vous pouvez les ajouter directement à la solution.If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. Pour ajouter un élément à une solution, dans le menu contextuel (clic droit) du nœud de solution dans l’Explorateur de solutions, choisissez Ajouter > Nouvel élément ou Ajouter > Élément existant.To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, choose Add > New Item, or Add > Existing Item.

Créer un projet .NET qui cible une version spécifique du .NET FrameworkCreate a .NET project that targets a specific version of the .NET Framework

Quand vous créez un projet, vous pouvez spécifier une version spécifique de .NET Framework à utiliser pour votre projet.When you create a project, you can specify a specific version of the .NET Framework that you want the project to use. Pour spécifier une version de .NET Framework, choisissez le menu déroulant Framework dans la boîte de dialogue Nouveau projet.To specify a .NET framework version, choose the Framework drop-down menu in the New Project dialog box.

Liste déroulante Framework dans la boîte de dialogue Nouveau projet

Note

Vous devez avoir .NET Framework 3.5 installé sur votre système pour pouvoir accéder aux versions de .NET Framework antérieures à .NET Framework 4.You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

Créer des solutions videsCreate empty solutions

Vous pouvez également créer des solutions vides qui ne contiennent pas de projets.You can also create empty solutions that have no projects. Utilisez plutôt cette méthode si vous souhaitez créer vous-même entièrement votre solution et vos projets.This might be preferable in cases where you want to construct your solution and projects from scratch.

Pour créer une solution videTo create an empty solution

  1. Dans le menu, choisissez Fichier > Nouveau > Projet....On the menu, choose File > New > Project....

  2. Dans le volet (Modèles) de gauche, choisissez Autres types de projets > Solutions Visual Studio dans la liste développée.In the left (Templates) pane, choose Other Project Types > Visual Studio Solutions in the expanded list.

  3. Dans le volet du milieu, choisissez Nouvelle Solution.In the middle pane, choose Blank Solution.

  4. Entrez les valeurs Nom et Emplacement de votre solution, puis choisissez OK.Enter Name and Location values for your solution, then choose OK.

Après avoir créé une solution vide, vous pouvez lui ajouter des projets ou éléments nouveaux ou existants en choisissant Ajouter un nouvel élément ou Ajouter un élément existant dans le menu Projet.After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

Comme mentionné plus haut, vous pouvez aussi ouvrir des fichiers de code sans avoir besoin d’un projet ou d’une solution.As mentioned earlier, you can also open code files without needing a project or solution. Pour en savoir plus sur le développement de code de cette façon, consultez Développer du code dans Visual Studio sans projets ni solutions.To learn about developing code in this way, see Develop code in Visual Studio without projects or solutions.

Créer un projet temporaire (C# et Visual Basic)Create a temporary project (C# and Visual Basic)

Si vous créez un projet .NET sans spécifier un emplacement sur disque, le projet est considéré comme temporaire.If you create a .NET-based project without specifying a disk location, it is a temporary project. Les projets temporaires sont utiles pour faire des essais avec des projets .NET.Temporary projects enable you to experiment with .NET projects. Quand vous travaillez avec un projet temporaire, vous pouvez choisir de l’enregistrer ou de le supprimer à tout moment.At any time while you are working with a temporary project, you can choose to save it or discard it.

Pour créer un projet temporaire, accédez d’abord à Outils > Options > Projets et solutions > Général et désélectionnez la case Enregistrer les nouveaux projets lors de la création.To create a temporary project, first go to Tools > Options > Projects and Solutions > General, and uncheck the Save new projects when created checkbox. Ouvrez ensuite la boîte de dialogue Nouveau projet.Then open the New Project dialog box as usual.

Supprimer une solution, un projet ou un élémentDelete a solution, project, or item

Vous pouvez supprimer des solutions et tout leur contenu définitivement, mais cela n’est pas possible par le biais de l’IDE de Visual Studio.You can delete solutions and their contents permanently, but not by using the Visual Studio IDE. En effet, quand vous supprimez des éléments dans Visual Studio, les éléments sont supprimés uniquement dans la solution ou le projet actifs.Deleting items within Visual Studio only removes them from the current solution or project. Pour supprimer définitivement une solution ou un autre composant de votre système, vous devez supprimer le dossier contenant les fichiers solution .sln et .suo dans l’Explorateur de fichiers.To permanently delete a solution or other component from your system, use File Explorer to delete the folder that contains the .sln and .suo solution files. Toutefois, avant de supprimer définitivement une solution, nous vous recommandons de sauvegarder les projets ou fichiers dont vous pourriez avoir besoin ultérieurement.However, before permanently deleting a solution, it's recommended that you back up any projects or files in case you need them again.

Note

Le fichier .suo est un fichier masqué qui n’apparaît pas dans les paramètres par défaut de l’Explorateur de fichiers.The .suo file is a hidden file that is not displayed under the default File Explorer settings. Pour afficher les fichiers masqués, dans le menu Affichage de l’Explorateur de fichiers, cochez la case Éléments masqués.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

Pour supprimer définitivement une solutionTo permanently delete a solution

  1. Dans l’Explorateur de solutions, dans le menu contextuel de la solution à supprimer, choisissez Ouvrir le dossier dans l’Explorateur de fichiers.In Solution Explorer, on the context menu of the solution you want to delete, choose Open folder in File Explorer.

  2. Dans l'Explorateur de fichiers, remontez d'un niveau.In File Explorer, navigate up one level.

  3. Choisissez le dossier contenant la solution, puis choisissez la touche Suppr.Choose the folder containing the solution and then choose the Delete key.

Voir aussiSee also