Rechercher dans les fichiersFind in Files

L’option Rechercher dans les fichiers vous permet de faire des recherches dans un ensemble défini de fichiers.Find in Files allows you to search a specified set of files. Les correspondances trouvées et les actions entreprises sont répertoriées dans la fenêtre Résultats de la recherche sélectionnée dans Options de résultat.The matches found and actions taken are listed in the Find Results window selected in Result options.

Vous pouvez utiliser l’une des méthodes suivantes pour afficher l’option Rechercher dans les fichiers de la fenêtre Rechercher et remplacer.You can use any of the following methods to display Find in Files in the Find and Replace window.

Pour afficher l'option Rechercher dans les fichiersTo display Find in Files

  1. Dans la barre de menus, choisissez Edition, puis Rechercher et remplacer.On the menu bar, choose Edit, Find and Replace.

  2. Choisissez Rechercher dans les fichiers.Choose Find in Files.

Pour annuler une opération de recherche, appuyez sur Ctrl + Pause.To cancel a Find operation, press Ctrl + Break.

Note

L’outil Rechercher et remplacer n’effectue pas de recherche dans les répertoires ayant l’attribut Hidden ou System.The Find and Replace tool does not search directories with the Hidden or System attribute.

RechercherFind what

Pour rechercher une nouvelle chaîne de texte ou expression, entrez-la dans cette zone.To search for a new text string or expression, specify it in the box. Pour rechercher l’une des 20 dernières chaînes que vous avez recherchées, ouvrez la liste déroulante et choisissez la chaîne.To search for any of the 20 strings that you searched for most recently, open the drop-down list and choose the string. Choisissez le bouton adjacent Générateur d’expressions si vous souhaitez utiliser une ou plusieurs expressions régulières dans votre chaîne de recherche.Choose the adjacent Expression Builder button if you want to use one or more regular expressions in your search string. Pour plus d’informations, consultez Utilisation d’expressions régulières dans Visual Studio.For more information, see Using Regular Expressions in Visual Studio.

Note

Le bouton Générateur d’expressions est activé uniquement si vous avez sélectionné Expressions régulières sous Options de recherche.The Expression Builder button will only be enabled if you have selected Use Regular Expressions under Find options.

Regarder dansLook in

L’option choisie dans la liste déroulante Regarder dans détermine si l’opération Rechercher dans les fichiers porte sur les fichiers actifs uniquement ou sur tous les fichiers figurant dans certains dossiers.The option chosen from the Look in drop-down list determines whether Find in Files searches only in currently active files or in all files stored within certain folders. Sélectionnez une étendue de recherche dans la liste ou cliquez sur le bouton Parcourir (...) pour afficher la boîte de dialogue Choisir des dossiers de recherche et spécifier l’ensemble de répertoires de votre choix.Select a search scope from the list or click the Browse (...) button to display the Choose Search Folders dialog box and to enter your own set of directories. Vous pouvez également taper un chemin directement dans la zone Regarder dans.You can also type a path directly into the Look in box.

Avertissement

Avec les options Solution complète ou Projet actuel, les fichiers solution et projet ne sont pas inclus dans la recherche.With the Entire Solution or Current Project options, project and solution files are not searched. Pour effectuer une recherche dans les fichiers projet, choisissez un dossier de recherche.If you want to look in project files, choose a search folder.

Note

Si l’option Regarder dans sélectionnée entraîne la recherche dans un fichier que vous avez extrait du contrôle de code source, la recherche ne porte que sur la version du fichier ayant été téléchargée sur votre ordinateur local.If the Look in option selected causes you to search a file that you have checked out from source code control, only the version of that file which has been downloaded to your local machine is searched.

Inclure les sous-dossiersInclude subfolders

Spécifie que les sous-dossiers du dossier choisi dans Regarder dans sont inclus dans la recherche.Specifies that subfolders of the Look in folder will be searched.

Options de rechercheFind options

Vous pouvez développer ou réduire la section Options de recherche.You can expand or collapse the Find options section. Les options suivantes peuvent être sélectionnées ou désélectionnées :The following options can be selected or cleared:

Respecter la casseMatch case
Si vous sélectionnez cette option, la fenêtre Résultats de la recherche affiche uniquement les correspondances qui respectent la casse.When selected, a Find Results search will be case-sensitive

Mot entierMatch whole word
Si vous sélectionnez cette option, la fenêtre Résultats de la recherche affiche uniquement les correspondances de mot entier.When selected, the Find Results windows will only return whole word matches.

Utiliser des expressions régulièresUse Regular Expressions
Si cette case est cochée, vous pouvez utiliser des notations spéciales pour définir des modèles de texte à rechercher dans les zones de texte Rechercher ou Remplacer par.If this check box is selected, you can use special notations to define patterns of text to match in the Find what or Replace with text boxes. Pour obtenir la liste de ces notations, consultez Utilisation d’expressions régulières dans Visual Studio.For a list of these notations, see Using Regular Expressions in Visual Studio.

Examiner ces types de fichiersLook at these file types
Cette liste indique les types de fichiers à examiner dans les répertoires choisis dans Regarder dans.This list indicates the types of files to search through in the Look in directories. Si ce champ est laissé vide, tous les fichiers présents dans les répertoires choisis dans Regarder dans sont examinés.If this field is blank, all of the files in the Look in directories will be searched.

Sélectionnez un élément dans la liste pour entrer une chaîne de recherche prédéfinie à rechercher dans les fichiers de ces types particuliers.Select any item in the list to enter a preconfigured search string that will find files of those particular types.

Options de résultatResult options

Vous pouvez développer ou réduire la section Options de résultat.You can expand or collapse the Result options section. Les options suivantes peuvent être sélectionnées ou désélectionnées :The following options can be selected or cleared:

Fenêtre Résultats de la recherche 1Find results 1 window
Si cette option est sélectionnée, les résultats de la recherche actuelle remplacent le contenu de la fenêtre Résultats de la recherche 1.When selected, the results of the current search will replace the content of the Find Results 1 window. Cette fenêtre s'ouvre automatiquement pour afficher les résultats de votre recherche.This window opens automatically to display your search results. Pour ouvrir cette fenêtre manuellement, sélectionnez Autres fenêtres dans le menu Affichage et choisissez Résultats de la recherche 1.To open this window manually, select Other Windows from the View menu and choose Find Results 1.

Fenêtre Résultats de la recherche 2Find results 2 window
Si cette option est sélectionnée, les résultats de la recherche actuelle remplacent le contenu de la fenêtre Résultats de la recherche 2.When selected, the results of the current search will replace the content of the Find Results 2 window. Cette fenêtre s'ouvre automatiquement pour afficher les résultats de votre recherche.This window opens automatically to display your search results. Pour ouvrir cette fenêtre manuellement, sélectionnez Autres fenêtres dans le menu Affichage et choisissez Résultats de la recherche 2.To open this window manually, select Other Windows from the View menu and choose Find Results 2.

Afficher uniquement les noms de fichierDisplay file names only
Affiche une liste des fichiers contenant des correspondances de recherche au lieu d'afficher les correspondances elles-mêmes.Displays a list of files containing search matches rather than displaying the search matches themselves.

Ajouter les résultatsAppend results
Ajoute les résultats de la recherche actuelle aux résultats des recherches précédentes.Appends the results from the search to the previous search results.

Voir aussiSee also

Recherche et remplacement de texteFinding and Replacing Text
Remplacer dans les fichiersReplace in Files
Commandes Visual StudioVisual Studio Commands